ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by dmsimard at 19:01:25 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (dmsimard, 19:01:39)
  2. Updates (felixfontein, 19:02:21)
    1. Ansible 3.0.0 has been released! \o/ (felixfontein, 19:02:21)
    2. docsite split began: https://docs.ansible.com/ansible/latest/ is Ansible 3, https://docs.ansible.com/ansible/2.10/ is Ansible 2.10 (not yet updated), https://docs.ansible.com/ansible-core/devel/ is ansible-core (felixfontein, 19:02:21)
    3. Contributor summit in ~two weeks, register if you haven't https://www.eventbrite.com/e/ansible-contributor-summit-202103-registration-141735886853 and check out topics on https://hackmd.io/uZDSLOOdS1Kx0xfZVIATmQ (dmsimard, 19:05:15)
    4. https://www.ansible.com/blog/announcing-the-community-ansible-3.0.0-package (dmsimard, 19:07:56)
    5. https://www.ansible.com/blog/ansible-3.0.0-qa (dmsimard, 19:08:01)
    6. https://blog.while-true-do.io/ansible-release-3-0-0/ (dmsimard, 19:08:39)

  3. Add a requirement not to store package installers and other large objects used for integration tests (felixfontein, 19:09:39)
    1. https://github.com/ansible-collections/overview/pull/157 (felixfontein, 19:09:42)
    2. https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst#licensing says that everything in the collection artefact must be licensed under GPLv3+, except possibly module_utils (which also allows BSD-2-clause) (felixfontein, 19:22:15)
    3. ACTION: dmsimard hunt down and follow up with gundalow and abadger1999 on the legal aspect of moving tests to separate package / removing from main package (felixfontein, 19:29:48)

  4. Users seem to expect that docs.ansible.com shows latest docs for collections released on galaxy (https://github.com/ansible/community/issues/539#issuecomment-778847740) (felixfontein, 19:53:03)
    1. Idea: Separate per-collection docsites for included collections on docs.ansible.com (or somewhere else)? (felixfontein, 19:53:07)
    2. Idea: Ansible devel docs: could contain docs for latest release (or also pre-releases) on galaxy? (Has been discussed in DaWGs meeting) (felixfontein, 19:53:10)
    3. AGREED: /ansible/devel/ should use the latest 'stable' releases (and not pre-releases) (felixfontein, 20:20:11)

  5. open floor (felixfontein, 20:22:40)
    1. https://github.com/ansible/community/issues/539 (dmsimard, 20:23:31)
    2. https://github.com/ansible/community/issues/539 (felixfontein, 20:23:32)
    3. add topics to the agenda for this community meeting at https://github.com/ansible/community/issues/539 (acozine, 20:24:06)
    4. https://github.com/ansible-collections/overview/pull/157 (felixfontein, 20:24:58)


Meeting ended at 20:26:41 UTC (full logs).

Action items

  1. dmsimard hunt down and follow up with gundalow and abadger1999 on the legal aspect of moving tests to separate package / removing from main package


Action items, by person

  1. dmsimard
    1. dmsimard hunt down and follow up with gundalow and abadger1999 on the legal aspect of moving tests to separate package / removing from main package


People present (lines said)

  1. felixfontein (142)
  2. dmsimard (63)
  3. samccann (40)
  4. acozine (35)
  5. odyssey4me (30)
  6. andersson007_ (23)
  7. tadeboro (15)
  8. zodbot (10)
  9. pabelanger (7)
  10. briantist (7)
  11. dericcrago (3)
  12. jillr (2)
  13. lmodemal (2)
  14. geerlingguy (1)


Generated by MeetBot 0.1.4.