ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:18 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 19:00:18)
  2. Updates (felixfontein, 19:00:31)
    1. community.network 1.3.1 will be released this weekend, right now it looks like only two announcement changelog fragments and no other change (felixfontein, 19:01:57)
    2. community.general 1.3.5 should be released beginning of next week (felixfontein, 19:03:30)
    3. Ansible 2.10.6 will be released on January 26th (current plan), and is probably the last 2.10.x release (felixfontein, 19:05:48)
    4. The bullhorn edition 18 has been released: https://mailchi.mp/redhat/the-bullhorn-18 (dmsimard, 19:06:58)

  3. What should we do with collections that contain non-standard directories? (tadeboro, https://github.com/ansible/community/issues/539#issuecomment-757138811) (felixfontein, 19:11:03)
    1. https://github.com/ansible-collections/ansible.netcommon/tree/main/plugins/cli_parsers is the source of them (pabelanger, 19:16:30)
    2. https://github.com/ansible-collections/community.docker/tree/main/plugins/plugin_utils (dmsimard, 19:16:30)
    3. https://github.com/ansible-collections/ansible.netcommon/pull/109 | closed, created 2020-08-04T17:52:36Z by Qalthos: New module: cli_parse [gate] (github-linkbot, 19:34:24)
    4. https://github.com/ansible-collections/ansible.utils/blob/main/plugins/action/fact_diff.py#L53-L90 <-- that's the 'plugin loader' (felixfontein, 19:34:43)
    5. https://github.com/ansible/ansible/pull/72497) | open, created 2020-11-05T13:34:41Z by felixfontein: Import sanity test for plugins [affects_2.11,core_review,docs,docsite,feature,has_issue,stale_ci,support:core,test] (github-linkbot, 19:40:19)
    6. AGREED: collections MUST only put plugin types recognized by ansible-core into the plugins/ directories at this time. The following collections have a temporary exception to use the plugin_utils, cli_parsers, fact_diff, and validate directories for the 2.10 and 3.0 release cycles until we figure out a final policy: ansible.utils, ansible.netcommon, community.crypto, community.docker, and (felixfontein, 20:01:02)
    7. ACTION: abadger1999 will add a PR to the overview requirements and checklist for the custom subdirectories decision. (abadger1999, 20:01:39)
    8. ACTION: samccann will steal abadger's wording to put into the docs themselves (samccann, 20:02:05)

  4. community.general: increase minor release frequency (felixfontein, 20:04:15)
    1. https://github.com/ansible/community/issues/539#issuecomment-733933170 (felixfontein, 20:04:34)
    2. AGREED: community.general minor releases should aim to be in sync with Ansible releases (i.e. a few days before) (felixfontein, 20:13:39)

  5. open floor (felixfontein, 20:15:29)
    1. https://dashboard.zuul.ansible.com/t/ansible/project/github.com/ansible-collections/ansible.utils has no sanity jobs listed. (tadeboro, 20:33:32)

  6. Weekly CI run requirement (abadger1999, 20:36:47)
    1. https://github.com/ansible-collections/ansible.utils/commits/main had no commit since December 8th (felixfontein, 20:48:04)
    2. https://github.com/sensu/sensu-go-ansible/blob/master/.circleci/config.yml#L136 (tadeboro, 20:51:05)

  7. Open floor (abadger1999, 20:52:51)
    1. The Bullhorn will be published on Thursdays starting from issue 19 in 2 weeks (Feb 4, 2021). (cybette, 20:53:17)


Meeting ended at 20:58:36 UTC (full logs).

Action items

  1. abadger1999 will add a PR to the overview requirements and checklist for the custom subdirectories decision.
  2. samccann will steal abadger's wording to put into the docs themselves


Action items, by person

  1. abadger1999
    1. abadger1999 will add a PR to the overview requirements and checklist for the custom subdirectories decision.
  2. samccann
    1. samccann will steal abadger's wording to put into the docs themselves


People present (lines said)

  1. felixfontein (161)
  2. abadger1999 (88)
  3. pabelanger (78)
  4. dmsimard (45)
  5. gundalow (31)
  6. tadeboro (29)
  7. cybette (21)
  8. zodbot (15)
  9. nitzmahone (12)
  10. samccann (11)
  11. ikhan (8)
  12. acozine (7)
  13. briantist (6)
  14. sivel (3)
  15. github-linkbot (2)
  16. mattclay (2)
  17. dericcrago (2)
  18. alongchamps (1)
  19. aderium (1)
  20. lmodemal (1)


Generated by MeetBot 0.1.4.