ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:53 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 19:00:53)
  2. Updates (felixfontein, 19:00:57)
    1. https://github.com/ansible/community/issues/539#issuecomment-758845140 (felixfontein, 19:04:30)
    2. reviewing new collections for Ansible 3.0.0 has begun! (felixfontein, 19:05:15)

  3. Collection dependency: avoid unnecessarily strict requirements to avoid dependency hell for Ansible building? (felixfontein, 19:10:49)
    1. we have to think how deprecation of collections will work (example: community.kubernetes -> kubernetes.core rename) (felixfontein, 19:22:13)
    2. postpone dependency discussion until someone has a concrete suggestion (felixfontein, 19:22:28)
    3. https://github.com/ansible-collections/community.kubernetes/projects/2 (jillr, 19:25:02)

  4. Should DOCUMENTATION, EXAMPLES, RETURN be required? (dmsimard) (felixfontein, 19:25:18)
    1. ACTION: dmsimard to propose a PR for clarifying requirements for DOCUMENTATION/EXAMPLES/RETURN so we can vote on it next meeting (dmsimard, 19:41:43)

  5. Should CoC be present in the repository, or is a link to the CoC enough? (tadeboro) (felixfontein, 19:43:09)
    1. https://github.com/ansible-collections/collection_template/blob/main/CODE_OF_CONDUCT.md (felixfontein, 19:46:56)
    2. AGREED: We require at least one of: link in README.md, file CODE_OF_CONDUCT.md (can have link or content of CoC) (felixfontein, 19:55:50)

  6. Differentiating between MUST change (blocker) to SHOULD change (nice to have, not a blocker) when providing feedback to applicants (dmsimard) (felixfontein, 19:56:56)
    1. https://github.com/ansible-collections/ansible-inclusion/discussions/4#discussioncomment-270408 is how I started. (tadeboro, 20:01:39)
    2. AGREED: Comments must say whether they need to be addressed, or are optional. (felixfontein, 20:24:39)

  7. Clarify "sanity tests must pass" - specifying `--python` on `ansible-test sanity` call can be problematic (felixfontein, 20:24:58)
    1. AGREED: Add "Collections must run an equivalent of `ansible-test sanity --docker`. If they do not use `--docker`, they must make sure that all tests run, in particular the compile and import tests (which should run for all Python versions). Collections can choose to skip certain Python versions that they explicitly do not support; this needs to be documented in README.md and in every (felixfontein, 20:44:15)

  8. open floor (felixfontein, 20:46:21)
    1. anyone want to help design the next Contributor summit t-shirt, please ping cybette (cybette, 20:47:44)


Meeting ended at 20:50:35 UTC (full logs).

Action items

  1. dmsimard to propose a PR for clarifying requirements for DOCUMENTATION/EXAMPLES/RETURN so we can vote on it next meeting


Action items, by person

  1. dmsimard
    1. dmsimard to propose a PR for clarifying requirements for DOCUMENTATION/EXAMPLES/RETURN so we can vote on it next meeting


People present (lines said)

  1. felixfontein (168)
  2. abadger1999 (51)
  3. dmsimard (40)
  4. tadeboro (34)
  5. gundalow (27)
  6. samccann (27)
  7. jillr (24)
  8. acozine (23)
  9. cybette (18)
  10. zodbot (13)
  11. mattclay (11)
  12. ikhan (6)
  13. dericcrago (3)


Generated by MeetBot 0.1.4.