ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:01:19 UTC (full logs).

Meeting summary

  1. agenda: https://github.com/ansible/community/issues/539#issuecomment-737419444 (felixfontein, 19:02:27)
    1. Bullhorn 15 has just been published https://mailchi.mp/redhat/the-bullhorn-15 (you should subscribe) (gundalow, 19:03:42)

  2. Announcements (felixfontein, 19:03:54)
    1. Bullhorn 15 has just been published https://mailchi.mp/redhat/the-bullhorn-15 (you should subscribe) (gundalow, 19:03:58)
    2. Ansible 2.10.4 has been released yesterday (felixfontein, 19:04:05)
    3. Ansible 2.10 contains new collections since last meeting: community.okd and community.hrobot (see https://github.com/ansible-collections/overview/issues/128 for overview) (felixfontein, 19:04:09)
    4. PR Day on 1st December was a great success, next is 17th December. Hope to see you there https://github.com/ansible/community/issues/407 (gundalow, 19:04:28)

  3. Are bugfix releases every ~3 weeks ok for community.general's stable-1 branch? (felixfontein, 19:06:24)
    1. AGREED: community.general 1.3.x bugfix releases will be ~every three weeks (felixfontein, 19:08:59)

  4. Should the next 'big' Ansible release in February 2021 be Ansible 3.0.0, or a higher version number? (felixfontein, 19:09:23)
    1. AGREED: the next 'big' Ansible version will be 3.0.0 in February 2021. we'll add docs everywhere that explain that it is not much different than 2.11 would have been, so users hopefully won't expect something bigger (felixfontein, 19:18:51)

  5. Criteria for inclusion of new collections in Ansible 3.0.0 (felixfontein, 19:19:03)
    1. https://github.com/ansible-collections/overview/issues/131 (felixfontein, 19:20:35)

  6. Matching ansible doc format and conventions (abadger1999, 19:24:31)
    1. existing checklist item on documentation is considered okay to start with. (abadger1999, 19:26:13)

  7. sanity tests (abadger1999, 19:26:51)
    1. AGREED: Collections MUST have sanity tests running against every major version of `ansible-core` that is supported by the collection (gundalow, 19:27:29)
    2. AGREED: sanity test requirement updated to require passing with rules on using ignores.txt: https://github.com/ansible-collections/overview/pull/132/files#diff-dacab21f27a6aa218b8dcaafcf6f5685df0ab52f231afa16e7a9ab5284b72c68 (abadger1999, 19:37:35)
    3. ACTION: gundalow to think about ignore.txt hackfest (gundalow, 19:39:23)

  8. license for collections (gundalow, 19:40:47)
    1. https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#SoftwareLicenses (abadger1999, 19:46:30)
    2. https://www.gnu.org/licenses/license-list.html (abadger1999, 19:46:59)
    3. https://opensource.org/licenses/alphabetical (abadger1999, 19:47:30)
    4. https://docs.ansible.com/ansible/latest/dev_guide/developing_modules_checklist.html (acozine, 19:57:08)
    5. https://www.apache.org/licenses/GPL-compatibility.html tldr, apache v2 okay to be in gplv3 code (like abadger1999 said) but not vis versa (resmo, 19:57:34)
    6. ACTION: abadger1999 to find out who manages legal@fedoraproject.org and whether we can piggyback off of the list they maintain for our needs or need to setup our own review process and list with red hat legal. (abadger1999, 20:06:19)
    7. AGREED: New licensing section to be added: https://github.com/ansible-collections/overview/pull/132/commits/7d93eb228f66a1bd581e0f014630af50891e7714 (abadger1999, 20:07:06)

  9. Make some things stricter (abadger1999, 20:07:40)
  10. Publically available issue tracker (abadger1999, 20:09:29)
    1. AGREED: MUST have a public & free issue tracker (gundalow, 20:12:50)

  11. CoC (gundalow, 20:12:53)
    1. AGREED: MUST have a CoC (or if not fall back to Ansible's) (gundalow, 20:13:05)

  12. Information on which kind of contributions are accepted (gundalow, 20:13:25)
  13. issue tracker proposal for vote (abadger1999, 20:17:40)
    1. AGREED: publically available issue tracker requirement is accepted: https://github.com/ansible-collections/overview/pull/132/commits/280c53b566901875d54d312b28fbf086275133a3 (abadger1999, 20:21:36)

  14. Information on which kind of contributions are accepted (abadger1999, 20:22:59)
    1. Discuss next time: Add to documentation section: "What type of contributions are accepted, if any, and the method for submitting contributions must be documented. This documentation SHOULD be in a CONTRIBUTING file in the root of the repository, or mentioned in the README." (felixfontein, 21:17:29)
    2. Discuss next time: Add a clause "Inclusion of a new collection in the Ansible package is ultimately at the discretion of the Ansible community review committee. Every rejected candidate will get feedback, and we try to have more precise rules for Ansible 4.0.0." (felixfontein, 21:17:34)
    3. https://github.com/ansible-collections/overview/pull/132 | open, created 2020-12-02T19:34:58Z by abadger: Must change changes to the checklist criteria (github-linkbot, 21:18:14)


Meeting ended at 21:19:19 UTC (full logs).

Action items

  1. gundalow to think about ignore.txt hackfest
  2. abadger1999 to find out who manages legal@fedoraproject.org and whether we can piggyback off of the list they maintain for our needs or need to setup our own review process and list with red hat legal.


Action items, by person

  1. abadger1999
    1. abadger1999 to find out who manages legal@fedoraproject.org and whether we can piggyback off of the list they maintain for our needs or need to setup our own review process and list with red hat legal.
  2. gundalow
    1. gundalow to think about ignore.txt hackfest


People present (lines said)

  1. felixfontein (168)
  2. abadger1999 (114)
  3. gundalow (77)
  4. jillr (60)
  5. dmsimard (48)
  6. samccann (47)
  7. acozine (37)
  8. andersson007_ (24)
  9. zodbot (22)
  10. resmo (19)
  11. aminvakil (17)
  12. geerlingguy (12)
  13. dericcrago (10)
  14. nitzmahone (8)
  15. cybette (8)
  16. lmodemal (4)
  17. github-linkbot (1)
  18. misc (1)
  19. briantist (1)
  20. baptistemm (1)


Generated by MeetBot 0.1.4.