ansible_contributors_summit_-_general_session
MINUTES

#ansible-community: Ansible Contributors Summit - General session

Meeting started by gundalow at 13:53:04 UTC (full logs).

Meeting summary

  1. Intros (gundalow, 14:05:22)
  2. Stats update (gundalow, 14:19:43)
    1. gwmngilfen is now talking about how Ansible Community Team uses data analysis to make informed discussions (gundalow, 14:20:19)
    2. gwmngilfen gave a presentation on Monday about Stats, that video will be available soon on YouTube (gundalow, 14:21:00)
    3. If you are interested in Contributing to Ansible please subscribe to The BullHorn: http://bit.ly/thebullhorn Community newsletter (gundalow, 14:21:51)
    4. One of the things we are keeping in mind is are collections performing better than gh/ansible/ansible. In terms of keeping on top of the backlog, helping find new maintainers, signs of burn out. (gundalow, 14:25:50)
    5. https://github.com/ansible/ansible/pull/68681) | open, created 2020-04-03T18:13:58Z by noonedeadpunk: Fix mask behaviour when service is enabled [affects_2.10,bug,collection,core_review,module,stale_ci,support:core,system] (github-linkbot, 14:28:06)
    6. ACTION: gwmngilfen To see if https://api.github.com/users/welcome[bot] type=bot is useful (though will not help if people are using regular user accounts) (gundalow, 14:37:11)
    7. On Monday we publiced https://www.katacoda.com/ansible-community/ for the first time. We have data that shows that it was userfull (gundalow, 14:39:35)
    8. I hope this helps explains why we do surveys, we really need this feedback. You should get a survey link next week (gundalow, 14:42:39)
    9. https://stats.eng.ansible.com/apps/meetups/ (cybette, 14:47:42)

  3. Ansible 2.10 (gundalow, 14:51:48)
    1. Ansible 2.10 was a major change to how Ansible was released. Its `ansible-base` + collections (gundalow, 14:52:07)
    2. https://github.com/ansible-collections/vyos.vyos/pull/94/checks for exmaple (pabelanger, 14:52:50)
    3. New docs https://docs.ansible.com/ansible/2.10/collections/ (notice it's 2.10/collections) (gundalow, 14:53:38)
    4. https://docs.github.com/en/free-pro-team@latest/graphql/reference/objects#checksuite suggests there's a CheckSuite api object, worth digging in a bit (gwmngilfen, 14:57:17)
    5. https://docs.github.com/en/free-pro-team@latest/graphql/reference/objects#checkrun (gwmngilfen, 14:57:47)
    6. We know there aren't any deb yet. We have to update a lot of the build scripts https://github.com/ansible-community/antsibull/issues/202 (gundalow, 14:57:52)
    7. We will be rewriting the `ansible` build scripts hopefully to public GitHub Actions (gundalow, 14:58:23)
    8. : QUESTION: Will we stick with patch releases every three weeks? (gundalow, 15:03:06)
    9. https://github.com/ansible/community/tree/master/meetings#wednesdays (felixfontein, 15:06:43)
    10. https://github.com/ansible-network/releases/blob/master/ansible_releases/cmd/generate_ansible_collection.py is how we build the collection (pabelanger, 15:09:15)

  4. Ansible 2.11, the future, policy and governance (gundalow, 15:13:33)
    1. AGREED: Chains that start in ansible-base MUST resolve in the Ansible package (gundalow, 16:02:49)
    2. https://github.com/ansible-collections/community.general/pull/1096 | closed, created 2020-10-14T19:18:17Z by patchback[bot]: [PR #1082/555eb621 backport][stable-1] solaris_zone: fix zone configuration with python3 [affects_2.10,bug,community_review,module,new_contributor,plugins,python3,system,tests] (github-linkbot, 16:04:04)

  5. Diversity and Inclusion update (gundalow, 16:26:00)
    1. Earlier in the year we setup a D&I working Group (gundalow, 16:27:09)
    2. We have two D&I sessions during Fest (gundalow, 16:27:23)
    3. https://github.com/ansible/community/wiki/Diversity/FAQs (jillr, 16:27:40)
    4. We've saved all the questions and will add to https://github.com/ansible/community/wiki/Diversity/FAQs (gundalow, 16:28:03)
    5. Feel free to join us in #ansible-diversity (gundalow, 16:28:13)
    6. This is the first year we had captioning available for some sessions (gundalow, 16:28:28)

  6. Documentation update (gundalow, 16:36:49)
    1. There are some pages that shouldn't be associated with a specific releases (gundalow, 16:37:42)
    2. Going forward ansible & ansible-base releases will diverge more. (gundalow, 16:38:35)
    3. We have a documentation working group breakout at 2000UTC (gundalow, 16:40:15)
    4. Anyone can and should help with documentation (gundalow, 16:48:01)
    5. https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-fix-and-maintain-the-documentation (samccann, 16:50:43)

  7. Content Team update (gundalow, 16:52:23)
    1. Brad and pabelanger give an updated on Content Team (gundalow, 16:52:57)
    2. index_of: https://github.com/ansible-collections/ansible.utils (for Plugins that are related to data manipulation will go) (gundalow, 17:05:36)
    3. jillr is now giving an updated on Cloud updates (gundalow, 17:07:18)

  8. Release candidates for stable branches & CHAOS (experimental feedback) (gundalow, 17:16:36)
    1. relrod is now speaking (gundalow, 17:16:47)
    2. Some features intentionally break the world for the greater-good (gundalow, 17:17:19)
    3. Seperate PyPi project & GitHub repository where we can experiment with features (gundalow, 17:26:31)
    4. Maybe a different entry point, ie `ansible-choas-playbook` so you can it installed along side `ansible-base` (gundalow, 17:27:57)

  9. Role Argument Spec Validation (gundalow, 17:30:12)
    1. sdoran and Shrews talking (gundalow, 17:30:21)

  10. BREAK (gundalow, 18:08:50)
  11. Minimum version of Python controller increase (gundalow, 19:00:56)
    1. https://docs.centos.org/en-US/8-docs/managing-userspace-components/assembly_using-appstream/ (noonedeadpunk, 19:07:50)
    2. https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-morning Line 162, please add notes there (gundalow, 19:11:16)

  12. Execution Environments (gundalow, 19:17:53)
    1. maxamillion and Shane talking about Execution Execution Environments (gundalow, 19:18:26)
    2. This does not mean you will be required to use a container to run/use Ansible. EE provides a nice portable Ansible control node as an option. (sdoran, 19:22:26)
    3. https://docs.openstack.org/infra/bindep/readme.html (noonedeadpunk, 19:24:03)
    4. https://github.com/ansible/ansible/issues/69203#issuecomment-663901637 (webknjaz, 19:34:21)

  13. Galaxy Next Gen (gundalow, 19:38:11)
    1. newswangerd is speaking (gundalow, 19:38:46)
    2. https://github.com/ansible/project-config/blob/master/zuul.d/secrets.yaml#L118 for example (pabelanger, 19:48:07)
    3. https://github.com/ansible/project-config/blob/master/zuul.d/jobs.yaml#L140 release job (pabelanger, 19:48:52)
    4. https://github.com/ansible/ansible/pull/69605 https://github.com/ansible/ansible/pull/70303 https://github.com/sivel/ansible-pulp-galaxy-ng (sivel, 20:03:14)
    5. https://github.com/ansible/ansible/pull/69605 | closed, created 2020-05-19T21:02:10Z by sivel: Test ansible-galaxy against pulp/pulp_ansible [affects_2.10,feature,needs_revision,support:community,support:core,test] (github-linkbot, 20:03:15)


Meeting ended at 21:23:03 UTC (full logs).

Action items

  1. gwmngilfen To see if https://api.github.com/users/welcome[bot] type=bot is useful (though will not help if people are using regular user accounts)


Action items, by person

  1. gwmngilfen
    1. gwmngilfen To see if https://api.github.com/users/welcome[bot] type=bot is useful (though will not help if people are using regular user accounts)


People present (lines said)

  1. gundalow (88)
  2. noonedeadpunk (59)
  3. pabelanger (58)
  4. felixfontein (37)
  5. gwmngilfen (29)
  6. geerlingguy (26)
  7. webknjaz (21)
  8. bcoca (15)
  9. cybette (14)
  10. baptistemm (14)
  11. sdoran (12)
  12. dmsimard (12)
  13. misc (9)
  14. sivel (9)
  15. agaffney (7)
  16. zodbot (6)
  17. jrglynn2 (6)
  18. samccann (5)
  19. gabrielzeven (5)
  20. nitzmahone (5)
  21. resmo (4)
  22. aminvakil (4)
  23. cyberpear (4)
  24. github-linkbot (3)
  25. jillr (3)
  26. ktdreyer (3)
  27. tadeboro (3)
  28. apple4ever (3)
  29. wolcen (2)
  30. zbr (2)
  31. maxamillion (2)
  32. andersson007_ (2)
  33. ole88 (2)
  34. TKersten (2)
  35. acozine (2)
  36. Qalthos (1)
  37. ptoal (1)
  38. relrod (1)
  39. abadger1999 (1)
  40. psuboss (1)
  41. shertel (1)
  42. jalexandre (1)
  43. Shrews (1)
  44. mattclay (0)
  45. jborean93 (0)
  46. jimi|ansible (0)
  47. newswangerd (0)
  48. nilashishc (0)
  49. matburt (0)
  50. mkrizek (0)
  51. thaumos (0)


Generated by MeetBot 0.1.4.