ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 18:00:51 UTC (full logs).

Meeting summary

  1. https://github.com/ansible/community/issues/539#issuecomment-701531177 (felixfontein, 18:02:22)
  2. updates (felixfontein, 18:04:31)
    1. community.network 1.2.0 has been released today, community.general 1.2.0 will follow later today (felixfontein, 18:04:43)
    2. there's a new sanity test in ansible-test which makes sure that version_added is never a patch version, and removal versions are never minor or patch versions (felixfontein, 18:05:24)
    3. github.com/ansible/* will be moving from Shippable to Azure Pipelines soon (ie next month or two) (gundalow, 18:08:27)
    4. github.com/ansible-collections/* can continue to use Shippable for a while, though we can move to Azure Pipelines as well and benefit from a much larger node pool compared to what we currently have with Shippable (gundalow, 18:09:38)
    5. For repos using GitHub Actions I don't expect any change (gundalow, 18:09:52)
    6. May start off with `community.crypto` which currently uses Shippable, though doesn't have quiet the traffic as c.general (gundalow, 18:11:15)
    7. Panel interviews for the new Community Team members are happening this week and next (gundalow, 18:15:37)

  3. Criteria for collection inclusion in Ansible 2.11 (gundalow, 18:22:41)
    1. ACTION: samccann to add where to document 2.11 collection requirements to DaWGs agenda (samccann, 18:43:23)
    2. eventual policy should include "when will collections be dropped from the ansible package" too. (abadger1999, 18:43:54)
    3. AGREED: Have a separate repo for the policy. When we vote that the policy is complete enough to start adding new collections for 2.11.0 we'll move it into ansible/ansible at a page location of docs' choosing and archive the initial policy repo. (+7) (felixfontein, 19:02:04)

  4. open floor (felixfontein, 19:26:10)
    1. Contributor Summit etherpad with proposed agenda (please contribute, especially for Thursday :)) https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-october-2020 (cybette, 19:26:21)


Meeting ended at 19:30:38 UTC (full logs).

Action items

  1. samccann to add where to document 2.11 collection requirements to DaWGs agenda


Action items, by person

  1. samccann
    1. samccann to add where to document 2.11 collection requirements to DaWGs agenda


People present (lines said)

  1. felixfontein (105)
  2. abadger1999 (47)
  3. geerlingguy (41)
  4. gundalow (36)
  5. samccann (32)
  6. tadeboro (17)
  7. zodbot (13)
  8. andersson007_ (9)
  9. cyberpear (7)
  10. cybette (4)
  11. gwmngilfen (3)


Generated by MeetBot 0.1.4.