ansible_community_meeting
LOGS
18:00:40 <felixfontein> #startmeeting Ansible Community Meeting
18:00:40 <zodbot> Meeting started Wed Jul 29 18:00:40 2020 UTC.
18:00:40 <zodbot> This meeting is logged and archived in a public location.
18:00:40 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:40 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:46 <felixfontein> so, who's around?
18:00:50 * gundalow waves
18:00:54 <andersson007_> o/
18:00:57 <gundalow> Just finishing up in another meeting
18:00:57 <samccann> \o
18:01:01 <felixfontein> #chair gundalow andersson007_ samccann
18:01:01 <zodbot> Current chairs: andersson007_ felixfontein gundalow samccann
18:01:07 <felixfontein> gundalow: sounds like fun, meetings all the time ;)
18:01:22 <andersson007_> i had 4 ours of meetings today. The day of meetings
18:01:44 <andersson007_> :)
18:01:47 <felixfontein> I fortunately had none, until now :)
18:02:08 <felixfontein> #topic https://github.com/ansible/community/issues/539
18:02:16 <felixfontein> (our agenda issue)
18:02:28 <cyberpear> o/
18:02:34 <felixfontein> #chair cyberpear
18:02:34 <zodbot> Current chairs: andersson007_ cyberpear felixfontein gundalow samccann
18:03:13 <samccann> heh went in late and updated my action items from last week... phew!
18:03:31 <samccann> fwiw you can link directly to any comment on that page
18:03:50 <felixfontein> abadger1999: are you around?
18:03:58 <felixfontein> samccann: I know, but there isn't really something yet
18:04:04 <abadger1999> Sorry, yes I am :-)
18:04:09 <felixfontein> #chair abadger1999
18:04:09 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear felixfontein gundalow samccann
18:04:24 <felixfontein> abadger1999: do you have updates regarding the freeze dates from robyn?
18:04:37 <abadger1999> She was agreeable but I don't think anything got done.
18:05:00 <abadger1999> I'll draft up an email and ask her to review it, then send it out.
18:05:03 <felixfontein> we really need to make announcements soon, and we have so many things we need for that that aren't done yet :)
18:05:06 <felixfontein> sounds good!
18:05:22 <abadger1999> Where should it go?  ansible-devel, post a link to #ansible-devel on irc....
18:05:36 <abadger1999> @action abadger1999 to draft and send a schedule email.
18:05:52 <cyberpear> mailing list should get any announcements, IMO
18:05:54 <felixfontein> #action abadger to draft and send a schedule email.
18:06:03 * acozine waves
18:06:13 <felixfontein> abadger1999: definitely post a link here and in #ansible-devel
18:06:16 <felixfontein> #chair acozine
18:06:16 <zodbot> Current chairs: abadger1999 acozine andersson007_ cyberpear felixfontein gundalow samccann
18:06:36 <abadger1999> cyberpear: <nod>  Which mailing lists ;-)  ansible-devel@ggroups.com I think is a defiite yes.
18:06:47 <abadger1999> should it go to announce list as well?
18:07:07 <felixfontein> I think ansible-devel is enough
18:07:28 <felixfontein> (I'm not sure I'm actually subscribed to the announce one... guess I should do that)
18:07:55 <felixfontein> what's the current state of https://github.com/ansible-collections/overview/pull/90 ?
18:08:05 <felixfontein> [WIP] Collection checklist
18:08:34 <felixfontein> also there's https://github.com/ansible-collections/overview/pull/82, does that need to be merged as well?
18:08:37 <abadger1999> That's a question for gundalow once he is out of his other meeting.
18:09:54 <gundalow> hum, I'd forgotten about #82
18:10:25 <gundalow> I think it could be useful, anyone want to take it over?
18:10:28 <felixfontein> gundalow: just found it when looking at the PR list :)
18:11:01 <abadger1999> #82 looks good to me... cyberpear was it you who was interested in this topic?  (Having terms commonly used defined somewhere)?
18:11:02 <felixfontein> I think it's useful
18:11:12 <felixfontein> needs a rebase though
18:11:26 <cyberpear> yes, definitely a good thing to finally merge
18:11:51 <felixfontein> gundalow: if you don't mind, I can rebase it
18:12:14 <gundalow> felixfontein: that would be great thank you
18:13:12 <abadger1999> Cool.
18:13:30 <felixfontein> #action felixfontein rebase ansible-collections/overview#82
18:14:28 <cyberpear> also 90 would be good to merge.  I'll try to review it today.
18:15:04 <abadger1999> gundalow: What is the status of #90?  How much Work-in-progress is it vs ready for (voting?  merging?)
18:15:08 <felixfontein> maybe something we can discuss here: https://github.com/ansible-collections/overview/pull/90#discussion_r459727230
18:16:03 <felixfontein> I rebased #82. should I add https://github.com/ansible-collections/overview/pull/82#discussion_r445096990 or merge it as-is?
18:16:12 <cyberpear> my guess is it needs some offline reviews, then a summary of points for discussion in a future meeting
18:16:38 <felixfontein> the main problem is that we need that checklist very soon
18:16:42 <cyberpear> "and earlier" makes sense to me
18:16:50 <gundalow> #90 I think the review comments from ~6 days ago make sense, I can add those. Then maybe merge. We can always improve later
18:16:51 <felixfontein> or at least a first version
18:17:01 <gundalow> It's an improvement over what we have today (nothing)
18:17:04 <felixfontein> gundalow: also fine for me
18:17:11 <abadger1999> I am a little concerned about: * Make sure that if a deprecation is added in a collection version that is included in 2.10.x, that the removal itself will only happen in a collection version included in 2.12.0 (or later), but **not** in a collection version included in 2.11.0.
18:17:39 <abadger1999> One of the features of having things in collections is that each collection can develop at its own pace.
18:18:10 <gundalow> abadger1999: yup, good call. That might be something worth discussing now
18:18:21 <gundalow> maybe it needs to be an example
18:18:40 <abadger1999> I'm not sure whether the ansible package interfering with that is good (end users know that modules won't break without a deprecation period announced in the previous ansible package)  or bad (now collection owners have to maintain backwards compat for longer)
18:18:52 <felixfontein> the main question is whether we want that ansible (the end-product) has a non-trivial deprecation period, or whether it cna happen that if you upgrade from 2.10 to 2.11, that something that wasn't deprecated is suddenly gone
18:19:09 <abadger1999> <nod> Yeah.
18:19:24 <abadger1999> I agree, that gets to the heart of the matter.
18:19:35 <felixfontein> if we don't mind this happening, we can simplify this to "stick to semver"
18:19:53 <abadger1999> Also: in which dir4ection is it easier to change later if it turns out we decide we were wrong.
18:20:32 <felixfontein> we can also formulate it as a guideline, instead of a requirement
18:21:44 <abadger1999> <nod> doing it as a should sounds good.
18:21:53 <felixfontein> any other opinions on #82 and https://github.com/ansible-collections/overview/pull/82#discussion_r445096990 ? if not, I'll commit that and then merge
18:22:10 <acozine> +1 to merging
18:22:16 <cyberpear> maybe suggest a deprecation in a 2.10.x release if it must be removed in 2.11, but prefer waiting until 2.12 (for example)
18:22:51 <felixfontein> cyberpear: the first part is semver :)
18:22:57 <acozine> we can always add/update in future and meanwhile some info is better than nothing
18:23:17 <felixfontein> I can create a PR for https://github.com/ansible-collections/overview/pull/90#discussion_r459727230 once #90 is merged, so we can discuss it more in there
18:23:43 <abadger1999> +1 to merge a strawman is easier for people to complain about^W^W propose changes to :-)
18:23:52 <felixfontein> #info #82 is merged
18:23:58 <abadger1999> Thanks!
18:24:22 <felixfontein> thanks fo all who worked on it!
18:24:27 <samccann> woot!
18:24:49 <gundalow> woot, thanks
18:28:12 <felixfontein> gundalow: so you're adding some of the remaining suggestions to #90 and then merge? or what's the plan with #90?
18:29:35 <gundalow> felixfontein: yup, I'll review the suggestions and bulk merge those
18:29:40 <gundalow> infact, let me do that now
18:29:51 <felixfontein> sounds good! :)
18:32:24 <felixfontein> maybe let's make a POLL about that deprecation period statement
18:33:16 <felixfontein> POLL a) we don't care as long as collections stick to semver, b) we SUGGEST they should make sure that removals happen at least two ansible versions after the deprecation (or one, if the deprecation happens in 2.x.0), c) we require that
18:33:36 <abadger1999> b
18:33:41 <felixfontein> b
18:33:56 <cyberpear> b
18:33:56 <abadger1999> I think that's a good balance... we're explaining why it's a good idea but they're still free to do what htey want.
18:33:58 <andersson007_> b
18:34:17 <andersson007_> abadger1999: +1
18:34:32 <felixfontein> #chair
18:34:32 <zodbot> Current chairs: abadger1999 acozine andersson007_ cyberpear felixfontein gundalow samccann
18:34:41 <samccann> b
18:36:11 <felixfontein> gundalow: acozine:
18:36:20 <acozine> sorry
18:36:22 <acozine> catching up now
18:36:24 <felixfontein> np
18:37:02 <acozine> b sounds fine - we can't be too controlling, otherwise we lose the power and flexibility of the collections concept
18:37:30 <felixfontein> #agreed we SUGGEST collections should make sure that removals happen at least two ansible versions after the deprecation (or one, if the deprecation happens in 2.x.0) (6 x yes, 0 x no)
18:37:35 <felixfontein> sounds good :)
18:37:56 <felixfontein> then I'll create a PR once #90 is merged and write that out, and then you all can fix my language ;)
18:38:18 <andersson007_> :D
18:39:04 <felixfontein> once we have the dates and #90 is merged with the follow-up PR, I think we can start creating issues in collection repositories
18:40:07 <felixfontein> #topic https://github.com/ansible-collections/overview/issues/88
18:40:43 <felixfontein> that's some more content for the issue, though that's probably already contained in #90 (have to re-check though(
18:41:52 <samccann> yeah I think that's mostly covered already
18:42:18 <samccann> though do we have that in docs.ansible.com yet?
18:43:08 <felixfontein> which part do you think should be in docs.ansible.com?
18:43:17 <samccann> https://docs.ansible.com/ansible/devel/community/development_process.html#changelogs
18:43:46 <samccann> so this is where we get a bit fuzzy on ansible vs ansible-base
18:44:05 <samccann> I don't know if the existing instructions still apply on ansible-base?
18:44:06 <felixfontein> that doc is more about using changelogs; collections can essentially do what they want, except maybe if they want to be part of ACD
18:44:19 <felixfontein> I think they do
18:44:25 <acozine> yeah, a lot of that community content needs updating to embrace the collections ecosystem
18:45:07 <samccann> so I think we need a section for 'developing collection changelogs that are compatible with Ansible' or something like that
18:45:22 <samccann> maybe we need to move that issue to ansible/ansible?
18:45:41 <samccann> I think it's covered in what y'all have for .rst files in ansible-collection repo
18:49:34 <acozine> I'm going back over the changelog/porting guide processes this afternoon, I can come up with a draft
18:49:51 <felixfontein> sounds good
18:49:59 <felixfontein> acozine: are you also adding docs on the new sections?
18:50:00 <acozine> that will give me a good way to document everything I remind myself of
18:51:03 <acozine> felixfontein: are there more new sections beyond the one on developing collection changelogs that are compatible with Ansible?
18:51:33 <felixfontein> acozine: not that I'm aware of
18:51:48 <acozine> okay, I was worried i'd missed something
18:52:03 <acozine> yeah, I can take care of that, or at least open a PR folks can review and comment on
18:52:58 <felixfontein> sounds good!
18:54:29 <felixfontein> just saw that
18:54:29 <felixfontein> At a minimim ``ansible-test sanity`` MUST be run from the `latest stable ansible-base branch <https://github.com/ansible/ansible/branches/all?query=stable->`_. We suggest to *additionally* run ``ansible-test sanity`` from the ``devel`` branch so that you find out about new linting requirements earlier.
18:54:37 <felixfontein> ooops
18:54:38 <felixfontein> sorry
18:54:43 <felixfontein> just saw that https://github.com/ansible/ansible/pull/70243 is also still open
18:55:39 <acozine> yeah, i read it again and made some suggestions, and we've had a conversation about the wording, not sure if we're all in agreement or not
18:55:48 <acozine> samccann: what are your latest thoughts on that one?
18:56:26 <samccann> I haven't gone back yet to read felixfontein's latest feedback from a few days ago
18:56:55 <samccann> I can look at it after this meeting and see if there are more open issues or if I just need to implement the feedback given
18:57:45 <felixfontein> we have to make sure it says the same as the corresponding part of https://github.com/ansible-collections/overview/pull/90
18:58:57 <samccann> ok I'll compare the two
19:03:07 <felixfontein> sounds good!
19:03:21 <abadger1999> I have the schedule email ready to run by RObyn: https://gist.githubusercontent.com/abadger/fed650e8b40e58c5498b2b38e739edda/raw/db89273136d947a583b8b7d07642137ef2201cac/gistfile1.txt
19:05:55 <felixfontein> abadger1999: sounds good!
19:07:23 <felixfontein> ok, anything else for today?
19:07:32 <felixfontein> #topic open floor
19:07:36 <gundalow> Nothing else from me
19:08:04 <gundalow> abadger1999: is ^ going into a ROADMAP file so we can keep on updating it?
19:08:46 <felixfontein> should we put that roadmap into ansible-build-data/2.10 for now?
19:09:02 <felixfontein> then all 2.10 related files (that aren't on docs.ansible.com) are in one place
19:09:05 <gundalow> acozine: samccann what was your decision on this
19:09:22 <abadger1999> that would be nice... we had briefly talked about it last week I think.
19:09:26 <felixfontein> eventually it would be nice to have a proper docsite or similar for that, but I guess that won't happen before 2.10.0 is out
19:09:39 <abadger1999> someone would probably just need to take that as an action item.
19:09:57 <abadger1999> yeah... lots of changes to our process to make for the 2.11 cycle.
19:09:58 <samccann> my initial feeling is we should treat it the same as we are for portingguide - we have one for ansible-base and one for ansible, and they all live on docs.ansible.com
19:10:24 <samccann> we will 'eventually' find some way to split ansible-base from Ansible, but that's down the road
19:10:39 <abadger1999> samccann: btw, I ran that (separate roadmaps,both on docs.a.c) by dylan and he was +1 to the idea.
19:10:45 <acozine> agreed that separating ansible-base from packaged-ansible when we can is going to make our lives easier in future
19:11:01 <felixfontein> definitely
19:11:34 <acozine> for the roadmap, I think we can put the collections roadmap in the build data for 2.10
19:12:00 <acozine> keeping it together until we figure out where its new home will be
19:12:48 <abadger1999> acozine: Okay, so for 2.10, you want me to just create a file in ansible-community/ansible-build-data:2.10/ ?
19:12:49 <samccann> how would a user interested in the roadmap find it if it's not on docs.ansible.com?
19:13:39 <acozine> oh, I see, these are two aspects of the same question
19:13:52 <acozine> sorry, I keep getting distracted . . .
19:15:02 <acozine> is this correct? We have 2 options: a) include the 2.11 roadmap in the ansible-build-data:2.10/ directory, or b) add it as a separate document on the Roadmaps page on docs.ansible.com
19:15:22 <acozine> and the question is, which is the better approach?
19:15:22 <felixfontein> 2.10
19:15:31 <acozine> heh
19:15:48 <felixfontein> but yes, that are the options
19:15:50 <acozine> that was a typo, or maybe a Freudian slip (2.10 is done now, right?)
19:16:14 <acozine> Okay, I'm with the program now . . .
19:17:08 <acozine> I think we put it in the Roadmaps section, with separate links for ansible-base roadmaps and packaged-ansible roadmaps
19:18:01 <acozine> if we decide one or the other is moving off of docs.ansible.com/ansible, then we can put a link there that says "this section is now only for X, for info on Y roadmaps, see <LINK>"
19:19:03 <felixfontein> sounds good
19:20:08 <abadger1999> Cool... who wants the action item? ;-)
19:20:28 <acozine> action is open a PR from existing material?
19:20:36 <acozine> or create the material then open a PR?
19:20:53 <abadger1999> I can give anyone the content  but I don't have a lot of time to finesse that into a good organization and well written prose.
19:21:21 <abadger1999> acozine: I'm going to be sending out the ansible-2.10 schedule ASAP: https://gist.githubusercontent.com/abadger/fed650e8b40e58c5498b2b38e739edda/raw/db89273136d947a583b8b7d07642137ef2201cac/gistfile1.txt
19:21:23 <acozine> if the content exists, I'm happy to massage it and open a PR if others will review
19:21:40 <acozine> so assign the action item to me
19:21:43 <abadger1999> acozine: (Once I get it approved by robyn)
19:21:49 <acozine> gotcha
19:22:10 <abadger1999> acozine: Cool.  Once robyn approves, I'll ping you in #ansible-docs (or slack if you want).
19:22:22 <acozine> abadger1999: sounds good
19:22:28 <acozine> likely to be today? this week?
19:22:33 <abadger1999> #action acozine to massage the schedule email into a roadmap page once it is approved and sent.
19:22:46 <abadger1999> acozine: I'm hoping today but I just need to get in touch with robyn first.
19:22:54 <acozine> perfect
19:23:46 <abadger1999> Likely if she needs any changes, it will just be tweaks to dates, not to the broad outline of what freezes mean.
19:26:17 <abadger1999> i think that's all for this topic :-)
19:26:34 <felixfontein> good :)
19:26:42 <felixfontein> anything else?
19:27:01 <felixfontein> if not, I guess it's time to end the meeting
19:27:12 <baptiste1m> thanks felixfontein
19:27:40 <felixfontein> #chair baptiste1m
19:27:40 <zodbot> Current chairs: abadger1999 acozine andersson007_ baptiste1m cyberpear felixfontein gundalow samccann
19:27:47 <baptiste1m> nope :)
19:28:00 <acozine> thanks everybody!
19:28:04 <felixfontein> welcome to the club of furniture ;)
19:28:09 <felixfontein> thanks everyone!
19:28:11 <felixfontein> #endmeeting