ansible_community_meeting
MINUTES

#ansible-community: Ansible Community Meeting

Meeting started by gundalow at 18:00:04 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/issues/539 (gundalow, 18:02:20)

  1. Release 1.0.0 of community.general and community.network (gundalow, 18:03:14)
    1. c.general and #c.network need have correctly generated plugin docs before we release 1.0.0 (gundalow, 18:15:47)
    2. https://github.com/ansible-community/antsibull/issues/147 (abadger1999, 18:23:23)
    3. AGREED: c.g and c.n 1.0.0 will be released on Friday, July 31st (felixfontein, 18:36:26)
    4. ACTION: felixfontein write instructions for how to do major release (and maybe also minor / patch releases) for c.g and c.n (felixfontein, 18:36:44)
    5. ACTION: felixfontein announce 1.0.0 date in repo issues (felixfontein, 18:36:54)
    6. ACTION: samcann mention collection docs, 1) what to check for 2) where to report issues 3) that we know c.general is broken 4) anything else on https://github.com/ansible-collections/overview/issues/45 (changes impacting contributors) (samccann, 18:38:49)
    7. ACTION: abadger do not release a new alpha on Thursday July 30th, but wait until Friday July 31st (felixfontein, 18:38:56)
    8. ACTION: samccann acozine republish 2.10 on Fri July 31 (after c.g release an ansible alpha release) (samccann, 18:39:53)
    9. antsibull-docs CLI change: Rename --ansible-base-cache to --ansible-base-source (abadger1999, 18:43:52)
    10. antsibull-build CLI change: Remove the redundant build- prefix from antsibull-build subcommands (abadger1999, 18:44:16)
    11. both antsibull-docs and antsibull-build file format change: Renaming "acd_" fields to "ansible_" and renaming default filenames in the same way. (abadger1999, 18:44:59)
    12. the changes that affect antsibull-docs will operate with backwards compatibility for at least a few weeks [probably until after 2.10.0 is released] (abadger1999, 18:45:55)
    13. ACTION: abadger to get clarification from rbergeron about some of th edates and milestones (abadger1999, 18:52:39)
    14. Question1: Which freeze date determines the major version of collections that will go into Ansible-2.10 (abadger1999 suggests beta freeze date)? (abadger1999, 18:54:02)
    15. Question2: Will either new minor releases or patch releases of collections be allowed between RC1 and GA of 2.10.0 (abadger1999 suggests no, but might need ask to adjust the rc->GA dates in that case)? (abadger1999, 18:55:30)
    16. https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_10.rst should link to the new ansible (add) roadmap (gundalow, 19:01:49)
    17. AGREED: `ansible` roadmap will live alongside ansible-base roadmap (which needs renaming) (gundalow, 19:17:21)

  2. Module versioning (gundalow, 19:18:36)
    1. http://docs.testing.ansible.com/ansible/2.10/collections/wti/remote/cpm_interface_config_module.html#ansible-collections-wti-remote-cpm-interface-config-module (samccann, 19:20:52)
    2. https://github.com/wtinetworkgear/wti-collection/blob/master/wti/remote/plugins/modules/cpm_interface_config.py#L31 (felixfontein, 19:30:01)
    3. https://github.com/ansible/community/issues/521#issuecomment-624153545 (felixfontein, 19:43:47)
    4. ACTION: samccann add to the collection checklist that version_added should not say 2.10, but should say collection version (samccann, 19:46:48)


Meeting ended at 19:55:48 UTC (full logs).

Action items

  1. felixfontein write instructions for how to do major release (and maybe also minor / patch releases) for c.g and c.n
  2. felixfontein announce 1.0.0 date in repo issues
  3. samcann mention collection docs, 1) what to check for 2) where to report issues 3) that we know c.general is broken 4) anything else on https://github.com/ansible-collections/overview/issues/45 (changes impacting contributors)
  4. abadger do not release a new alpha on Thursday July 30th, but wait until Friday July 31st
  5. samccann acozine republish 2.10 on Fri July 31 (after c.g release an ansible alpha release)
  6. abadger to get clarification from rbergeron about some of th edates and milestones
  7. samccann add to the collection checklist that version_added should not say 2.10, but should say collection version


Action items, by person

  1. acozine
    1. samccann acozine republish 2.10 on Fri July 31 (after c.g release an ansible alpha release)
  2. felixfontein
    1. felixfontein write instructions for how to do major release (and maybe also minor / patch releases) for c.g and c.n
    2. felixfontein announce 1.0.0 date in repo issues
  3. rbergeron
    1. abadger to get clarification from rbergeron about some of th edates and milestones
  4. samccann
    1. samccann acozine republish 2.10 on Fri July 31 (after c.g release an ansible alpha release)
    2. samccann add to the collection checklist that version_added should not say 2.10, but should say collection version
  5. UNASSIGNED
    1. samcann mention collection docs, 1) what to check for 2) where to report issues 3) that we know c.general is broken 4) anything else on https://github.com/ansible-collections/overview/issues/45 (changes impacting contributors)
    2. abadger do not release a new alpha on Thursday July 30th, but wait until Friday July 31st


People present (lines said)

  1. felixfontein (123)
  2. gundalow (85)
  3. samccann (58)
  4. abadger1999 (57)
  5. acozine (34)
  6. cyberpear (24)
  7. zodbot (14)
  8. nitzmahone (2)
  9. gwmngilfen (1)
  10. baptistemm (1)
  11. rbergeron (0)
  12. gregdek (0)


Generated by MeetBot 0.1.4.