ansible_contributors_summit
MINUTES

#ansible-community: Ansible Contributors Summit

Meeting started by gundalow at 10:57:51 UTC (full logs).

Meeting summary

    1. Agenda https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020 (gundalow, 10:58:53)
    2. Etherpad https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020 (cybette, 11:08:24)

  1. Etherpad https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020 (felixfontein, 11:08:53)
    1. Now doing Introductions: Who are you (real name & IRC/GitHub). What are you hoping to get from today (gundalow, 11:10:24)
    2. Ansible Code of Conduct https://docs.ansible.com/ansible/latest/community/code_of_conduct.html (gundalow, 11:10:49)
    3. https://drive.google.com/drive/folders/1NDIQlx9olAYSTBfzwquhrFK9bKqP0YSG (gregdek, 11:18:23)
    4. ACTION: cybette actual Angry Spuds https://www.anonymouspotato.com/ (gundalow, 11:31:08)

  2. Recap of what we are doing and why (gundalow, 11:32:45)
    1. Some info on Collections https://github.com/ansible-collections/overview/blob/master/README.rst (gundalow, 11:39:04)

  3. ansible-base (gundalow, 11:44:14)
    1. jimi|ansible is now give an overview of `ansible-base` (gundalow, 11:44:31)
    2. `pip install ansible` will continue to give you a working Ansible setup (Core Engine plus modules). `ansible` depends on the new `ansible-base` package (gundalow, 11:45:14)
    3. use-cases and criteria for modules being kept in `ansible-base` https://github.com/ansible-collections/overview/blob/master/README.rst#q-what-exactly-is-ansible-base-for-and-what-does-it-contain (gundalow, 11:46:58)

  4. new `ansible` package (gundalow, 11:59:53)
    1. You can test this today `pip uninstall ansible --user && pip install ansible==2.10.0a2 --user` (gundalow, 12:02:10)
    2. ACTION: gundalow claim `builtin` https://github.com/ansible/galaxy/issues/2432 (gundalow, 12:02:37)
    3. we are really interested in if this new package "just works" for you. (gundalow, 12:06:34)

  5. Collections in Ansible (gundalow, 12:14:02)
    1. Collections in the Ansible 2.10 package: https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd.in (gundalow, 12:14:07)
    2. IDEA: from geerlingguy -- blog post on ansible 2.10 is coming, here's what we're testing and how you can install / help / etc. (rbergeron, 12:14:09)
    3. Community collections: https://github.com/ansible-collections/ (gundalow, 12:14:31)
    4. Community Collections on Galaxy https://galaxy.ansible.com/community (gundalow, 12:15:18)
    5. https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd.in (gundalow, 12:39:46)
    6. Fedora proven packager policy for reference: https://docs.fedoraproject.org/en-US/fesco/Provenpackager_policy/ (gregdek, 12:47:17)
    7. reminder that there is no ACD, only Ansible :) (gregdek, 12:47:26)

  6. Community Stats (gundalow, 13:02:04)
    1. Now over to gwmngilfen who's giving some details of how we use data and statistics to make informed decisions on Community health (gundalow, 13:02:49)
    2. You can see the growth (in terms of unique contributors) to the collection repos at https://stats.eng.ansible.com/apps/collections/contributors/ (gundalow, 13:13:47)

  7. Meetups (gundalow, 13:45:13)
    1. cybette (who looks after Ansible Meetups, events and outreach) gives an update on meetups (gundalow, 13:45:44)
    2. https://en.wikipedia.org/wiki/Chaos_Communication_Congress ? (gwmngilfen, 13:55:03)
    3. https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020 (rbergeron, 14:22:07)

  8. Unconference Planning (rbergeron, 14:22:38)
    1. https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020 (rbergeron, 14:23:01)
    2. scroll down to Unconference section (rbergeron, 14:23:14)
    3. gregdek elaborated on "how this works" (rbergeron, 14:23:32)
    4. gregdek pitched session on "the bullhorn" (rbergeron, 14:23:48)
    5. carol pitches "virtual conferences" -- even though we can't meet in person, we should keep things going so we can stay connected, and what can we do virtually to make that happen? (rbergeron, 14:25:15)
    6. multiple volunteers for Testing! (rbergeron, 14:27:46)
    7. Gundalow pitches "how to keep community collections moving" (rbergeron, 14:28:21)
    8. ACTION: gundalow to fix Bot so links aren't to master (gundalow, 14:32:25)
    9. rbergeron possibly leading session on improving the proposal process assuming it is later in the day (rbergeron, 14:37:47)
    10. alicia pitching D&I session (rbergeron, 14:37:59)
    11. alicia pitching docs in the new world; what do people want, what strategies should we be adopting, what help do community members need, all topics around documentation (rbergeron, 14:39:11)
    12. robyn gave up on typing all the pitches (rbergeron, 14:51:12)

  9. Community Collections contributor workflow (gundalow, 15:12:52)
    1. kubernetes experinces: 5-6 people driving it (abadger1999, 15:16:04)
    2. kubernetes experiences: focused on kubernetes so testing is easier (abadger1999, 15:16:29)
    3. vision: geerlinguy would like to see large collections like community.general break up in the future (abadger1999, 15:17:30)
    4. community.kubernetes testing (Sanity, Integration, Molecule) https://github.com/ansible-collections/community.kubernetes/blob/master/.github/workflows/ci.yml (gundalow, 15:17:38)
    5. gwmngilfen offering his expertise to help collect and anaylze data about contributions, bugs, and general health (abadger1999, 15:19:05)
    6. ACTION: gwmngilfen to look into activity heatmaps (gwmngilfen, 15:20:06)
    7. ACTION: investigate if we can get Molecule code coverage into codecov.io (gundalow, 15:20:32)
    8. Example Code coverage https://codecov.io/gh/ansible-collections/community.zabbix/tree/master/ansible_collections/community/zabbix/plugins (gundalow, 15:21:30)
    9. These issues and PRs will be closed with a note to say "Move to the `collection:XXX` repo" https://github.com/ansible/ansible/labels/needs_collection_redirect (gundalow, 15:22:35)
    10. geerlinguy excited to see the separation of core and collections when the collection-related issues in ansible/ansible are closed (abadger1999, 15:22:59)
    11. each issue and PR will be closed with a message to look at the PR labels to decide where to move to. (abadger1999, 15:24:01)
    12. a script exists to move prs but not issues. (abadger1999, 15:24:19)
    13. ACTION: cybette to create docs hackathon session for 10am UTC Tue (Issues and PR move) (gundalow, 15:27:23)
    14. about 8 networking collection. All managed by the same team (abadger1999, 15:28:54)
    15. networking team talks to each other every day (abadger1999, 15:29:13)
    16. networking team testing: Has a large matrix of devices and python versions. Easier to manage than when it was in ansible/ansible (abadger1999, 15:30:45)
    17. Example of Grafana's CI running against a matrix of Grafana_version, Python_version, ansible_version: https://github.com/ansible-collections/community.zabbix/blob/master/.github/workflows/plugins.yml#L57-L114 (gundalow, 15:32:35)
    18. https://github.com/ansible-collections/ansible.netcommon/pull/75 Example of tests running on PRs in network collections (Qalthos, 15:33:12)
    19. networking team is closing and redirecting issues manually. (abadger1999, 15:34:29)
    20. taking a set of issues tagged with collection_redirect every week and closing in the ansible/ansible repo and reopening in the network collection repos. (abadger1999, 15:35:09)
    21. Network Team are manually closing & redirecting issues and PRs. The team is working through this list https://github.com/ansible/ansible/issues?q=is%3Aopen+label%3Aneeds_collection_redirect++label%3Anetworking (gundalow, 15:35:10)
    22. networking team handles the issue moving in a one hour meeting every week. (abadger1999, 15:36:00)
    23. at 10amET tomorrow's doc hackathon will work on the wording of this PR close statement to generalize for closing/moving the big batch of stuff still on ansible/ansible - https://github.com/ansible/ansible/issues/70374 (samccann, 15:39:29)
    24. Example of human closing and redirecting new issues & PR https://github.com/ansible/ansible/issues/70374#issuecomment-651362731 (gundalow, 15:41:57)
    25. for a large colection like community.general... Can we do something like: PR gets opened. No one looks at it for (a week). Ask if the PR submitter would like to become a new maintainer. (abadger1999, 15:43:17)
    26. ACTION: For issue/pr relocation need to make it clear that "If this *is* still relevant, please recreate in the new place (gundalow, 15:47:58)

  10. Diversity and Inclusion (gundalow, 15:50:12)
    1. experience for first-time contributors is important in bringing in diverse contributors (acozine, 15:56:18)
    2. D&I slidedeck from mozilla - https://docs.google.com/presentation/d/13UxBGj2lI66SLjl6sp4NE3DH2ndT0k5QM0pPyyzZXuY/edit#slide=id.g3240500814_4_74 (samccann, 15:57:46)
    3. Older Mozilla research https://docs.google.com/presentation/d/1hsJLv1ieSqtXBzd5YZusY-mB8e1VJzaeOmh8Q4VeMio/edit#slide=id.g43d857af8_0177 (gundalow, 15:58:02)
    4. Mozilla: Contributors who received code reviews within 48 hours on their first bug have an exceptionally high rate of returning and contributing. (gundalow, 15:58:14)
    5. Mozilla: Contributors who wait longer than 7 days for code review on their first bug have virtually zero percent likelihood of returning. (gundalow, 15:58:30)
    6. : Showing a contributor the next bug they can work on dramatically improves the odds of contributing. (gundalow, 15:58:40)
    7. https://opensourcesurvey.org/2017/#insights (jillr, 15:59:23)
    8. for PR review I personally like https://sage.thesharps.us/2014/09/01/the-gentle-art-of-patch-review/ (gundalow, 16:03:40)
    9. if you think people aren't using the best (welcoming) language in Ansible (IRC, GitHub, etc, etc) please feel free to ping me directly and I'll happily educate (gundalow, 16:05:27)
    10. #ansible-diversity exists now, all are welcome (gundalow, 16:05:44)
    11. ACTION: gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow (gwmngilfen, 16:11:48)
    12. consider incorporating review guidelines like https://docs.openstack.org/project-team-guide/review-the-openstack-way.html (acozine, 16:12:27)
    13. ACTION: gwmngilfen stratify contributors along more than first/not-first contributor status (gwmngilfen, 16:14:13)
    14. ACTION: acozine to expand https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-and-submit-pull-requests (acozine, 16:15:37)
    15. ACTION: jillr to create GitHub issue for D&I (gundalow, 16:26:40)
    16. ACTION: jillr to add D&I into next issue of The Bullhorn (gundalow, 16:27:01)
    17. https://github.com/ansible/community/wiki/Diversity (jillr, 16:29:32)

  11. Documentation in the new world order (gundalow, 16:30:48)
    1. ACTION: gundalow to speak to gregdek about throwing more $$$ at Shippable (gundalow, 16:33:36)
    2. https://docs.ansible.com/ansible/devel/dev_guide/developing_collections.html# (acozine, 16:40:42)
    3. https://docs.ansible.com/ansible/devel/community/contributing_maintained_collections.html#contributing-maintained-collections (acozine, 16:40:55)
    4. https://docs.ansible.com/ansible/devel/user_guide/collections_using.html (acozine, 16:41:04)
    5. example of how the generated collections docs look - https://toshio.fedorapeople.org/ansible/docsite/collections/ (samccann, 16:50:31)
    6. Docs working group https://github.com/ansible/community/wiki/Docs (cybette, 16:52:54)
    7. https://github.com/ansible-community/antsibull is where the docs pipeline lives (acozine, 16:57:00)
    8. https://puppet.com/docs/puppet/latest/puppet_index.html (baptistemm, 17:03:42)
    9. https://docs.ansible.com/ansible/devel/index.html (samccann, 17:03:49)
    10. Link for Bullhorn Outline issue #6: https://docs.google.com/document/d/1CS8Y6CpBriwyNfL5nwnQ03pQ6bJiAtLJnyqaINnE4x8/edit (gregdek, 17:05:01)

  12. The Bullhorn: The Ansible Community newsletter (gundalow, 17:06:34)
    1. Docs Working Group info: https://github.com/ansible/community/wiki/Docs (acozine, 17:07:07)
    2. gregdek is now talking about the Ansible Bullhorn (gundalow, 17:11:27)
    3. ACTION: cybette to subscribe ansible-devel to The Bullhorn (cybette, 17:13:43)
    4. We want more content on Ansible Working Groups (gundalow, 17:16:54)
    5. ACTION: gregdek add "New Collections" list community.proxysql, community.digitalocean (gundalow, 17:17:39)
    6. ACTION: gregdek will move outline of Bullhorn #6 to ansible/community repo issue (and post that link in the next Bullhorn!) (gregdek, 17:22:52)
    7. IDEA: where to promote The Bullhorn? Templated slide decks for virtual meetups; reddit; twitter (@ansible + individuals); linkedin; etc. (rbergeron, 17:25:41)
    8. ACTION: gregdek Slide template for Virtual Meetups (gundalow, 17:26:50)
    9. https://twitter.com/AnsiBull/status/654991717725138944 (rbergeron, 17:26:59)
    10. ACTION: rbergeron to ask Jim to promote The Bullhorn (gundalow, 17:28:36)
    11. Where do people discuss Ansible https://github.com/ansible/community/issues/525 (gundalow, 17:29:14)
    12. List of Ansible notification modules https://docs.ansible.com/ansible/2.9/modules/list_of_notification_modules.html (gundalow, 17:30:50)
    13. ACTION: gregdek to see if there are AWX, ansible-lint, Molecule updates to include in Bullhorn (gundalow, 17:36:21)

  13. Testing Ansible content (gundalow, 17:50:36)
    1. CI where `community.kubernetes` use Molecule https://github.com/ansible-collections/community.kubernetes/blob/master/.github/workflows/ci.yml#L67-L99 (gundalow, 17:52:58)
    2. https://docs.ansible.com/ansible/latest/dev_guide/testing_running_locally.html#testing-running-locally doesn't say anything about what it's for, how to use it, etc. (geerlingguy, 17:57:02)
    3. ACTION: Google `ansible-test documentation` needs improving (gundalow, 17:57:18)
    4. ACTION: We need some "Getting started with ansible-test" docs in https://docs.ansible.com/ansible/latest/dev_guide/testing.html (gundalow, 17:58:14)
    5. molecule or more complex CI is good for big items like k8 where you have to set up some complexity to test it. (samccann, 17:58:51)
    6. ACTION: Need to document where `ansible-test integration` vs `molecule` (Requiring external infra) is needed (gundalow, 17:58:56)
    7. network collections using zuul (samccann, 17:59:00)
    8. but ansible-test is the baseline that has to pass in general to be sure 'all the things' like docs etc work (samccann, 17:59:23)
    9. ACTION: need to document that ansible-test is for modules & plugins. not for Roles (gundalow, 17:59:54)
    10. molecule also has strong roles support. (samccann, 17:59:54)
    11. ACTION: Maybe write a table of tool vs things they can test. (gundalow, 18:00:28)
    12. ACTION: - consider adding some tidbits re molecule/test inside the collection template in github itself (samccann, 18:02:29)
    13. ACTION: docs: GitHub Actions are good for testing against multiple versions of application (API) under test (Grafana, Zabbix). Shippable is good where you want to test against multiple Operating systems (gundalow, 18:03:01)
    14. some info from geerlingguy on molecule vs ansible-test - https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-molecule and https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-ansible-test (samccann, 18:04:11)
    15. ACTION: Can Molecule generate codecoverage to feed into codecov.io (gundalow, 18:04:40)
    16. github Actions - from the user perspective, is easy to use/pickup. K8 collection is using it. (samccann, 18:07:44)
    17. podman also using github actions (samccann, 18:08:08)
    18. ansible-test, molecule, ansible-lint are tests, zuul, travis, shippable are CIs to run those tests (samccann, 18:14:36)
    19. What to run: ansible-test, ansible-lint, molecule, etc (gundalow, 18:15:06)
    20. scheduling: GitHub Actions, Travis, Zuul, Shippable, etc (gundalow, 18:15:31)
    21. - how 'popular' are each scheduling tool in opensource may influence contributors (aka I know XXX and ansible uses XXX so I can more easily contribute) (samccann, 18:17:09)
    22. zuul is good at cross-project testing (aka a change in nxos collection doesn't break the ios collection etc) (samccann, 18:18:30)
    23. Unit tests are often best for `plugins/module_utils` when you want to test specific functions. Integration tests are often best for `plugins/modules` when you want to validate the interaction of a module on the system (samccann, 18:22:27)
    24. community.internal_test_tools - a collection for containing tools useful for testing collections (samccann, 18:24:29)
    25. ACTION: document `community.internal_test_tools` (what/why) from "Developing collections" and "/dev_guide/" (gundalow, 18:25:22)
    26. collection_template repo, which is what we fork when making new collection repos https://github.com/ansible-collections/collection_template. PR#4 in there update the GitHub Action (gundalow, 18:27:05)
    27. unittest with AnsibleModule framework : https://github.com/ansible/ansible/blob/devel/test/units/module_utils/conftest.py and example using it https://github.com/ansible/ansible/blob/devel/test/units/module_utils/basic/test_exit_json.py (samccann, 18:29:13)

  14. Plans for Ansible Galaxy and it's relationship to Automation Hub (gundalow, 18:30:47)
    1. https://github.com/ansible/galaxy_ng/issues/58 (geerlingguy, 18:31:03)
    2. https://github.com/ansible/galaxy/issues/2253 (geerlingguy, 18:33:02)
    3. https://docs.ansible.com/ansible/devel/dev_guide/migrating_roles.html#migrating-roles (samccann, 18:37:43)

  15. Ending up (gundalow, 18:53:58)
    1. THANK YOU EVERYBODY (gundalow, 18:59:15)
    2. Tue & Wednesday is Hackathon in #ansible-community (gundalow, 18:59:28)
    3. Documentation Hackathon in #ansible-docs 14:00 UTC (gundalow, 18:59:58)
    4. We will have a hackathon on writing some content for The Bullhorn (gundalow, 19:00:14)
    5. next two days is also "Open Office Hours", so feel free to ask any other questions, or more technical PR review stuff (gundalow, 19:01:47)
    6. ACTION: Write summary of Contributor Summit in Bullhorn draft (gundalow, 19:03:29)


Meeting ended at 19:03:42 UTC (full logs).

Action items

  1. cybette actual Angry Spuds https://www.anonymouspotato.com/
  2. gundalow claim `builtin` https://github.com/ansible/galaxy/issues/2432
  3. gundalow to fix Bot so links aren't to master
  4. gwmngilfen to look into activity heatmaps
  5. investigate if we can get Molecule code coverage into codecov.io
  6. cybette to create docs hackathon session for 10am UTC Tue (Issues and PR move)
  7. For issue/pr relocation need to make it clear that "If this *is* still relevant, please recreate in the new place
  8. gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow
  9. gwmngilfen stratify contributors along more than first/not-first contributor status
  10. acozine to expand https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-and-submit-pull-requests
  11. jillr to create GitHub issue for D&I
  12. jillr to add D&I into next issue of The Bullhorn
  13. gundalow to speak to gregdek about throwing more $$$ at Shippable
  14. cybette to subscribe ansible-devel to The Bullhorn
  15. gregdek add "New Collections" list community.proxysql, community.digitalocean
  16. gregdek will move outline of Bullhorn #6 to ansible/community repo issue (and post that link in the next Bullhorn!)
  17. gregdek Slide template for Virtual Meetups
  18. rbergeron to ask Jim to promote The Bullhorn
  19. gregdek to see if there are AWX, ansible-lint, Molecule updates to include in Bullhorn
  20. Google `ansible-test documentation` needs improving
  21. We need some "Getting started with ansible-test" docs in https://docs.ansible.com/ansible/latest/dev_guide/testing.html
  22. Need to document where `ansible-test integration` vs `molecule` (Requiring external infra) is needed
  23. need to document that ansible-test is for modules & plugins. not for Roles
  24. Maybe write a table of tool vs things they can test.
  25. - consider adding some tidbits re molecule/test inside the collection template in github itself
  26. docs: GitHub Actions are good for testing against multiple versions of application (API) under test (Grafana, Zabbix). Shippable is good where you want to test against multiple Operating systems
  27. Can Molecule generate codecoverage to feed into codecov.io
  28. document `community.internal_test_tools` (what/why) from "Developing collections" and "/dev_guide/"
  29. Write summary of Contributor Summit in Bullhorn draft


Action items, by person

  1. acozine
    1. acozine to expand https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-and-submit-pull-requests
  2. cybette
    1. cybette actual Angry Spuds https://www.anonymouspotato.com/
    2. cybette to create docs hackathon session for 10am UTC Tue (Issues and PR move)
    3. cybette to subscribe ansible-devel to The Bullhorn
  3. gregdek
    1. gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow
    2. gundalow to speak to gregdek about throwing more $$$ at Shippable
    3. gregdek add "New Collections" list community.proxysql, community.digitalocean
    4. gregdek will move outline of Bullhorn #6 to ansible/community repo issue (and post that link in the next Bullhorn!)
    5. gregdek Slide template for Virtual Meetups
    6. gregdek to see if there are AWX, ansible-lint, Molecule updates to include in Bullhorn
  4. gundalow
    1. gundalow claim `builtin` https://github.com/ansible/galaxy/issues/2432
    2. gundalow to fix Bot so links aren't to master
    3. gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow
    4. gundalow to speak to gregdek about throwing more $$$ at Shippable
  5. gwmngilfen
    1. gwmngilfen to look into activity heatmaps
    2. gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow
    3. gwmngilfen stratify contributors along more than first/not-first contributor status
  6. jillr
    1. jillr to create GitHub issue for D&I
    2. jillr to add D&I into next issue of The Bullhorn
  7. rbergeron
    1. rbergeron to ask Jim to promote The Bullhorn
  8. UNASSIGNED
    1. investigate if we can get Molecule code coverage into codecov.io
    2. For issue/pr relocation need to make it clear that "If this *is* still relevant, please recreate in the new place
    3. Google `ansible-test documentation` needs improving
    4. We need some "Getting started with ansible-test" docs in https://docs.ansible.com/ansible/latest/dev_guide/testing.html
    5. Need to document where `ansible-test integration` vs `molecule` (Requiring external infra) is needed
    6. need to document that ansible-test is for modules & plugins. not for Roles
    7. Maybe write a table of tool vs things they can test.
    8. - consider adding some tidbits re molecule/test inside the collection template in github itself
    9. docs: GitHub Actions are good for testing against multiple versions of application (API) under test (Grafana, Zabbix). Shippable is good where you want to test against multiple Operating systems
    10. Can Molecule generate codecoverage to feed into codecov.io
    11. document `community.internal_test_tools` (what/why) from "Developing collections" and "/dev_guide/"
    12. Write summary of Contributor Summit in Bullhorn draft


People present (lines said)

  1. gundalow (175)
  2. felixfontein (136)
  3. geerlingguy (113)
  4. samccann (66)
  5. misc (59)
  6. baptistemm (59)
  7. abadger1999 (57)
  8. gwmngilfen (56)
  9. rbergeron (48)
  10. sshnaidm|mtg (47)
  11. acozine (38)
  12. gregdek (36)
  13. sshnaidm|ruck (35)
  14. resmo (29)
  15. zodbot (25)
  16. cybette (23)
  17. jimi|ansible (19)
  18. bcoca (16)
  19. berkhan (13)
  20. shaps (12)
  21. anshulbehl (12)
  22. jillr (12)
  23. andersson007_ (12)
  24. persysted (10)
  25. maxamillion (7)
  26. rosowiecki (5)
  27. madonius (4)
  28. Im0_ (4)
  29. Pilou (4)
  30. shertel (3)
  31. adev (3)
  32. TKersten (3)
  33. cyberpear (2)
  34. Qalthos (1)
  35. sivel (1)
  36. dmsimard (1)
  37. zbr (1)
  38. pabelanger (0)
  39. tcraxs (0)
  40. phips (0)


Generated by MeetBot 0.1.4.