ansible_contributor_summit_2020
MINUTES

#ansible-community: Ansible Contrib Summit 2020 - main stream @ https://bluejeans.com/228187643

Meeting started by gundalow at 10:50:33 UTC (full logs).

Meeting summary

    1. Join via Bluejeans https://bluejeans.com/228187643 (cybette, 10:52:12)

  1. Welcome and intros (gundalow, 11:06:16)
    1. Welcome to the 8th Ansible Contributors Summit (gundalow, 11:07:55)
    2. We know the world has become a bit crazy recently, we really appreciate you taking the time to join us today, which is a real testament to the Ansible Community (gundalow, 11:08:44)
    3. We are now going round the virtual room doing introductions and 1) saying who we are Real & GitHub/IRC names 2) What our interest in Ansible is 3) What we'd like to get from today (gundalow, 11:09:58)
    4. Contributor summit attendance + info for swag: https://forms.gle/Uv9Zdaz7aTAAwtsQ8 (cybette, 11:31:44)

  2. Collection Overview (gregdek, 11:35:22)
    1. Ansible was a single repo, but Ansible module growth has made a single repo less sustainable over time (gregdek, 11:36:40)
    2. Collections What/why/how overview https://github.com/ansible-collections/overview/blob/master/README.rst#where-we-ve-come-from-and-where-we-are-going (gundalow, 11:37:17)
    3. Collections user guide: https://docs.ansible.com/ansible/latest/user_guide/collections_using.html (gundalow, 11:37:56)
    4. Collections development guide: https://docs.ansible.com/ansible/latest/dev_guide/developing_collections.html (gundalow, 11:38:09)
    5. collections allow developers to move at their own speed, but users just want a simple way to consume content without worrying about collection release cycles (gregdek, 11:38:37)
    6. with collections, there is no longer a single global namespace for modules, now each collection has its own namespace (gregdek, 11:40:10)
    7. Fully Qualified Collection Name (FQCN) = The full definition of a module, plugin, or role hosted within a collection, in the form namespace.collection.content_name. For example `ansible.windows.win_command` (gundalow, 11:41:06)
    8. See https://github.com/ansible-collections/overview/blob/master/README.rst#terminology for a full list of Collection Terminology https://github.com/ansible-collections/overview/blob/master/README.rst#terminology (gundalow, 11:41:32)
    9. `ansible/ansible:devel` is now `ansible-base` (ie without most modules) (gundalow, 11:44:41)
    10. With collections, we will introduce the idea of "execution environments", which are container-based virtual environments using ansible-base + ansible-runner + particular collection requirements, and that's what awx/tower will use to run content in the future (gregdek, 11:47:06)
    11. Execution environments allow for different environments for different users/use cases (gregdek, 11:47:27)
    12. Docs on the existing Ansible Tower and collections (not including "execution Environments") https://docs.ansible.com/ansible-tower/latest/html/userguide/projects.html#collections-support (gundalow, 11:47:51)
    13. q: with having namespaces, module names might not be unique different collection might have the same name. In a play we could define all namespaces, what would haben if you add 2 namespaces with a module named identically? (gundalow, 11:49:04)
    14. module and plugins operate a first found. You can always use the FQCN (Fully Qualified Collection Name) ie rather than just using `ping` you could use `cisco.ios.ping` or `ansible.windows.ping` (gundalow, 11:50:30)

  3. Molecule (gundalow, 11:53:34)
    1. zbr (The Molecule Maintainer) is doing a short presentation on Molecule (gundalow, 11:54:39)
    2. https://sbarnea.com/slides/molecule/#/ (gregdek, 11:54:56)
    3. Molecule project is designed to aid in the development and testing of Ansible roles. Molecule provides support for testing with multiple instances, operating systems and distributions, virtualization providers, test frameworks and testing scenarios. (gundalow, 11:55:22)
    4. Molecule documentation https://molecule.readthedocs.io/en/latest/ (gundalow, 11:55:34)
    5. Slides which zbr is going through https://sbarnea.com/slides/molecule/#/ (gundalow, 11:56:22)
    6. If you are interested in Molecule feel free to join #ansible-molecule on IRC (gundalow, 11:56:41)
    7. Molecule has many drivers they can be found at https://github.com/ansible-community?q=molec&type=&language= (gundalow, 11:58:56)
    8. We are looking for people to help with Molecule, and especially the drivers (above URL) (gundalow, 11:59:22)
    9. Q: Can anyone create drivers A: Yes, only needs the Python entry point. If you think the driver maybe useful for others please ask in #ansible-molecule and we can host it (and provide CI) along side the existing drivers in https://github.com/ansible-community?q=molec&type=&language= (gundalow, 12:16:16)

  4. Community Data (gundalow, 12:21:55)
    1. gwmngilfen is now presenting how the Community Team uses data to make decisions (gundalow, 12:23:07)
    2. https://stats.eng.ansible.com/apps/meetups/ then click on `meetup maps` (gundalow, 12:26:31)
    3. https://stats.eng.ansible.com/apps/ (gregdek, 12:26:39)
    4. https://www.stackalytics.com/ (dmellado, 12:33:25)
    5. ACTION: gundalow to add community.network to Collection stats (gundalow, 12:35:13)
    6. ACTION: ikhan to privide gwmngilfen with lists of other repos to add to https://stats.eng.ansible.com/apps/collections/contributors/ (gundalow, 12:35:34)
    7. git tag `pre-ansible-base` in ansible/ansible is the commit before most of the modules got `git rm`'ed (gundalow, 12:44:38)

  5. 15m break, back @ 14:10 UTC (nitzmahone, 12:55:30)
    1. https://stats.eng.ansible.com/apps/collections/contributors/ is the url for the contributor stuff, if anyone missed it above (gwmngilfen, 13:03:49)

  6. Intros part 2 (gundalow, 13:12:23)
    1. Just doing another round of intros for people that have joined the call since we started earlier (gundalow, 13:12:47)

  7. ansible-lint (gundalow, 13:19:46)
    1. zbr is giving an presentation on ansible-lint (gundalow, 13:20:08)
    2. ansible-lint docs: https://docs.ansible.com/ansible-lint/ (gundalow, 13:25:06)
    3. ansible-lint repo: https://github.com/ansible/ansible-lint (gundalow, 13:25:25)

  8. Collections: User Experience (gundalow, 13:41:28)
    1. nitzmahone is now explaining about how we ended up with `ansible-base` (gundalow, 13:41:52)
    2. Definition of ansible-base https://github.com/ansible-collections/overview/blob/master/README.rst#q-what-exactly-is-ansible-base-for-and-what-does-it-contain (gundalow, 13:44:15)
    3. https://github.com/ansible-community/molecule/pull/2620/files (zbr, 13:52:07)
    4. https://github.com/ansible-collections/overview/blob/master/README.rst#terminology (gundalow, 13:54:33)
    5. ACTION: DOCS: "if i used to x to install ansible and do y with it, now i should do z" (install everything; use everything and one new collection; Use a new module in a collection; I don't care about collections I just want to do my day job) (gundalow, 14:18:47)
    6. ACTION: DOCS: Need some diagrams (gundalow, 14:19:00)
    7. ACTION: gundalow to tidyup Collections content migration & ACD (gundalow, 14:27:42)
    8. AGREED: ansible-galaxy cli needs a clear mechanism to install collections via source if the provider makes the source available (gregdek, 14:31:27)
    9. ACTION: extend user-facing documentation of how to install collections (include options beyond ACD) (acozine, 14:33:14)
    10. ACTION: belfast77 / nitzmahone to connect with product management around downstream packaging needs (nitzmahone, 14:34:04)
    11. ACTION: overhaul https://docs.ansible.com/ansible/devel/community/maintainers.html to be a Collection Maintainers page (acozine, 14:34:27)
    12. AGREED: collections changelogs can use any solution maintainers prefer, however, we will develop a procedure for amalgamating them based on one solution (acozine, 14:36:16)

  9. Collections: Development and Contributor (gundalow, 14:37:14)
    1. webknjaz is now explaining how the migration happened from a technical perspective (gundalow, 14:37:50)

  10. 15 minute break (gundalow, 14:46:08)
    1. related issue regarding collection installation https://github.com/ansible/ansible/issues/61680 (shertel, 15:01:11)

  11. new join intros (nitzmahone, 15:03:52)
  12. Collections development status (gundalow, 15:05:45)
    1. Collection Status https://github.com/ansible-collections/overview/blob/master/status.rst (gundalow, 15:08:14)
    2. ACTION: gundalow status.rst update aws repo names (gundalow, 15:09:43)
    3. Most Collections can be found at https://github.com/ansible-collections/ (gundalow, 15:13:47)
    4. https://github.com/ansible-collections/grafana/blob/master/galaxy.yml (gundalow, 15:14:12)
    5. ACTION: gwmngilfen to work on tracking which parts of community.general are getting large (gwmngilfen, 15:17:43)
    6. https://www.ansible.com/logos - > Community vs Red Hat logos (cybette, 15:19:36)

  13. routing/redirection in 2.10 (nitzmahone, 15:21:46)
    1. https://github.com/ansible/ansible/pull/67684 (nitzmahone, 15:21:48)
    2. nitzmahone is now talking about how 2.9 playbooks will still work out of the box when people install Ansible 2.10 (gundalow, 15:22:47)

  14. Collection docs (gundalow, 15:33:37)
    1. acozine is now talking about how Collection documentation will be generated (gundalow, 15:34:06)
    2. 2.9 module index https://docs.ansible.com/ansible/latest/modules/modules_by_category.html <- Based on the directory structure under `lib/ansible/modules/` (before modules were deleted) (gundalow, 15:35:16)
    3. 2.9 Module URL https://docs.ansible.com/ansible/latest/modules/dnsimple_module.html (gundalow, 15:35:52)
    4. Example Collection doc http://docs.testing.ansible.com/collections/purestorage.flasharray/purefa_user_module.html (gundalow, 15:39:59)
    5. Collection level (plugin index) http://docs.testing.ansible.com/collections/purestorage.flasharray/index.html#plugins-in-purestorage-flasharray (gundalow, 15:42:17)
    6. ACTION: DOCS: Table showing old and new URLs (gundalow, 15:42:29)
    7. 2.9 Porting Guides https://docs.ansible.com/ansible/devel/porting_guides/porting_guides.html (gundalow, 15:50:45)
    8. ACTION: Document (best case separate tool chain) that allows people to build module docs outside of Ansible. Or perhaps Collection Explorer. Link to this from dev_guide. https://opendev.org/openstack/tripleo-ansible/src/branch/master/doc/source/_exts/ansible-autodoc.py https://docs.openstack.org/tripleo-ansible/latest/ https://github.com/ansible-community/collection-explorer (gundalow, 15:54:06)
    9. There is a tool that allows you to view locally installed Collection documentation https://github.com/ansible-community/collection-explorer (gundalow, 15:54:32)
    10. https://sensu.github.io/sensu-go-ansible/ (tadeboro, 15:55:01)
    11. ACTION: gundalow Summit (and hackathon) writeup to Reddit (gundalow, 15:58:17)

  15. 15 minute break (gundalow, 16:01:22)
  16. 15min break, back at 16:15UTC (nitzmahone, 16:01:53)
  17. ACD (nitzmahone, 16:17:53)
  18. ACD (the ansible package) bulid process (gundalow, 16:18:06)
    1. https://toshio.fedorapeople.org/ansible/acd/ansible-2.10-file-layout.png (abadger1999, 16:18:50)
    2. abadger1999 is now talking about how the new `ansible` package will be built (gundalow, 16:19:30)
    3. https://toshio.fedorapeople.org/ansible/acd/ansible-2.10-file-layout.png shows what `ansible` package will look like on disk (gundalow, 16:19:47)
    4. ACTION: DOCS: "How do I X" what happens if ansible.posix exists in 2 different directories? (gundalow, 16:22:15)
    5. https://gist.github.com/abadger/1f14caded92117fbd3036842c875701c (abadger1999, 16:23:31)
    6. possible ACD Build process https://gist.github.com/abadger/1f14caded92117fbd3036842c875701c (gundalow, 16:25:21)
    7. https://github.com/abadger/misc-work/tree/master/ansible/build_acd (abadger1999, 16:31:50)
    8. ACD build scripts (work in progress) https://github.com/abadger/misc-work/tree/master/ansible/build_acd (gundalow, 16:32:27)
    9. ACD parse_args (gundalow, 16:33:14)
    10. https://toshio.fedorapeople.org/ansible/acd/acd.in (abadger1999, 16:33:23)
    11. https://toshio.fedorapeople.org/ansible/acd/acd-2.10.build (abadger1999, 16:34:27)
    12. https://toshio.fedorapeople.org/ansible/acd/acd-2.10.0.deps (abadger1999, 16:37:37)
    13. https://toshio.fedorapeople.org/ansible/acd/ (abadger1999, 16:38:42)
    14. ACTION: ACD Testing: testing would be required because without it, someone would break the acd with their own reqs (gundalow, 16:48:10)

  19. Cloud Collections (gundalow, 16:53:24)
    1. jillr now explains how the different Cloud Collections are setup (gundalow, 16:55:16)
    2. Ansible Cloud Team: AWS, VMware (gundalow, 16:55:36)
    3. https://github.com/openstack/ansible-collections-openstack (sshnaidm, 16:59:17)
    4. Release notes & Changelog fragments https://github.com/ansible-collections/overview/issues/18 (gundalow, 16:59:46)
    5. ACTION: jillr check where inventory scripts (not plugins) are (gundalow, 17:04:04)
    6. ACTION: DOCS: search for `contrib` as that directory no longer exist (gundalow, 17:05:56)
    7. ACTION: DOCS: search for `contrib/inventory` in docs to point people to the new individual repos (and new directory structure) (gundalow, 17:07:09)

  20. Community Process for Collections (gundalow, 17:09:38)
    1. https://github.com/ansible-collections/community.general/tree/master/plugins/modules/cloud/misc/ (felixfontein, 17:10:24)
    2. Contributor Collection status https://github.com/ansible-collections/overview/blob/master/status.rst (gundalow, 17:10:25)
    3. Survey link: https://forms.gle/Uv9Zdaz7aTAAwtsQ8 (cybette, 17:18:13)


Meeting ended at 17:20:12 UTC (full logs).

Action items

  1. gundalow to add community.network to Collection stats
  2. ikhan to privide gwmngilfen with lists of other repos to add to https://stats.eng.ansible.com/apps/collections/contributors/
  3. DOCS: "if i used to x to install ansible and do y with it, now i should do z" (install everything; use everything and one new collection; Use a new module in a collection; I don't care about collections I just want to do my day job)
  4. DOCS: Need some diagrams
  5. gundalow to tidyup Collections content migration & ACD
  6. extend user-facing documentation of how to install collections (include options beyond ACD)
  7. belfast77 / nitzmahone to connect with product management around downstream packaging needs
  8. overhaul https://docs.ansible.com/ansible/devel/community/maintainers.html to be a Collection Maintainers page
  9. gundalow status.rst update aws repo names
  10. gwmngilfen to work on tracking which parts of community.general are getting large
  11. DOCS: Table showing old and new URLs
  12. Document (best case separate tool chain) that allows people to build module docs outside of Ansible. Or perhaps Collection Explorer. Link to this from dev_guide. https://opendev.org/openstack/tripleo-ansible/src/branch/master/doc/source/_exts/ansible-autodoc.py https://docs.openstack.org/tripleo-ansible/latest/ https://github.com/ansible-community/collection-explorer
  13. gundalow Summit (and hackathon) writeup to Reddit
  14. DOCS: "How do I X" what happens if ansible.posix exists in 2 different directories?
  15. ACD Testing: testing would be required because without it, someone would break the acd with their own reqs
  16. jillr check where inventory scripts (not plugins) are
  17. DOCS: search for `contrib` as that directory no longer exist
  18. DOCS: search for `contrib/inventory` in docs to point people to the new individual repos (and new directory structure)


Action items, by person

  1. belfast77
    1. belfast77 / nitzmahone to connect with product management around downstream packaging needs
  2. gundalow
    1. gundalow to add community.network to Collection stats
    2. gundalow to tidyup Collections content migration & ACD
    3. gundalow status.rst update aws repo names
    4. gundalow Summit (and hackathon) writeup to Reddit
  3. gwmngilfen
    1. ikhan to privide gwmngilfen with lists of other repos to add to https://stats.eng.ansible.com/apps/collections/contributors/
    2. gwmngilfen to work on tracking which parts of community.general are getting large
  4. ikhan
    1. ikhan to privide gwmngilfen with lists of other repos to add to https://stats.eng.ansible.com/apps/collections/contributors/
  5. jillr
    1. jillr check where inventory scripts (not plugins) are
  6. nitzmahone
    1. belfast77 / nitzmahone to connect with product management around downstream packaging needs
  7. UNASSIGNED
    1. DOCS: "if i used to x to install ansible and do y with it, now i should do z" (install everything; use everything and one new collection; Use a new module in a collection; I don't care about collections I just want to do my day job)
    2. DOCS: Need some diagrams
    3. extend user-facing documentation of how to install collections (include options beyond ACD)
    4. overhaul https://docs.ansible.com/ansible/devel/community/maintainers.html to be a Collection Maintainers page
    5. DOCS: Table showing old and new URLs
    6. Document (best case separate tool chain) that allows people to build module docs outside of Ansible. Or perhaps Collection Explorer. Link to this from dev_guide. https://opendev.org/openstack/tripleo-ansible/src/branch/master/doc/source/_exts/ansible-autodoc.py https://docs.openstack.org/tripleo-ansible/latest/ https://github.com/ansible-community/collection-explorer
    7. DOCS: "How do I X" what happens if ansible.posix exists in 2 different directories?
    8. ACD Testing: testing would be required because without it, someone would break the acd with their own reqs
    9. DOCS: search for `contrib` as that directory no longer exist
    10. DOCS: search for `contrib/inventory` in docs to point people to the new individual repos (and new directory structure)


People present (lines said)

  1. gundalow (155)
  2. gregdek (73)
  3. felixfontein (68)
  4. nitzmahone (53)
  5. abadger1999 (44)
  6. zbr (40)
  7. jpmens (39)
  8. sshnaidm (36)
  9. gwmngilfen (36)
  10. resmo (28)
  11. jtanner (28)
  12. shaps (27)
  13. cybette (26)
  14. rrey (23)
  15. acozine (23)
  16. odyssey4me (22)
  17. dmellado (21)
  18. madonius (20)
  19. fobhep (19)
  20. tadeboro (16)
  21. belfast77 (15)
  22. jimi|ansible (14)
  23. rbergeron (14)
  24. TKersten (13)
  25. zodbot (11)
  26. webknjaz (10)
  27. jillr (7)
  28. ikhan (6)
  29. digigrate_ (5)
  30. mohitmkspy (5)
  31. agaffney (3)
  32. leogallego (3)
  33. misc (3)
  34. mattclay (2)
  35. sshnaidm|off (1)
  36. jhawkesworth (1)
  37. shertel (1)
  38. Goneri (1)
  39. Pilou (0)
  40. digigrate (0)
  41. ganeshrn (0)
  42. phips (0)


Generated by MeetBot 0.1.4.