ansible_community_pr_review
MINUTES

#ansible-community: Ansible Community PR Review

Meeting started by gundalow at 12:00:39 UTC (full logs).

Meeting summary

  1. Bug PR review (gundalow, 12:08:54)
    1. First query https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Apr+is%3Aopen+-label%3Abackport++-label%3Asupport%3Acore+-label%3Asupport%3Acurated+-label%3Anetworking+-label%3Anew_module+-label%3Aaws+-label%3Aazure+-label%3Adocker+-label%3Alinode+-label%3Avmware++-label%3Awindows++label%3Abug+-label%3Aaws+-label%3Aazure+-label%3Adocker+-label%3Alinode+-label%3Anetworking+-label%3Avmware+-label%3Awindows (gundalow, 12:09:16)
    2. https://github.com/ansible/ansible/pull/52699 os_coe_cluster module overrides param labels with wrong behavior #52699 (gundalow, 12:12:21)
    3. https://github.com/ansible/ansible/pull/52685 gcp_compute: use env variables on inventory script (gundalow, 12:17:00)
    4. https://github.com/ansible/ansible/pull/52675 Fix redfish_facts GetPsuInventory command not returning correct output (gundalow, 12:18:30)
    5. https://github.com/ansible/ansible/pull/52668 Use local dummy repo for flatpak_remote integration tests (gundalow, 12:21:11)
    6. ACTION: ask mattclay to review 52668 (gundalow, 12:25:16)
    7. https://app.shippable.com/github/ansible/ansible/runs/108979/77/console (gundalow, 12:28:40)
    8. https://docs.ansible.com/ansible/latest/dev_guide/testing_integration.html (akasurde, 12:29:47)
    9. https://github.com/ansible/ansible/pull/52642 VMware: Refactor guest inventory plugin (gundalow, 12:32:41)
    10. ACTION: lib/ansible/plugins/inventory/vmware needs adding to BOTMETA (gundalow, 12:33:56)
    11. https://github.com/ansible/ansible/pull/52594 redhat_subscription: Exempt register vars from shell expansion (gundalow, 12:38:17)
    12. ACTION: merge 52594 (gundalow, 12:49:06)
    13. We don't merge during today as this allows people to continue to review and add comments. (gundalow, 12:49:24)
    14. https://github.com/ansible/ansible/pull/52553 Add Hetzner Cloud Inventory Plugin (gundalow, 12:50:03)
    15. ACTION: See if plugins/inventory have some built-in for reading env, if so update https://docs.ansible.com/ansible/devel/plugins/inventory.html (gundalow, 13:07:40)
    16. https://github.com/ansible/ansible/pull/52574 postgresql_privs change fail to warn if role(s) does not exist (gundalow, 13:08:03)
    17. https://github.com/ansible/ansible/pull/52564 pids: case insensitive string comparison for process names (gundalow, 13:26:55)
    18. ACTION: merge 52564 (no backport, new in 2.8) (gundalow, 13:30:00)
    19. https://github.com/ansible/ansible/pull/52452 osx_defaults: refactor (gundalow, 13:31:01)
    20. https://github.com/ansible/ansible/pull/52234 Fix reviews issues for scaleway_lb (gundalow, 13:38:01)
    21. ACTION: merge 52234 (no backport) (gundalow, 13:43:06)
    22. https://github.com/ansible/ansible/pull/52166 Fix idempotence in rabbitmq_plugin (gundalow, 13:43:28)
    23. ACTION: merge & backport 52166 (gundalow, 13:48:49)
    24. https://github.com/ansible/ansible/pull/52721 identity: Issue warning if GSSAPI parameters can't be used (gundalow, 13:50:06)
    25. ACTION: 52721 merge (no backport) (gundalow, 13:54:21)
    26. https://github.com/ansible/ansible/pull/52117 archive: Fix empty files to dest (gundalow, 13:55:28)
    27. https://github.com/ansible/ansible/pull/52234#pullrequestreview-206316858 (dag, 13:59:15)
    28. https://github.com/ansible/ansible/pull/52117 archive: Fix empty files to dest (gundalow, 14:00:16)
    29. https://github.com/ansible/ansible/pull/52004 terraform: patch state 'planned' outputs and perform minor refactor (gundalow, 14:05:55)
    30. https://github.com/ansible/ansible/pull/36811 Fixed lvol ValueError with float size. (gundalow, 14:11:04)
    31. ACTION: review and possibly merge 36811 (gundalow, 14:21:21)
    32. ACTION: merge 52004 (gundalow, 14:23:15)
    33. https://github.com/ansible/ansible/pull/51953 onepassword_facts bug fixes (gundalow, 14:23:39)
    34. https://github.com/ansible/ansible/pull/45355 mysql_user: fix compatibility issues with various MySQL/MariaDB versions (gundalow, 14:30:21)
    35. https://github.com/ansible/ansible/pull/51938 rhsm_repository: Properly handle no repos (gundalow, 14:50:49)
    36. ACTION: merge 51938 & backport once changelog has been added (gundalow, 14:52:26)
    37. https://github.com/ansible/ansible/pull/51916 extra_args_precommand parameter added to zypper_repository module (gundalow, 14:52:58)
    38. ACTION: merge 51916 (gundalow, 14:57:20)
    39. https://github.com/ansible/ansible/pull/51721 flatpak_remote: Fixing out of index error (gundalow, 15:01:29)
    40. https://github.com/ansible/ansible/pull/51721#issuecomment-464827401 (bmalynovytch[m], 15:08:18)
    41. https://github.com/ansible/ansible/pull/51594 crypttab: Trim trailing newlines (gundalow, 15:11:54)
    42. https://github.com/ansible/ansible/pull/51594 crypttab: Trim trailing newlines (gundalow, 15:14:08)
    43. ACTION: merge & backport (with changelog) 51594 (gundalow, 15:15:17)
    44. https://github.com/ansible/ansible/blob/d7f334b92164775b51e386dd3fe62e1466e0184a/lib/ansible/modules/system/crypttab.py#L245 (bmalynovytch[m], 15:15:55)
    45. https://github.com/ansible/ansible/pull/51541 lxd_container fix to check for snap package install unix.socket (gundalow, 15:16:03)
    46. ACTION: see if 51541 has +1's and merge if needed (gundalow, 15:21:13)
    47. https://github.com/ansible/ansible/pull/51505 https://github.com/ansible/ansible/pull/51505 (gundalow, 15:24:52)
    48. https://github.com/ansible/ansible/pull/51130 Update filetree.py to allow lists as input (gundalow, 15:27:00)
    49. ACTION: gundalow review BOTMETA and add (lookup) plugin maintainers (gundalow, 15:31:11)
    50. https://github.com/ansible/ansible/pull/51064 fix(rabbitmq_plugin): fixed an issue, when module successfully reports installation of non existing plugins (gundalow, 15:36:43)
    51. ACTION: merge 51064 (gundalow, 15:41:21)
    52. https://github.com/ansible/ansible/pull/50763 Fix Grafana dashboard overwriting (gundalow, 15:45:22)
    53. ACTION: 24550 check CI status and merge once stale_ci has been removed (gundalow, 15:47:42)
    54. ACTION: merge 49981 (gundalow, 16:42:04)
    55. https://github.com/ansible/ansible/pull/49943 Fix netbox url with string concat (gundalow, 16:43:16)
    56. ACTION: review, merge, add comment about backport on 49776 (gundalow, 16:44:42)
    57. we've covered 52721 - 49665, which takes us to last PR review (19th Dec 2018) (gundalow, 16:46:59)

  2. Docs PR review (gundalow, 16:47:05)
    1. Docs PRs https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Apr+is%3Aopen+label%3Adocs+-label%3Awip+sort%3Acreated-asc+ (gundalow, 16:48:48)
    2. ACTION: merge 24550 (gundalow, 16:50:26)
    3. https://github.com/ansible/ansible/pull/13620 update_json for module intermediate comm (gundalow, 16:51:21)
    4. https://github.com/ansible/ansible/pull/39114 Adding haversine filter - mathstuff.py (gundalow, 16:59:26)
    5. https://github.com/ansible/ansible/pull/39174 Passing environmental variable to task definition (gundalow, 17:11:18)
    6. https://github.com/ansible/ansible/pull/37080 Environment file feature (gundalow, 17:13:50)
    7. https://github.com/ansible/ansible/pull/42775 (acozine, 17:50:34)
    8. ACTION: - verify output on https://github.com/ansible/ansible/pull/43993/files and merge (samccann, 18:18:50)
    9. ACTION: gundalow to create fresh https://github.com/ansible/ansible/pull/44986 and use `C(...)` (gundalow, 18:22:50)
    10. https://github.com/ansible/ansible/blob/devel/lib/ansible/modules/cloud/google/gcp_compute_network_facts.py#L152 (samccann, 18:32:02)
    11. ACTION: merge 52553 (gundalow, 18:40:08)
    12. ACTION: review docs portion and merge 49006 (samccann, 18:46:13)
    13. ACTION: gundalow to create new PR to replace 49705 (gundalow, 18:54:09)
    14. ACTION: merge 50204 (samccann, 19:01:12)
    15. ACTION: - add docs review to https://github.com/ansible/ansible/pull/52355 (samccann, 19:34:00)


Meeting ended at 19:40:22 UTC (full logs).

Action items

  1. ask mattclay to review 52668
  2. lib/ansible/plugins/inventory/vmware needs adding to BOTMETA
  3. merge 52594
  4. See if plugins/inventory have some built-in for reading env, if so update https://docs.ansible.com/ansible/devel/plugins/inventory.html
  5. merge 52564 (no backport, new in 2.8)
  6. merge 52234 (no backport)
  7. merge & backport 52166
  8. 52721 merge (no backport)
  9. review and possibly merge 36811
  10. merge 52004
  11. merge 51938 & backport once changelog has been added
  12. merge 51916
  13. merge & backport (with changelog) 51594
  14. see if 51541 has +1's and merge if needed
  15. gundalow review BOTMETA and add (lookup) plugin maintainers
  16. merge 51064
  17. 24550 check CI status and merge once stale_ci has been removed
  18. merge 49981
  19. review, merge, add comment about backport on 49776
  20. merge 24550
  21. - verify output on https://github.com/ansible/ansible/pull/43993/files and merge
  22. gundalow to create fresh https://github.com/ansible/ansible/pull/44986 and use `C(...)`
  23. merge 52553
  24. review docs portion and merge 49006
  25. gundalow to create new PR to replace 49705
  26. merge 50204
  27. - add docs review to https://github.com/ansible/ansible/pull/52355


Action items, by person

  1. gundalow
    1. gundalow review BOTMETA and add (lookup) plugin maintainers
    2. gundalow to create fresh https://github.com/ansible/ansible/pull/44986 and use `C(...)`
    3. gundalow to create new PR to replace 49705
  2. UNASSIGNED
    1. ask mattclay to review 52668
    2. lib/ansible/plugins/inventory/vmware needs adding to BOTMETA
    3. merge 52594
    4. See if plugins/inventory have some built-in for reading env, if so update https://docs.ansible.com/ansible/devel/plugins/inventory.html
    5. merge 52564 (no backport, new in 2.8)
    6. merge 52234 (no backport)
    7. merge & backport 52166
    8. 52721 merge (no backport)
    9. review and possibly merge 36811
    10. merge 52004
    11. merge 51938 & backport once changelog has been added
    12. merge 51916
    13. merge & backport (with changelog) 51594
    14. see if 51541 has +1's and merge if needed
    15. merge 51064
    16. 24550 check CI status and merge once stale_ci has been removed
    17. merge 49981
    18. review, merge, add comment about backport on 49776
    19. merge 24550
    20. - verify output on https://github.com/ansible/ansible/pull/43993/files and merge
    21. merge 52553
    22. review docs portion and merge 49006
    23. merge 50204
    24. - add docs review to https://github.com/ansible/ansible/pull/52355


People present (lines said)

  1. gundalow (291)
  2. samccann (96)
  3. acozine (83)
  4. bmalynovytch[m] (70)
  5. bcoca (46)
  6. akasurde (31)
  7. dag (24)
  8. zodbot (21)
  9. LukasKaemmerling (18)
  10. webknjaz (15)
  11. alongchamps (14)
  12. cabral404 (14)
  13. resmo (14)
  14. akasurde_ (11)
  15. sivel (6)
  16. themroc (6)
  17. hvtuananh (6)
  18. orthanc (6)
  19. winem_ (6)
  20. mrproper (5)
  21. moshloop_ (5)
  22. felixfontein (4)
  23. ironfroggy (2)
  24. dbpiv (2)
  25. navalkp (2)
  26. stroobl (2)
  27. baptistemm_ (1)
  28. ezmac (1)
  29. Pilou (1)
  30. kkao07 (1)
  31. bmalynovytch (1)


Generated by MeetBot 0.1.4.