ansible_community_pr_review
MINUTES

#ansible-community: Ansible Community PR Review

Meeting started by gundalow at 09:01:34 UTC (full logs).

Meeting summary

    1. For the general community PR review days we will be ignoring anything that has a Working Group (https://docs.ansible.com/ansible/devel/community/communication.html#working-groups) as through 2019 we will have dedicated Working Group review sessions (gundalow, 09:06:20)
    2. This is all very informal. Please do ask questions, if you are confused by something, chances are others are. We will go through PR by PR and we will use the MeetingBot to track what needs merging. This allows other people to add comments through the day (gundalow, 09:08:20)
    3. Thank you all that are here, for our second big PR review days. Today we will be focusing on `bugfix` PRs. (gundalow, 09:09:02)

  1. pr:bug `is:pr is:open -label:backport -label:support:core -label:support:curated -label:networking -label:new_module -label:aws -label:azure -label:docker -label:linode -label:vmware -label:windows label:bug -label:aws -label:azure -label:docker -label:linode -label:networking -label:vmware -label:windows` (gundalow, 09:09:53)
    1. Starting with https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Apr+is%3Aopen+-label%3Abackport++-label%3Asupport%3Acore+-label%3Asupport%3Acurated+-label%3Anetworking+-label%3Anew_module+-label%3Aaws+-label%3Aazure+-label%3Adocker+-label%3Alinode+-label%3Avmware++-label%3Awindows++label%3Abug+-label%3Aaws+-label%3Aazure+-label%3Adocker+-label%3Alinode+-label%3Anetworking+-label%3Avmware+-label%3Awindows (gundalow, 09:10:08)
    2. https://github.com/ansible/ansible/pull/50134 (gundalow, 09:11:40)
    3. Use GitHub to provide feedback so it's tracked. IRC is for general discussion (gundalow, 09:16:46)
    4. ACTION: merge and backport 50134 (gundalow, 09:20:56)
    5. Giving details of what you've tested, or what type of review comments you've given allow an informed decision to be made (gundalow, 09:32:44)
    6. ACTION: gundalow 50103 update BOTMETA for inventory (gundalow, 09:38:49)
    7. ACTION: merge 50103, request backport (gundalow, 09:41:59)
    8. ACTION: 50076 merge once it's got a changelog (gundalow, 09:45:03)
    9. Being mindful of user experience (backwards compatibility) is an import thing in reviews (gundalow, 09:55:18)
    10. ACTION: 50025 merge + backport once changelog added (gundalow, 10:03:24)
    11. ACTION: merge 49952, ask for backport inc changelog (gundalow, 10:15:02)
    12. ACTION: gundalow inventory scripts (and plugins) are not getting labels, or pinging authors (gundalow, 10:23:51)
    13. ACTION: 49884 merge once it's got a changelog (and possibly backport) (gundalow, 10:28:42)
    14. https://xkcd.com/1296/ (gundalow, 10:38:25)
    15. https://github.com/theforeman/foreman-ansible-modules (akasurde, 10:43:24)
    16. ACTION: 49731 need to look code as whole and then merge (akasurde, 10:53:28)
    17. ACTION: 49723 requested for unit test, code LGTM (akasurde, 10:58:02)
    18. ACTION: 49705 added a note for updating documentation fragement (akasurde, 11:08:26)
    19. ACTION: 49665 added comments for PR author to address (akasurde, 11:22:05)
    20. MySQL needs some maintianers (gundalow, 12:00:02)
    21. ACTION: review and maybe merge 48597 (gundalow, 13:18:20)
    22. ACTION: gundalow remove afternburn https://github.com/ansible/ansible/pull/48558#issuecomment-446642255 (gundalow, 13:24:51)
    23. ACTION: merge 50134 (gundalow, 13:36:34)
    24. ACTION: merge 48168 (gundalow, 14:06:04)
    25. https://github.com/ansible/ansible/blob/013f69477a37a2b353a4680deaa118fa8ecd3d35/lib/ansible/modules/cloud/misc/proxmox_kvm.py#L575 (bob_cheesey, 14:12:16)
    26. ACTION: merge 48558 (gundalow, 14:42:40)

  2. Docs PRs (gundalow, 16:18:37)
    1. https://github.com/ansible/ansible/pull/45396 (acozine, 17:03:55)
    2. Thanks everybody! (gundalow, 18:55:32)


Meeting ended at 18:55:34 UTC (full logs).

Action items

  1. merge and backport 50134
  2. gundalow 50103 update BOTMETA for inventory
  3. merge 50103, request backport
  4. 50076 merge once it's got a changelog
  5. 50025 merge + backport once changelog added
  6. merge 49952, ask for backport inc changelog
  7. gundalow inventory scripts (and plugins) are not getting labels, or pinging authors
  8. 49884 merge once it's got a changelog (and possibly backport)
  9. 49731 need to look code as whole and then merge
  10. 49723 requested for unit test, code LGTM
  11. 49705 added a note for updating documentation fragement
  12. 49665 added comments for PR author to address
  13. review and maybe merge 48597
  14. gundalow remove afternburn https://github.com/ansible/ansible/pull/48558#issuecomment-446642255
  15. merge 50134
  16. merge 48168
  17. merge 48558


Action items, by person

  1. gundalow
    1. gundalow 50103 update BOTMETA for inventory
    2. gundalow inventory scripts (and plugins) are not getting labels, or pinging authors
    3. gundalow remove afternburn https://github.com/ansible/ansible/pull/48558#issuecomment-446642255
  2. UNASSIGNED
    1. merge and backport 50134
    2. merge 50103, request backport
    3. 50076 merge once it's got a changelog
    4. 50025 merge + backport once changelog added
    5. merge 49952, ask for backport inc changelog
    6. 49884 merge once it's got a changelog (and possibly backport)
    7. 49731 need to look code as whole and then merge
    8. 49723 requested for unit test, code LGTM
    9. 49705 added a note for updating documentation fragement
    10. 49665 added comments for PR author to address
    11. review and maybe merge 48597
    12. merge 50134
    13. merge 48168
    14. merge 48558


People present (lines said)

  1. gundalow (210)
  2. akasurde (47)
  3. bob_cheesey (31)
  4. winem_ (29)
  5. acozine (28)
  6. felixfontein (25)
  7. bcoca (25)
  8. zodbot (17)
  9. shaps (16)
  10. resmo (10)
  11. rbarlik (6)
  12. fridim (5)
  13. navalkp (4)
  14. jhawkesworth_ (3)
  15. davegarath (3)
  16. terbolous (2)
  17. robertgwilliam (2)
  18. jtanner (2)
  19. michaelkaye (1)
  20. bartmon (1)
  21. xenlo (0)


Generated by MeetBot 0.1.4.