ansible_azure_working_group
LOGS
00:02:17 <Kylie_> #startmeeting ansible_azure_working_group
00:02:18 <zodbot> Meeting started Thu Jul 19 00:02:17 2018 UTC.
00:02:18 <zodbot> This meeting is logged and archived in a public location.
00:02:18 <zodbot> The chair is Kylie_. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:18 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:02:28 <Kylie_> #chair yuwei, jborean93
00:02:28 <zodbot> Current chairs: Kylie_ jborean93 yuwei
00:02:39 <jborean93> Matt won't be here this week
00:02:44 <jborean93> he's at a conference today and tomorrow
00:03:02 <Kylie_> Ok.
00:03:02 <yungezz> Hello
00:03:20 <Kylie_> So we have Jordan, Yuwei and Catherine now. Matt will not be here today.
00:03:28 <yungezz> Ok
00:03:35 <Kylie_> #topic key vault
00:03:38 <jborean93> sorry for my tardiness with the reviews
00:03:47 <jborean93> had Monday and Tuesday off and things built up a bit
00:04:58 <jborean93> I've only briefly skimmed the document you sent yesterday
00:05:04 <Kylie_> Jordan, Catherine send out design doc for key vault. One is to change Ansible parsing; the other is to add a lookup plugin.
00:05:31 <Kylie_> How do you think? Catherine, feel free jump in here.
00:05:52 <jborean93> The Ansible parsing would require some talk with Matt and maybe the other internal teams. I'm not too sure how that mechanism really works and how we want to expose that to end users
00:06:09 <yungezz> I have 2 tested pr ready  also for it
00:06:23 <jborean93> For https://github.com/ansible/ansible/pull/42295, I'm sure may change based on the cloud auth inventory work that is going on for 2.7
00:06:33 <yungezz> I will send samples on how to use it
00:07:16 <jborean93> This may be something that should be part of an Ansible proposal and brought forward to the core team
00:07:20 <yungezz> Can you share more details about cloud authority?
00:07:28 <jborean93> s/core team/ansible meetings/
00:08:01 <jborean93> Here is the proposal for cloud auth https://github.com/ansible/proposals/issues/24
00:08:02 <yungezz> I heard it several times,but not know how to use it or support it
00:08:10 <yungezz> Thx
00:08:14 <jborean93> it's not in yet, still in development for 2.7
00:08:36 <jborean93> I believe this is the newer proposal https://github.com/ansible/proposals/issues/90
00:08:54 <yungezz> I can see how to update my plugin to follow cloud authentication
00:09:57 <jborean93> The vault integration side probably needs further input from some other people in the core team
00:10:16 <Kylie_> Jordan, what is your opinion for the solution https://github.com/ansible/ansible/pull/42290?
00:10:21 <yungezz> For parsing part, do you have idea is there external contributions before?
00:10:48 <jborean93> I haven't seen any before but I've never worked in that area of Ansible
00:10:58 <yungezz> Jordan means need core team info
00:11:04 <jborean93> So I'm not sure whether the intent was to expose that to end users right now
00:11:13 <yungezz> Ok
00:11:14 <jborean93> usually if we want to do that, we make it a plugin
00:11:52 <jborean93> AFAIK most 3rd party vault integrations are done through lookups
00:12:36 <yungezz> Plugin is lightweight but not so straight forward to user, so we investigate parsing
00:12:47 <yungezz> Could you give an example
00:12:56 <jborean93> yea, that's hopefully what the cloud auth stuff is hoping to simplify a bit
00:13:07 <yungezz> Ok
00:13:15 <jborean93> I found the hardest part is passing in the credentials required to authenticate with the service
00:13:29 <yungezz> So my follow up is to look at cloud Authenticator
00:13:51 <yungezz> Yes, that’s what MSI resolved and good at
00:14:03 <yungezz> No need extra user credentials
00:14:27 <jborean93> I'm not sure what Matt may have in mind, he would probably reply to the email when he has time with his thoughts
00:14:36 <yungezz> Ok
00:14:47 <yungezz> Thanks Jordan
00:15:33 <yungezz> @Kylie_: what’s next topic?
00:16:25 <Kylie_> Double confirm the process. Should we also file a proposal by following the format of https://github.com/ansible/proposals/issues/90? Or should we reply our ideas on https://github.com/ansible/proposals/issues/90?
00:17:01 <jborean93> if you want to discuss the cloud auth stuff in general I would comment on that proposal
00:17:11 <jborean93> ryansb is working on that for this release
00:17:36 <yungezz> Let’s look at what cloud auth first, to see if it’s related with keyvault integration
00:18:00 <jborean93> If you want to talk about adding the vault parser as in https://github.com/ansible/ansible/pull/42290, then I would say a proposal would be a good first step
00:18:01 <Kylie_> #topic Ansible 2.7 plan
00:18:24 <Kylie_> Understand. Thank you Jordan.
00:18:34 <yungezz> Ok thanks
00:18:38 <Kylie_> https://docs.ansible.com/ansible/devel/roadmap/ROADMAP_2_7.html
00:19:00 <Kylie_> So 2.7 will code freeze on September 13. Right?
00:20:06 <Kylie_> We would like to have new features for web App, route table, application gateway, facts and CDN/Traffic Manager for Web App scenario catch up 2.7. It seems we have only less than 2 months to review them and merge them if review pass.
00:20:06 <jborean93> yep for community stuff it is the 13th
00:20:24 <jborean93> core is the 6th but that shouldn't be any of your stuff
00:20:59 <Kylie_> Including Key Vault Catherine proposed,  Azure stack and Inventory performance Matt are working on.
00:21:11 <yungezz> Lots of staff
00:21:22 <Kylie_> If we propose vault parser, it should be 6th.
00:21:31 <yungezz> Yes
00:21:53 <jborean93> parser would probably be included in core, it's a fine line with a few other stuff but usually we turn a blind eye to the Azure stuff
00:22:45 <jborean93> As long as the change isn't massive we are usually find with pushing Azure stuff to community
00:23:07 <yungezz> Even changing core code?
00:23:40 <jborean93> probably depends on what it changes and the scope
00:24:07 <jborean93> Best bet is to have your stuff ready before the 9th
00:24:18 <Kylie_> I see. Thank you Jordan.
00:25:25 <Kylie_> Then your effort to review new modules are important. I also could raise this needs (more bandwidth of you and Matt are needed to review PRs for new modules).
00:25:43 <Kylie_> #topic PR
00:26:26 <jborean93> Can you give me 2 PRs you think are the most important to look at. I will review them after lunch today
00:27:17 <Kylie_> I would like to prioritize below 2 first.
00:27:19 <Kylie_> https://github.com/ansible/ansible/pull/38279#issuecomment-405493445
00:28:23 <Kylie_> This one was submitted by external contributor. Zim put much effort to help him improve the PR. We really would like to encourage external contributor continue to contribute to Ansible/Azure.
00:28:27 <yungezz> I m back
00:28:38 <jborean93> ok, that will be the first one after lunch
00:29:07 <Kylie_> The other one is https://github.com/ansible/ansible/pull/41683 . This fix will help a customer scenario.
00:30:05 <jborean93> if it is a bugfix, the changes are mimimal and tests pass, feel free to merge those
00:30:44 <yungezz> Nice
00:31:39 <yungezz> Since previously we add a objectid lookup plugin
00:31:42 <Kylie_> Catherine, how do you think about 41683? Could we merge it directly? Or you still need Jordan take a look?
00:31:52 <yungezz> Per Matt clay suggestion
00:31:56 <yungezz> I think we can go merge it
00:32:28 <jborean93> yep, I remember that, sounds good to merge that as it is now, considering the lookup plugin is just for the test (and is in the test folder)
00:32:34 <yungezz> Let me ping Zim for it
00:32:40 <yungezz> Thx
00:33:12 <Kylie_> Ok. Thank you. Then Jordan, can you please help see PRs for Web App? In fact, you need to take care of below 2 which are for Web App scenario.
00:33:16 <Kylie_> webapp https://github.com/ansible/ansible/pull/40005
00:33:16 <Kylie_> app service plan https://github.com/ansible/ansible/pull/40906
00:33:59 <Kylie_> #action jborean93, review https://github.com/ansible/ansible/pull/38279#issuecomment-405493445
00:34:08 <jborean93> will do that today
00:34:23 <Kylie_> #action jborean93, review webapp https://github.com/ansible/ansible/pull/40005 and https://github.com/ansible/ansible/pull/40906.
00:34:55 <Kylie_> Thank you. We still have below 3 PRs. Please help review them after you complete above ones. Thanks.
00:34:58 <Kylie_> autoscale: https://github.com/ansible/ansible/pull/41533
00:34:58 <Kylie_> 
00:34:58 <Kylie_> route table: https://github.com/ansible/ansible/pull/41175
00:34:58 <Kylie_> 
00:34:58 <Kylie_> app gateway: https://github.com/ansible/ansible/pull/39940
00:35:11 <yungezz> Thanks
00:35:12 <jborean93> will do
00:35:16 <Kylie_> Any other topic?
00:35:28 <yungezz> No from my side
00:35:51 <yuwei> me neither
00:36:12 <Kylie_> Ok. Thank you all. Then leave time to Jordan for reviewing topics:).
00:36:16 <Kylie_> #endmeeting