rdo_meeting_(2016-01-06)
LOGS
15:00:41 <chandankumar> #startmeeting RDO meeting (2016-01-06)
15:00:41 <zodbot> Meeting started Wed Jan  6 15:00:41 2016 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:41 <zodbot> The meeting name has been set to 'rdo_meeting_(2016-01-06)'
15:00:51 <chandankumar> \o/
15:00:52 <rbowen> Hullo, folks!
15:00:57 <chandankumar> #chair rbowen
15:00:57 <zodbot> Current chairs: chandankumar rbowen
15:00:57 <elmiko> hi
15:01:03 <number80> o/
15:01:06 <chandankumar> #chair elmiko number80
15:01:06 <zodbot> Current chairs: chandankumar elmiko number80 rbowen
15:01:16 <jruzicka> welcome to the future
15:01:24 <chandankumar> #chair jruzicka
15:01:24 <zodbot> Current chairs: chandankumar elmiko jruzicka number80 rbowen
15:01:48 <social> \o/
15:01:53 <chandankumar> #chair social
15:01:53 <zodbot> Current chairs: chandankumar elmiko jruzicka number80 rbowen social
15:02:23 <chandankumar> #link RDO meeting etherpad link https://etherpad.openstack.org/p/RDO-Packaging
15:02:46 <chandankumar> let me start with the first topic of 2016.
15:03:03 <chandankumar> #topic updates on RDO packaging
15:03:30 <trown> o/
15:03:38 <chandankumar> rdoinfo patch for python-magnumclient is sent
15:03:42 <chandankumar> #chair trown
15:03:42 <zodbot> Current chairs: chandankumar elmiko jruzicka number80 rbowen social trown
15:03:51 <chandankumar> #link https://github.com/redhat-openstack/rdoinfo/pull/135
15:04:22 <chandankumar> openstack-magnum package review is still in progress https://bugzilla.redhat.com/show_bug.cgi?id=1292794
15:04:27 <chandankumar> <EOF>
15:04:49 <imcsk8> o/
15:04:56 <number80> #chair imcsk8
15:04:56 <zodbot> Current chairs: chandankumar elmiko imcsk8 jruzicka number80 rbowen social trown
15:05:16 <chandankumar> number80, https://github.com/redhat-openstack/rdoinfo/pull/135 rdoinfo link
15:05:34 <number80> yup
15:05:41 <number80> just left you a comment
15:05:51 <chandankumar> number80, will update the patchset.
15:05:55 <number80> ack
15:06:07 <chandankumar> any more queries to RDO packaging updates?
15:06:13 <jruzicka> yes
15:06:25 <jruzicka> but apevec isn't here
15:06:35 <jruzicka> I want to know status of rdoinf and it's forks
15:06:49 <jruzicka> and whether or not the to unite the forks as one has come :)
15:06:56 <jruzicka> *the time to unite
15:07:01 <number80> jruzicka: we're trying to have a single rdoinfo database for all branches (at least for liberty + mitaka)
15:07:11 <jruzicka> number80, any obstacles in that?
15:07:23 <number80> jruzicka: currently, only opm has been tricky to handle
15:07:35 <jruzicka> I planed to let rdoinfo live for a cycle or two and then apply engineering to the horrible mosnter it would become :)
15:07:36 <number80> but Alan has probably some minor tweaks in mind
15:07:46 <number80> *nods*
15:07:47 <jruzicka> oh, astounding success
15:07:58 <jruzicka> very well, that's all from me :)
15:08:11 <number80> jruzicka: just add the point in next week meeting agenda :)
15:08:33 <chandankumar> jruzicka, Thanks :)
15:08:34 <jruzicka> right
15:08:44 <chandankumar> moving to next topic
15:08:51 <chandankumar> #topic Python 3 porting effort
15:09:19 <number80> #action reboot py3 reviews
15:09:24 <chandankumar> from the last meeting we have already completed oslo-libraries
15:09:27 <number80> #action number80 reboot py3 reviews
15:09:37 <chandankumar> #link https://trello.com/c/ReowuP4z/105-python3
15:09:51 <number80> I need to do some more reviews this week
15:10:00 <chandankumar> number80, great :)
15:10:29 <chandankumar> number80, do we start client python 3 prting r we still wait for reviews of oslo?
15:10:37 <chandankumar> *or
15:11:08 <number80> oslo needs to be merged before or we'll get build failures notifications from delorean
15:11:18 <chandankumar> ok
15:11:46 <chandankumar> any more queries related to python3 porting?
15:11:47 <number80> but well, let's already add a status point for next week, I'll try to get as much as possible merged by next week
15:12:00 <chandankumar> ok
15:12:28 <chandankumar> moving to next topic
15:12:35 <chandankumar> #topic Oslo libraries updates
15:12:53 <chandankumar> #link https://trello.com/c/xeD4dBAs/117-update-oslo-to-match-upper-constraints
15:13:55 <number80> that topic has been raised, and well, I'm in favor in upgrading oslo more frequently
15:14:23 <number80> Are you ok w/ that? suggestions?
15:14:34 <chandankumar> i am ok with that
15:15:28 <chandankumar> i will again start putting the list of packages version updates on etherpad so that people can take it from there
15:15:40 <number80> ok
15:15:52 <number80> update the card when you have it ready
15:16:01 <chandankumar> number80, sure
15:16:09 <chandankumar> moving to next topic
15:16:18 <chandankumar> #topic Facter3 in RDO
15:16:51 <number80> I had the request, while I can update it in Fedora, CentOS has a too old version of Boost
15:17:27 <number80> Basically, I was wondering if we should target Mitaka or Liberty?
15:18:14 <imcsk8> i guess it's safer to target Mitaka
15:18:15 <chandankumar> due to version updates it might break some of the packages in mitaka
15:18:32 <number80> imcsk8: ok
15:18:57 <chandankumar> number80, what is facter3?
15:19:16 <number80> chandankumar: well, it's a puppet dependency, it could break stuff for puppet stuff, but the request itself came from our puppeeters :)
15:20:01 <chandankumar> ok
15:20:03 <number80> I'm not too far from having a facter3 build on CentOS, I need to fix my Boost package and we should be good
15:20:37 <chandankumar> #link https://trello.com/c/EN1kbuox/116-add-facter3-in-rdo
15:20:41 <number80> #action hguemar import facter3 in Mitaka
15:21:23 <number80> I guess we can move to the next topic
15:21:46 <chandankumar> #topic Liberty current-passed-ci repo status
15:21:56 <chandankumar> trown, dmsimard go ahead
15:22:40 <trown> RDO Manager current-passed-ci deploys a cloud that is unable to launch instances... which is not ideal
15:22:58 <number80> except if you want a noop cloud :)
15:23:19 <number80> trown: what is actually broken?
15:23:26 <trown> I am rerunning https://ci.centos.org/view/rdo/job/rdo-delorean-promote-liberty/ with an old hash that previously had 100% tempest smoke to try to get back to a working current-passed-ci
15:23:34 <number80> ok
15:23:57 <trown> I think I found the root cause of not being able to launch instances, and filed a revert https://review.openstack.org/264160
15:24:10 <jruzicka> "state of the art noop cloud"
15:24:21 <chandankumar> #link https://review.openstack.org/264160
15:24:22 <number80> good
15:24:26 <jruzicka> who does NOT want that?!
15:24:30 <imcsk8> XD
15:24:30 <rbowen> hehe
15:24:37 <chandankumar> hehe
15:24:38 <trown> however... it could be that the patch that reverts only shows an issue that existed before, because it changes vif_plugging_fatal to true
15:25:23 <trown> tldr: liberty delorean is borked, I am working on unborking it, and will send an email to the list when it is unborked
15:26:39 <chandankumar> ok
15:26:56 <chandankumar> trown, can we move to next topic?
15:26:59 <jruzicka> #info liberty delorean is borked and in process to be unborked
15:27:16 <number80> perfect summary
15:27:47 <trown> chandankumar: yep
15:27:51 <chandankumar> ok
15:28:05 <chandankumar> #topic RDO upcoming events
15:28:09 <rbowen> #info Doc day - Jan 20/21
15:28:16 <chandankumar> #link https://review.openstack.org/264160
15:28:25 <dmsimard> o/ sorry I'm late
15:28:27 <rbowen> Join us here on IRC to address the open docs/website issues
15:28:28 <rbowen> #link https://github.com/redhat-openstack/website/issues
15:28:45 <rbowen> #info Mitaka test day, Jan 28/29
15:28:55 <jruzicka> oh wow 43 closed cos issues
15:28:59 <rbowen> Kind of conflicts with FOSDEM, but it's what people preferred, by a narrow margin, over the alternatives.
15:29:03 <jruzicka> *doc issues
15:29:07 <rbowen> And then
15:29:10 <chandankumar> rbowen, since we have lots of events this month, we need to make promotion for each events so that we can get maximum participation
15:29:14 <rbowen> #info RDO Day @ FOSDEM schedule - https://www.rdoproject.org/events/rdo-day-fosdem-2016/
15:29:16 <jruzicka> rbowen++
15:29:30 <rbowen> Yes, I'm working to get the word out, while not getting it drowned in the noise
15:29:34 <rbowen> January is very busy.
15:29:42 <jruzicka> kudos to everyone working on the docs <3
15:29:44 <number80> rbowen: I just need to a good LTE connection while travelling to Brussels :)
15:29:49 <rbowen> There's also DevConf
15:30:07 <rbowen> I'll be there, but I'm not sure whether there's much RDO-related content or whatever.
15:30:13 <rbowen> But I know there's a lot of RDO people there.
15:30:20 <jruzicka> I'll be presenting rdopkg on devconf
15:30:26 <rbowen> Awesome.
15:30:26 <jruzicka> saturday 14:30 probably
15:30:38 <jruzicka> thanks to number80 undying enthusiasm :)
15:30:45 <number80> jruzicka: I'll be attending!
15:30:50 <jruzicka> hell yeah
15:30:54 <rbowen> In related news, if you have an upcoming event of any kind that you are attending or speaking at, I would be glad to help get the word out about it.
15:30:59 <jruzicka> I need to get ack from aortega about FOSDEM
15:31:02 <jruzicka> but I hope to come too
15:31:07 <rbowen> And, to that end, see my email to rdo-list about the OpenStack speakers burea.
15:31:09 <rbowen> bureau
15:31:17 <rbowen> That's all I have. Thank you.
15:31:23 <chandankumar> rbowen Thanks :)
15:31:37 <chandankumar> #topic chair for next meeting
15:31:46 <jruzicka> I can do it I guess.
15:31:46 <chandankumar> who wants to volunteer for next meeting?
15:31:59 <chandankumar> #action jruzicka to chair for next meeting
15:31:59 <jruzicka> I'm just a really bad timekeeper
15:32:15 <number80> jruzicka: one has to learn :)
15:32:21 <jruzicka> number80, I'll do my best, sensei-sama
15:32:22 <chandankumar> jruzicka, i will give a reminder to u
15:32:24 <number80> lol
15:32:28 <number80> roshi is better
15:32:32 <chandankumar> *you
15:32:39 <jruzicka> ;)
15:32:48 <chandankumar> #topic open discussion
15:33:16 <jruzicka> what was the first painful thing you needed to do in new year? :)
15:33:27 <jruzicka> I'm asking because I'm wondering what to improve next.
15:33:48 <rbowen> Encouraging raw beginners to try out RDO as part of a test day.
15:33:50 <chandankumar> jruzicka, i have already started going to gym from next year
15:33:50 <trown> getting out of bed
15:33:50 <dmsimard> figuring out that liberty packstack was in fact mitaka packstack was pretty painful :)
15:34:03 <chandankumar> sorry from this year
15:34:04 <imcsk8> oh yeah
15:34:11 * jruzicka lol'd
15:34:33 <trown> dmsimard: still is in current-passed-ci :(
15:34:38 * imcsk8 still in bed :P
15:34:46 <dmsimard> btw
15:34:55 <dmsimard> I'm toying with the idea of something like toolbox.rdoproject.org
15:35:01 <jruzicka> dmsimard, oh?
15:35:05 <rbowen> Ah? Tell me more. What does that mean?
15:35:06 <dmsimard> to index all our tools and docs all over the place
15:35:15 <imcsk8> that sounds cool
15:35:17 <dmsimard> i.e, links to various CI environments where our jobs run on
15:35:22 <rbowen> Which is a bit of a condemnation of the main RDOproject.org site, hmm?
15:35:26 <jruzicka> oh yeah, an index of all things RDO
15:35:26 <dmsimard> like http://versiontracker.dmsimard.com/compare/liberty
15:35:33 <jruzicka> that's a REAAALLY good idea.
15:35:37 <dmsimard> and eventually monitoring I want to put in place
15:35:58 <dmsimard> rbowen: it's a good point to put it on the actual website
15:35:59 <number80> dmsimard: different from the dashboard card?
15:36:07 <rbowen> I would love to talk more with you about the main site, and what we can do to make it useful enough that we dont need another site for that. Not that I object to the plan, but I'm frustrated with the main site and its lack of usability.
15:36:14 <snecklifter> rbowen, I'm currently trying to make it less condemnable
15:36:15 <dmsimard> but I'd need some hostname to host tools under (monitoring, the rpm tracker)
15:36:25 <rbowen> Yes, and I have hugely appreciated all of the PRs in the last few days.
15:36:33 <dmsimard> rbowen: no, no, I agree, the index should actually go on the website
15:36:34 <snecklifter> thanks for the quick action on them
15:36:40 <dmsimard> but I meant a DNS for hosted tools
15:36:49 <jruzicka> the idea is good, just integrate with the website
15:37:07 <jruzicka> yes, we should connect all the dots
15:37:22 <dmsimard> I'd like the version tracker to be hosted somewhere other than my personal server :P
15:37:27 <jruzicka> many fancy stuffs by many different people
15:37:29 <snecklifter> jruzicka, fewer dots would be appreciated I think
15:37:30 <rbowen> Anything I can do on the main site, I'm prepared to do, up to and includnig complete structural overhaul.
15:37:47 <rbowen> It's way too hard to find stuff on there now.
15:37:49 <jruzicka> snecklifter, indeed, merging and minimising the dots is even better
15:37:52 <jruzicka> but openstack is many things
15:37:55 <jruzicka> with many problems
15:37:59 <dmsimard> rbowen: I'll give it some more thought, just thinking out loud here
15:38:06 <jruzicka> which I'm affraid will result in many tools :)
15:38:17 <snecklifter> From a user perspective, documentation is all over the place
15:38:18 <rbowen> jcoufal had some great ideas a year ago, and it took so long to get the new site running I think that he moved on to other things.
15:38:34 <jruzicka> snecklifter, really, you felt overwhelmed by documentation?
15:38:42 <snecklifter> I've just removed a link to SpinalStack documentation over a year old
15:38:50 <snecklifter> jruzicka, no, lost
15:39:01 <dmsimard> snecklifter: I see where you're going but this isn't about documentation
15:39:11 <snecklifter> so the main website heads off to tripleo for RDO-Manager
15:39:12 <dmsimard> this is about linking to places and tools related to RDO
15:39:16 <rbowen> On the bright side, it's still a *tiny* site, so reorging it shouldn't be difficult, but it's still a little overwhelming.
15:39:25 <snecklifter> which then links to fedorapeople but only for liberty
15:39:40 <dmsimard> i.e, https://ci.centos.org/view/rdo/ & https://prod-rdojenkins.rhcloud.com/ & http://versiontracker.dmsimard.com/compare/liberty & eventually others
15:39:40 <snecklifter> and then it was linking to old SpinalStack stuff
15:40:06 <imcsk8> rbowen: is the way to go to help with the docs is to fix isses in here? https://github.com/redhat-openstack/website/issues
15:40:16 <snecklifter> but I completely realise how much you guys do on very little resource
15:40:28 <rbowen> imcsk8: That is certainly one way, yes.
15:40:48 <rbowen> Although I also need to go through those carefully and ensure that they're the right things to fix.
15:41:00 <snecklifter> dmsimard, yes, sorry, didn't mean to hijack thread :)
15:41:03 <imcsk8> rbowen: it'll try to help with that as much is i can
15:41:15 <rbowen> We also need to diagram how we'd like the site laid out (information, not design) and make sure that things are a way that makes sense.
15:41:29 <rbowen> Which is on my list for this month, preferably before the doc day.
15:42:23 <jruzicka> rbowen, agreed. Ideally, it would be with all the information accessible from the root node after reasonable amount of clicks :)
15:42:34 <jruzicka> oh man I'm missing words
15:42:39 <rbowen> :)
15:42:42 <rbowen> As is the website.
15:42:44 <jruzicka> *it would be a tree structure
15:43:00 <jruzicka> rbowen, still better docs story then upstream :-p
15:43:18 <jruzicka> as snecklifter pointed out, I see it as miracle we have that much docs with our manpower :)
15:43:28 <dmsimard> The docs on rdoproject.org is just a bit awkward to browse and navigate
15:43:41 <dmsimard> I like the way this is laid out: http://docs.openstack.org/openstack-ops/content/
15:43:50 <jruzicka> yes, not very consistent
15:43:57 <snecklifter> dmsimard, I disagree, I think its fine to browse but so many dead links or old content
15:44:02 <jruzicka> lots of different pieces of information put together
15:44:19 <dmsimard> Perhaps a wiki would be better for collaboration, I don't know
15:44:21 <Humbedooh> rbowen: hm, seems no one did anything about the mail archives being broken yet :| still getting connection resets there, and I've tried pinging lots of people
15:44:38 <Humbedooh> but it's a minor nit, I suppose
15:44:38 <dmsimard> Just a quick doc edit requires a lot of steps, it's a low barrier to entry, but still
15:44:45 <snecklifter> dmsimard, lower barrier to entry to correct the problems
15:44:50 <snecklifter> lol
15:45:12 <snecklifter> Should people have to learn git to contribute doc edits, I'm not sure
15:45:52 <jruzicka> dmsimard, I like git + asciidoc approach as seen here: https://www.rdoproject.org/packaging/rdo-packaging.html
15:45:55 <rbowen> They should be able to do wysiwyg edits directly on github. Although that's perhaps not obvious at the moment.
15:46:19 <jruzicka> dmsimard, but that's nice for devs, not so much for users who just want to edit I guess
15:46:26 <snecklifter> dmsimard, how about a link on the front page directing people to file an issue on github if they spot bad docs?
15:46:37 <chandankumar> snecklifter, we also need to verify the edits made by people whether it is correct or not while using wiki
15:46:39 <rbowen> There is one. It's just perhaps kind of hidden.
15:46:41 <snecklifter> like the update to the RDO-Manager one I just committed for example
15:46:46 <rbowen> It's way downa t the bottom of the page.
15:46:59 <dmsimard> I don't know, I'm just trying to say that if I spot a typo, I need to fork the website on github, clone the repo, find the right page in the source, edit it, commit it, push it, submit a pull request
15:47:00 <rbowen> We had a "edit on github" banner for a while, but it was removed. I can't say I ever understood why.
15:47:43 <dmsimard> I can do that
15:47:50 <dmsimard> but perhaps some won't
15:47:53 <snecklifter> rbowen, that would be good
15:48:38 <rbowen> Here: https://github.com/redhat-openstack/website/issues/244
15:48:57 <rbowen> In particular: https://github.com/redhat-openstack/website/pull/100
15:49:09 <rbowen> apevec requested that it be removed.
15:49:15 <rbowen> There was no discussion as to why.
15:49:37 <dmsimard> "Fork me on github" ribbon != edit on github
15:49:52 <jruzicka> oh right
15:49:55 <snecklifter> yeah, "improve me on github" would be even better
15:49:58 <dmsimard> http://aral.github.io/fork-me-on-github-retina-ribbons/right-turquoise@2x.png is kinda cheesy indeed
15:50:09 <rbowen> ok, I've seen "edit on github" banners on some sites. I'll see if I can find what needs done to do that.
15:50:22 <dmsimard> rbowen: read the docs has it http://weirdo.readthedocs.org/en/latest/
15:51:00 * number80 suggest to wrap up
15:51:15 <rbowen> +1
15:51:22 <rbowen> I have to go off to another meeting here soon.
15:51:38 <chandankumar> number80, dmsimard will i close the meeting?
15:51:39 <rbowen> dmsimard: thanks. I'll see what, exactly, that links to, and replicate it on our ite.
15:51:54 <rbowen> s/ite/site/
15:52:00 <dmsimard> Sure, was just abusing the open floor :)
15:52:08 <dmsimard> chandankumar: ^
15:52:11 <jruzicka> chandankumar is gonna do it!
15:52:16 <number80> nah, it's fine :)
15:52:20 <jruzicka> HE'S GONNA DO IT
15:52:24 <chandankumar> #endmeeting