rdo
LOGS
15:02:04 <trown> #startmeeting RDO packaging meeting (2015-10-07)
15:02:05 <zodbot> Meeting started Wed Oct  7 15:02:04 2015 UTC.  The chair is trown. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:25 <trown> #rollcall
15:02:48 <xaeth> o/
15:02:54 <jruzicka> o/
15:03:02 <jpena> o/
15:03:14 <sasha2> AliRezaTaleghani: passed
15:03:19 <apevec> \o
15:03:20 <trown> #link https://etherpad.openstack.org/p/RDO-Packaging
15:03:27 <jschlueter> o/
15:03:32 <number80> o/
15:03:58 <alphacc> o/
15:04:23 <dyasny> sasha2, there you are
15:04:41 <trown> #topic META: rename the meeting to "RDO meeting"
15:05:04 <apevec> yes, easy one for the start :)
15:05:10 <trown> :)
15:05:10 <number80> +0
15:05:15 <apevec> I propose we rename this meeting to general one
15:05:31 <dmsimard> o/
15:05:31 <apevec> packaging is maint point of RDO but to encourage other topics here
15:05:41 <apevec> like docs and meetups etc.
15:05:52 <trown> makes sense to me
15:05:56 <sasha2> dyasny: yes, "there can be only one"....oops
15:06:00 <apevec> I'd like to hear rbowen's take on this, but he's at the conf
15:06:13 <aortega> +1
15:06:26 <jschlueter> ack sounds like it matches what these meetings have actually been about
15:06:30 <apevec> yeah
15:06:43 <jruzicka> as long as they don't get longer... ;)
15:07:11 * apevec apevec to rename wherever needed (reminder, agenda) meeting title to "RDO meeting"
15:07:32 <trown> #action apevec to rename wherever needed (reminder, agenda) meeting title to "RDO meeting"
15:07:34 <apevec> ah
15:07:41 <apevec> # vs / :)
15:07:43 <jschlueter> timebox meeting to 1 hour ... also apevec can you make sure to add etherpad with minutes to the invite?
15:07:51 <social> o/
15:08:08 <apevec> number80, ^ how fedcal invite be edited?
15:08:09 <blinky_ghost_> ibravo: still doesn't work
15:08:19 <apevec> s/how/how can/
15:08:23 <number80> apevec: you just need to login in fedocal and edit the meeting
15:08:32 <number80> I added you in the meeting owners
15:08:37 <apevec> thanks
15:08:49 <trown> ok moving on?
15:08:55 <jschlueter> #action apevec add etherpad with meeting agenda to invite
15:09:09 <trown> #topic     RDO tooling: feature requests and priorties (mostly rdopkg, but also status of upstream Packaging RPM project)
15:09:40 <apevec> number80, jruzicka, ^ we have some good news?
15:09:56 <jruzicka> good news are in the etherpad right bellow that string :)
15:10:01 <number80> :)
15:10:12 <jruzicka> since you read faster then I type I did that beforhead :)
15:10:37 <apevec> thanks, I'd like that we come up with the priorities for "next steps"
15:11:01 <trown> #link https://github.com/redhat-openstack/rdopkg/issues
15:11:03 <jruzicka> only thing from that that needs announcemnt is `rdopkg patchlog`
15:11:24 <jruzicka> it just shows patches in patches branch
15:11:25 <apevec> ^ we could use github rdopkg issues to priorities features
15:11:40 <jruzicka> run it and see if it's useful to you ;)
15:11:52 <jruzicka> (it hls excluded patches at least)
15:12:15 <jruzicka> Indeed, I monitor github issues
15:12:24 <apevec> number80, jruzicka - maybe we could meet off-meeting to triage list of tooling issues/RFEs?
15:12:42 <number80> apevec, jruzicka ack
15:12:49 <apevec> so we don't take time here
15:13:04 <number80> i agree with that :)
15:13:09 <apevec> #action apevec to schedule rdopkg triage with jruzicka and number80
15:13:13 <jruzicka> yup, tl;dr if someone needs something in rdopkg poke me and/or use github issues
15:13:36 <apevec> number80, anything of note from upstream Packaging-rpm land?
15:13:46 <apevec> I was not following that close enough,
15:14:00 <apevec> but I saw you got design summit sessions?
15:14:16 <apevec> number80, with your upstream PTL hat on :)
15:14:46 <number80> apevec: atm, we need to change your strategie and push our distro-specific specs and keep the common spec as a side effort
15:15:20 <apevec> push where?
15:15:24 <jruzicka> well it is a side effort
15:15:38 <jruzicka> that was my perception at least
15:15:40 <number80> apevec: on openstack space and have builders
15:15:42 <jruzicka> when the time permits
15:15:44 <jruzicka> ;)
15:16:03 <number80> more or less, it will end up that at some point we'll have delorean hosted upstream
15:16:03 <jruzicka> huh and then change to common?
15:16:05 <trown> when the time permits always sounds like never to me
15:16:10 <number80> jruzicka: +2
15:16:13 <apevec> number80, within Packaging-rpm ?
15:16:18 <number80> apevec: yes
15:16:27 <apevec> that didn't fly last time we tried
15:16:43 <jruzicka> trown, some work has been done ;) a little but non-zero
15:16:47 <apevec> but yeah, we said we'll revisit that
15:16:53 <number80> apevec: well, as we have nobody full-time on that project, we were able to get compromises :)
15:17:37 <apevec> number80, ok, so you'll propose that in Tokyo? Send me draft proposal please
15:17:49 <number80> apevec: ack
15:18:02 <number80> #action hguemar send proposal draft
15:18:04 <jruzicka> I just hope I didn't go through the project-config and governance reviews for nothing :-p
15:18:24 <number80> jruzicka: not at all
15:18:39 <number80> we just need to get results at a faster pace
15:18:41 <apevec> jruzicka, no, pymod2spec would have good home in openstack bigtent
15:18:43 <dmsimard> brb
15:18:51 <trown> anything else for RDO tooling topic?
15:18:57 <apevec> jruzicka, just import it :)
15:19:03 <apevec> trown, let's move on
15:19:07 <trown> #topic New package Request
15:19:12 <jruzicka> oh right and we're so ready for when the time permits
15:19:31 <trown> I can take this one since chandankumar could not make the meeting
15:19:38 <apevec> that one is interesting: This SCM request method has been deprecated. Please see https://fedoraproject.org/wiki/PackageDB_admin_requests.
15:20:13 <apevec> trown, ^ just for that to point there's a new procedure (I didn't realize)
15:20:27 <apevec> but otherwise, it's not meeting slot worthy topic imho
15:20:31 <trown> apevec: I did not either
15:20:44 <trown> #link https://fedoraproject.org/wiki/PackageDB_admin_requests.
15:20:56 <apevec> it's regular JFDI item :)
15:21:18 <trown> #topic Packages needs version bump
15:21:33 <apevec> django stuf -> mrunge
15:22:08 <apevec> I'll take oslo
15:22:26 <apevec> what's jmespath ??
15:22:59 <apevec> it's not in Fedora pkgdb
15:23:00 <jschlueter> google says: json query package ...
15:23:06 <apevec> typo? needs pkg review?
15:23:08 <number80> apevec: parameters checking lib for REST api
15:23:11 <number80> it's in fedora
15:23:29 <bkosick> Hey all,   I'm wondering if I have a problem, the following script has been running for ~12 hours now, no errors yet:
15:23:30 <trown> looks like fancy jq
15:23:31 <bkosick> openstack overcloud deploy --ceph-storage-scale 1 --templates -e storage-environment.yaml
15:23:32 <bkosick> I'm trying to follow the virtual setup on the tripleO doc site
15:23:44 <trown> bkosick: meeting now, ask after
15:23:53 <bkosick> np
15:23:58 <apevec> ahh python-jmespath
15:24:05 * number80 did the review back in 2013
15:24:24 <apevec> number80, please ping maintainers
15:24:27 <number80> ack
15:24:38 <number80> .whoowns python-jmespath
15:24:38 <zodbot> number80: gholms
15:24:47 <apevec> number80, but 	lkundrak did last builds
15:24:55 <apevec> s/last/all/
15:25:01 <apevec> except mass-rebuild one
15:25:07 <number80> i'll ping gholms anyway
15:25:13 <trown> #action number80 to follow up with python-jmespath maintainers
15:25:42 <trown> #topic RDO Doc Hack Day
15:25:58 <number80> it's next week?
15:26:05 <apevec> that was rbowen?
15:26:09 <trown> is there a date set for it?
15:26:47 <number80> trown: 12 and/or 13 october
15:27:16 <number80> rbowen isn't around
15:27:19 <trown> number80: I thought that was the RDO Test Day? or are they being done at the same time?
15:27:55 <number80> shaunm: ^
15:28:13 <number80> trown: both, I think
15:28:31 <number80> (shaunm is the documentation ninja from OSAS who will help us)
15:28:31 <jschlueter> is there a page up for Doc Hack Day?
15:28:33 <trown> ok makes sense, since we would find doc issues during testing
15:28:59 <jschlueter> also an email would probably be nice announcing it on the mailing list
15:29:26 <trown> #info RDO Doc Hack Day will coincide with the Oct. 12-13 RDO Test Day
15:30:11 <trown> number80: apevec rbowen is at a conference this week? so probably wont be sending any email about these?
15:30:13 <apevec> last related was Rich pre-announcing it on Sep 14 [Rdo-list] beta.rdoproject.org
15:30:30 <apevec> trown, yeah
15:30:47 <number80> trown: he is at linuxcon EU
15:31:05 <apevec> trown, if you have all pieces ready for rdo-mgr testday, can you send that announcement?
15:31:06 <trown> I was planning an email for RDO Test day after the next topic, should I include that it will also be Doc Hacking?
15:31:16 <number80> I'll be focusing on documentation next on monday/tuesday
15:31:20 <apevec> trown, no
15:31:48 <apevec> trown, let's leave doc to Rich, I'm not sure what are the areas he needs most help with
15:32:09 <apevec> priority should be to resolve blockers for pushing beta.rdo to production
15:32:27 <trown> apevec: works for me
15:33:00 <trown> #topic RDO Test Day Oct. 12-13
15:33:12 <trown> I put this one on the agenda
15:33:35 <apevec> what's the status, which repos will be used?
15:33:50 <trown> we never confirmed this as a test day, but it was the last one proposed and not too many other opportunities before summit
15:33:52 <jschlueter> #action jschlueter putting together website page pull request for test day 2
15:34:17 <dmsimard> apevec: should have people using current-passed-ci
15:34:44 <trown> dmsimard: my vote would be to only have people test things that have passed some amount of CI
15:34:46 <apevec> dmsimard, ack - but rdo-manager has some weird repo combination still?
15:34:56 <jschlueter> focus should probably be RDO Manager this time
15:35:01 <trown> apevec: weird, but documented
15:35:38 <dmsimard> Upstream is on rc2, what we have right now in current-passed-ci is a mix of rc1 and rc2 (http://versiontracker.dmsimard.com/compare/liberty)
15:35:42 <trown> #info RDO-Manager basic CI is passing (non-HA no network isolation)
15:35:55 <apevec> dmsimard, not every project had rc2
15:36:01 <trown> #link https://ci.centos.org/view/rdo/
15:36:16 <dmsimard> apevec: We got some new rc2 packages in, I'll try and see if we can promote
15:36:45 <trown> so right now, we could really only test this basic scenario for rdo-manager if we limit to what has passing CI
15:37:12 <apevec> trown, no hope to get CI passing more scenarios?
15:37:20 <trown> I think there is a good chance that we can have network-isolation working with docs by Friday
15:37:30 <dmsimard> trown: The basic scenario that is known to be passing CI ? Then we probably want people testing other scenarios to flag issues ?
15:37:34 <trown> I think it is just some configuration that has changed
15:38:18 <trown> dmsimard: I think that is a recipe for disaster... ie it is not failing CI for no reason
15:39:06 <trown> humans will always do things differently than CI, so I see value in having human validation that the docs can get you to the same place as CI
15:39:18 <dmsimard> fair
15:39:45 <trown> and I think it is mean to give people a known broken thing and say "test it"
15:39:49 <ibravo> yet I believe we should allow for other test scenarios as well to see how users are planning to use RDO Manager
15:40:25 <dmsimard> apevec: slightly off topic, liberty is release 7 and mitaka is 8, right ?
15:40:34 <apevec> dmsimard, nope
15:40:37 <trown> dmsimard: 8 and 9
15:40:40 <apevec> it's per project semver
15:40:58 <apevec> ah you mean OSP ?
15:41:00 <sasha2> trown: so I fail on https://bugzilla.redhat.com/show_bug.cgi?id=1268992
15:41:05 <apevec> that's not discussed here :)
15:41:07 <trown> sasha2: still in meeting
15:41:16 <dmsimard> apevec: Well some packages right now are in semver 7.x, others are 8.x
15:41:31 <apevec> dmsimard, yep
15:41:33 <apevec> it's per project
15:41:40 <apevec> some are 5.0.0
15:41:41 <dmsimard> then again, glance is at 11 so
15:41:45 <dmsimard> ... yeah.
15:41:49 <trown> #action trown to send announcement to rdo-list for Oct 12-13 test day with RDO-Manager information
15:42:02 <apevec> yes, I'll find you the link to openstack-dev discussion where those semvers where set
15:42:20 <trown> it is number of integrated releases the project has participated in
15:42:25 <apevec> basically, it was made seemigly random to avoid any ideas about "integrated" release
15:42:29 <apevec> which was abandoned
15:42:44 <apevec> trown, yeah, but that just random decision
15:42:49 <apevec> could have been anything
15:42:56 <dmsimard> k sorry for sidetracking
15:43:01 <apevec> point is: no single release version
15:43:12 <apevec> it's "Liberty"
15:43:20 <trown> ok anything else on Test Day topic?
15:43:22 <apevec> but semver goes on now on it's own
15:43:37 <apevec> nope
15:43:49 <chandankumar> o/
15:43:51 <jschlueter> we really need to get some documentation around RDO manager and tempest testing ...
15:43:55 <jschlueter> for test day
15:44:08 <apevec> yeah, using tempest rpm
15:44:14 <trown> #action trown to send PR to website for Test Day page with "basic" and "stretch" scenarios
15:44:16 <apevec> eggmaster, ^ is there any docs?
15:44:27 <jschlueter> last time I had hard time finding and putting things together for trying to test tempest
15:44:53 <trown> ah good point... CI is not yet running tempest btw
15:45:00 <apevec> jschlueter, there's readme in our branch of tempest, not sure if it is up to date
15:45:09 <ibravo> will it be a section on 'what to do if you find an issue?'
15:45:18 <apevec> https://github.com/redhat-openstack/tempest/blob/rebased-upstream/README.rpm
15:45:19 <eggmaster> apevec: if there are, idk where.
15:45:35 <apevec> eggmaster, ^ that one, is it still valid?
15:45:35 <trown> ibravo good point, I will make sure to include that
15:45:47 <trown> where to file BZ etc
15:46:39 <eggmaster> apevec: question for dkranz, sry mate, idk about this.
15:46:45 <jschlueter> apevec: yea I tried following a number of pieces but didn't have luck last time... should have links in new testday page to help people find and go through this
15:47:13 <apevec> jschlueter, do you want to chase dkranz to update his README.rpm ?
15:47:14 <trown> jschlueter: that would be very nice... but may not happen in the next 2 days if nobody knows that now
15:47:15 <jschlueter> trown: hmm that seems like a problem that CI isn't running tempest yet.
15:47:40 <trown> jschlueter: CI was not running at all 2 days ago, so yes, but also progress
15:47:45 <jschlueter> #action jschlueter followup with dkranz to get tempest test info for testday updated
15:48:03 * jschlueter nods
15:48:23 <trown> jschlueter: but yes tempest is a must have for CI
15:48:36 <trown> ok moving on
15:48:40 <trown> #topic Liberty RC2
15:49:04 <chandankumar> trown, can i proceed?
15:49:09 <trown> go for it
15:49:11 <apevec> short one: some projects had RC2 - maintainers please rebase your distgits!
15:49:31 <chandankumar> Here is the trello card to track RC2 https://trello.com/c/GPqDlVLs/63-liberty-rc-rpms
15:49:48 <apevec> chandankumar, ack there are checklists with builds there
15:49:57 <chandankumar> #link RDO Liberty Progress https://trello.com/c/GPqDlVLs/63-liberty-rc-rpms
15:49:59 <apevec> cross when done and let me know
15:50:20 <chandankumar> sure
15:50:23 <apevec> I'd like to create full repo in liberty-testing today
15:50:39 <apevec> then run manual smoketest on it
15:51:01 <apevec> next step is to work on CI promoting job to release repo
15:51:20 <apevec> so each new update would be CI tested
15:51:52 <apevec> after GA we'll use rdopkg update
15:52:03 <dmsimard> apevec: what full repo are you speaking of ?
15:52:41 <apevec> dmsimard, cloud7-openstack-liberty-testing
15:52:52 <dmsimard> and common ?
15:53:10 <apevec> + common of course, but those should be complete at this point
15:53:22 <dmsimard> So you want to promote a set of these to -candidate or something ?
15:53:23 <apevec> liberty-testing is missing few clients and openstack-* RC  builds
15:53:40 <apevec> dmsimard, -candidate is first Koji tag where new builds end up
15:53:56 <dmsimard> liberty-testing for me is http://cbs.centos.org/repos/cloud7-openstack-liberty-testing/x86_64/os/Packages/
15:53:57 <apevec> then it's tagged -testing (manually ATM, rdoupdate in the future)
15:54:14 <dmsimard> oh ok, so what do you want to create, then ?
15:54:16 <apevec> then we have CI promote job on it
15:54:31 <apevec> and what passes gets tagged -release
15:54:34 <apevec> that's the plan
15:54:42 <dmsimard> ok
15:55:00 <apevec> dmsimard, previously there were separate CI jobs for rdoupdate (ask eggmaster about it)
15:55:13 <apevec> which were internal and breaking a lot
15:55:23 * dmsimard sighs
15:55:25 <apevec> I wanted to simplify that for Liberty
15:55:37 <apevec> and have everything in ci.centos (eventually)
15:55:51 <trown> ok most important topic of the meeting now
15:55:53 <apevec> eggmaster is hitting some issues w/ ci.centos infra
15:55:55 <trown> #topic chair rotation for next meeting
15:56:05 <chandankumar> anyone up?
15:56:25 <apevec> eggmaster, dmsimard, let's take this production/rdoupdate CI off-meeting
15:56:29 <eggmaster> ack
15:56:42 <dmsimard> yeah
15:56:46 <trown> going once
15:57:05 <trown> going twice
15:57:07 <chandankumar> trown, i will chair for next meeting.
15:57:07 <apevec> what's the default, incubent wins? :)
15:57:19 <sasha2> sold!
15:57:25 <trown> apevec: that was coming if chandankumar did not graciously step in
15:57:33 <chandankumar> hehe
15:57:36 <trown> thanks chandankumar
15:57:37 <jschlueter> #link https://github.com/redhat-openstack/website/pull/114 initial pull request for testday 2
15:57:48 <trown> #action chandankumar to chair next meeting
15:58:06 <number80> trown: if nobody were to step up, I would
15:58:46 <chandankumar> ack
15:58:58 <number80> it's not that difficult, but it's saner that it rotates
15:59:32 <trown> ya I would not want to do it every week
15:59:43 <trown> #topic open floor
16:00:07 <chandankumar> jruzicka, i will help on this https://trello.com/c/SB7rvQTI/69-update-verwatch from next week
16:00:08 <dmsimard> 1 minute is not enough to chat about delorean vs delorean-deps :)
16:00:18 <trown> I guess we are over time now, but is there anything that did not go in agenda?
16:00:33 <trown> dmsimard: ya maybe that should go in agenda for next week
16:00:33 <social> can I ask for https://review.gerrithub.io/#/c/249242/ and https://review.gerrithub.io/#/c/249125/ reviews ?
16:00:45 <jruzicka> chandankumar, OK, great, it really needs updating
16:00:50 <jruzicka> chandankumar, rewriting even
16:00:54 <jruzicka> should use rdoinfo
16:01:07 <dmsimard> trown: I'll try and cook a solution in the meantime
16:01:21 <dmsimard> At least so khaleesi can do what I want it to do
16:01:29 <trown> cool
16:01:55 <chandankumar> jruzicka, sure
16:01:57 <trown> we are over, so I will go ahead and close out the meeting
16:02:02 <trown> #endmeeting