rdo
LOGS
15:01:01 <chandankumar> #startmeeting RDO packaging meeting (2015-09-02)
15:01:01 <zodbot> Meeting started Wed Sep  2 15:01:01 2015 UTC.  The chair is chandankumar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:19 <chandankumar> o/
15:01:23 <social> o/
15:01:24 <rbowen> o/
15:01:27 <number80> o/
15:01:31 <chandankumar> #chair social rbowen number80
15:01:31 <zodbot> Current chairs: chandankumar number80 rbowen social
15:01:32 <jpena> o/
15:01:37 <chandankumar> #chair jpena
15:01:37 <zodbot> Current chairs: chandankumar jpena number80 rbowen social
15:02:42 <chandankumar> #topic Discover module removal from upstream openstack-* packages
15:03:01 <chandankumar> #info patch regarding removing discover module from test-requirements sent and is merged in sahara, cinder, nova, designate, ceilometer, manila, magnum, zaqar, barbican, ironic
15:03:20 <chandankumar> thanks to trown tosky social for helping on that. :)
15:03:25 <trown> o/
15:03:32 <chandankumar> #chair trown
15:03:32 <zodbot> Current chairs: chandankumar jpena number80 rbowen social trown
15:03:57 <chandankumar> we have one review pending on glace
15:04:00 <chandankumar> #link https://review.openstack.org/218285
15:04:15 <chandankumar> if you know any glance reviewer, Please add to it
15:04:27 <chandankumar> moving to next topic
15:04:54 <chandankumar> #topic RDO packages specs update to python3
15:05:33 <chandankumar> i have created a etherpad to track the progress of updating the specs of RDO packages to python 3
15:05:38 <chandankumar> #link https://etherpad.openstack.org/p/RDO-python3-porting-packages
15:06:01 <jpena> do we have a prioritized list of packages to update?
15:06:13 <chandankumar> jpena, right now no
15:06:16 <number80> jpena: all oslo and clients
15:06:28 <apevec> belated o/
15:06:33 <chandankumar> #chair apevec
15:06:33 <zodbot> Current chairs: apevec chandankumar jpena number80 rbowen social trown
15:06:58 <chandankumar> python-oslo-utils and python-eventlet seems to be blocker for other packages
15:07:27 <apevec> yeah config and utils are used everywhere else
15:07:40 <apevec> and i18n
15:07:52 <apevec> i18n already had python3- ?
15:08:08 <chandankumar> apevec, paragan is working on python-oslo-i18n with new python package guidelines
15:08:08 <jpena> ok, so I'll pick some and help with the effort
15:08:11 <chandankumar> apevec, yes
15:08:19 <apevec> ah yes, new guidelines
15:08:23 <trown> i added some to that etherpad that are missing,
15:08:31 <number80> please take care of obsoleting the python-xxx modules
15:08:39 <number80> cause issues with upgrade
15:09:12 <chandankumar> #info take care of obsoleting the python-xxx modules while updating the spec to python3
15:09:13 <apevec> number80, that should be in Fedora guidelines, shouldn't it?
15:09:22 <paragan> right I am checking the same now with python-oslo-i18n update
15:09:31 <number80> apevec: yes, I plan to raise the issue to FPC
15:09:46 <apevec> cool, thanks
15:10:32 <chandankumar> for python-eventlet i have updated spec ready .
15:10:35 <chandankumar> #link
15:10:38 <chandankumar> #link https://chandankumar.fedorapeople.org/python-eventlet.spec
15:10:50 <chandankumar> if someone review it that would be great.
15:11:04 <apevec> send it to eventlent maintainers
15:11:08 <social> how is it with fedora packages should I sync delorean/rawhide packages?
15:11:17 <apevec> pixelb is one of the co-maint
15:11:18 <number80> .whoowns python-eventlet
15:11:18 <zodbot> number80: abbot
15:11:46 <chandankumar> #action chandankumar to send a mail to python-eventlet maintainer with updated spec
15:11:59 <apevec> social, yes, what is already in fedora should be update to liberty-3 in Rawhide this week
15:12:30 <social> apevec: ack, I'll probably try to send maintainer request to all the fedora packages so I can do it
15:12:32 <apevec> I've updated oslo up to version before my PTO
15:12:59 <apevec> ok, I'll approve it when I see them
15:13:17 <chandankumar> ok
15:13:22 <chandankumar> moving to next topic
15:13:24 <number80> needs to check if I can add packages to buildroot, if we can, I may push a rdo-macros in CBS buildroot
15:13:41 <apevec> number80, what is rdo-macros?
15:14:13 <number80> apevec: package shipping some newer rpm-macros from fedora, to reduce the gap with EL7
15:14:26 <number80> like the new %py*_* macros
15:14:30 <apevec> ah good idea
15:14:44 <apevec> number80, where do you maintain it?
15:14:48 <jpena> number80: if you do that, we should also add it to delorean
15:14:52 <pixelb> chandankumar, Quick glance of python3 support looks good (I notice greenlet already has python3 support in fedora)
15:15:08 <number80> apevec: I haven't had the time to finish it, it's based on epel-macros
15:15:20 <number80> but i'll add it in trello
15:15:25 <apevec> ack
15:15:36 <chandankumar> pixelb, http://koji.fedoraproject.org/koji/buildinfo?buildID=670833
15:16:22 <apevec> social, let's add checklist in https://trello.com/c/GPqDlVLs/63-liberty-3-rpms so we can split rawhide sync/build
15:16:36 <chandankumar> pixelb, it is not there in rawhide and neither in f23 http://koji.fedoraproject.org/koji/buildinfo?buildID=659383
15:17:24 <apevec> social, I've added lists for you and me, please add to your list what you plan to update in Rawhide
15:17:47 <apevec> I'll take python-oslo-*
15:18:17 <chandankumar> apevec, i will help you with some packages or i will take python-* packages .
15:18:22 <number80> https://trello.com/c/eT0jvRGN/67-rdo-rpm-macros
15:18:44 <pixelb> chandankumar, I'll commit the eventlet update to rawhide/f23. It looks good. thanks!
15:18:51 <apevec> man, we're now mixing multiple topics :)
15:19:02 <chandankumar> apevec, oh sorry
15:19:02 <social> yeah now I'm completly lost :)
15:19:05 <apevec> let's close py3
15:19:09 <number80> +1
15:19:16 <apevec> add actions
15:19:46 <apevec> #action pixelb  commit the eventlet update to rawhide/f23
15:19:50 <apevec> #undo
15:19:50 <zodbot> Removing item from minutes: ACTION by apevec at 15:19:46 : pixelb  commit the eventlet update to rawhide/f23
15:19:58 <apevec> #action pixelb  commit the eventlet py3 update to rawhide/f23
15:20:09 <chandankumar> #action chandankumar to update the specs of python-* packages to py3
15:20:31 <apevec> anything else for py3?
15:20:40 <chandankumar> no
15:21:15 <chandankumar> moving to next topic
15:21:29 <apevec> ack
15:21:34 <chandankumar> #topic new package scm requests
15:21:59 <chandankumar> openstack-ironic-python-agent is approved and ready for package scm request
15:22:07 <chandankumar> #link https://bugzilla.redhat.com/show_bug.cgi?id=1257329
15:22:15 <trown> I put the request in for it too
15:22:30 <chandankumar> trown, Thanks :)
15:22:33 <chandankumar> trown++
15:22:33 <zodbot> chandankumar: Karma for trown changed to 2 (for the f22 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:23:06 <apevec> that package is now also imported in openstack-packages
15:23:21 <chandankumar> apevec, great:)
15:23:21 <apevec> it just needs rdoinfo PR to get it into Delorean Trunk
15:23:24 <trown> there is a PR to get it going in delorean https://github.com/redhat-openstack/rdoinfo/pull/77
15:23:41 <apevec> ah cool, I'll review it and merge
15:23:55 <chandankumar> #info openstack-ironic-python-agent is imported in openstack-packages.
15:24:01 <apevec> #action apevec to review Add ironic-python-agent in rdoinfo
15:24:37 <chandankumar> moving to next topic
15:24:51 <chandankumar> #topic new package under review
15:25:09 <chandankumar> there are two packages needs reviewer.
15:25:17 <chandankumar> #link python-jsonpath-rw-ext - https://bugzilla.redhat.com/show_bug.cgi?id=1259075
15:26:09 <chandankumar> sorry there is one one package
15:26:16 <chandankumar> feel free to take it
15:26:28 <number80> #link python-yaql https://bugzilla.redhat.com/show_bug.cgi?id=1257178
15:26:38 <number80> new deps for murano web ui
15:27:04 <chandankumar> number80, Thanks for adding that :)
15:27:17 <chandankumar> any more new packages which needs reviews?
15:27:30 <chandankumar> s/packages/package
15:27:46 <apevec> they should be add to RDO-Liberty tracker
15:27:48 <number80> I hope that we won't learn about new deps now
15:27:59 <number80> apevec: both are already added
15:28:08 <apevec> #link https://bugzilla.redhat.com/show_bug.cgi?id=RDO-LIBERTY-REVIEWS
15:28:10 <apevec> ok
15:28:56 <chandankumar> i will review this package python-jsonpath-rw-ext
15:29:10 <chandankumar> #action chandankumar to review python-jsonpath-rw-ext
15:29:41 <number80> yaql is lesser priority as murano is big tent project so it does not impact release schedule
15:30:14 <chandankumar> ok
15:30:42 <apevec> next topic?
15:30:43 <chandankumar> moving to next topic
15:30:46 <chandankumar> #topic liberty-3 Rawhide updates
15:31:08 <chandankumar> apevec, any updates
15:31:30 <apevec> yes, as we interleaved earlier, plan is to sprint Rawhide+CBS Liberty rebuilds this week
15:31:50 <apevec> I've added checklists for splitting the effort in https://trello.com/c/GPqDlVLs/63-liberty-3-rpms
15:32:02 <apevec> social offered to help
15:32:29 <apevec> in short, job is to merge rpm-master changes into Fedora master
15:32:35 <apevec> and update to the latest release
15:32:53 <chandankumar> social++
15:33:14 <chandankumar> #link https://trello.com/c/GPqDlVLs/63-liberty-3-rpms
15:33:33 <apevec> I'll update oslo to the updates released while I was on pto last 2weeks
15:33:46 <apevec> #action apevec to update pyton-oslo-* to the latest releases
15:33:56 <apevec> then we move to clients
15:34:10 <apevec> related card is https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora
15:34:22 <chandankumar> #link https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora
15:34:31 <apevec> which I need to sumarize on rdo-list
15:34:48 <apevec> tl;dr in f24 we're removing openstack-* from Fedora
15:34:56 <apevec> oslo, clients and deps stay
15:35:04 <apevec> in Rawhide
15:35:21 <apevec> for Delorean Trunk which runs on F21 we'll do rebuilds in copr
15:35:42 <apevec> and EL7 will be from CBS Cloud SIG
15:36:10 <apevec> I hope this makes sense, I'll try better explanation in email :)
15:36:21 <apevec> number80, you had concerns w/ Copr rebuild?
15:36:55 <number80> apevec: we may need specific builder per fedora release, as python-cryptography is dependant on openssl ABI
15:37:32 <apevec> right, for now Copr is F21 only until we move Delorean to newer Fedora
15:37:40 <number80> apevec: ack
15:38:07 <number80> F22 users may experience issues
15:38:19 <apevec> #action apevec to post on rdo-list summary from https://trello.com/c/wzdl1IlZ/52-openstack-in-fedora
15:38:31 <apevec> number80, ah I see now what you mean
15:38:56 <apevec> F22 doesn't have cryptography ?
15:39:59 <number80> apevec: very old release, and I can't update it without breaking many packages
15:40:08 <apevec> I see
15:40:47 <apevec> number80, ok, but Copr can have multiple targets, so we can add F22 for Delorean on Fedora users
15:40:53 <number80> +1
15:42:24 <apevec> done, I'll rebuild what we have now
15:43:17 <chandankumar> ok moving to next topic.
15:43:56 <chandankumar> #topic open floor
15:44:29 <social> number80: when you'll have subunit ready so I can poke lrintel with beer?
15:48:27 <chandankumar> any more topic left to discuss? if not then i close the meeting on a countdown of 5.
15:48:57 <apevec> chandankumar, next chair rotation!
15:49:20 <apevec> it's not rotating very much :)
15:49:36 <apevec> any other willing chairs except chandankumar  ?
15:50:18 <chandankumar> if nobody raises hand i can go ahead for chair for next meeting.
15:50:45 <apevec> ok, I hopped for bigger pool of rotating chairs :)
15:51:03 <apevec> I'll put more advertisment on rdo-list
15:51:12 <chandankumar> apevec, :)
15:51:33 <chandankumar> closing the meeting now
15:51:34 <chandankumar> 5
15:51:35 <chandankumar> 4
15:51:35 <chandankumar> 3
15:51:36 <chandankumar> 2
15:51:38 <chandankumar> 1
15:51:43 <chandankumar> #endmeeting