rdo_community_meeting
LOGS
14:02:04 <DrBacchus> #startmeeting
14:02:04 <zodbot> Meeting started Tue Jan 14 14:02:04 2014 UTC.  The chair is DrBacchus. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:13 <DrBacchus> #topic RDO Community meeting
14:02:22 <DrBacchus> https://etherpad.openstack.org/p/rdo_community_manager_sync
14:02:54 <mburned> #link https://etherpad.openstack.org/p/rdo_community_manager_sync
14:03:03 <kashyap> DrBacchus, I have an appointment that I have to run to in 5 minutes, so may not spend much time here.
14:03:09 <DrBacchus> Ok.
14:03:29 <DrBacchus> There's not a lot on the agenda this time, so I guess it's just a good way to see if IRC meetings work. :)
14:04:02 <DrBacchus> First item of business is to start thinking about the next test day.
14:04:19 <kashyap> That depends on when Icehouse M2 is. /me tries to check
14:04:21 <DrBacchus> The milestone 2 release is scheduled for the 23rd, and so the 30th has been suggested as a good date.
14:04:45 <DrBacchus> Unfortunately, on that day some of us will be on the way to FOSDEM. Which is fine, but it just means less participation.
14:05:01 <DrBacchus> I guess yeylon suggested the 30th? I forget.
14:05:02 <kashyap> Ah, ok
14:05:50 <DrBacchus> I wanted to start talking about it early, so that we didn't have a last minute scramble like last time, so any assitance on getting the ball rolling on that would be great.
14:06:15 <DrBacchus> The M1 test day was helpful, with 48 tickets opened. Thanks everyone.
14:06:35 <kashyap> Also, M2 packages need to be available by then - pixelb may shed some light on it here
14:06:50 <sgordon> if we have a fixed date / instructions early i would like to publicize via redhatstack.com
14:06:57 <sgordon> or DrBacchus is welcome to frame a post for it :)
14:07:34 <DrBacchus> So we need to get consensus on the date. If the 30th works for a majority of folks, I'm content to sit it out this time.
14:08:05 <DrBacchus> I guess we need to take that to the list, since we need the agreement of the QA and packaging folks before we just pick a date.
14:08:38 <DrBacchus> next item is the hangout, which I'd like to start doing again, but that's mostly a reminder to me, so that I'll actually make it happen. Unless someone wants to volunteer right now.
14:08:41 <DrBacchus> :)
14:08:54 <DrBacchus> I'm starting to gather items for the February newsletter.
14:08:58 <mburned> DrBacchus: can you add me as a meeting chair so i can capture notes?
14:09:06 <DrBacchus> #link http://etherpad.corp.redhat.com/RDONewsletter2014-02
14:09:20 <DrBacchus> #addchair mburned
14:09:29 <DrBacchus> I thought everything we said went into the notes. No?
14:09:47 <mburned> DrBacchus: it does, but if you #info things, it creates a more readable summary
14:09:49 <kashyap> Yes, everything is logged, and specific things will be highlighted
14:09:52 <DrBacchus> Ah. Got it. Thanks.
14:09:55 <kashyap> (if you use the hash tags)
14:10:03 <mburned> #meetingname RDO Community meeting
14:10:03 <zodbot> The meeting name has been set to 'rdo_community_meeting'
14:10:16 <DrBacchus> Anyways, I'm gathering items for the february newsletter. If you have anything that you'd like to see mentioned in there, please add them to the etherpad linked above.
14:10:23 * kashyap off for now
14:10:31 <mburned> #topic Next test day
14:10:42 <mburned> #info M2 is set for 23-Jan
14:10:48 * DrBacchus waits for mburned to catch up. :)
14:10:52 <mburned> #info 30-Jan proposed as next test day
14:11:36 <DrBacchus> February 1-2 is FOSDEM, followed shortly afterwards by Infrastructure.Next a few towns over.
14:11:43 <mburned> #info possible conflict with people traveling to FOSDEM
14:12:17 <mburned> DrBacchus: previous test day was 2 days, right?
14:12:21 <DrBacchus> I will be there, and would like to try to do audio interviews with as many RDO/OpenStack engineers as I can, for use in Joe Brockmeier's new "Forecast" podcast show, as well as on the RDO site.
14:12:31 <DrBacchus> Yeah, so I guess 30th and 31st would be what we'd do.
14:12:43 <DrBacchus> Although probalby 29-30 would be less stressful, so it's not Friday.
14:13:09 <DrBacchus> I'll write a note to the mailing list(s) suggesting those dates and see what folks think.
14:13:19 <mburned> #info need to followup on when packages for M2 will be available
14:13:32 <mburned> #info and see when people can do the Test Day
14:13:50 <DrBacchus> #info Rich will propose dates to the mailing list and see if there's agreement.
14:14:13 <mburned> #action DrBacchus to propose dates to mailing list to reach agreement
14:14:53 <mburned> #info stats from previous test day:  48 new tickets opened
14:15:26 <mburned> #topic Google Hangout
14:15:47 <mburned> DrBacchus: all caught up now, i think
14:15:48 <DrBacchus> #action DrBacchus needs to start bugging people about doing hangouts, so that we can get back in the practice of doing those.
14:16:03 <DrBacchus> #topic February newsletter
14:16:09 <DrBacchus> #link https://etherpad.openstack.org/p/rdo_community_manager_sync
14:16:26 <DrBacchus> #info If you have topics you'd like to see in the February newsletter, please add them to the etherpad
14:16:36 <DrBacchus> #topic FOSDEM
14:16:40 <mburned> should we move the newsletter pad to etherpad.openstack.org
14:16:43 <mburned> ?
14:16:50 <DrBacchus> Ah. Yes, that would be a good idea.
14:17:00 <mburned> (that's the wrong link for the newsletter
14:17:07 <DrBacchus> Bah.
14:17:29 <mburned> #topic February Newsletter (revisited)
14:17:36 <DrBacchus> #link http://etherpad.corp.redhat.com/RDONewsletter2014-02
14:17:45 <DrBacchus> But, yeah, I'll move it to somewhere public.
14:17:57 <mburned> #action DrBacchus to move content to etherpad.openstack.org
14:18:05 <mburned> #topic FOSDEM
14:18:12 <mburned> #info dates:  1-2 February
14:18:36 <mburned> #info Infrastructure.Next happening shortly after in a nearby town
14:18:50 <DrBacchus> If you're going to be at FOSDEM, I'd like to do a 10 minute interview with you about what you do around RDO/OpenStack, for Joe Brockmeier's podcast, and for the RDO website.
14:19:04 <morazi> DrBacchus, do you think it is worthwhile to discuss the items you presently have as topics on RDONewsletter (thinking 1 sentence summary) to help folks think about any additional topics that might be of interest
14:19:07 <mburned> #info DrBacchus would like to interview as many engineers as possible
14:19:37 <mburned> morazi: i'll post those at the end
14:19:45 <DrBacchus> Oh, ok, I was about to paste them.
14:19:51 <DrBacchus> Um ... where were we?
14:20:12 <DrBacchus> Oh, yeah. If you'd like to speak at Infrastructure.next, contact jzb@redhat.com
14:20:26 <mburned> #info if you'll be at FOSDEM/Infrastrucutre.Next, please contact DrBacchus so he can interview you
14:20:39 <mburned> if you want to speak at Infrastructure.next contact jzb@redhat.com
14:20:51 <mburned> #info if you want to speak at Infrastructure.next contact jzb@redhat.com
14:20:59 <mburned> DrBacchus: any info on the devroom?
14:21:09 <mburned> or presentations that we have lined up?
14:21:14 <DrBacchus> The schedule for the devroom has been posted. One moment ...
14:21:41 <mburned> #info devroom for Virt/IAAS exists, schedule posted
14:21:44 <DrBacchus> #link https://fosdem.org/2014/schedule/track/virtualisation_and_iaas/
14:22:05 <mburned> anything else for FOSDEM?
14:22:28 <DrBacchus> I don't think so, other than, speak up on the mailing list if you're going to be there, so folks can meet.
14:22:46 <mburned> ok, then moving on
14:22:53 <mburned> #topic Bitergia stats
14:23:03 <mburned> #link http://openstack.redhat.com/stats/
14:23:11 <DrBacchus> Not much to say here, other than, we have cool stats, done by the same folks that do Stackalytics - Bitergia.
14:23:35 <DrBacchus> They're interesting and informative, and if you haven't looked yet, have a look. They're pretty awesome, particularly if you're a stats geek like me.
14:23:54 <mburned> #info mostly informative with cool graphs
14:23:57 <DrBacchus> :)
14:24:16 <DrBacchus> Then we have CentOS Cloud SIG
14:24:24 <mburned> #topic CentOS Cloud SIG
14:24:42 <DrBacchus> If you're not on the centos-devel mailing list, it would be a good thing to join.
14:24:49 <mburned> #info every cloud project in the world wants to be part of this
14:24:58 <DrBacchus> mburned, and many other people, have started "Let's have a Cloud SIG" thread.
14:25:11 <mburned> #info organizational kickoff meeting on hangout on 23-Jan
14:25:33 <mburned> #info DrBacchus and mburned have been invited to speak
14:25:35 <DrBacchus> The consensus is, I think, coming around to let's have one unified cloud sig with variants for each cloud platform (openstack, eucalyptus, opennebula, and so on)
14:26:07 <mburned> #info consensus is to have one sig with multiple variants for each cloud platform
14:26:23 <DrBacchus> I haven't caught up with the overnight mailing list traffic yet this morning, so I don't know what's been said since last night.
14:26:44 <DrBacchus> But there's clearly a lot of energy, and people wanting to see this happen. So jump in and speak up.
14:27:04 <DrBacchus> Anything else we need to talk about there?
14:27:23 <mburned> #topic Feb Newsletter revisited
14:27:27 <mburned> #info Current Topics:
14:27:32 <pixelb> DrBacchus, kashyap sorry was on call. Icehouse milestone 2 is released upstream Jan 23rd. So having that packaged and available for Jan 30th is feasible. Note we also want to provide Icehouse milestone #2 packages available for el7 beta
14:27:38 <mburned> #info move to IRC meetings
14:27:40 <mburned> #info FOSDEM
14:27:52 <mburned> #info Infrastructure.Next
14:27:54 <mburned> #info SCALE
14:27:56 <DrBacchus> pixelb: That would be really good.
14:28:02 <mburned> #info CentOS Cloud SIG
14:28:23 <DrBacchus> pixelb: Is it a problem, do you think, doing a test day on Thursday/Friday rather than midweek? Do you think we'll lose a lot of participation?
14:28:39 <mburned> #info if you have other topics, please let us know or post them to the etherpad
14:28:55 <morazi> DrBacchus, it might be good to put some info about bug triage days here as well since we are trying to incubate that as a formal thing.  The more places we can mentioned it, the better I think
14:28:59 <morazi> mburned, ^^
14:29:14 <mburned> morazi: yep, thanks for the reminder...
14:29:29 <mburned> #topic testday (continued)
14:29:44 <mburned> DrBacchus: i'm not sure how relevant it is for rdo
14:29:46 <pixelb> DrBacchus, Not a problem. Generally we had them on Tue/Wed. Fri is an issue for some EMEA folks though
14:30:07 <mburned> but in ovirt, we shied away from thursday/friday mostly because of the Tel Aviv people that work Sun-Thu
14:30:38 <DrBacchus> pixelb: the 30th is Thursday. So if we want to move it earlier, we just need to know the earliest packages can be available.
14:30:40 <mburned> but rdo seems to be less geographically centered there...
14:30:44 <DrBacchus> Yeah
14:31:02 <DrBacchus> And, some folks (not very many) will be traveling to FOSDEM on the 30th, too.
14:31:11 <mburned> let's see what people say on the list
14:31:18 <mburned> i think Wed/Thu would be better...
14:31:23 <DrBacchus> Ok. I'll take that to the list. There's already an action item for that.
14:31:35 <mburned> pixelb: would having packages ready for Wednesday work?
14:31:55 <DrBacchus> That's the 28th
14:31:58 <DrBacchus> 29th rather
14:32:20 <DrBacchus> with m2 on thursday the 23rd the prior week.
14:32:27 <pixelb> Honestly I'd be happier with Feb 4th/5th (Tue/Wed)
14:32:34 <mburned> #info packages can definitely be ready for 30-Jan
14:32:51 <mburned> #info 4-5 Feb also proposed
14:33:02 <DrBacchus> pixelb: If the extra week makes the test day more successful, we should do that. Rushing it is no good.
14:33:13 * mburned good with that
14:33:23 <mburned> but let's see if we get objections on the mailing list...
14:33:27 <pixelb> I would say el6 packages would be ready for 30-Jan. But we'd also like to test el7 beta packages, and also include newer projects like trove, savanna, marconi...
14:33:28 <DrBacchus> Ok, will do.
14:34:02 <flaper87> pixelb: +1 :)
14:34:28 <mburned> #info preference here seems to be 4-5 February
14:34:39 <DrBacchus> I will still be travelling on the 4th/5th, but that's fine. I'll propose those dates on rdo-list and see what folks say.
14:34:40 <mburned> any other thoughts/comments on test day?
14:35:07 <pixelb> flaper87, marconi packaged and test cases for test day, would that be feasible?
14:36:54 <pixelb> flaper87, I'll be sending an email to the list later about packaging of newer projects etc. for RDO
14:37:04 <DrBacchus> Ok, well, moving on then. morazi what did you want to say about bug triage.
14:37:23 <mburned> #info looking to test el7 beta and add newer projects like trove savanna and marconi
14:37:39 <mburned> #info further discussion will be on the mailing list
14:37:40 <mburned> #topic Bug triage meeting
14:38:03 <mburned> #info a bug triage meeting has been organized for the 3rd Wednesday of each month here on IRC
14:38:14 <morazi> DrBacchus, mostly wanted to give kashyap and mburned a chance to talk about the proposal for the date & point to the existing docs w/r/t agenda & process for the meeting
14:38:27 <flaper87> pixelb: sounds feasible. I could take care of marconi or find someone to do it :P
14:38:31 <flaper87> fvollero: ^^^^
14:38:43 <flaper87> I remember you mentioned something about wanting to package marconi!
14:38:51 <morazi> #link https://home.corp.redhat.com/wiki/RHOSBugTriage
14:39:04 <mburned> #info first meeting set for tomorrow 15-Jan at the same time as this meeting
14:39:23 <mburned> #info we'll review the current open issues and bugs during this meeting
14:39:25 <morazi> blargh, not the link I meant
14:39:43 <mburned> #info we'll also re-evaluate the recurrence of this meeting if we find that it's too much or not enough
14:40:07 <morazi> http://openstack.redhat.com/RDO-BugTriage
14:40:10 <mburned> #link https://etherpad.openstack.org/p/RDO-BugTriage
14:40:25 <morazi> cheers
14:41:04 <DrBacchus> I should add that to the newsletter
14:41:11 <mburned> #info anyone interested in participating can just show up...
14:41:58 <DrBacchus> Ok, the last thing on the list is the ask.openstack.org open questions list.
14:42:11 <mburned> #topic Open Forum Questions
14:42:15 <DrBacchus> Here, again, there's not much to say, as people have been incredibly responsive when I've bugged them about answering questions.
14:42:34 <DrBacchus> There are, however, a handful of questions - probably the first 4 in the list - that have been open a long time and could use some love.
14:42:52 <DrBacchus> I also need to figure out how to filter questions that are answered, but the answer hasn't been accepted.
14:43:14 <DrBacchus> I don't know how many folks actually bother to accept/agree the answer - it's not very many
14:43:22 <mburned> can we tag them as "solution-proposed" or something?
14:43:36 <mburned> and then when accepted, remove that?
14:43:39 <DrBacchus> So there's actually a lot of questions where someone has posted an answer, but it's not really an answer, it's more of a comment.
14:43:43 <mburned> or maybe just leave it...
14:43:58 <DrBacchus> Alas, I still don't have sufficient karma to convert an answer to a comment, but I'm getting there.
14:44:23 <DrBacchus> mburned: Seems a reasonable suggestion. I don't like to leave people hanging.
14:44:30 <fvollero> flaper87: what ?
14:44:43 <flaper87> fvollero: nevermind!
14:44:56 <flaper87> fvollero: keep doing whatever you are doing :)
14:45:05 <mburned> #info problem:  how do we filter issues that have proposed solutions but no accepted answers?
14:45:06 <fvollero> flaper87: :(
14:45:18 <mburned> #info proposal:  add a "solution-proposed" flag or similar
14:45:41 <mburned> #info also, get more people to have enough karma to convert comments to answers
14:46:10 <DrBacchus> Meanwhile, I keep trying to go through and follow up on those posts that have answers that don't seem to be actual answers, to see if the original poster is even still tracking it.
14:46:30 <DrBacchus> There's a lot of drive-by postings, so it's hard to determine how much effort is really worth while there.
14:46:55 <DrBacchus> #link https://ask.openstack.org/en/questions/scope:unanswered/sort:answers-asc/page:1/query:rdo/
14:47:11 <DrBacchus> That's the unanswered RDO list. 17 this morning. We've been holding at around 9 for the last few weeks.
14:47:43 <DrBacchus> That's all I've got. Anybody else?
14:48:32 <mburned> DrBacchus: can we query on how long they've been open?
14:48:38 <mburned> or how long since there was any activity?
14:48:58 <mburned> maybe then we can review things open with no comments in the last week...
14:49:06 <mburned> or we can move that to the bug triage meeting...
14:49:11 <DrBacchus> I can add that info to the list. I've not had much luck with the API, but I haven't spent a lot of time on it.
14:49:31 <DrBacchus> kashyap didn't want to add that to the bug triage meeting. He said there's enough to cover there already.
14:49:43 <mburned> ok
14:49:54 <DrBacchus> But if I can get the API to cooperate, I'll do a weekly mailing to rdo-list or biweekly or something.
14:50:20 <mburned> #action DrBacchus to investigate the api to see if we can do queries based on age/inactivity
14:50:38 <mburned> #info and then we can review old open issues
14:50:46 <mburned> #topic other topics
14:50:56 <mburned> anyone have anything else to bring up today?
14:50:57 <DrBacchus> But the list in the etherpad is by age, and the one at the top is several months old.
14:51:32 <DrBacchus> Thank you everyone for your indulgence while we had this meeting. Please feel free to speak up if you have anything to add.
14:51:59 <DrBacchus> If nobody has anything else, we can adjourn.
14:52:20 <mburned> DrBacchus: first question there, maybe just ask if this is still and issue, and if there is no answer, then we can close it
14:52:41 <mburned> *still an issue
14:52:57 <DrBacchus> There's no comment since sep 24
14:53:28 <mburned> there is a linked bug in launchpad
14:53:35 <mburned> which is marked "Fix Released"
14:53:54 <DrBacchus> excellent I'll ping to see if it's still a problem.
14:54:28 <mburned> ok, final call -- will end meeting if no other topics
14:54:30 <mburned> going once...
14:54:33 <DrBacchus> #action DrBacchus will ping https://ask.openstack.org/en/question/5288/nova-network-is-crashing-hard/ to see if it's still an issue
14:55:18 <DrBacchus> ok, I think we're done then.
14:55:48 <DrBacchus> #endmeeting