openlmi_public_irc_meeting
LOGS
12:58:45 <sgallagh> #startmeeting OpenLMI (2014-05-05)
12:58:45 <zodbot> Meeting started Mon May  5 12:58:45 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:58:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:58:46 <sgallagh> #meetingname OpenLMI Public IRC Meeting
12:58:46 <zodbot> The meeting name has been set to 'openlmi_public_irc_meeting'
12:58:49 <sgallagh> #chair sgallagh tsmetana jsafrane rdoty
12:58:49 <zodbot> Current chairs: jsafrane rdoty sgallagh tsmetana
12:58:55 <sgallagh> #info Meetings are recorded and will be posted on www.openlmi.org. Opinions expressed do not necessarily reflect the reviews of the participant's employer.
12:59:00 <sgallagh> #topic Roll Call
12:59:23 <sgallagh> .hellomynameis sgallagh
12:59:24 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
12:59:38 <tsmetana> .hellomynameis tsmetana
12:59:39 <zodbot> tsmetana: tsmetana 'Tomas Smetana' <tsmetana@redhat.com>
13:00:40 <rnovacek> .fas rnovacek
13:00:41 <zodbot> rnovacek: rnovacek 'Radek Novacek' <rnovacek@redhat.com>
13:00:58 <tbzatek_> .fas tbzatek
13:00:59 <zodbot> tbzatek_: tbzatek 'Tomas Bzatek' <tbzatek@redhat.com>
13:01:55 <sgallagh> #topic Agenda
13:01:59 <sgallagh> #info Agenda Item: Bug Triage
13:02:27 <sgallagh> Anyone have anything else they'd like on the agenda?
13:03:24 * tsmetana doesn't
13:03:30 <sgallagh> ok
13:03:36 <sgallagh> #topic Bug Triage
13:03:41 <sgallagh> #url https://fedorahosted.org/openlmi/report/9
13:03:53 <sgallagh> We'll go through the NEEDS_TRIAGE in the order they appear on that report
13:04:29 <tsmetana> k
13:04:30 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/127 - [RFE] OpenLMI should configure PAM stack to avoid remote attacks
13:04:43 <tsmetana> 1.1.0 as per the last comment
13:04:45 <tsmetana> :)
13:04:55 <sgallagh> Agreed :)
13:05:13 <sgallagh> tsmetana: Will you handle updating the tickets as usual?
13:05:20 <tsmetana> sgallagh: yes.
13:05:27 <sgallagh> #agreed Move to OpenLMI 1.1.0
13:05:42 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/178 - HelloWorld for Indications
13:06:31 <sgallagh> Has this example script been merged in yet? I don't think so.
13:06:39 <tsmetana> me neither.
13:06:56 <sgallagh> It's a non-code change, so I'd like to do it in the stable branch
13:07:28 <sgallagh> (non-code meaning documentation example, obviously)
13:08:06 <tsmetana> ok.
13:09:20 <sgallagh> 1.0.2, then?
13:09:29 <tsmetana> agreed
13:09:34 <sgallagh> We should finish that up and release it soon, too.
13:09:38 <sgallagh> (aside)
13:10:06 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/303 - Add abrt provider
13:10:53 <tsmetana> depending on importance of this it can be 1.2.0 or any later.
13:11:11 <sgallagh> Yeah, I was thinking 1.2.0 at the earliest as well
13:11:32 * sgallagh forgot to mark the previous topic...
13:11:33 <sgallagh> #undo
13:11:33 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x10571190>
13:11:34 <tsmetana> it may be good to talk to the abrt team... jfilak was about to write a provider...
13:11:40 <sgallagh> #agreed Move to 1.0.2
13:11:44 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/303 - Add abrt provider
13:12:13 <sgallagh> tsmetana: The provider can be written at any time. If someone external wants to contribute it sooner, let them :)
13:12:40 <sgallagh> #agreed Defer to 1.2.0 or later
13:13:01 <tsmetana> priority minor?
13:13:03 <sgallagh> #info If the abrt team wants to contribute this provider, it may be accepted earlier than 1.2.0 if it is complete.
13:13:07 <sgallagh> tsmetana: Yes
13:13:11 <tsmetana> aok
13:13:39 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/128 - Test with IPv6
13:13:49 <sgallagh> Have we received any confirmation on this from QA?
13:14:10 <tsmetana> no. i asked them several times to add a comment to the ticket at least...
13:15:00 <tsmetana> sgallagh: i'll reassing this to amahdal.
13:15:08 <sgallagh> Thanks
13:15:22 <sgallagh> #info Reassigning to amahdal for confirmation of the testing.
13:15:38 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/309 - correct error codes in account provider
13:16:38 <tsmetana> tbzatek: ^^ any progress on this one?
13:16:38 <sgallagh> We need to be careful about this. Changing the error codes returned is technically changing API.
13:17:00 <tsmetana> sgallagh: hm... true...
13:17:04 <tbzatek> tsmetana: planned for the next few weeks
13:17:13 <tbzatek> but yeah, the concern about API break is true
13:17:55 <tsmetana> soo... what to do with it?
13:18:05 <sgallagh> We should only do this in a Y release and release note it carefully, I think
13:18:08 <tsmetana> close as "too late"? or move to 2.0.0
13:18:19 <tsmetana> ok
13:18:52 <tsmetana> that means 1.2.0
13:18:53 <sgallagh> We could add new errors and add a global setting to allow squishing them back to just CIM_ERR_FAILED if it's set.
13:19:11 <tbzatek> well we don't guarantee error codes stability, whenever a new version of underlying library comes, the codes could change very well the same way
13:19:21 <tsmetana> sgallagh: this may end up in explosion of such options...
13:20:28 <sgallagh> tbzatek: Well, one of the theoretical advantages to OpenLMI is that it should abstract such changes
13:20:28 <tbzatek> hmm, and in fact, recent libuser versions added new error codes so the problem is already there
13:20:37 <sgallagh> oof
13:20:41 <tbzatek> sgallagh: probably, yes
13:21:08 <sgallagh> Can CIM errors carry a payload? (like D-BUS errors do?)
13:22:13 <tbzatek> these are standardized CIM errors, we also have function return codes that are custom defined
13:23:41 <sgallagh> The value of doing this probably outweighs the cost.
13:24:11 <sgallagh> We still have an opportunity to update the documentation to state that any CIM_ERR_* is possible to be returned
13:24:34 <sgallagh> I assume there's at least a standard function like cim_is_error(), rather than necessarily having to check for each possible one explicitly?
13:24:50 <tbzatek> that's up to clients
13:25:20 <sgallagh> tbzatek: I mean, do lmiwbem and other wbem libraries have such a function?
13:25:20 <tbzatek> I'll take this in account while reviewing the provider code, we may need masking function
13:25:39 <sgallagh> Probably a useful thing to add to lmiwbem if not.
13:25:54 <sgallagh> (And arguably contribute back to pywbem as well)
13:26:09 * sgallagh will file a bug
13:26:12 * tbzatek has no idea about pywbem
13:26:26 <tbzatek> I'll update the ticket with this concern
13:26:27 <sgallagh> #action sgallagh to file RFE for cim_is_error()
13:26:32 <sgallagh> tbzatek: Thanks
13:26:41 <sgallagh> Shall we agree on 1.2.0 or later, then?
13:26:57 <tsmetana> sgallagh: let's try 1.2.0 for now
13:26:59 <tbzatek> that should be fine
13:27:07 <sgallagh> #agreed Target at 1.2.0
13:27:21 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/310 - LogicalFile: extend tests: provider configuration
13:28:22 <sgallagh> Proposal: make a "task" since tests aren't shipped, aim at 1.1.0?
13:28:34 <sgallagh> s/shipped/deployed/
13:29:09 <tsmetana> ok
13:29:51 <sgallagh> #agreed Change to "task", target for 1.1.0
13:30:10 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/308 - RFE: LogicalFile: allow creation of symlinks
13:31:02 <sgallagh> This one has a real user request behind it, but is going through a lot of discussion
13:31:19 <sgallagh> I think it got sidelined a bit by the authorization discussion
13:31:22 <tsmetana> sgallagh: i actually thought we didn't want to do it after all...
13:31:47 <sgallagh> tsmetana: I'm not sure if we have agreement on that point.
13:32:04 <tsmetana> sgallagh: all right...
13:32:17 <sgallagh> The primary argument is that it gives you an easy way to break your system. (Fair enough point)
13:32:39 <sgallagh> But Pegasus already basically gives you root privileges, so I'm not sure this is a sufficient reservation
13:33:18 <sgallagh> I'm still waiting on the customer to give us their justification, unfortunately.
13:33:25 <sgallagh> So shall we leave this in triage a bit longer?
13:33:38 <tsmetana> sgallagh: ok.
13:33:42 <tsmetana> let's wait
13:34:05 <sgallagh> #agreed Leave in triage until the customer requesting it provides more justification
13:34:17 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/271 - [RFE] lmi command support for persistent network setting
13:34:26 <tsmetana> this one looks rather odd.
13:34:33 <tsmetana> rnovacek: any comments? ^^
13:34:55 <sgallagh> Sounds like we have a persistence problem?
13:34:56 <rnovacek> tsmetana: oh, I wanted to ask fskola about it
13:35:10 <sgallagh> That sounds more like a bug than an RFE
13:35:13 <rnovacek> I haven't reproduced it myself
13:35:30 <tsmetana> sgallagh: it sounds weird. it's supposed to work.
13:36:01 <sgallagh> rnovacek: Please ping fskola and get more information.
13:36:01 <rnovacek> I'll ask about details
13:36:07 <sgallagh> tsmetana: Leave in triage for now?
13:36:13 <tsmetana> yes.
13:36:20 <sgallagh> #action rnovacek to ask for more information
13:36:35 <sgallagh> #agreed Leave in triage as we gather more information
13:36:50 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/305 - openlmi-scripts-network should provide 'list' command
13:37:29 <tsmetana> one more for rnovacek...
13:37:31 <sgallagh> Is this something we could squeeze into 1.1.0?
13:38:39 <rnovacek> should be fairly easy
13:39:24 <tsmetana> 1.1.0 then
13:39:32 <sgallagh> #agreed Target at 1.1.0
13:39:46 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/307 - setup_logging() does not work on Python 2.6
13:40:16 <sgallagh> Given that the 1.1.0 primary driver is backporting to older systems, I'd raise this one to a blocker for 1.1.0
13:40:27 <sgallagh> (It looks like a pretty easy fix, which helps)
13:40:38 <tsmetana> 1.1.0
13:41:05 <tsmetana> ...and blocker as well
13:41:16 <sgallagh> #agreed Blocker for 1.1.0
13:41:27 <sgallagh> #topic https://fedorahosted.org/openlmi/ticket/275 - Extended partition size is always 1024
13:41:29 <sgallagh> Last one...
13:41:43 <tsmetana> depends on blivet...
13:42:23 <tsmetana> let's leave it as is for now?
13:42:41 <sgallagh> Blivet bug is targeted at RHEL 7.1
13:42:49 <sgallagh> So that's probably in the 1.1.0 timeframe
13:43:14 <tsmetana> ok...
13:43:41 <sgallagh> I'd suggest we put it in that bucket to track it.
13:44:00 <sgallagh> But leaving it in triage is fine too, actually
13:44:10 <sgallagh> Maybe that's better... more noticeable in triage
13:44:16 <sgallagh> Sorry, thinking as I go :)
13:44:52 <tsmetana> i don't have any strong opinion about this one... just that the blivet bug is out of our control.
13:45:12 <tsmetana> so leaving it untriaged seems to be "more correct" here.
13:46:00 <sgallagh> #agreed Leave in triage until we get more information from the Blivet team
13:46:05 <sgallagh> #topic Open Floor
13:46:12 <sgallagh> Any other topics?
13:46:35 <sgallagh> Maybe we should talk about doing a bug roll-up for OpenLMI 1.0.2 in the near future, now that RHEL 7 rc is out with numerous fixes since 1.0.1
13:46:59 <rnovacek> ticket https://fedorahosted.org/openlmi/ticket/271 clarified
13:47:18 <rnovacek> I would say 1.1.0
13:47:29 <tsmetana> rnovacek: ok. thanks.
13:47:47 <tsmetana> so... 1.1.0 for now.
13:48:09 <tsmetana> sgallagh: and we can also set a target date for 1.0.2
13:48:29 <tsmetana> sgallagh: trac tells me we're 5 weeks over the deadline.
13:49:39 <sgallagh> tsmetana: That was always a placeholder of "a little while after 1.0.1"
13:50:10 <tsmetana> sgallagh: i know. but now we should specify it more precisely
13:50:18 <sgallagh> tsmetana: I think we're pretty much in good shape for a release.
13:50:34 <sgallagh> The only thing we'd probably want to do is clean up the documentation
13:50:58 <sgallagh> Maybe have a one or two-week doc sprint and then release?
13:51:10 <tsmetana> sgallagh: sounds good.
13:51:30 <tsmetana> all: any objections? ^^
13:53:50 <tsmetana> i take it as no...
13:54:07 <sgallagh> Shall we say Friday the 16th, then?
13:54:47 <tsmetana> yes
13:54:52 <sgallagh> I'll send an email to the -devel list announcing the doc cleanup sprint and plan to release, then
13:55:00 <tsmetana> sgallagh: ok. thank you.
13:55:04 <sgallagh> #agreed Release 1.0.2 on 2014-05-16
13:55:16 <sgallagh> #action sgallagh to send email about doc sprint to the openlmi-devel list
13:55:27 <sgallagh> Any other topics?
13:56:17 <tsmetana> looks like no.
13:56:35 <sgallagh> Thank you for participating
13:56:38 <sgallagh> #endmeeting