atomic_developer_bundle_weekly_meeting
LOGS
15:02:25 <lalatenduM> #startmeeting Atomic Developer Bundle Weekly Meeting
15:02:25 <zodbot> Meeting started Mon Jan 25 15:02:25 2016 UTC.  The chair is lalatenduM. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:25 <zodbot> The meeting name has been set to 'atomic_developer_bundle_weekly_meeting'
15:02:44 <lalatenduM> Who all are here for the meeting?
15:03:38 <praveenkumar> .fas kumarpraveen
15:03:38 <zodbot> praveenkumar: kumarpraveen '' <kumarpraveen.nitdgp@gmail.com>
15:03:39 <lalatenduM> .hellomynameis lalatendu
15:03:42 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
15:03:59 <nshaikh> .hellomynameis nshaikh
15:04:00 <zodbot> nshaikh: nshaikh 'Navid Ahmed Shaikh' <shaikhnavid14@gmail.com>
15:04:20 <lalatenduM> dustymabe: tkral cdrage ^^
15:04:51 <lalatenduM> I dont see poornima here, she was here last week I think
15:05:17 <nshaikh> yes
15:05:40 <lalatenduM> lets start
15:05:52 <lalatenduM> #topic ADB 1.6.0 release
15:05:54 <cdrage> woah didn't see this on my calendar
15:05:57 <cdrage> but
15:06:01 <cdrage> .hellomynameis cdrage
15:06:02 <zodbot> cdrage: cdrage 'Charlie Drage' <charlie@charliedrage.com>
15:06:12 <nshaikh> #info: ADB 1.6.0  release <https://github.com/projectatomic/adb-atomic-developer-bundle/releases/tag/v1.6.0>
15:06:19 <lalatenduM> cdrage: I had sent the invite to tools mailing list
15:06:35 <lalatenduM> I forgot to ping dharmit
15:06:55 <lalatenduM> nshaikh: thanks
15:07:05 <nshaikh> #info : Tested the build on Linux, Mac and Windows - closed the tracker issue <https://github.com/projectatomic/adb-atomic-developer-bundle/issues/203>
15:07:07 <dharmit> lalatenduM: Hi! Ah the weekly ADB meeting.
15:07:21 <dharmit> .fas dharmit
15:07:22 <zodbot> dharmit: dharmit 'Dharmit Shah' <shahdharmit@gmail.com> - shahdharmit 'Dharmit Shah' <shahdharmit@gmaill.com>
15:08:06 <lalatenduM> nshaikh: awesome , looks like you are only one guy did the tetsing :)
15:08:09 <lalatenduM> testing*
15:08:27 <nshaikh> lalatenduM, or the one who commented on the issue! ;-)
15:08:33 <lalatenduM> :)
15:09:03 <nshaikh> We should have release announcement going out hopefully today after blog post on projectatomic
15:09:06 <lalatenduM> nshaikh: I guess you will send the announcemnet mail later today
15:09:13 <lalatenduM> nshaikh: yup
15:09:30 <nshaikh> #action: Navid to send release announcement after blog is published on projectatomic.io
15:09:31 <lalatenduM> anything else on the topic?
15:10:06 <nshaikh> lalatenduM, praveenkumar : Should we talk about the OpenShift systemd service files inclusion in the box ?
15:10:16 <lalatenduM> nshaikh: sure
15:10:30 <lalatenduM> #topic OpenShift systemd service files inclusion in the box
15:10:37 <dustymabe> .hellomynameis dustymabe
15:10:38 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
15:10:39 <bexelbie> .hello bex
15:10:40 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
15:10:52 <praveenkumar> Openshift vagrantfile is updated for adb-1.6 release which will have v1.1.1 instead of master tag and templates update.
15:10:53 <lalatenduM> bexelbie: dustymabe _o/
15:11:28 * bexelbie still thinks that emoticon thing makes it look like you are drowning with one broken arm
15:11:50 <lalatenduM> bexelbie: :)
15:12:06 <praveenkumar> lalatenduM: I have some plan in mind for openshift service file for adb, will write it down and then discuss (may be next week).
15:12:13 <lalatenduM> praveenkumar: the openshift image caching in ADB is still pending
15:12:44 <nshaikh> #action: Praveen to draft the OpenShift service files plan on ADB issues list.
15:12:48 <lalatenduM> #action praveenkumar to discuss Plan for openshift service file for adb
15:12:50 <praveenkumar> lalatenduM: We had one meeting with bstinson about pipeline and we have to sync up to make it available.
15:12:59 <lalatenduM> praveenkumar: ok
15:13:31 <lalatenduM> The next ADB release is next week
15:13:47 <lalatenduM> as the we got delayed last week's release
15:14:04 <nshaikh> okay
15:14:06 <bexelbie> I believe we should shift that date if we can for ADB
15:14:21 * bexelbie wonders if the next topic needs to be the adb-utils RPM/repo
15:14:36 <lalatenduM> bexelbie: the idea was to do release of ADB and atomicapp on alternate week
15:14:50 <bexelbie> then we did it well
15:14:56 <bexelbie> as atomic app went last week :)
15:15:34 <nshaikh> Should we also log updates about vagrant-adbinfo (or similar) in ADB meeting ?
15:15:36 <lalatenduM> cdrage: dustymabe when is teh next atomic app release
15:15:47 <lalatenduM> nshaikh: yes
15:15:55 <dustymabe> lalatenduM: well we are supposed to do one this week (to get back on our schedule)
15:16:00 <cdrage> recently had a discussion with DV tha twe move our release dates to
15:16:11 <cdrage> Monday in order to help with the CDK / ADB releases
15:16:28 <cdrage> so instead of next week on Wednesday for our next release, we'd do it Monday
15:16:50 <bexelbie> given that it makes sense to wait a week on ADB, unless we want them in the same week
15:17:01 <lalatenduM> cdrage: ok, cool
15:17:04 <bexelbie> if we do that we should probably coordinate all the tools shipping at once ...
15:17:10 <dustymabe> hmm. something about a monday release doesn't seem like fun
15:17:10 <bexelbie> so we don't spam with release annoucements
15:17:11 <bexelbie> :)
15:17:13 <cdrage> what works best with you guys? if we do it the same week or every other week?
15:17:32 <bexelbie> if we wait ADB we can let Atomic App move to Tuesday safely
15:17:45 <bexelbie> possibly with ADB the following Tuesday?
15:17:46 <lalatenduM> cdrage: IMO every other week
15:17:52 <lalatenduM> bexelbie: +1
15:18:10 <lalatenduM> Mondays are difficult for a release
15:18:13 <cdrage> so this week is ADB's release right? we can push ours to next week
15:18:16 <cdrage> yeah :(
15:18:17 <lalatenduM> Wednesday works best
15:18:20 <bexelbie> So Atomic App on Tuesday; build ADB candidate on Wednesday with that Atomic App.  Then test with a push to Centos for Monday move to cloud and Tuesday announce?
15:18:45 <cdrage> okay, wednesday it is, DV just suggested it so it gives us two days before CDK / ADB release in case any problems arise
15:18:56 <lalatenduM> bexelbie: works for me
15:19:01 <cdrage> bexelbie: we can do that
15:19:03 <lalatenduM> nshaikh: praveenkumar ^
15:19:20 <cdrage> dustymabe: good with you?
15:19:27 <bexelbie> I have a feeling I own this for mail to the container-tools list ... am I right?
15:19:38 <lalatenduM> bexelbie: you are welcome :)
15:19:38 <nshaikh> +1
15:19:51 <dustymabe> cdrage: so keep the same schedule?
15:19:54 <dustymabe> sounds good to me
15:20:04 * bexelbie has another topic: ADB delivery space - can go after RPM convo
15:20:15 <bexelbie> dustymabe, cdrage are you all going to do Tuesdays or Wednesdays?
15:20:29 <lalatenduM> #info Atomic App on Tuesday; build ADB candidate on Wednesday with that Atomic App.  Then test with a push to Centos for Monday move to cloud and Tuesday announce
15:20:31 <dustymabe> bexelbie: we've been doing Wednesdays
15:20:53 <lalatenduM> ahh I need to change the info
15:20:57 <bexelbie> dustymabe, are you wanting to keep that? If so let's adjust for that above
15:21:07 <cdrage> I'm fine either doing tuesday or wednesday, if it works well with CDK building (since we're on diff timezones and we normally do late day releases) makes sense to change to tuesdays
15:21:39 <cdrage> tuesdays++
15:21:48 <DV> cdrage: I would push Atomic App on mondays
15:21:54 <DV> just to be on the safe side
15:22:09 <bexelbie> DV a tuesday release still gives us 7 days, 5 business days
15:22:14 <bexelbie> on an alternate week release cycle
15:22:44 <DV> well that assume alternate
15:22:57 <DV> which we likely break from time to time
15:23:42 <bexelbie> so should we plan for all releases to be in a single week?
15:23:50 <lalatenduM> and we wil again adjust the cycle to do alternate
15:24:25 <lalatenduM> bexelbie: nope, DV is suggesting alternate week I think
15:24:53 <DV> in general we will alternate
15:25:08 <bexelbie> so are we going to email out the idea in the info, and treat same week releases as an exception to be handled as needed on the spot?
15:26:04 <lalatenduM> bexelbie: yeah
15:26:23 <bexelbie> ok, I'll put an email together in a pad, get it reviewed and send it out for lazy consensus
15:26:45 <lalatenduM> bexelbie: sounds good
15:27:30 <lalatenduM> #action bexelbie to send a mail to container-tools about atomicapp and adb release cycle
15:28:08 <lalatenduM> praveenkumar: should we try to fix teh openshift stuf for Adb NEXT RELEASE?
15:28:28 <lalatenduM> s/NEXT RELEASE/ nect release/
15:28:36 <lalatenduM> next*
15:29:01 <praveenkumar> lalatenduM: that is the plan, but let's discuss about adb-utils stuff because I want to move those issue in that repo.
15:29:06 <praveenkumar> bexelbie: ^^
15:29:17 <lalatenduM> ok
15:29:20 <lalatenduM> moving on
15:29:33 <lalatenduM> #topic adb-utils
15:30:08 <lalatenduM> Looks like we are going with adb-utils name
15:30:19 <praveenkumar> #link https://www.redhat.com/archives/container-tools/2016-January/msg00043.html
15:30:45 <bexelbie> I think the name works and is easily changed by downstream packagers/modifiers
15:31:15 <lalatenduM> I dont like teh idea of changing names , upstream vs downstream , but thats just me
15:31:18 <lalatenduM> :)
15:31:34 <nshaikh> Lets not get into naming discussions please!
15:31:37 <bexelbie> lalatenduM, we can't control how downstream packagers choose to productize
15:31:57 <lalatenduM> bexelbie: yup
15:31:59 <bexelbie> If, for example, Red Hat wants to productize it under a different name, that is their choice :P
15:32:13 <lalatenduM> #info adb-utils name is final
15:32:41 <lalatenduM> bexelbie: right, I just dont like the problem , it shoudl not an issue at all
15:32:41 <nshaikh> We need a git repo with README / TODO and a request for moving the repo under projectatomic namespace
15:32:48 <lalatenduM> not be an*
15:33:04 <nshaikh> praveenkumar, would you like to take the AI ? ^
15:33:06 <lalatenduM> Do we knwo who can do that?
15:33:19 <lalatenduM> langdon: DV jzb
15:33:32 <langdon> lalatenduM, yes?
15:33:51 <lalatenduM> langdon: https://www.redhat.com/archives/container-tools/2016-January/msg00043.html
15:33:52 <praveenkumar> nshaikh: yes I will send mail to owner and make it available on projectatomic namespace.
15:34:05 <lalatenduM> we need the git repo
15:34:41 <nshaikh> thanks praveenkumar
15:35:00 <lalatenduM> anything else on this topic?
15:35:19 <nshaikh> I think we are good on adb-utils side.
15:35:24 <langdon> lalatenduM, just a quick q.. adb-utils != adb-info?
15:35:30 <bexelbie> +1 for next topic
15:35:38 <bexelbie> langdon, yes that is true
15:35:39 <nshaikh> langdon, No!
15:35:41 <lalatenduM> langdon: its a new RPM package for ADB
15:35:54 <bexelbie> adb-utils is not adb-info
15:36:00 <lalatenduM> bexelbie: +1
15:36:03 <langdon> ha.. those were awesomely unhelpful responses :)
15:36:08 <bexelbie> langdon, :)
15:36:08 <langdon> but.. .i get it
15:36:09 <praveenkumar> :)
15:36:11 <nshaikh> hehe :-)
15:36:12 <bexelbie> we try to cover the baes
15:36:13 <bexelbie> bases
15:36:15 <lalatenduM> langdon: sorry :)
15:36:17 <langdon> in progress....
15:36:26 <lalatenduM> next topic
15:36:30 <bexelbie> langdon, praveenkumar will email with the repo we need moved
15:36:48 <langdon> bexelbie, ohh, its a "move"? i thought it was a new..
15:36:57 <bexelbie> langdon, I think it can be either
15:37:06 <praveenkumar> langdon: bexelbie yes create a new one.
15:37:09 <bexelbie> we acted as though move was the only option
15:37:14 <langdon> praveenkumar, bexelbie just make me an admin on the project in your account (whitel) .. and i can move
15:37:34 <langdon> bexelbie, praveenkumar uhh. ok... whichever is fine with me.. i just need to know which to do
15:37:38 <bexelbie> langdon, praveenkumar you all should resolve this in PM so I will stop butting in :)
15:37:51 <praveenkumar> sure :)
15:38:08 <praveenkumar> lalatenduM: any other topic?
15:38:18 <bexelbie> I have one
15:38:22 <bexelbie> can we talk about delivery of hte ADB
15:38:34 <lalatenduM> Guys, we have crossed our meeting time :)
15:38:41 <lalatenduM> nope nothing for now
15:38:52 <lalatenduM> bexelbie: may be next meeting :)
15:39:02 <bexelbie> I hope so ...
15:39:04 <lalatenduM> or Over mail in between
15:39:18 <bexelbie> yep
15:39:22 <bexelbie> I'll do what I can :)
15:39:31 <lalatenduM> I will create an etherpad for teh meeting so that we can prioritize topics
15:39:35 <lalatenduM> in future
15:39:39 <bexelbie> cool
15:40:12 <lalatenduM> #endmeeting