weekly_gluster_community_meeting
LOGS
12:01:45 <kshlm> #startmeeting Weekly Gluster community meeting
12:01:46 <zodbot> Meeting started Wed Feb 10 12:01:45 2016 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:46 <zodbot> The meeting name has been set to 'weekly_gluster_community_meeting'
12:02:09 <kshlm> #topic Rollcall
12:02:13 <kshlm> Rollcall time!
12:02:24 <kshlm> Raise your hands if you're present.
12:02:30 * kshlm o/
12:02:49 <amye> o/
12:02:55 * skoduri is here
12:03:01 * aravindavk here
12:03:06 * jdarcy is
12:03:11 * Saravanakmr is here
12:03:45 <kshlm> Some relavtively new names this week.
12:03:50 * jiffin is here
12:03:57 <kshlm> Anymore people around?
12:03:59 * ira is.
12:04:30 * jwd is here
12:04:52 <kshlm> Okay. Let's start the actual meeting.
12:05:05 * atinm is partially here
12:05:05 <kshlm> The agenda is at https://public.pad.fsfe.org/p/gluster-community-meetings
12:05:16 <kshlm> #topic Last weeks AIs
12:06:07 <kshlm> Because of my mistake last week, we didn't have the meeting minutes generated, and I wasn't able to send out the meeting updates email.
12:06:22 <kshlm> So I don't think a lot of people have finished their AIs.
12:06:51 <kshlm> The Fedora-Infra team, imported the logs I gave them, and made them available yesterday.
12:07:06 <kshlm> Anyways let's begin with the 1st AI.
12:07:24 <kshlm> #topic ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:07:30 <kshlm> ndevos isn't around.
12:07:36 <kshlm> And he hasn't sent this out yet.
12:07:47 <kshlm> This goes to next weeks list.
12:07:51 <kshlm> #action ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:08:11 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:08:29 <kshlm> I spoke with csim at DevConf, but unfortunately this wasn't one of the topics.
12:08:41 <kshlm> I'll get back to him on this.
12:08:45 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:09:01 <kshlm> #topic rastar and msvbhat to consolidate and publish testing matrix on gluster.org in two weeks time, amye can help
12:09:11 <kshlm> msvbhat is out this week.
12:09:18 <rastar> not done yet
12:09:21 <kshlm> So rastar do you have any update?
12:09:25 <kshlm> Okay.
12:09:39 <kshlm> Next week for sure then?
12:10:06 <kshlm> #action rastar and msvbhat to consolidate and publish testing matrix on gluster.org in a weeks time, amye can help
12:10:10 <kshlm> Next week it is.
12:10:24 <kshlm> #topic kkeithley to send a mail about using sanity checker tools in the codebase in two weeks.
12:10:39 <kshlm> kkeithley is also out this week, and possibly next week.
12:10:46 <kshlm> Carrying this on as well.
12:10:50 <kshlm> #action kkeithley to send a mail about using sanity checker tools in the codebase in two weeks.
12:11:14 <kshlm> Skipping the next AI, as I've done it already.
12:11:20 <kshlm> #topic pranithk to close 3.7.7 tracker and open a 3.7.8
12:11:34 <kshlm> Can someone in the Bangalore office check if pranithk is in?
12:11:54 <kshlm> If he is, please ask him to come online, and attend this meeting.
12:12:20 <kshlm> I'll skip this and his other AI till the 3.7 topic comes up.
12:12:39 <kshlm> #topic amye to propose a rotating schedule for community
12:13:11 <amye> done
12:13:25 <amye> just had to hit send on an email trapped in my drafts folder :)
12:13:30 <atinm> pranithk is not around
12:13:40 <kshlm> atinm, Thanks.
12:13:52 <kshlm> amye, Cool! I was wondering if I had seen that mail.
12:13:58 <amye> New proposal for 15:00 UTC
12:14:10 <amye> 3 hours different for March 2 and March 16th
12:14:11 * jdarcy sent a message two years after it was drafted once.
12:14:19 <amye> I was trying to avoid that. :)
12:14:28 <amye> Please weigh in if that time is terrible.
12:15:03 <kshlm> amye, Any given time will be wrong for some one.
12:15:04 <hagarth> when we first started the community meeting, it used to start at 1500 UTC IIRC
12:15:11 <kshlm> I think it's fine though.
12:15:45 <amye> I've noticed that thing about timezones.
12:15:46 <kshlm> hagarth, Yup. 2030 IST.
12:16:13 <jdarcy> WFM
12:16:26 <hagarth> wfm too
12:16:44 <amye> ack
12:16:47 <amye> I like. :)
12:17:05 <amye> it's 07:00 PST, which is slightly easier
12:17:09 <kshlm> Good.
12:17:27 <kshlm> I'll skip humble's topics, as I know he hasn't done them.
12:17:54 <kshlm> #topic amye to start killing various news on the gluster.org properties
12:18:10 <amye> This is an over time thing. :)
12:18:19 <kshlm> Yeah.
12:18:29 <kshlm> You can take your time on this.
12:18:41 <amye> Doesn't have to roll onto next week, I can continually garden that one.
12:18:53 <amye> Although, PRs welcome. :)
12:18:54 <kshlm> As you say.
12:19:03 <kshlm> PRs on what?
12:19:24 <kshlm> The gluster.org site?
12:19:25 <amye> If someone has things that they very much want on news, PRs welcome.
12:19:34 <kshlm> Ah. Okay.
12:19:37 <amye> (or, as we used to say, patches welcome)
12:20:51 <jdarcy> (or, before that, get off my lawn)
12:20:56 <amye> Also true.
12:21:05 <amye> Except I want people on this particular lawn.
12:21:05 <kshlm> He he :)
12:21:41 <kshlm> Okay, onto 3.7
12:21:49 <kshlm> #topic GlusterFS 3.7
12:22:01 <kshlm> I know pranith has tagged 3.7.8
12:22:10 <kshlm> But he hasn't announced it yet.
12:22:37 <kshlm> Anyone knows when he plans to?
12:22:51 * post-factum already testing 3.7.8 :)
12:22:56 <kshlm> Also, have the package builders built the packages?
12:23:02 <kshlm> post-factum, nice to know.
12:23:09 <post-factum> and yes, there are rpms available
12:23:21 <kshlm> post-factum, From where?
12:23:42 <post-factum> https://download.gluster.org/pub/gluster/glusterfs/3.7/3.7.8/ huh?
12:24:07 <kshlm> I didn't know that!
12:24:26 <kshlm> I didn't see any updates on the packagers list about pacakges being built.
12:24:33 <hagarth> kshlm: probably kkeithley uploaded the RPMs?
12:24:38 <kshlm> I think we can officially announce now?
12:24:42 * post-factum too, found them occasionally
12:25:00 <kshlm> Do we wait for pranith to do it? Or can someone else do it?
12:25:37 <hagarth> kshlm: we can send out an announcement if all packages are available
12:26:19 <kshlm> I don't see debs yet.
12:26:48 <kshlm> I think we can announce if some of the packages are available.
12:27:05 <kshlm> That should (sort of) force the other packagers to package it.
12:27:14 <kshlm> hagarth, What do you say?
12:27:27 <hagarth> kshlm: I am ok with that
12:27:39 <kshlm> Okay.
12:27:47 <kshlm> So, do you want to announce?
12:28:08 <hagarth> kshlm: go ahead with the announcement
12:28:18 <hagarth> kshlm: do we have release notes for 3.7.8?
12:28:35 <kshlm> hagarth, If I'm announcing, I'll do them.
12:28:42 <hagarth> kshlm: ok
12:28:42 <kshlm> #action kshlm to announce 3.7.8
12:29:00 <kshlm> Onto 3.6 now.
12:29:05 <kshlm> #topic GlusterFS 3.6
12:29:19 <kshlm> I did the last 3.6.8 release.
12:29:34 <raghu> I am planning to make 3.6.9 be next week.
12:29:39 <kshlm> I didn't do a good job of announcing it. Or adding release-notes originally.
12:29:51 <raghu> kshlm: I need some help in pushing the patches
12:30:06 <kshlm> I've added release notes (basically git log) for all the 3.6.x releases.
12:30:16 <kshlm> raghu, What kind of help?
12:30:31 <raghu> kshlm: Everytime I say cherrypick a patch it just automatically submitts a new patchset
12:30:59 <raghu> which has to go through all the regression tests
12:31:00 <kshlm> raghu, Okay. Maybe we can discuss this after the meeting?
12:31:05 <raghu> kshlm: sure
12:31:27 <kshlm> Ping me later, if I don't ping you first.
12:31:43 <raghu> ok
12:31:55 <kshlm> #info 3.6.9 on track for next week (week of 14th february 2016)
12:32:07 <kshlm> #info raghu is back as the release-3.6 maintainer.
12:32:17 <kshlm> #topic GlusterFS 3.5
12:33:29 <kshlm> ndevos was planning on doing 3.5.8 for the 10th.
12:33:44 <kshlm> Which is today.
12:33:53 <ndevos> hey, I *just* got connected now :)
12:34:01 <amye> oh hey ndevos
12:34:06 <kshlm> ndevos, hey!
12:34:10 <ndevos> and indeed, 3.5.8 will be done this week
12:34:22 <kshlm> Good to know.
12:34:32 <kshlm> #info 3.5.8 will be done this week.
12:34:36 <amye> hurray
12:34:55 <kshlm> ndevos, anything to add?
12:34:56 <ndevos> its not really great to have two releases in a week, but well, we dont have many options...
12:35:07 <ndevos> no, not really.
12:35:10 <kshlm> 3.7.8 was an emergency release.
12:35:12 <ndevos> thanks Manikandan for the patches!
12:35:14 <csim> done before friday ?
12:35:23 <Manikandan> ndevos, np ;-)
12:35:31 <ndevos> csim: yes, I hope so
12:35:55 <kshlm> ndevos, I hope so too.
12:36:04 <csim> (cause, gerrit migration, etc)
12:36:12 <kshlm> #topic GlusterFS 3.8 and 4.0
12:36:28 <kshlm> Any 3.8 updates available?
12:36:50 <ndevos> support for seek has been merged, or at least almost
12:36:59 <jdarcy> Most of it.  ;)
12:37:06 <kshlm> ndevos, Good progress for 1 week!
12:37:27 <hagarth> ndevos: do we have all the feature pages populated in the desired way for 3.8?
12:37:52 <ndevos> hagarth: no idea, I did not have time to look into that the last few weeks with a busy conf schedule
12:38:16 <hagarth> ndevos: the last time I checked it did look sparse
12:38:35 <hagarth> and none of the feature pages had the "forward compatibility" etc. populated
12:39:04 * jdarcy just merged the posix patch for seek.
12:39:12 <hagarth> I suppose we should change the feature page template to also identify core reviewer(s) upfront along with the  owners
12:39:14 <ndevos> hagarth: yeah, we need to get that addressed
12:39:18 * amye will weep if we can't get feature pages updated by the end of the month.
12:39:19 <hagarth> yay!
12:39:32 <amye> is that a reasonable timeline?
12:39:45 <hagarth> I like the idea of having reviewers and owners working together as a patchset evolves
12:39:53 <hagarth> amye: looks reasonable to me
12:40:29 <amye> I sent an email last week to everyone who was listed as a maintainer/owner on the 3.8 roadmap
12:40:30 <hagarth> ndevos: we also would need to publish tentative code freeze and other significant milestones
12:40:39 <amye> I can follow up on that
12:41:02 <hagarth> ndevos: we can discuss this offline and evolve a plan, no rush atm :)
12:41:14 <ndevos> hagarth: and requirements before we allow merging of patches for impacting changes (like feature page, design, ...)
12:41:37 <hagarth> ndevos: right
12:41:47 <amye> documentation.
12:41:47 <jdarcy> Significantly more 4.0 stuff is appearing Gerrit.  Some of it has even been merged.
12:42:06 * amye would like a documentation gateway before merging of code. :)
12:42:36 <kshlm> jdarcy, Like what?
12:42:48 <ndevos> I'm not sure how we can write documentation, before a feature is in a released version... I dont want to confuse users?
12:42:50 <kshlm> Any update on Gluster-4.0 would be good right now.
12:43:17 <atinm> ok
12:43:17 <amye> ndevos, at least being able to make sure that this is something that someone who wants to get involved could understand.
12:43:21 <jdarcy> kshlm: Some pieces of NSR.  There's at least one DHT2 patch still in the queue (just framework though).  Both plus GlusterD 2 have had spec patches submitted.
12:43:39 <amye> Not user docs, developer documentation.
12:44:12 <atinm> We have been also working hard to get the etcd bootstrapping in place, there are still some missing pieces
12:44:31 <atinm> the last couple of weeks have been little slow from GD2 team because of conf schedule and legacy glusterd issues
12:44:41 * ndevos is in a train, and will enter a tunnel (disconnect) shortly
12:44:43 <kshlm> On the topic of GD2, I've got a couple of updates as well.
12:45:18 <kshlm> We had a discussion around how to do a flexible volgen for GD2.
12:45:41 <kshlm> I've got some pictures and some notes, that I need to put together into a consumable format.
12:45:48 <jdarcy> kshlm: I'd like to hear/see more when you can.
12:46:19 <atinm> kshlm, and the discussion was between?
12:46:21 <jdarcy> NSR work is ongoing, currently knee-deep in reconciliation infrastructure.
12:46:31 <kshlm> jdarcy, You were missed in that discussion.
12:46:55 <jdarcy> Also the NSR team might nearly double by EOM.
12:46:56 <hagarth> kshlm: likewise, interested in taking a look
12:47:37 <kshlm> atinm, this was in the meetings we had in Brno.
12:47:54 <atinm> kshlm, ok
12:47:59 <kshlm> atinm, Also on the topic of etcd, I spoke with purpleidea at FOSDEM and DevConf.
12:48:34 <kshlm> His new config management tool, which he's writing in Go, is also planning to do a similar sort of etcd management.
12:49:03 <atinm> kshlm, I'd love to see an email from you covering all these discussions :)
12:49:09 <kshlm> We're planning on discussing the same further some time later this week.
12:49:17 <kshlm> atinm, That's on my list of stuff to do.
12:49:24 <jdarcy> It's a pretty common need, I think.  How do you manage something that is itself core to the management of other things?
12:49:29 <kshlm> I just got back yesterday.
12:49:31 <hagarth> kshlm: is the new config management tool going to be around RSN?
12:49:40 <atinm> kshlm, sure I know, take your time :)
12:49:43 <kshlm> hagarth, What is RSN?
12:49:58 <ndevos> Real Soon Now?
12:50:07 <kshlm> Ah.
12:50:13 <jdarcy> Real Soon Now, or Round Sunday Noon
12:50:14 <kshlm> I don't think so.
12:50:21 * Saravanakmr lots of abbreviations going on :)
12:50:43 <kshlm> But we wanted to see if we could collaborate on this very similar part of code.
12:51:14 <kshlm> I'll be writing all this up. Hopefully, by the weekend.
12:51:28 <kshlm> Friday seems like a good time to do this.
12:52:06 <hagarth> kshlm: ok
12:52:10 <kshlm> Okay.
12:52:23 <kshlm> Do we have anything else for 3.8 and 4.0?
12:52:33 <jdarcy> Not from me.
12:52:39 <kshlm> Okay.
12:52:41 <kshlm> #topic Open Floor
12:53:00 <kshlm> #topic Gerrit/Jenkins migration on Friday 12th Feb, 2016 - http://thread.gmane.org/gmane.comp.file-systems.gluster.infra/901
12:53:14 <kshlm> So this is just a heads up to the people in the meeting.
12:53:26 <kshlm> We'll be sending out an announcement to the mailing list after the meeting.
12:53:49 <jdarcy> FYI: I'm back to full time.
12:53:56 * ira cheers.
12:54:08 <amye> jdarcy, nice
12:54:19 <kshlm> This Friday at 0900UTC, we plan to migrate jenkins and gerrit out of iWeb and onto the Red Hat community hardware.
12:54:24 <jdarcy> Probably not permanent, not sure if it's actually effective yet.
12:54:48 <kshlm> csim will be doing the migration, and in the worst case, it could take upto 8hours.
12:55:06 <hagarth> jdarcy: yay!
12:55:07 <csim> in fact, i was looking at just doing gerrit for now
12:55:11 <kshlm> So, be ready for a downtime on friday.
12:55:17 <jdarcy> Also, relatedly, will be in BLR February 23-29.
12:55:20 <kshlm> csim, no problems with that either.
12:55:47 <jdarcy> csim: Yay, that'll be a huge improvement.
12:56:09 <kshlm> What would you need to do jenkins as well?
12:56:15 <csim> time :)
12:56:19 <kshlm> That's where were seeing problems now.
12:56:38 <hagarth> csim: jenkins is the bigger problem atm
12:56:44 <kshlm> Jenkins master cannot get reliable connection to the slaves on rackspace.
12:56:59 <csim> I will try to get port open from network team for the jenkins server then
12:57:13 <csim> because the rest could be done on friday
12:57:30 <csim> worst case, we can still use the old server until every details are ironed out
12:58:04 <kshlm> csim, sounds okay to me.
12:58:15 <kshlm> So hagarth would you like to do this announcement?
12:58:25 * ira will be in BLR 13-27.
12:58:46 * ndevos will be in BLR 6-21 March
12:58:55 <hagarth> kshlm: sure, can do. let me know the exact schedule and I will send out a note.
12:59:16 <kshlm> hagarth, Okay. We can fine tune the details on the thread we have ongoing in gluster-infra.
12:59:37 <hagarth> kshlm: ok
12:59:39 <kshlm> #action hagarth to send migration/downtime announcement to the mailing lists.
12:59:42 <csim> do we have something planned to keep people busy during the day ?
12:59:56 <csim> (like non coding activities, such as "review docs, etc")
12:59:58 <amye> Writing their feature pages. *ducks*
13:00:12 <csim> amye: I heard that writing blog post can be done collaboratively too
13:00:30 <kshlm> I'll be spending my time writing up conference reports.
13:00:37 <hagarth> csim: people can work on code in their local repositories too
13:00:40 <amye> kshlm++
13:00:41 <glusterbot> amye: kshlm's karma is now 3
13:00:52 <csim> hagarth: true :)
13:01:13 <hagarth> so it should be fine :)
13:01:21 <kshlm> csim, We'll add suggestions in the announcement.
13:01:40 <kshlm> Okay. So the migration is on!
13:01:50 <kshlm> We're over time by 1 minute.
13:01:59 <kshlm> #topic Next weeks meeting host?
13:02:04 <kshlm> So who wants to do this?
13:02:11 <csim> mhhh, I had one topic for open floor
13:02:24 <kshlm> csim, sorry. I didn't check?
13:02:37 * atinm strongly feels that we should have a rotation policy
13:02:38 <csim> kshlm: nope, just forgot to ask for it :)
13:02:57 <csim> but wanted to know who know about download.gluster.com (not .org)
13:03:08 <atinm> It can't be like only 3-4 people doing it every time
13:03:11 <kshlm> atinm, we'll start with alphabetical order. You go first.
13:03:15 <kshlm> :)
13:03:21 <post-factum> :D
13:03:23 <kshlm> csim, So you couldn't find out?
13:04:03 <atinm> kshlm, I've no issues hosting next week's show but who is next to me :)
13:04:18 <csim> kshlm: well, I have iweb access, but no option to reset password or anything, so before I engage support, i wanted to see if someone here have access
13:04:29 <kshlm> hagarth, Do you have any clue who used to manage gluster.com systems?
13:04:56 <kshlm> csim, Okay.
13:05:02 <hagarth> csim, kshlm: I think we have raised tickets in the past IIRC
13:05:12 <kshlm> If anyone has any info on this, it should be hagarth.
13:06:00 <csim> alternative, we kill it with fire right away
13:06:12 <hagarth> csim: I am okay with killing that
13:06:18 <amye> I like burning it with fire
13:06:19 <jdarcy> Seems like the right thing to me.
13:06:34 <jdarcy> And douse the ashes with sulfuric acid.
13:08:14 <kshlm> I have no objections to this.
13:08:42 <hagarth> atinm: let us evolve a rotation policy for the meetings and have adequate "volunteers" for the rotation ;)
13:08:47 <amye> We should still figure out who owns it, but we can take that offline
13:09:14 <hagarth> amye: right
13:09:23 <atinm> hagarth, adequate volunteers, umm :)
13:09:38 <kshlm> hagarth & atinm, you guys seem to be volunteering your selves for this task.
13:10:03 <hagarth> kshlm, atinm: let us discuss this offline
13:10:25 <kshlm> hagarth, Okay with me. As long as it's on mailing lists or IRC.
13:10:27 <kshlm> :)
13:10:41 <kshlm> So atinm you're okay with next week right?
13:10:58 * jdarcy notes that, alphabetically, amye is before atinm.
13:11:10 <hagarth> kshlm: yep .. anything apart from evolving a list right now, right here works for me ;)
13:11:44 <kshlm> hagarth, okay.
13:12:16 <kshlm> #action atinm hagarth kshlm to create a list of rotating volunteers for hosting community meetings.
13:12:24 <kshlm> And with this I think we are done.
13:12:34 <hagarth> kshlm: thank you!
13:12:35 <post-factum> thx kshlm
13:12:44 <kshlm> Weekly announcement time!
13:12:57 <kshlm> Weekly reminder to announce Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:12:57 <kshlm> REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:12:57 <kshlm> Etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:13:12 <kshlm> And done!
13:13:15 <kshlm> #endmeeting