gluster_weekly_community_meeting_23-12-2015
LOGS
12:01:12 <kshlm> #startmeeting Gluster Weekly community meeting 23-12-2015
12:01:13 <zodbot> Meeting started Wed Dec 23 12:01:12 2015 UTC.  The chair is kshlm. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:13 <zodbot> The meeting name has been set to 'gluster_weekly_community_meeting_23-12-2015'
12:01:29 <kshlm> #topic Rollcall
12:01:59 * amye is here
12:02:09 * justinclift is here
12:02:29 * Manikandan is here
12:02:50 <kshlm> Hmm, not a lot of people around today.
12:03:05 <amye> Pretty quiet day. ;)
12:03:12 <justinclift> ;)
12:03:17 <Manikandan> kshlm, ;)
12:04:08 * ndevos is here, but only briefly
12:04:39 <amye> We had 2 action items from last week -- and neither of those people are here
12:04:46 * overclk is here..
12:04:48 <justinclift> Heh
12:05:13 * poornimag is here
12:05:15 * obnox somwehat here
12:05:15 * rastar is here
12:06:30 <kshlm> We have 9 people including me. Shall we start the meeting?
12:07:00 <kshlm> amye, I'm surprised you're up early!
12:07:12 <amye> kshlm: I'm in Rome this week. ;)
12:07:21 <justinclift> ;)
12:07:30 <obnox> amye: oh, wow
12:07:31 <justinclift> In the right TZ for a change :D
12:07:34 <amye> So it's 13:00. I like this way better than 04:00.
12:07:48 <kshlm> amye, cool
12:07:52 <amye> s/right/different
12:07:55 <justinclift> amye you should apply to keep in Rome :D
12:08:22 <kshlm> Let's start the meeting. We have enought activity now.
12:08:30 <kshlm> #topic Last weeks AIs
12:08:44 <kshlm> #topic ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes
12:08:58 <ndevos> oh... I'll do that next year!
12:09:08 <kshlm> ndevos, cool!
12:09:21 <ndevos> or, someone else can volunteer for that ;-)
12:09:35 <kshlm> #info ndevos will send out the reminder next year.
12:09:52 <justinclift> ... any idea which part of next year?  That's pretty broad... ;)
12:10:33 <kshlm> ndevos, I'll still keep this AI on you.
12:11:20 <kshlm> #action ndevos to send out a reminder to the maintainers about more actively enforcing backports of bugfixes (next year)
12:11:42 <kshlm> #topic raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.8
12:12:21 <kshlm> skipping and carrying this forward this. raghu hasn't done this, and isn't going to be around till the after the new year.
12:12:34 <kshlm> #action raghu to call for volunteers and help from maintainers for doing backports listed by rwareing to 3.6.8
12:12:58 <kshlm> #topic msvbhat and rastar to follow up on the results of the "Gluster testing matrix" email
12:13:00 * atinm arrives late and will be here partially
12:13:08 <kshlm> rastar, msvbhat, anything?
12:13:25 <rastar> kshlm: i just replied to the mail
12:13:36 <rastar> we have to consolidate and publish on web
12:13:50 <rastar> will do it in 2 weeks
12:14:04 <kshlm> So shall I consider this AI done?
12:14:22 <rastar> kshlm: no, lets keep it open till it goes on to gluster.org
12:17:14 * amye can assist with the publishing part post-Jan 1
12:18:54 <kshlm> Sorry! My net connection quit.
12:19:18 <kshlm> I was replying to rastars ai.
12:19:59 <kshlm> The last thing I got was rastar saying 'kshlm: no, lets keep it open till it goes on to gluster.org'
12:20:17 <obnox> kshlm: 13:17 * amye can assist with the publishing part post-Jan 1
12:20:24 <obnox> that was it
12:20:42 <kshlm> obnox, I said that?
12:20:54 <kshlm> Huh, anyways.
12:21:01 <obnox> kshlm: no, amye said "/me .... "
12:21:10 <obnox> so she can assist ...
12:21:14 <kshlm> Okay.
12:21:36 <amye> :)
12:21:40 <kshlm> #action rastar and msvbhat to consolidate and publish testing matrix on gluster.org. amye can help post Jan 1.
12:21:46 <kshlm> Thanks obnox.
12:21:49 <amye> Happy to help with the WordPress happenings.
12:22:00 <kshlm> #topic kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github
12:22:16 <amye> csim is out until Jan 4, probably best to hold on that.
12:22:35 <kshlm> This hasn't been done yet. We still need the bugzilla bot account.
12:22:49 <kshlm> amye, thanks for letting us know.
12:23:19 <kshlm> #action kshlm & csim to set up faux/pseudo user email for gerrit, bugzilla, github (after csim comes back on 4th Jan)
12:23:22 <amye> Let's hold that AI until after the new year.
12:23:25 <amye> Ack, thanks.
12:23:36 <kshlm> #topic hagarth to decide on 3.7.7 release manager
12:23:42 * msvbhat joins late
12:24:00 <rastar> that is done
12:24:03 <kshlm> #info pranithk volunteered to be the release-manager for 3.7.7
12:24:27 <kshlm> rastar, :)
12:24:32 <kshlm> #topic amye to get on top of disucssion on long-term releases
12:24:54 <kshlm> amye, this is still ongoing, right?
12:25:06 <amye> Indeed. It's going to be a long term thing.
12:25:10 <amye> Tied to 3.8 release.
12:25:19 <justinclift> Ooooh.  Long term releases sounds like a good idea.
12:25:30 <amye> Happy to keep it up on the meeting but until we get close to 3.8's actual release, there's not much to talk about. ;)
12:26:06 <kshlm> So 3.8 is going to be our long-term release?
12:26:18 <amye> No
12:27:01 <amye> This is a conversation about 'how or if our long term release strategy should change with the 3.8 release'
12:27:07 <ndevos> if 3.6 or 3.7 would become a long-term release, we should inform users early, otherwise we need to push them a little more for upgrading to the next
12:28:01 <kshlm> amye, I remember that now.
12:28:08 <amye> kshlm++
12:28:08 <zodbot> amye: Karma for kshlm changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:28:09 <glusterbot> amye: kshlm's karma is now 1
12:28:15 <kshlm> I think we'll keep this open.
12:28:31 <amye> Ok. It's a hagarth AI.
12:28:38 <amye> But happy to be the placeholder for it.
12:28:43 * kkeithley wonders what zodbot just did
12:28:59 <kshlm> #action amye/hagarth to get on top of disucssion on long-term releases
12:29:19 <amye> kkeithley, I woke it up with karma.
12:29:19 <kshlm> #topic amye/sankarshan to post Gluster Monthly News by the end of December
12:29:31 <amye> Oh, the AI on that one was 'January'.
12:29:38 <kshlm> amye, okay.
12:29:52 <amye> January is when the newsletters kickoff again.
12:29:53 <kshlm> When in january? early, mid, late?
12:30:13 <amye> Depends on how many things people add to the publicpad. Would prefer mid.
12:30:24 <kshlm> #info Newsletters will kickoff in January.
12:30:31 <kshlm> amye, Okay.
12:30:55 <ndevos> do we still use https://public.pad.fsfe.org/p/gluster-weekly-news for that?
12:31:00 <amye> all y'all can add 'new things that you want to highlight to community' to public etherpad ^
12:31:07 <amye> Sure. Until someone has something better.
12:31:12 <ndevos> ok :)
12:31:15 <kshlm> #action amye/sankarshan to post Gluster Monthly News in January, preferrably by mid Jan.
12:31:26 <ndevos> #link https://public.pad.fsfe.org/p/gluster-weekly-news
12:31:48 <kkeithley> I understand the karma thing. what's all the f23 release cycle and badges stuff
12:31:57 <kshlm> #topic hagarth to create 3.6.8 for bugzilla version
12:32:53 <kkeithley> he hasn't done it. I can do it too, fwiw, and I will once we have an actual 3.6.8
12:33:32 <kshlm> kkeithley, actually it's done.
12:33:39 <kshlm> #link https://bugzilla.redhat.com/show_bug.cgi?id=glusterfs-3.6.8
12:33:40 <glusterbot> Bug glusterfs: could not be retrieved: InvalidBugId
12:34:04 <ndevos> kkeithley: https://badges.fedoraproject.org/user/kkeithley vs https://badges.fedoraproject.org/user/devos
12:34:09 <kkeithley> is it? okay.  Actually, anyone can do it. just send email to bugzilla-requests@redhat.com
12:34:56 <kshlm> kkeithley, Ah, I was thinking of the 3.6.8 tracker bug.
12:35:11 <ndevos> kshlm: that tracker is filed against 3.6.7, not 3.6.8
12:35:22 <kkeithley> no, there is no version 3.6.8
12:35:24 <ndevos> there is no 3.6.8 version yet
12:35:25 <kkeithley> yet
12:35:42 <kshlm> ndevos, kkeithley, Yup. My mistake
12:35:51 <kshlm> Let's keep this open.
12:36:11 <kshlm> #action hagarth to create 3.6.8 for bugzilla version
12:36:11 <kkeithley> I can go ahead and get them added now, if that's what people want
12:36:49 * ndevos doesnt want the 3.6.x versions at all, but he might have lost that battle
12:37:10 <kkeithley> huh?
12:37:49 <kshlm> kkeithley, You can take your time on it. There's no urgent requirement for it.
12:38:05 <ndevos> (I prefer simple 3.5, 3.6 and 3.7, no need for those extra minors)
12:39:02 <kshlm> #topic kkeithley to send a mail about using sanity checker tools in the codebase
12:40:12 <kkeithley> haven't done it. :-/
12:40:21 <kshlm> kkeithley, ok.
12:40:34 <kshlm> I'll carry it forward.
12:40:41 <kshlm> #action kkeithley to send a mail about using sanity checker tools in the codebase
12:40:59 <kshlm> #topic rtalur/rastar will send a seperate email about the Gerrit patch merge strategies to the maintainers list
12:41:50 <kshlm> rastar, what was this about exactly?
12:42:21 <rastar> This about moving to fast forward merge
12:42:28 <rastar> Have not done yet :(
12:42:34 <rastar> will do by next week
12:42:46 <kshlm> rastar, okay. I'll carry the AI forward.
12:43:02 <kshlm> #action rtalur/rastar will send a seperate email about the Gerrit patch merge strategies to the maintainers list
12:43:13 <kshlm> So we're done with the AIs.
12:43:22 <kshlm> #topic GlusterFS-3.7
12:43:42 <kshlm> The only update I have is that pranithk is the release-manager for 3.7.7.
12:44:33 <kshlm> We're nearly at the scheduled release date (30th) but I doubt we'll have a release by then.
12:45:07 <kshlm> I haven't seen enough activity around 3.7.7.
12:45:15 <kshlm> Anyone else has anything to add here?
12:45:42 <atinm> kshlm, I think we have been backporting patches in 3.7
12:45:52 <atinm> kshlm, so not sure about your concerns
12:46:57 * obnox might try to land a few more cleanups to the samba/ctdb facing hook scripts
12:47:18 <ndevos> hmm, 140 patches after 3.7.6? git log --oneline v3.7.6...origin/release-3.7 | wc -l
12:47:51 <atinm> ndevos, that proves that branch is pretty active, isn't it :)
12:47:53 <kkeithley> yes, I expect the ganesha team wants to clean up it's hook scripts too. ndevos?
12:48:09 <kkeithley> s/it's/its/
12:48:33 <ndevos> kkeithley: well, that is not a requirement for 3.7.7, but we might want to get that in, yeah
12:49:03 <kkeithley> no, it's not a _requirement_.
12:49:21 <ndevos> oh, "clean up" can be a lot... not sure if we're thinking of the same changes - but no need to discuss that here
12:49:46 <kkeithley> just what we (you, me, jdarcy) were disussing
12:50:00 <obnox> ndevos: :-) the rpcbind related things?
12:50:05 <kkeithley> rpcbind dependency
12:50:45 <ndevos> yes, that'll be posted later today, and we can backport that if we want to
12:50:51 <kshlm> Sorry again. My home internet connection has been really bad today.
12:51:09 <kshlm> Will all this be done before next week?
12:52:14 <ndevos> kshlm: yes, but not a lot to do there - http://termbin.com/ooml
12:53:07 <kshlm> ndevos, thanks for the log
12:53:10 <kshlm> ndevos++
12:53:10 <zodbot> kshlm: Karma for devos changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:53:10 <glusterbot> kshlm: ndevos's karma is now 4
12:53:35 <kshlm> #info glusterfs-3.7.7 still on target for scheduled release.
12:54:01 <kshlm> Thanks for the 3.7 updates guys.
12:54:11 <kshlm> #topic GlusterFS-3.6
12:54:51 <kshlm> raghu is out for the next 2-3 weeks. So he will not be able to do a release in this period.
12:55:16 <kshlm> He asked for volunteers to do 3.6.8, I don't think anyone put their hand up.
12:56:01 <kshlm> 3.6.8 was supposed to have been released by now, as per the release schedule.
12:56:43 <kshlm> Any volunteers?
12:57:13 <kshlm> No?
12:57:22 <kshlm> I'll take it up.
12:57:34 <kshlm> I'll try to do the release over the weekend.
12:57:41 <ndevos> kshlm++ awesome
12:57:41 <zodbot> ndevos: Karma for kshlm changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:57:46 <kshlm> #info kshlm will be the release-manager for 3.6.8
12:58:12 <kshlm> #info 3.6.8 slipped scheduled release on 20th, now targetted for 26th.
12:58:24 <kshlm> #topic GlusterFS-3.5
12:58:35 <kshlm> ndevos, anything you want to say.
12:59:07 <ndevos> nothing to see here
12:59:17 <kkeithley> move along
12:59:36 <kshlm> Cool thanks.
12:59:46 <kshlm> #topic Open Floor
13:00:04 <kshlm> Oops, we still have Gluster.Next
13:00:09 <kshlm> #topic Gluster.Next
13:00:15 <atinm> kshlm, :)
13:00:19 <kshlm> atinm, Do you want to say something.
13:00:25 <atinm> kshlm, yup
13:00:53 <atinm> kshlm, We have had a discussion across the teams about coming up with a MVP from each initiatives
13:01:11 <atinm> MVP stands for minimum viable product
13:01:41 <kshlm> atinm, thanks for clearing that up ;-)
13:01:43 <overclk> atinm: proposition?
13:02:01 <atinm> We'll be sharing that details shortly with the community and seeking their feedback about the same
13:02:46 <atinm> apart from that work continues, considering its an year end, we haven't had much progress
13:02:47 <kshlm> The basic idea here is to get the new things into the communities hands as quickly as possible.
13:03:07 <atinm> kshlm, thanks for adding to it, I was about to come to it
13:03:24 <overclk> kshlm, atinm: similar update for dht2 (considering year end)..
13:03:36 <kshlm> overclk, thanks.
13:03:45 <atinm> That's pretty much what we have from Gluster 4.0 side
13:04:22 <kshlm> (back to the MVP)
13:05:21 <kshlm> to get stuff into the communities hands, we need to first define the minimum amount of things to be done to show how our new feature works.
13:05:55 <kshlm> So each team working on Gluster-4.0 features will be proposing what their MVP is, and will provide an estimated time to get to it.
13:06:33 <kshlm> Further details on this and on how we plan to release the mvp will be shared in a mail to the community.
13:06:52 <kshlm> Either atinm or hagarth would possibly be doing this.
13:07:13 <atinm> kshlm, put an action item on me/hagarth
13:07:22 <kshlm> atinm, cool
13:07:43 <kshlm> #action atinm/hagarth to share details on the MVP plan for Gluster-4.0
13:08:10 <kshlm> I don't think we have any further updates on 3.8, so let's move on the Open Floor.
13:08:16 <kshlm> #topic Open Floor
13:08:52 <kshlm> I see no topics other than the normal announcements and a new link to a backports etherpad.
13:09:07 <ndevos> kshlm, msvbhat: care to share a line about the CentOS CI testing that will happen soon?
13:09:13 <kshlm> Is the backports etherpad itself a topic, or is it another announcement?
13:09:29 <kshlm> ndevos, Thanks for reminding me about that!
13:09:48 <ndevos> it was there last week too... I think kkeithley likes the backport etherpad (not sure if users know about it)
13:10:01 <kshlm> #topic CI testing on CentOS CI
13:10:38 <kshlm> A small group of volunteers has been formed, who will take a dive into making use of the CentOS CI infra to test glusterfs.
13:10:46 <kkeithley> It's not that I like it, so much as nobody is putting backports in the wordpress wiki either.
13:11:23 <kshlm> ndevos++ for pulling this group together.
13:11:29 <kkeithley> just trying to lower the barrier for people to request backports.
13:11:55 <msvbhat> Yeah, ndevos++. I will try to start it off tomorrow
13:12:20 <kshlm> We had a hangout with Brian Stinson to get an introduction to the centos CI infra.
13:12:35 <ndevos> we're collecting details about the tests we're going to add on https://wiki.centos.org/SpecialInterestGroup/Storage/Gluster/CI
13:12:47 <amye> kshlm, is there a link for that or emails?
13:13:03 <kshlm> #link https://wiki.centos.org/SpecialInterestGroup/Storage
13:13:21 <kshlm> amye, the link ndevos gave will contain details regarding this effort.
13:13:30 <kshlm> #link https://wiki.centos.org/SpecialInterestGroup/Storage/CI
13:13:37 <msvbhat> https://youtu.be/U3uEfW_igQE
13:13:40 <amye> ack
13:13:48 <msvbhat> Youtube hangout link
13:13:56 <kshlm> ndevos had sent out a call for volunteers on the community lists.
13:14:06 <amye> Erm, kshlm, the /CI page doesn't exist yet
13:14:16 <amye> That's on purpose, right?
13:14:19 <kshlm> Further communication happened on private emails.
13:14:28 <kshlm> amye, I put in the wrong link.
13:14:36 <kshlm> #link https://wiki.centos.org/SpecialInterestGroup/Storage/Gluster/CI
13:14:40 <amye> oh ok, I will be quiet.
13:14:45 <kshlm> ^ is the correct link.
13:15:02 <kshlm> #link https://youtu.be/U3uEfW_igQE
13:15:12 <kshlm> msvbhat, thanks for the link.
13:15:47 <kshlm> We'll be updating the linked wiki with details of our plans and progress.
13:15:57 <ndevos> if others want to add upstream Gluster testing (multi node!?) or test packages from the Storage SIG, let me know and we'll get you the accounts and all
13:16:43 <kshlm> This is all I have.
13:17:22 <kshlm> ndevos thanks again for remembering this.
13:17:35 <kshlm> There are no more topics left for the day.
13:17:47 <kshlm> We are 15 minutes overtime.
13:18:01 <kshlm> I'll end the meeting if there is nothing further to discuss.
13:18:21 * ndevos does not have anything else
13:18:39 <kshlm> Thanks everyone for attending today's meeting.
13:18:44 <amye> Crickets
13:18:47 <kshlm> As always remember the following
13:18:51 <kshlm> Weekly reminder to announce Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:18:51 <kshlm> REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
13:18:51 <kshlm> Etherpad for backport requests  https://public.pad.fsfe.org/p/gluster-backport-requests
13:18:51 <ndevos> thanks kshlm!
13:19:06 <kkeithley> versions 3.5.8, 3.6.8, and 3.7.7  have been added to bugzilla
13:19:15 <kshlm> kkeithley, Awesome!
13:19:47 <kshlm> Good{morning,afternoon,evening,night} to everyone.
13:19:59 <kshlm> See you all next week.
13:20:03 <kshlm> #endmeeting