gluster-meeting
LOGS
12:00:12 <kdhananjay> #startmeeting
12:00:12 <zodbot> Meeting started Wed Sep  2 12:00:12 2015 UTC.  The chair is kdhananjay. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:37 <kdhananjay> #info agenda is available @ https://public.pad.fsfe.org/p/gluster-community-meetings
12:00:46 <kdhananjay> #topic roll call
12:00:48 * anoopcs is here
12:00:53 * ndevos is present
12:01:00 * hagarth is here
12:01:09 * rjoseph is present
12:01:24 * tigert is in
12:01:35 * partner lurking
12:01:39 * skoduri is here
12:01:46 * jiffin is here
12:02:30 <kdhananjay> #topic Action items from last week
12:02:51 <kdhananjay> #topic raghu to fill in the contents for release schedule and ask tigert to push the page in gluster.org
12:03:18 <kdhananjay> Looks like raghu is not here.
12:03:27 <hagarth> kdhananjay: I think this was done
12:03:40 <kdhananjay> hagarth: OK great.
12:03:41 <ndevos> raghu doesnt seem to be there? maybe tigert has more info?
12:03:42 <lpabon> here
12:03:54 <hagarth> #link - http://www.gluster.org/community/release-schedule/
12:04:07 <kdhananjay> hagarth: Cool!
12:04:18 <ndevos> ah, thanks!
12:04:39 <kdhananjay> #topic msvbhat/rastar to send update mailing list with a DiSTAF how-to and start discussion on enhancements to DiSTAF.
12:05:15 <ndevos> they posted a start for the improvements in the glusterfs-specs repo
12:05:43 <kdhananjay> ndevos: safe to say it's done?
12:05:48 <ndevos> #link DiSTAF improvements for review http://review.gluster.org/12048
12:06:00 * msvbhat joins late
12:06:05 <ndevos> kdhananjay: not sure, I would like to see an announcement and request for review on the mailinglist
12:06:13 <hagarth> ndevos: +1
12:06:29 * rafi joins late
12:06:34 <msvbhat> ndevos: Will send the review link to mailing list soon
12:06:35 * rastar joins late
12:06:37 * poornimag joins late
12:06:44 <ndevos> msvbhat: okay, thanks!
12:07:04 <ndevos> kdhananjay: so, not done yet, check/remind msvbhat next week again?
12:07:35 <kdhananjay> #action msvbhat to make announcement on DiSTAF enhabcements and review request on the mailing list
12:07:55 <kdhananjay> Moving on ...
12:08:02 <kdhananjay> #topic kshlm to check back with misc on the new jenkins slaves.
12:08:10 <kdhananjay> kshlm not here.
12:08:18 <kdhananjay> Does anyone else have an update on this perhaps?
12:09:02 <hagarth> no clue on this one
12:09:05 <kdhananjay> Err... I guess not.
12:09:16 <kdhananjay> hagarth: OK. Will retain this for the next week.
12:09:27 <kdhananjay> #topic kslm to send  out an announcement regarding the approaching deadline for Gluster 3.7 next week.
12:09:42 <kdhananjay> Think he did this.
12:09:47 <ndevos> thats done, and the release happened too
12:09:59 <kdhananjay> Great.
12:10:23 <ndevos> packaging is in progress, and when most distributions are ready there will be an announcement
12:10:41 <kdhananjay> Right.
12:10:50 <kdhananjay> On to the next topic.
12:10:53 <kdhananjay> #topic hchiramm to improve release documentation
12:11:01 <kdhananjay> hchiramm not here/
12:11:11 <kdhananjay> Anyone else who has an update on this?
12:11:39 <rastar> I don't think we made any progress on this
12:11:49 <kdhananjay> OK.
12:11:53 <rastar> it needs a discussion too, possibly on open floor?
12:12:01 * raghu arrives late
12:12:01 <ndevos> what is "release documentation"?
12:12:22 <rastar> Jeff wanted a place for tracking features
12:12:26 <rastar> feature planning etc
12:12:44 <ndevos> ah, okay -> open floor :)
12:12:47 <rastar> None of  gluster-docs, gluster-spec and glusterfs repo are place for this
12:12:49 <kdhananjay> ;)
12:13:36 <kdhananjay> #topic raghu to announce 3.6.5 on mailing lists
12:14:16 * overclk is late to the meeting..
12:14:17 <kdhananjay> raghu: ^^
12:14:52 <kdhananjay> or for that matter anyone else who has seen this announcement on the lists :)
12:15:12 <anoopcs> That's done.
12:15:17 <anoopcs> #link http://www.gluster.org/pipermail/gluster-devel/2015-August/046570.html
12:15:25 <kdhananjay> anoopcs: Ah great. Thanks!
12:15:41 <kdhananjay> Moving on ..
12:15:51 <kdhananjay> #topic krishnan_p to update Gluster News about Gluster.next progress
12:16:00 <kdhananjay> krishnan_p absent.
12:16:19 <kdhananjay> Anyone else who could represent this?
12:16:25 <jdarcy> There have been some updates sent for sub-projects.  Much appreciated.
12:16:32 <ndevos> its not on https://public.pad.fsfe.org/p/gluster-weekly-news yet
12:17:14 <kdhananjay> OK. Adding this for discussion next week.
12:17:24 <kdhananjay> #action krishnan_p to update Gluster News about Gluster.next progress
12:17:37 <kdhananjay> #topic krishnan_p to send an email about nanomsg.org to gluster-dev
12:17:45 <jdarcy> Saw that.
12:18:02 <kdhananjay> OK great!
12:18:19 <kdhananjay> #topic GlusterFS 3.7
12:18:53 <kdhananjay> Anything to talk about here?
12:19:04 <hagarth> 3.7.4 update happened before here.
12:19:15 <hagarth> any volunteers for release manager of 3.7.5?
12:19:58 * ndevos looks at the MAINTAINERS file
12:20:22 <hagarth> we don't have to find one right away. i will post a note on devel asking for volunteers.
12:20:32 <ndevos> maybe we could randomly pick someone from that file?
12:21:29 <hagarth> ndevos: yes, we could do a roulette with names from there :)
12:21:56 <ndevos> hagarth: yeah: git show origin/master:MAINTAINERS | grep '^M:' | sort -u
12:22:06 <hagarth> kdhananjay: that's pretty much about 3.7.x
12:22:32 <kdhananjay> hagarth: So do we do this in the ML? Or offline?
12:23:03 <ndevos> hagarth: probably try maintainers@gluster.org ?
12:23:15 <hagarth> kdhananjay: will try on gluster-devel
12:23:21 <kdhananjay> OK.
12:23:54 <kdhananjay> #action hagarth to post a note on gluster-devel asking for volunteers for the role of release maintainer for 3.7.5
12:24:13 <kdhananjay> #topic GlusterFS 3.6
12:24:24 <kdhananjay> raghu: Anything to talk about here?
12:24:43 <raghu> kdhananjay: nope. Just done with 3.6.5
12:24:51 <raghu> more backports for 3.6.6 are welcome
12:25:04 <raghu> will be making 3.6.6. on 20th of september
12:25:21 <kdhananjay> #info Backports to release-3.6 for towards the 3.6.6 release are welcome.
12:25:40 <kdhananjay> #info raghu to make 3.6.6 on 20th of September
12:25:49 <kdhananjay> Moving on ..
12:25:59 <kdhananjay> #topic GlusterFS 3.5
12:26:21 <kdhananjay> Does poornimag still need volunteers to help backport glfs_fini patches?
12:26:21 <ndevos> not much progress to report here
12:26:31 <kdhananjay> ndevos: Cool.
12:26:44 <ndevos> yeah, we still would like to get the backports in, someone would need to work on that
12:27:06 <kdhananjay> #info  poornimag needs help in porting glfs_fini patches to 3.5
12:27:14 <poornimag> regarding this
12:28:01 <ndevos> bug 1134050 contains the list of patches that need backporting...
12:28:36 <poornimag> after discussing with the team, it doesn't sound like backporting is a great idea, and since there are no volunteers yet
12:28:54 <poornimag> i would suggest, i will send a mail on devel
12:29:14 <kdhananjay> poornimag: OK. Sounds good.
12:29:20 <poornimag> and if there are volunteers keen on putting the required effort  will go ahead
12:29:30 <poornimag> else we drop it
12:29:43 <ndevos> poornimag: yeah, thats a good approach
12:30:07 <kdhananjay> #action poornimag to send a mail on gluster-devel asking for volunteers to backport glfs_fini patches to release-3.5
12:30:07 <poornimag> so the AI on me will be to send a mail on devel and co-ordinate with volunteers if any
12:30:21 <ndevos> poornimag: also, 3.8 might be ready in december or so, users will need to update from 3.5 by then anyway
12:30:38 <poornimag> oh thats good news:)
12:31:10 <kdhananjay> Alright. Moving on ...
12:31:23 <kdhananjay> #topic GlusterFS 3.8
12:31:41 <kdhananjay> hagarth: You have anything to add here?
12:31:59 <poornimag> After discussing with the co-developers i would like to propose Leases feature for 3.8
12:32:10 <hagarth> nothing much atm, I am working on providing more details on 3.8 soon on the MLs.
12:32:15 <rastar> share reservations/share modes from my side for 3.8
12:32:21 <poornimag> on behalf of skoduri, rjoseph, rtalur
12:32:24 <hagarth> poornimag, rastar: fantastic!
12:33:40 <kdhananjay> OK then, on to next topic.
12:33:48 <kdhananjay> #topic GlusterFS 4.0
12:34:01 <kdhananjay> jdarcy: ^^
12:34:25 <jdarcy> Ohters have sent updates on GlusterD 2.0, DHT 2.0.
12:34:42 <jdarcy> I'm still getting back on my feet from multiple vacations, starting to dive in on NSR.
12:35:26 <jdarcy> Relatedly, we're having a meetup September 14 @ Facebook HQ, where there seems to be interest in Gluster.Next features.
12:35:36 <jdarcy> Dan, Shyam, and I are all going.
12:35:43 <kdhananjay> Cool!
12:35:49 <jdarcy> http://www.meetup.com/GlusterFS-Silicon-Valley/events/224932563/
12:36:18 <ndevos> we really need a calendar on our website...
12:36:26 <jdarcy> +3
12:37:24 <lpabon> jdarcy: that sounds interesting
12:38:05 <jdarcy> Should be.  Looking forward to seeing who else will be there.
12:38:30 <hagarth> there's also a meetup in BLR on september 12th
12:38:45 <hagarth> http://www.meetup.com/glusterfs-India/events/222201221/
12:39:00 <kdhananjay> #info GlusterFS meetup in Bengaluru on September 12th - http://www.meetup.com/glusterfs-India/events/222201221/
12:39:44 <ndevos> who would like to organise a meeting in Amsterdam?
12:40:35 <ndevos> ... not all at once please!
12:41:59 <hagarth> anything else on 4.0?
12:42:03 <kdhananjay> Ok, I guess I'll move on to the next topic ;)
12:42:06 <jdarcy> hagarth: Nope.
12:42:15 <kdhananjay> #topic Open Floor
12:42:19 <jdarcy> ndevos: Organize?  Nope.  Attend?  Abso-fing-lutely.  ;)
12:42:22 * justinclift arrives late
12:42:28 <hagarth> justinclift: :O
12:42:43 <kdhananjay> rastar: You were saying something about release documentation
12:42:50 * hagarth better late than ... ;)
12:42:51 <kdhananjay> Now is your time :)
12:42:53 <ndevos> jdarcy: that counts two of us :)
12:42:56 <justinclift> hagarth: Well, I did leave a bunch of stuff still needing to be done… ;)
12:43:24 <hagarth> ndevos: if you sponsor my travel, happy to organize the meetup :D
12:43:36 <rastar> yes just a min
12:43:59 <rastar> jdarcy: this is about a place to document release planning
12:43:59 <ndevos> hagarth: I can sponsor your "hotel" :P
12:44:23 <rastar> we haven't got any good suggestions on that..
12:44:23 <jdarcy> hagarth: I don't have anything to report on that, but it's still something we need.
12:44:49 <hagarth> rastar: I wonder if a summary status page on gluster.org is all what we need
12:44:58 <rastar> kshlm suggested using gluster.org
12:45:09 <rastar> hagarth: yes that is what kshlm and I agreed on
12:45:29 <ndevos> jdarcy: what kind of release planning are you thinking of? got examples from other projects?
12:45:34 <hagarth> rastar: sounds good to me.  we can always keep that page updated.
12:45:47 <rastar> but it means changing website
12:45:54 <rastar> is there some easier alternative?
12:46:02 <jdarcy> ndevos: Nothing heavyweight, just a list of subprojects with %done and upcoming milestones.
12:46:06 <hagarth> rastar: I doubt
12:46:13 <ndevos> jdarcy: ah, ok
12:46:14 <hagarth> ndevos: possibly something like this - https://blueprints.launchpad.net/manila/kilo
12:46:53 <rastar> ok, lets go ahead and try a page on gluster.org
12:47:05 <lpabon> why not use launchpad.net ? like hagarth said.. it has a great method of doing release management and announcements
12:47:06 <jdarcy> hagarth: Kind of, but I think it'd be nice to have progress info as well (even if it's a SWAG).
12:48:09 <hagarth> jdarcy: this is probably more relevant - https://blueprints.launchpad.net/manila/liberty
12:48:13 <jdarcy> lpabon: I could live with it.  I think I even have an account already.
12:48:16 <hagarth> as it is an ongoing dev cycle
12:49:34 <ndevos> hmm, looks interesting
12:49:40 <hagarth> rastar: maybe we should start a discussion on our MLs highlighting various options
12:49:44 <justinclift> Yeah
12:49:49 <lpabon> +1
12:50:10 <justinclift> Launchpad also enables other stuff - like translations - pretty easily
12:50:19 <justinclift> That *might* turn out to be useful
12:50:45 <kdhananjay> rastar: Would you be taking this up?
12:50:49 <lpabon> and .. sorry to say... a better bug tracker .. >.>
12:50:55 <justinclift> :D
12:51:54 <kdhananjay> rastar or hchiramm
12:52:15 <ndevos> there is also http://taiga.cloud.fedoraproject.org/ that should provide kanban/scrum like tracking of features
12:52:38 * ndevos hasnt tried it yet, but would be willing to
12:53:24 <hagarth> ok, let us discuss and arrive at a workflow
12:53:28 <jdarcy> I'm looking at Taiga and OrangeScrum right now.
12:53:59 <lpabon> ndevos: interesting.. i'll check it out
12:55:37 <kdhananjay> we've got 5 more minutes left.
12:55:39 <hagarth> justinclift: have you seen the announcement on forge?
12:55:42 <rastar> kdhananjay: yes, ai on me for sending a mail to start it out
12:55:58 <justinclift> hagarth: No.  I tried loading the forge last night, and it wasn’t responding at all
12:56:00 <kdhananjay> rastar: Cool rastar
12:56:20 <justinclift> hagarth: Figured I better get off my arse and get it done :)
12:56:36 <hagarth> justinclift: rather kshlm's announcement on forge in our MLs
12:56:41 <justinclift> Ahhh
12:56:44 * justinclift goes looking
12:56:53 * justinclift isn’t subscribed any more
12:57:17 <jdarcy> If there's already a Fedora-hosted instance of Taiga, that seems like an instant front-runner to me.
12:57:27 <kdhananjay> #action rastar to initiate discussion on exploring the different approaches towards doing GlusterFS release management and announcements
12:57:40 <ndevos> jdarcy: yeah, I'd like to try that
12:57:40 <justinclift> hagarth: Found it: http://www.gluster.org/pipermail/gluster-devel/2015-September/046626.html
12:57:50 <hagarth> justinclift: right, that is the one
12:58:13 <kdhananjay> 2 more minutes to go before we wrap up
12:58:37 <justinclift> hagarth: The migration status for each of the projects is/was tracked in the repo I was working on: https://github.com/gluster/forge/blob/master/old_forge_repos.txt
12:58:49 <justinclift> hagarth: I’m not sure if Kaushal is working from that
12:58:52 <hagarth> justinclift: right, kshlm is looking into that.
12:59:05 <hagarth> justinclift: maybe you can drop him a note for better co-ordination
12:59:09 <justinclift> Yeah
12:59:13 <justinclift> Will do :)
12:59:34 <kdhananjay> Anything else we want to discuss?
12:59:49 <kdhananjay> #info REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
12:59:56 <kdhananjay> #info REMINDER to announce Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
13:00:07 <justinclift> Email to Kaushal sent
13:00:13 <hagarth> justinclift: fantastic, thanks!
13:00:52 <kdhananjay> OK I guess not.
13:01:01 <kdhananjay> Thanks everyone for attending the meeting!
13:01:04 <hagarth> kdhananjay: thanks for hosting this meeting!
13:01:05 <kdhananjay> See you next week.
13:01:08 <kdhananjay> #endmeeting