gluster-meeting
LOGS
12:01:26 <meghanam_> #startmeeting
12:01:26 <zodbot> Meeting started Wed Aug 19 12:01:26 2015 UTC.  The chair is meghanam_. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:55 <meghanam_> #info agenda is available @ https://public.pad.fsfe.org/p/gluster-community-meetings
12:02:17 <meghanam_> #topic roll call
12:02:21 * poornimag is here
12:02:27 * kkeithley_blr is here
12:02:31 * kotreshhr is here
12:02:35 * ndevos _o/ hello!
12:02:38 * kshlm thinks that the Agenda link should be set to the topic of the channel
12:02:38 * raghu is here
12:02:47 * rafi1 is here
12:02:47 * kshlm o/
12:02:51 * hchiramm_ is here
12:03:01 * skoduri is here
12:03:09 <ndevos> kshlm: that needs an operator for this channel
12:03:12 <kkeithley_blr> need a channel operator
12:03:15 <hchiramm_> #topic : https://public.pad.fsfe.org/p/gluster-community-meetings
12:03:31 * rastar is here
12:04:47 <meghanam_> I'll move on to the next topic in a minute.
12:05:06 <meghanam_> #topic Action items from last week
12:05:11 <kshlm> Looks like JohnMarkWalker owns this channel.
12:05:35 <meghanam_> #topic tigert to send a reminder mail to ask for feedback for gluster calendar integration
12:05:36 * tigert is here
12:05:36 <kkeithley_blr> should tranfer to Amye
12:05:50 <hchiramm_> yep :)
12:06:00 <meghanam_> tigert, do you have any updates on that?
12:06:18 <tigert> did send, though today so not much new happened there yet
12:06:26 <tigert> on the topic,
12:06:34 <asengupt> #rollcall asengupt
12:07:02 <meghanam_> moving on to the next one
12:07:03 <tigert> I will try to catch up with brian proffitt about some ideas for calendaring (he is thinking similar stuff for other projects under our OSAS umbrella)
12:07:24 <ndevos> tigert: okay, that sounds like a good idea
12:07:31 <hchiramm_> tigert, yeah .. that would be better
12:07:39 <meghanam_> #topic raghu to fill in the contents for release schedule and ask tigert to push the page in gluster.org
12:08:04 <meghanam_> Is raghu here?
12:08:12 <raghu> meghanam_: I could not do it this week. Will do it by next week.
12:08:44 <meghanam_> Alright. Can I move this to next week then?
12:09:14 <raghu> meghanam_: sure. Put it as an AI for me next week.
12:09:18 <meghanam_> #action raghu to fill in the contents for release schedule and ask tigert to push the page in gluster.org
12:09:25 <meghanam_> Next topic
12:09:41 <meghanam_> #topic rtalur to setup a new project gerrit specs in review.gluster.org
12:10:01 <meghanam_> rastar?
12:10:14 <hchiramm_> meghanam_, its done
12:10:38 <kshlm> I'm happy to report that it's fully operational as well!!
12:10:39 <rastar> meghanam_: hchiramm_ and I did it..
12:10:40 <hchiramm_> http://review.gluster.org/#/admin/projects/glusterfs-specs
12:10:51 <rastar> it still needs a bit of work
12:10:57 <hchiramm_> rastar, kshlm too :)
12:10:57 <kshlm> Replication to github is working as well!
12:11:03 <hchiramm_> rastar++ kshlm++
12:11:16 <kshlm> rastar, What else is remaining?
12:11:17 <rastar> need to make github read only
12:11:26 <kshlm> rastar, that's not possible.
12:11:28 <hchiramm_> awesome.. so our spec is on glusterfs-spec under review.gluster.org
12:11:31 <rastar> and setup automatic sync between gerrit and github
12:11:37 <kshlm> We just don't merge on github.
12:11:40 <hchiramm_> rastar, its there now
12:11:44 <kshlm> rastar, the replication is working.
12:11:50 <hchiramm_> and most of the people dont have push access to github
12:11:55 <hchiramm_> so it should be fine for now
12:11:57 <rastar> kshlm: we were aiming to make it similar to glusterfs code repo
12:11:57 <ndevos> hchiramm_: update the README.md with the instructions about the repo?
12:12:10 <kshlm> ndevos, Already done.
12:12:11 <hchiramm_> ndevos, yes,
12:12:19 <hchiramm_> bit more can be added
12:12:26 <hchiramm_> will do it soon
12:12:32 <kshlm> Yeah. It's minimal instructions now.
12:12:32 <meghanam_> #topic  msvbhat to  do 3.7.3 announcement on the gluster blog and social media
12:12:34 <ndevos> kshlm: cool, thanks!
12:12:45 <meghanam_> msvbhat?
12:12:50 <ndevos> I think he did :)
12:13:04 * ndevos looks for the link
12:13:08 <kshlm> Yep.
12:13:12 <kshlm> Thanks msvbhat
12:13:56 <ndevos> hmm, not sure... https://medium.com/@msvbhat would be his blog
12:14:24 <meghanam_> #topic pranithk to write up a post announcing EC's production readiness
12:14:48 <kshlm> Hmm, he seems to just have done a `week in gluster` post https://medium.com/@msvbhat/gluster-news-of-the-week-30-2015-30452f44a144
12:15:45 <kshlm> On pranithk's AI, the last time I spoke to him, he said we didn' want to do it for the current release.
12:15:59 <meghanam_> That's a little confusing now. It doesn't say anything about the release?
12:16:13 <kshlm> He mentioned that there were some new issues that cropped up.
12:16:30 <kshlm> meghanam_, The AI was originally to do the announcement along with 3.7.3.
12:16:48 <kshlm> I think we can remove this AI.
12:16:52 <meghanam_> Alright..
12:16:55 <atinm> kshlm, I think that has not been done yet
12:16:58 <ndevos> #info ec in glusterfs-3.7.3 is not deemed production ready yet :-/
12:17:13 <atinm> kshlm, I don't see anything on the social media about 3.7.3
12:17:56 <meghanam_> #action  msvbhat to  do 3.7.3 announcement on the gluster blog and social media
12:18:24 <kshlm> I know that hagarth has access to our social media accounts, and was generally the person who did the annoncements there.
12:18:26 <meghanam_> #topic msvbhat/rtalur to send update mailing list with a DiSTAF how-to and start discussion on enhancements to DiSTAF.
12:18:46 <meghanam_> rastar, do you have updates on this?
12:18:52 <rastar> meghanam_: not yet :(
12:18:56 <kshlm> So, without him around I don't think anyone else can do the announcements.
12:19:02 <rastar> please change it for next week
12:19:18 <meghanam_> #action msvbhat/rtalur to send update mailing list with a DiSTAF how-to and start discussion on enhancements to DiSTAF.
12:19:49 <meghanam_> #topic  kshlm  to test the new jenkins slave in ci.gluster.org
12:20:20 <kshlm> I haven't done anything regarding this the past week.
12:20:30 <kshlm> Last I checked, misc was running tests.
12:20:35 <kshlm> I need to check back with him.
12:20:45 <meghanam_> Do I move it to next week or will you need more time?
12:21:03 * msvbhat arrives late to the meeting
12:21:08 <kshlm> #action kshlm to checkback with misc on the new jenkins slaves.
12:21:21 <meghanam_> Alright.
12:21:36 <meghanam_> #topic poornimag to backport one of the libgfapi related changes into 3.5
12:21:37 <csim> the fedora build is still not building, not sure why
12:21:47 <csim> and didn't had time to install a centos 6 one
12:22:15 <ndevos> csim: pass me the logs at one point (not today) and I'll try to see why it fails
12:22:17 <Guest4573> I have updated the BZ with the pathces that needs backport
12:22:27 <meghanam_> poornimag?
12:22:36 <kshlm> csim, I'll help too.
12:22:39 <rastar> meghanam_: Guest4573  is poornimag
12:23:17 <Guest4573> this will easily be 2 week effort and i don't have that bandwisht
12:23:32 <Guest4573> if anyone could help me out with it?
12:23:41 <msvbhat> atinm: I clubbed 3.7.3 announcement in new from the week #30
12:23:47 <Guest4573> *bandwidth
12:24:06 <kshlm> Guest4573, are you poornimag?
12:24:14 <Guest4573> kshlm, yes
12:24:20 <kshlm> Just checking :)
12:24:47 <meghanam_> Bring this up when the discussion for 3.5 begins please.
12:25:07 <Guest4573> yes
12:25:31 <meghanam_> #action poornimag needs help to backport glfs_fini patches to 3.5
12:26:00 <meghanam_> #topic Instead of maintaining a public pad, integrate the gluster event details in gluster.org, tigert / hchiramm to work on it
12:26:45 <meghanam_> tigert?
12:26:47 <kshlm> Isn't this the same as calendaring?
12:27:06 <meghanam_> hchiramm_
12:27:18 <meghanam_> Any updates on this?
12:27:44 <msvbhat> he sent a mail about the same to the list
12:27:56 <hchiramm_> meghanam_, not from me
12:28:17 * kshlm is AFK for a couple of minutes
12:29:17 <meghanam_> #topic kkeithley to drop a follow up mail about spurious failure fixes
12:29:59 <meghanam_> kkeithley_blr?
12:30:43 <ndevos> I did not see an email from kkeithley_blr about it, bot sure who sent it though..
12:30:52 <ndevos> *but
12:31:06 * meghanam_ is checking
12:31:26 * msvbhat will be afk for some time
12:31:42 <meghanam_> It's done.
12:31:49 <meghanam_> And that was the last topic.
12:31:52 <Saravana_> meghanam_, Can we have a additional topic :)
12:32:12 <meghanam_> What is it?
12:32:20 <Saravana_> a suggestion related to gluster-users mailing list
12:32:33 <hchiramm_> Saravana_, add it to open floor
12:32:35 <meghanam_> We can move this to the open floor
12:32:57 <Saravana_> ok
12:33:02 <meghanam_> thanks
12:33:09 <meghanam_> #topic GlusterFS 3.7
12:33:11 <ndevos> Saravana_: you can add that to the meeting etherpad :)
12:33:29 <Saravana_> ndevos, ok
12:33:57 <ndevos> maybe kshlm was going to do the next 3.7 release?
12:34:03 <rafi1> Saravana_: #info https://public.pad.fsfe.org/p/gluster-community-meetings
12:34:20 * kshlm is back
12:34:31 <rafi1> kshlm: right time :)
12:34:42 <rafi1> 3.7 on the plate :)
12:34:46 <kshlm> According the schedule the next 3.7 release happens in the last week of August.
12:34:50 <meghanam_> #info Open BZs  https://bugzilla.redhat.com/showdependencytree.cgi?maxdepth=2&id=glusterfs-3.7.4&hide_resolved=1
12:34:55 <kshlm> We have about 2 weeks till release.
12:35:20 <kshlm> I'll send out an announcement regarding the approaching deadline next week.
12:35:55 <meghanam_> #action kslm to send  out an announcement regarding the approaching deadline for Gluster 3.7 next week.
12:36:30 <meghanam_> Are there any other specific things to discuss?
12:36:38 <meghanam_> regarding 3.7?
12:36:41 <kshlm> None.
12:36:45 <meghanam_> Alright.
12:37:00 <meghanam_> #topic GlusterFS 3.6
12:37:37 <meghanam_> Do you have anything to discuss raghu?
12:37:46 <raghu> I am planning to make 3.6.5 this friday. I have merged changes wich have passed regression and got an ack
12:38:04 <raghu> there are still 3-4 patches remaining in the queue which have to pass regressions
12:38:12 <meghanam_> #action raghu to make 3.6.5 this Friday.
12:38:25 <raghu> if there is nothing critical change that has to go in I plan to make the release on friday
12:38:49 <meghanam_> Alright. Thanks.
12:39:38 <meghanam_> #topiic GlusterFS 3.5
12:39:50 <meghanam_> #topic GlusterFS 3.5
12:40:15 <meghanam_> Can someone help poornimag to backport libgfapi patches to 3.5?
12:40:47 <ndevos> the plan is to release 3.5.x around the 10th of each month, so we still have some time to do the backports
12:40:59 <ndevos> but, as poornima mentioned, it is quite a lot of wok
12:41:02 <ndevos> *work
12:41:24 <Guest4573> ndevos, yes
12:41:29 <meghanam_> Guest4573, are you there?
12:42:14 <ndevos> https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.5.6 contains all the bugs that are proposed for 3.5.6
12:43:02 <meghanam_> #info Bugs proposed for 3.5.6 https://bugzilla.redhat.com/showdependencytree.cgi?id=glusterfs-3.5.6
12:43:14 <ndevos> #info help with backporting patches for bug 1134050 is very welcome!
12:43:32 <ndevos> thats all for 3.5, I think
12:43:39 <meghanam_> Okay.
12:44:07 <meghanam_> #topic GlusterFS 3.8
12:45:04 <meghanam_> raghu, Do you happen to have any details on GlusterFS 3.8
12:45:05 <meghanam_> ?
12:45:18 <meghanam_> Anyone else?
12:45:20 <kkeithley_blr> Oh, BTW, back to spurious failures email. Yes, I sent that. And things seem to be somewhat better today so I don't have TN&KA.
12:46:04 <meghanam_> Yes. We checked that. Thanks kkeithley_blr.
12:46:47 <meghanam_> If there is nothing, I'll move on to the next topic.
12:46:55 <rafi1> kkeithley_blr: people are scared of your nuclear option :)
12:47:03 <meghanam_> #topic GlusterFS 4.0
12:47:06 <raghu> meghanam_: I dont have much details about GlusterFS 3.8. But I think it might happen by the end of this year
12:47:31 <meghanam_> Thanks raghu. Any roadmap?
12:47:58 <kkeithley_blr> The nuclear option is where I take back the hot sauces I brought
12:48:00 <kkeithley_blr> ;-)
12:48:01 <raghu> meghanam_: roadmap? I dont have much details. hagarth might be knowing more about it
12:48:08 <meghanam_> Alright.
12:48:26 <jdarcy> Still catching up on 4.0, there's a meeting after this one.
12:49:17 <Saravana_> ndevos, meghanam_  updated open floor.
12:49:56 <meghanam_> #info jdarcy to provide more details on Gluster 4.0 next week.
12:50:05 <meghanam_> Thanks Saravana_
12:50:21 <meghanam_> #topic open floor
12:50:47 <kkeithley_blr> If anyone is interested in numbers
12:50:57 <kkeithley_blr> downloads/installs from download.gluster.org since 2015-08-01
12:50:57 <kkeithley_blr> 3.7.3 total: 53580+
12:50:57 <kkeithley_blr> + rhel/centos 6: 25936
12:50:57 <kkeithley_blr> + rhel/centos 7: 14964
12:50:57 <kkeithley_blr> + f21: 635
12:51:16 <meghanam_> #topic     Weekly reminder to announce Gluster attendance of events: https://public.pad.fsfe.org/p/gluster-events
12:51:40 <hchiramm_> kkeithley, Awesome!!
12:52:04 <kkeithley_blr> that was fun.
12:52:06 <krishnan_p> kkeithley1, thanks for the stats. Very encouraging.
12:52:07 <hchiramm_> kkeithley_, thanks for capturing this info
12:52:10 <meghanam_> #topic     REMINDER to put (even minor) interesting topics on https://public.pad.fsfe.org/p/gluster-weekly-news
12:52:12 <hchiramm_> kkeithley++
12:53:15 <meghanam_> #topic     Per release documentation. Users are landing on 3.2 documentation from google itseems. How can we make this better
12:53:41 <hchiramm_> meghanam_, status is WIP .
12:53:48 <hchiramm_> need some more time to sort this out..
12:54:02 * kshlm has to drop off
12:54:34 <meghanam_> #action hchiramm_ to improve release documentation
12:54:40 <kkeithley_blr> the redirect page is at least the _third_ link on the results now
12:54:51 <hchiramm_> meghanam_, its not about that :)
12:54:57 <hchiramm_> its about google indexing ..
12:55:09 <hchiramm_> kkeithley_blr, I think eventually it will be on top..
12:55:13 <meghanam_> #topic     Can we add a FAQ page in the HOME page here: http://www.gluster.org/mailman/listinfo/gluster-users
12:55:19 <kkeithley_blr> right
12:55:22 <hchiramm_> however we need to enable anaylytics and sitemap for the smae
12:55:26 <hchiramm_> smae/same
12:55:39 <hchiramm_> so that google will pick it up faster
12:56:10 <ndevos> Saravana_: I think a FAQ can get added, you could send an email to gluster-infra@gluster.org for thar, csim can probably do it
12:56:29 <ndevos> Saravana_: but, have a FAQ prepared somewhere :-)
12:56:35 * krishnan_p has to drop off too
12:56:42 <hchiramm_> Saravana_, can u be bit more detail about FAQ
12:57:15 <Saravana_> hchiramm_, please have a look at openfloor https://public.pad.fsfe.org/p/gluster-community-meetings
12:57:30 <Saravana_> ndevos, do we have some FAQ already ?
12:58:10 <meghanam_> Saravana_, ndevos asks you to have it ready.
12:58:45 <hchiramm_> https://github.com/gluster/glusterdocs/blob/master/Administrator%20Guide/Troubleshooting.md
12:58:50 <hchiramm_> Saravana_, ^^^
12:58:56 <Saravana_> hchiramm_, Thanks!
12:59:32 <Saravana_> ndevos, I will send out a mail in gluster-infra , will refer this document for preparing the page.
12:59:53 <hchiramm_> Saravana_, please feel free to update it via sending a Pull Request
13:00:11 <ndevos> Saravana_: thanks, better include all the details in the email, anything that makes it easier helps ;-)
13:00:24 <meghanam_> #action on Saravana_ to send out a mail to gluster-infra
13:00:26 <Saravana_> hchiramm_, sure , Thanks.
13:00:37 <hchiramm_> Saravana_, yw
13:01:04 <meghanam_> Is there anything else to discuss?
13:01:57 <meghanam_> Thanks to everybody who joined the meeting
13:02:07 <hchiramm_> thanks meghanam++
13:02:11 <ndevos> many thanks meghanam_!
13:02:14 <meghanam_> I'll see you next week.
13:02:19 <kkeithley_blr> don't forget to #endmeeting
13:02:22 <ndevos> and thanks rafi1 too :)
13:02:29 <rafi1> ndevos: :)
13:02:33 <meghanam_> Thanks rafi1
13:02:38 <meghanam_> #endmeeting