gluster-meeting
LOGS
12:05:42 <kkeithley> #startmeeting
12:05:43 <zodbot> Meeting started Wed Jul  1 12:05:42 2015 UTC.  The chair is kkeithley. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:05:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:05:48 <kkeithley> rollcall
12:05:55 * RaSTar is here
12:05:56 * poornimag is here
12:06:07 * obnox waves
12:06:08 <ndevos> wohoo! kkeithley is our host :D
12:06:14 * kshlm o/
12:06:25 * raghu is here
12:06:25 * rjoseph is here
12:06:33 <kkeithley> agenda at https://public.pad.fsfe.org/p/gluster-community-meetings
12:06:35 * overclk is here
12:07:00 * gd is here
12:07:13 <kkeithley> #topic action items from last week
12:07:23 <kkeithley> JustinClift to demo the new Forge this week
12:07:42 <kkeithley> thunder and lightning going on. Hope we don't lose power
12:08:09 <kkeithley> Justin's last day at Red Hat was yesterday, so that's probably a not going to happen
12:08:23 <kkeithley> did anyone get a hand-off from Justin on that?
12:08:41 * kkeithley guesses not
12:08:57 <ndevos> no, I thought he wanted to finish that before leaving...
12:09:24 <ndevos> maybe misc or csim knows more about it?
12:09:43 <kkeithley> right. I'll take an action to check with his management to see what kind of hand-off we got
12:09:58 <kkeithley> #action kkeithley to check on new Forge hand-off from JustinClift
12:10:19 <kkeithley> next, hchiramm to updpate about packaging emails
12:10:49 <kkeithley> is hchiramm here?  I did see email from him indicating we have a couple packaging volunteers
12:11:25 <kkeithley> or hchiramm_home
12:11:36 <kkeithley> okay
12:11:44 <kkeithley> next, tigert summarize options for integrating a calendar on the website, call for feedback.
12:12:46 <ndevos> I think tigert is on holidays
12:13:03 <kkeithley> okay, nothing there, next is hagarth will start with planned roadmaps for all gluster.next releases [TBD - will do so by next week]
12:13:28 <kkeithley> then csim/misc to pickup the requesting of public IPs and those kind of things for our new servers
12:13:48 <ndevos> that is for the Jenkins slaves
12:14:10 <ndevos> I think you spoke to KB about using something in the CentOS infra?
12:14:26 <ndevos> maybe that is an option too, care to share? :)
12:15:15 <kkeithley> okay. yes, that's correct. hagarth and I both spoke to kb.  We are allowed to use the CentOS jenkins infra.  misc/csim has what he needs to know to start running jobs there.
12:16:27 <kkeithley> N.B. that CentOS isn't generally hosting Jenkins for "just anyone." We are being allowed to use it because we're members of the CentOS Storage SIG. If it weren't for that it would require CentOS board approval.
12:16:53 <ndevos> hmm, sounds as if its still the same bottleneck :-/
12:17:12 <kkeithley> Anyway, they have a veryh high powered server and the VMs are there, we just need to start using them.
12:18:00 <kkeithley> They have a fat pipe to the internet and to storage, so they're supposed to be pretty fast.  And we don't have to pay for using them, like we do for the rackspace VMs
12:18:19 <ndevos> okay, sounds like a plan, but we need to get access somehow, someone needs to do some initial work to prepare the environment for our tests
12:18:20 <kkeithley> I suspect it's in our best interest to start using them
12:19:05 <ndevos> misc+csim is quite busy from what I understand, is there someone else that can and want to help out with this?
12:19:41 <kkeithley> anyone who wants to help can ping me and I'll send the details
12:20:07 <kkeithley> any other questions about Jenkins infra?
12:20:16 <kkeithley> questions or comments?
12:20:17 <ndevos> #info volunteers more than welcome to help out with the Jenkins infrastructure provided by the CentOS people
12:20:55 <kshlm> I really think we need to fix up gerrit first.
12:21:12 <RaSTar> +1
12:21:13 <kshlm> Getting more jenkins slaves, will only hammer gerrit more.
12:21:39 <ndevos> not more jenkins slave, replacesments for the rackspace ones
12:21:56 <ndevos> ... move that 's' a little around
12:22:50 <ndevos> gerrit is supposed to move to the new server we have, but that is waiting for public IP addresses....
12:22:55 <kkeithley> well, eventually we can have as many as we want, but I'm hearing that gerrit needs some work
12:23:10 <RaSTar> I still have problems with gerrit, pages fail to load..
12:23:15 <kshlm> With the new beefy servers and the CentOS infra, we're sure to get more slaves. Gerrit needs work.
12:23:18 <RaSTar> It seems like something related to javascript on this version of gerrit
12:23:37 <RaSTar> can we move to 2.11 and try?
12:24:04 <kshlm> Let's take this discussion later, and continue with the meeting for now.
12:24:06 * ndevos isnt a Gerrit admin and has no aspiration to become one
12:24:23 <kkeithley> indeed
12:24:41 <kkeithley> next is hagarth should remove the meeting invite request, which is done
12:24:50 <kkeithley> then raghu to announce 3.6.4beta2 in the mailing list (post RPM build)
12:24:57 * hchiramm : sorry for being late.  reg# packaging , yes, we have volunteers. I will start a thread soon explaining the next action plan
12:25:21 <kkeithley> 3.6.4beta2 rpms are on download.gluster.org. I have not seen an announcement though. Did I miss it?
12:25:24 <hchiramm> 3.6.4beta2 rpms are ready .. I think raghu will be announcing it soon..
12:25:51 <raghu> kkeithley: I have not yet announced it. I am preparing the release-notes and you can expect the announcement EOD today
12:26:09 <kkeithley> #info raghu will announce 3.6.4beta2
12:26:19 <kkeithley> #info raghu will announce 3.6.4beta2 today
12:26:31 <kkeithley> next is ndevos to release 3.5.5 before end of June
12:26:42 <kkeithley> missed it!  Do we have a new ETA?
12:26:50 <ndevos> its still june, right?
12:27:14 <ndevos> I hoped to do it last weekend, but there is still a little work needed on one patch
12:27:23 <ndevos> I'm trying to get it done this week
12:27:45 <kkeithley> I think it's July where I am
12:28:10 <kkeithley> It might still be June in Hawaii though
12:28:12 * ndevos had an additional second, but would have liked an additional week
12:28:23 <krishnan_p> ndevos :)
12:28:25 <kkeithley> ;-)
12:29:32 <kkeithley> So by Friday (3 July)?
12:29:43 <ndevos> lets try!
12:30:15 <kkeithley> #info ndevos will release 3.5.5 by 3 July (which is a holiday in the U.S.)
12:31:08 <kkeithley> next is hagarth to push 4.0 roadmap on the site - [TBD, will do so by next week]
12:31:14 <kkeithley> so not done
12:31:30 <kkeithley> #action hagarth to push 4.0 roadmap on the site by 10 July
12:31:42 <kkeithley> then overclk to put up feature page for lockdep
12:31:53 <overclk> kkeithley, not done
12:32:05 <kkeithley> soon?
12:32:12 <overclk> kkeithley, target for next meeting please (along with other details in -devel ML)
12:32:17 <kkeithley> okay
12:32:37 <kkeithley> #info overclk to put up feature page for lockdep by 10 July and on -devel mailing list
12:33:05 <kkeithley> then krishnan_p to send out email on devel list about improving our epoll solution
12:33:11 <kkeithley> I don't remember seeing that.
12:33:53 <krishnan_p> kkeithley, not ready yet. I haven't gotten around working on that.
12:34:03 <krishnan_p> kkeithley, I will aim for 10 July too.
12:34:40 <kkeithley> #info krishnan_p to send out email on devel list about improving our epoll solution by 10 July
12:34:44 <kkeithley> okay, thanks
12:34:51 <kkeithley> okay, next
12:34:57 <kkeithley> #topic GlusterFS 3.7
12:35:34 <kkeithley> Atin, anything to report? An ETA for 3.7.3 perhaps?
12:36:14 <atinm> kkeithley, I think lot of patches came in after 3.7.2
12:36:18 <bene2> kkeithley, what do you mean by "improving our epoll solution"?
12:36:35 <atinm> kkeithley, so we do have a strong reason for releasing 3.7.3
12:36:45 <atinm> kkeithley, probably in another couple of week's time?
12:37:12 <atinm> kkeithley, I don't think we have any major issue reported by the community on 3.7.2
12:37:29 <atinm> kkeithley, so we can wait for another couple of weeks
12:37:46 <krishnan_p> bene2, https://public.pad.fsfe.org/p/glusterfs-epoll attempts to list a few of those.
12:37:46 <ndevos> yeah, I think so too, atinm
12:37:59 <kkeithley> so mid-July?  17 July or 24 July?
12:38:24 <ndevos> 24th, earliest?
12:38:36 <ndevos> unless someone hits a real issue?
12:38:48 <atinm> ndevos, sounds good
12:39:07 <kkeithley> so more like late July?
12:39:27 <ndevos> yeah, something like that, no fixed date :)
12:39:35 <kkeithley> #info 3.7.3 ETA late July.
12:39:43 <kkeithley> yeah, I'm not trying to carve it in stone. ;-)
12:40:11 <kkeithley> bene2: don't know, KP can say more about it off-line perhaps.
12:40:22 <kkeithley> anything else about 3.7?
12:40:35 <kkeithley> going once
12:40:41 <kkeithley> going twice?
12:40:46 <kkeithley> next
12:40:52 <kkeithley> #topic GlusterFS 3.6
12:41:19 <kkeithley> so 3.6.4beta2 is out.  How long are we going to let that soak before GA?
12:41:33 <kkeithley> A couple of weeks?
12:42:16 <ndevos> raghu: ?
12:42:28 <raghu> 1 more week
12:42:50 <raghu> next week (max end of next week)
12:43:12 <kkeithley> so both 3.6.4 and 3.5.5 will land around the same time then.
12:43:32 <ndevos> stable releases ftw!
12:43:51 <kkeithley> ndevos: you're not planning on doing any betas?
12:44:04 <ndevos> no, nobody reports back on betas
12:44:07 <kkeithley> save that for the next topic
12:44:09 <kkeithley> right
12:44:31 <kkeithley> #info 3.6.4 GA next week.
12:44:45 <kkeithley> anything else for 3.6?
12:45:19 <kkeithley> hearing nothing, next is
12:45:24 <kkeithley> #topic GlusterFS 3.5
12:45:43 <ndevos> now? no, nobody reports back on betas
12:45:53 <kkeithley> right, so
12:46:00 <kkeithley> #info 3.5.5 GA next week
12:46:07 <kkeithley> correct?
12:46:16 <ndevos> yeah, or this week(end)
12:46:22 <kkeithley> anything else about 3.5?
12:46:32 * ndevos did not hear anything
12:46:44 <kkeithley> okay, next
12:46:52 <kkeithley> #topic GlusterFS 4.0
12:47:05 <kkeithley> anyone have anything they want to say about it?
12:47:44 <kkeithley> guess not
12:47:53 <kkeithley> #topic Open Floor
12:48:17 <kkeithley> Anyone?
12:50:07 <kkeithley> one, I'd like to shift focus to more unit tests and less on regression tests?
12:50:27 <kkeithley> And I'd like to get developers to stop using "inline"
12:50:49 <RaSTar> +1 for stop using inline
12:51:24 <obnox> as in the C keyword?
12:51:32 <kkeithley> yeah, the inlines are biting us where gcc-5.x is used
12:51:50 <kkeithley> yes, the C language
12:51:52 <obnox> k
12:52:41 <RaSTar> by unit tests you mean cmockery?
12:52:52 <ndevos> s/cmockery/cmocka/
12:52:57 <kkeithley> actually we've switched to cmocka
12:52:57 <RaSTar> ok
12:54:01 <kkeithley> well, I've put those thoughts out there. I don't expect we're going to make/take any decisions on them today
12:54:30 <soumya> +1 to more unit tests
12:54:44 <ndevos> we need some guidance on when to add unit tests, and more examples of how to write them to get ideas
12:55:31 <ndevos> who would like to start with a chapter in the developers docs and explain why/how to do it?
12:55:49 <kkeithley> I was hoping that we'd get some of our interns to write some, but the idea of unit tests is that the developer who writes the code also writes the unit tests that go with it.
12:56:15 <kkeithley> unit tests done correctly anyway
12:56:25 <ndevos> yes, they should be part of the patch that gets submitted, just like regression tests
12:56:45 <RaSTar> yes..I will try to get some initial doc done. It would be good to have a buddy though.
12:57:21 <ndevos> RaSTar: I'm sure you can reach out to Andreas Schneider if you have questions about cmocka
12:57:48 <RaSTar> ndevos: Just checked now that is by Andreas :)
12:57:54 <RaSTar> would be happy to approach him
12:58:10 <kkeithley> that would be great. thanks
12:58:18 <ndevos> RaSTar: yeah, he helped with the migration from cmockery2 to cmocka, and wont hesitate to look into gluster sources :)
12:58:19 <RaSTar> but learning a new library/tool is more fun if not alone
12:58:35 <kkeithley> okay, we're up to the end of the hour. Any last might thoughts?  short ones?
12:58:50 <ndevos> yeah, <someone> propose a roster/schedule for hosting the weekly meeting (all maintainers should participate)
12:59:23 <ndevos> we have many maintainers now, and all of them should be visibly active in our community
12:59:41 <ndevos> it is expected that all of them will be hosting this meeting every now and then
12:59:46 <kkeithley> +1 for a roster of meeting hosts
13:00:28 <ndevos> anyone that wants to put a schedule together, or has an idea how to create such a schedule?
13:00:42 <soumya> RaSTar, well am okay to pitch in ... but please spare with my abrupt absence if any mainly because of <release-schedules> :)
13:01:37 <kkeithley> okay, motion to adjourn?
13:01:47 <kkeithley> or are there any more topics?
13:02:10 * ndevos does not have a topic
13:02:20 <kkeithley> going once
13:02:28 <kkeithley> going twice
13:02:39 <kkeithley> #endmeeting