gluster-meeting
LOGS
12:01:34 <ndevos> #startmeeting
12:01:35 <zodbot> Meeting started Tue Feb 10 12:01:34 2015 UTC.  The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:43 <ndevos> welcome all!
12:02:32 <ndevos> todays agenda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:02:40 <ndevos> #topic Roll Call
12:02:59 <ndevos> who's attending?
12:03:04 * kkeithley_ is here
12:03:33 <partner> i guess you two can then agree on the things :)
12:03:59 <kkeithley_> I think lala is in Brno at QE Camp
12:04:08 <ndevos> I do not think we have to agree, *I* am the chair of this meeting :D
12:04:16 <partner> haha
12:04:39 <ndevos> hchiramm: meeting time?
12:05:01 * kkeithley_ thinks ndevos is channeling Alexander Haig
12:05:29 * hchiramm is here
12:06:33 <ndevos> kkeithley_: he was "Supreme Commander", that has quite a nice touch
12:07:33 <ndevos> hmm, I'll skipt the "last week action items", because none of the assignees are there
12:07:40 <kkeithley_> He's the one who said "I'm in charge here now" when Ronald Reagan was shot at. In his case though he wasn't in charge.
12:08:02 <ndevos> ah, right
12:08:20 <ndevos> and the assignee(s) that are there, did not do the action items anyway..
12:08:38 <ndevos> #topic Group Triage
12:09:31 <ndevos> no bugs that have NEEDINFO for bugs@gluster.org
12:09:42 <ndevos> but, we have several new bugs to triage
12:09:59 <ndevos> the triaging was skipped last week due to low attendence of the meeting :-/
12:10:01 <kkeithley_> 1191005
12:10:04 <kkeithley_> 1191006
12:10:07 <ndevos> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&chfield=%5BBug%20creation%5D&chfieldfrom=-2w&chfieldto=Now&f1=keywords&list_id=3224443&o1=notsubstring&product=GlusterFS&v1=Triaged
12:10:30 <kkeithley_> or perhaps I should let ndevos triage that
12:11:08 <kkeithley_> 1190877
12:12:03 <kkeithley_> BTW, we need Version 3.6.2 now
12:12:10 <kkeithley_> in bugzilla
12:12:24 <ndevos> hchiramm: ^
12:12:28 * ndevos 1188232
12:12:38 <hchiramm> ndevos, sure
12:13:24 <ndevos> #action hchiramm will get version 3.6.2 in Bugzilla
12:13:27 * ndevos 1187128
12:13:44 <kkeithley_> 1190058
12:14:36 <ndevos> 1187140
12:15:16 <kkeithley_> 1189473
12:16:04 <ndevos> 1187296
12:17:31 <hchiramm> 1187456
12:18:06 <kkeithley_> 1188886
12:18:33 * hchiramm :  Zstream marked bug can also be marked as 'triaged' , Isnt it
12:20:43 <kkeithley_> 1188242
12:21:51 <kkeithley_> 1188145
12:22:17 <ndevos> hchiramm: we dont do Zstream, so it is not really relevant for us?
12:22:40 <hchiramm> yeah, but look at this bug
12:22:43 <hchiramm> https://bugzilla.redhat.com/show_bug.cgi?id=1187456
12:23:09 <hchiramm> I think as part of downstream bug tracking , they added 'zstream' key word
12:23:32 <ndevos> hchiramm: right, and you can remove it again :):
12:23:46 <hchiramm> so I doubt whether the 'triaged' key word can create collision there.. ideally it shouldnt .. because the bug is filed under GlusterFS produce
12:23:50 <kkeithley_> 1187372
12:23:51 <hchiramm> produce/product
12:24:09 <ndevos> hchiramm: the depends-on is backwards in that butg too
12:24:19 <ndevos> butg?! BUG
12:24:47 <hchiramm> yeah, ok. I will add triaged key word addition to Z stream :)
12:24:56 <hchiramm> lets see :)
12:25:08 <ndevos> hchiramm: if a product wants to use the community bugs, they should follow the community guidelines
12:25:31 * ndevos would drop the Zstream keyword, because it has no meaning to the community
12:26:29 <kkeithley_> downstream needs to clone the bug, filed against RHS, then they can use ZStream on that bug
12:26:46 <hchiramm> kkeithley_, true..
12:27:10 <hchiramm> let me remove the zstream from upstream bug
12:27:24 <ndevos> 1187347
12:27:53 <kkeithley_> 1187952
12:29:51 <hchiramm> ndevos, u should have triaged urself 1191006
12:29:55 <hchiramm> :)
12:30:00 <hchiramm> 1191006
12:30:28 <kkeithley_> 1188064
12:30:49 <hchiramm> rafi, we have removd "zstream" from 1187456
12:31:29 <ndevos> hchiramm: haha, yeah...
12:31:44 <rafi> hchiramm: ok :)
12:31:57 <ndevos> 1190069
12:32:03 <hchiramm> 1190069
12:32:04 <hchiramm> ahhhh
12:32:07 <hchiramm> ndevos, ^^^
12:32:12 <hchiramm> u started with that bug ?
12:32:51 <hchiramm> any way I updated that bug :)
12:33:36 <ndevos> mid-air collision :-/
12:33:47 <hchiramm> 1188066
12:33:49 <hchiramm> :/
12:34:52 <ndevos> 1190551
12:34:58 <hchiramm> done :)
12:37:35 <kkeithley_> \o/
12:37:39 <hchiramm> \o/
12:39:04 <ndevos> sorry to spoil your day, but 3.6 still has some untriaged bugs:
12:39:08 <ndevos> https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&product=GlusterFS&f1=keywords&f2=version&o1=nowords&o2=regexp&v1=Triaged&v2=^3.6
12:39:45 <hchiramm> ../o../o
12:40:06 * kkeithley_ wonders why didn't those show up in the first list?
12:40:33 <kkeithley_> some of those are _old_.
12:40:56 <kkeithley_> s/_old_/very old/
12:42:02 <ndevos> well, the list only shows the new bugs from last week
12:42:18 <ndevos> or, in the case of the url here, from the last 2 weeks
12:42:19 <kkeithley_> the _first_ list?
12:42:37 <ndevos> what is the _first_ list for you?
12:43:01 <kkeithley_> (07:10:07 AM) ndevos: #link https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&chfield=%5BBug%20creation%5D&chfieldfrom=-2w&chfieldto=Now&f1=keywords&list_id=3224443&o1=notsubstring&product=GlusterFS&v1=Triaged
12:43:25 <ndevos> thats only the recent (last 2 weeks) bugs
12:43:47 <ndevos> we have *many* more bugs that are not triaged
12:43:53 <kkeithley_> okay, yep
12:44:10 <kkeithley_> right
12:45:20 <kkeithley_> 1138229 (misfiled against Gluster, s/b RHS)
12:46:34 <kkeithley_> and RHS doesn't have a gfapi component
12:46:47 <hagarth> kkeithley_: could it be related to the client packages that go out with RHEL?
12:48:05 <ndevos> kkeithley_: I think RHEL has a glusterfs-api component?
12:49:06 <kkeithley_> okay, let me check
12:49:57 <kkeithley_> no, just a glusterfs component
12:50:52 <ndevos> ah, well, glusterfs is the component because that is the name of the src.rpm
12:51:09 <kkeithley_> Red Hat Enterprise Linux {6,7}
12:56:03 <kkeithley_> 1147236.  do we claim that 3.6 clients work with 3.3 servers?
12:56:52 <ndevos> no, we do not claim that
12:57:19 <hchiramm> [CentOS-devel] Gluster Updates for Storage SIG -> thread in gluster-users also talk about the same content kkeithley_
12:57:40 <ndevos> and we do not support 3.3 anymore, update!
12:58:57 <kkeithley_> I know there was a recent (last few days) about 3.4 and 3.6. (And I thought we had a work-around for 3.4)
13:00:04 <ndevos> I think pranith wanted to explain some details about that, there may be an incompatibility with some  self-heal locking - or something like that
13:00:08 <kkeithley_> indeed, but the bug is filed against 3.6. Anyway, I'm closing it as NOTABUG
13:00:33 <ndevos> #topic Open Floow
13:00:48 <ndevos> you, know, that should read Floor
13:01:03 <ndevos> TCP seems to inject typos
13:01:20 <ndevos> is there any other topic to discuss?
13:01:31 <ndevos> kkeithley_, hchiramm, hagarth, partner: ?
13:01:45 <hagarth> ndevos: nothing else from me atm
13:02:01 <hchiramm> nothing from myside
13:02:10 <kkeithley_> #action: hchirramm to add 3.6.2 to bugzilla?
13:02:15 <hchiramm> kkeithley_, will do
13:02:19 <ndevos> thats been done :)
13:02:22 <hchiramm> ah.. 3.6.2?
13:02:28 <kkeithley_> Version:
13:02:29 <hchiramm> its done..
13:02:32 <ndevos> well, the #action :)
13:02:34 <kkeithley_> excellent
13:02:46 <hchiramm> :)
13:02:52 <kkeithley_> now I can go shovel snow
13:03:11 <ndevos> make a picture of your snow man please!
13:03:12 <kkeithley_> chop wood, carry water, shovel snow
13:03:18 <hchiramm> \o
13:03:24 <ndevos> #endmeeting