gluster-meeting
LOGS
12:01:06 <ndevos> #startmeeting
12:01:06 <zodbot> Meeting started Tue Jan 20 12:01:06 2015 UTC.  The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:35 <ndevos> Todays aganda: https://public.pad.fsfe.org/p/gluster-bug-triage
12:01:47 <ndevos> #topic Roll Call
12:01:49 * partner at background
12:01:58 * kkeithley_ ishere
12:02:02 * ndevos heard that lalatenduM is in a meeting
12:02:14 <ndevos> hchiramm_: ?
12:02:24 * hchiramm_ in
12:03:12 <ndevos> okay, lets get started then, maybe others will join later
12:03:22 <ndevos> #topic Last weeks action items
12:03:40 <ndevos> #topic hchiramm request NetBSD to be added to the hardware list in Bugzilla
12:03:53 <hchiramm_> done
12:04:00 <ndevos> ah, good!
12:04:21 <ndevos> then I can go on with the NetBSD queries
12:04:53 <hchiramm_> yep :)
12:04:54 <tigert> heya
12:04:54 <ndevos> none of the other action items were done, or their assignees are not here now
12:05:02 * ndevos _o/ tigert
12:05:23 <ndevos> #topic Group Triage
12:06:00 <ndevos> no bugs waiting for input from gluster-bugs@redhat.com
12:06:17 <ndevos> and, we only have 7 new bugs: http://goo.gl/0IqF2q
12:06:57 <ndevos> when you start to triage a bug, list it here so that you obtain an IRC lock for it
12:07:00 <kkeithley_> I'll take 1183340
12:07:22 * ndevos takes 1181669
12:09:37 * hchiramm_ locks 1183764
12:10:50 * ndevos picks 1181870 next
12:14:37 <ndevos> oh, I'm doing 1183229 already
12:16:36 * ndevos opens 1182547
12:16:48 <kkeithley_> actually, what do we thing about 1183340. This is a report that an obscure ARM distro that doesn't have *context() functions in libc, so glusterd doesn't run. (gets ENOTIMPL).  Maybe I should close it as WONTFIX? We're not going to get a Synology NAS box
12:16:55 <kkeithley_> s/thing/think/
12:17:32 * hchiramm_ :any chance for RFE :)
12:17:58 <hchiramm_> kkeithley_, I do think its better to close it as WONTFIX
12:20:41 <ndevos> yeah, I think we should support armv7hl and up, similar to Fedora - we should not spend (too much) time on armv5tel (and the like)
12:21:25 <ndevos> wait, Raspberry PI is armv6, and that works, right? maybe its limitation of the libc implementation?
12:21:25 <kkeithley_> <cough>Pidora/Raspbian</cough>
12:21:28 <kkeithley_> but yeah
12:21:55 <kkeithley_> yeah, the Synology NAS libc is borked
12:22:56 <kkeithley_> I think I'll start with a need info first, and then CLOSE/WONTFIX, unless he wants to provide a fix for his platform.
12:23:41 <ndevos> the reporter says glibc-2.15 is used, would that really not provide the *context() functions for some platforms?
12:24:21 <kkeithley_> apparently so
12:25:59 <hchiramm_> kkeithley_, having a follow up WONTFIX would be an ideal route :)
12:26:31 <kkeithley_> Yup, we'll start by telling him "the cat is on the roof"
12:27:02 <lalatenduM> ndevos, I am back from meeting
12:27:16 <lalatenduM> but looks like you guys have covered it all :)
12:28:09 <hchiramm_> kkeithley++ :)
12:28:28 <ndevos> kkeithley_: from my quick checking in the sources, glibc-2.20 contains getcontext()/setcontext() for arm
12:28:59 <ndevos> sysdeps/unix/sysv/linux/arm/getcontext.S contains the function, same for setcontext()...
12:29:10 <kkeithley_> hmmm.  apropos of nothing, someone in the Pune offiice is doing a webinar on working "cross culture with Indian teams"   Should I take it? ;-)
12:29:34 <lalatenduM> kkeithley_, yeah , and it tell us abt it
12:29:37 <lalatenduM> :)
12:29:39 <hchiramm_> kkeithley_, u are already doing it :)
12:29:53 <tigert> :)
12:30:26 <hchiramm_> \o
12:31:27 <ndevos> kkeithley_: if you join that webinar, you should ask if there is one on working cross culture with European colleagues too
12:31:48 <kkeithley_> There actually is, and North America too.
12:32:01 <lalatenduM> yeah they have list of the sessions
12:32:05 <ndevos> wow
12:32:07 <lalatenduM> i have seen it somewhere
12:32:11 <kkeithley_> Well, Czech anyway
12:32:23 <kkeithley_> One little corner of Europe
12:32:24 <ndevos> lalatenduM: you want to triage the last bug?
12:32:47 <lalatenduM> ndevos, ahh it is still thr
12:32:49 <lalatenduM> will do it
12:33:30 <lalatenduM> https://bugzilla.redhat.com/show_bug.cgi?id=1182514 this is on mainline
12:33:45 <ndevos> yeah, that one
12:33:48 <lalatenduM> wondering how he installed gluster
12:33:59 <lalatenduM> nothing in the description
12:34:27 <ndevos> the reporter seems to be doing regular tests and all, he (or she) reports quite some bugs
12:36:16 <ndevos> #topic Open Floor
12:36:29 <ndevos> Did anyone bring any additional topics for today?
12:36:34 <hagarth> I have one
12:36:42 <ndevos> oh, and welcome!
12:36:55 <ndevos> go ahead :)
12:36:58 <hagarth> can we automate coverity scan reports to be sent on gluster-devel?
12:37:06 <hagarth> thanks, sorry about the delay today :)
12:37:14 <lalatenduM> hagarth, yeah I think so
12:37:30 <lalatenduM> Covscan is giving option to integrate it with travis ci
12:37:39 <lalatenduM> I wanted to do that
12:37:46 <lalatenduM> but not getting enough time
12:37:53 <lalatenduM> hchiramm_, you want to help?
12:37:57 <lalatenduM> doing it
12:38:09 <hagarth> lalatenduM: yeah, doing something like that would be fantastic
12:38:19 <hagarth> one of the goals for 3.7 is to be coverity scan clean
12:38:19 <hchiramm_> lalatenduM, unfortunately no.. busy with other stuffs
12:38:35 <hagarth> hchiramm_: can one of our interns help? ;)
12:39:13 <hchiramm_> hagarth, let me check
12:39:20 <hagarth> hchiramm_: thanks!
12:39:28 <lalatenduM> hchiramm_, thanks
12:39:41 <ndevos> hagarth: oh, we have interns?
12:39:52 <hagarth> ndevos: hchiramm_ has :D
12:39:57 <ndevos> hehe
12:39:57 <hchiramm_> ndevos, yes :)
12:41:38 <ndevos> #action lalatenduM and hchiramm_ will check if the interns (or one of them) can help with regular covscan runs+emails
12:41:54 <lalatenduM> hagarth, can please take a quick look on this bug https://bugzilla.redhat.com/show_bug.cgi?id=1182514 , it is crash bug
12:42:00 <ndevos> any other topics?
12:42:02 <lalatenduM> is a crash bug*
12:42:06 <hagarth> lalatenduM: checking
12:42:26 <hagarth> lalatenduM: looks like a known issue
12:42:41 <lalatenduM> hagarth, cool
12:42:54 <hagarth> lalatenduM: searching for the original bz
12:43:26 <hagarth> 1176393 it is
12:43:33 <hagarth> http://review.gluster.org/9320 fixes it
12:44:15 <lalatenduM> hagarth, thanks :)
12:44:48 <lalatenduM> hagarth, closing the bug as a duplicate of 1176393
12:44:57 <hagarth> lalatenduM: cool
12:46:08 <ndevos> hagarth, lalatenduM: do we regulary run portmark against volumes?
12:46:23 <lalatenduM> ndevos, I dont think so
12:46:29 <hagarth> ndevos: I am not aware of that
12:47:08 <ndevos> lalatenduM: maybe ask where to get postmark if we dont have it? it seems to come from NetApp, but all links I find are dead
12:47:34 <lalatenduM> hagarth, ndevos sorry we are running it :0
12:47:42 <lalatenduM> in downstream though
12:47:51 <hagarth> lalatenduM: do we run trinity?
12:48:14 <lalatenduM> hagarth, nope
12:48:39 <lalatenduM> ndevos, we have local copy of postmark I think
12:48:39 <hagarth> lalatenduM: http://codemonkey.org.uk/projects/trinity/ - might be interesting to run for some -ve tests
12:49:01 <lalatenduM> hagarth, ok
12:49:17 <lalatenduM> hagarth, will take a look
12:49:40 <hagarth> lalatenduM: cool, I intend running it sometime soon too.
12:49:57 <ndevos> lalatenduM: is there an interest in automatically creating/installing/deleting VMs on Rackspace to run automated tests/
12:50:55 <lalatenduM> ndevos, yes and no
12:50:55 <hagarth> ndevos: think so, I have been thinking about formal nightly sanity tests for glusterfs.
12:51:28 <lalatenduM> ndevos, hagarth last time we had a discussion around it , we thought containers will help us
12:51:33 <lalatenduM> I mean docker
12:51:53 <lalatenduM> but it does not look feasible as of now
12:52:02 <ndevos> hagarth: yeah, me too - regular and often run, bugging developers that wrote a patch since it broke
12:52:13 <hagarth> lalatenduM: yes, I am interested in kickstarting nightly sanity runs soon.
12:52:36 <lalatenduM> hagarth, yup CI would halp for sure
12:52:37 <hagarth> ndevos: shall we sync up offline about this? we can come up with a bunch of tests .. raghu is also interested in this
12:52:40 <lalatenduM> help*
12:52:55 <ndevos> hagarth: sure
12:53:05 <kkeithley_> this isn't really the right meeting for this but...     lpabon added cmockery so that we could start writing unit tests. Is anyone actually writing unit tests? If not, can we remove cmockery? I'd rather have unit tests get written, but if they're not ever going to be, why are we carrying this dependency?
12:53:15 <kkeithley_> Anyway, food for thought for tomorrow's meeting perhaps.
12:53:38 <hagarth> kkeithley_: sure, will add it to the agenda.
12:54:00 <ndevos> #action hagarth start/sync email on regular (nightly) automated tests
12:54:06 <lalatenduM> Also lots of qa engineers in red hat are looking for nightly builds from master branch
12:54:17 <ndevos> lalatenduM: we have those!
12:54:20 <kkeithley_> we have nightly builds
12:54:25 <lalatenduM> right
12:54:32 <ndevos> lalatenduM: http://www.gluster.org/community/documentation/index.php/User%3ANdevos/NightlyBuilds
12:54:40 <lalatenduM> we need to publicize those
12:54:56 <ndevos> feel free to :)
12:55:23 <lalatenduM> hagarth, did you also get thisi question now a days ?
12:55:24 <hagarth> ndevos: the last 3.7dev build happened on Jan 8th?
12:55:29 <hagarth> lalatenduM: yes I do
12:55:38 <ndevos> hagarth: uh, no idea
12:55:43 <lalatenduM> ndevos, yeah lets sync on this
12:56:09 <hagarth> ndevos: was checking out the latest build in d.g.o for master and it seemed to point to 8th Jan
12:56:34 <ndevos> hagarth: hmm, yeah, looks like it
12:57:10 <kkeithley_> And we have nightly runs of cppcheck, clang and clang-analyze runs of master, 3.6, and 3.5
12:57:17 <ndevos> hagarth: sometimes syncing to download.gluster.org fails :-/
12:57:27 <ndevos> https://copr.fedoraproject.org/coprs/devos/glusterfs/builds/ has the last build from 15 Jab.
12:57:31 <ndevos> *Jan.
12:57:32 <hagarth> ndevos: I see
12:57:33 <lalatenduM> ndevos, in http://download.gluster.org/pub/gluster/glusterfs/nightly/
12:57:45 <lalatenduM> I dont see anything for master branch i.e. 3.7dev
12:58:02 <ndevos> lalatenduM: that is the glusterfs directory without version
12:58:48 <hagarth> kkeithley_: where are the results archived?
12:58:49 <lalatenduM> ndevos, hagarth we need to modify these stuff to make it easier
12:58:55 <lalatenduM> for other to consume
12:58:57 <kkeithley_> http://download.gluster.org/pub/gluster/glusterfs/static-analysis/
12:59:05 <ndevos> hagarth: sometimes build.gluster.org does weird things to dns or inserts a web-proxy, or something - thats an ongoing issue :-/
12:59:33 <hagarth> kkeithley_: fantastic, thanks!
12:59:34 <kkeithley_> And ISTR that I wrote something on the wiki
12:59:38 <ndevos> lalatenduM: easier then installing a dgo-nightly RPM and 'yum install glusterfs' ?
12:59:40 <lalatenduM> ndevos, and on https://copr.fedoraproject.org/coprs/devos/glusterfs/builds/, the last build is on 15th , why not on 19th or 20th?
12:59:49 <hagarth> ndevos: ah ok
13:00:12 <ndevos> lalatenduM: sometimes build.gluster.org does weird things to dns or inserts a web-proxy, or something - thats an ongoing issue :-/
13:00:12 <lalatenduM> ndevos, we need a constant path for kickstart files work nicely
13:00:41 <lalatenduM> ndevos, ok
13:00:57 <ndevos> lalatenduM: no, you do not, just install that dgo-nightly package in your %post and run "yum install ..." from %post too
13:01:34 <ndevos> lalatenduM: you could also include that download.gluster.org repo in your kickstart and install the packages without the dgo-nightly rpm
13:01:37 <lalatenduM> ndevos, yeah that can done too
13:01:53 <lalatenduM> ndevos, need to check how automation can consume easily
13:01:55 <ndevos> dgo-nightly is like a *-release package, it provides a .repo file
13:02:06 <lalatenduM> ndevos, yeah
13:02:25 <ndevos> lalatenduM: sure, send an email to the list and I'll respond if nobody else does
13:02:40 <lalatenduM> ndevos, will do
13:02:54 <kkeithley_> we started to write a -release package a long time ago
13:03:06 <lalatenduM> kkeithley_, ah right
13:03:17 <lalatenduM> I think ndevos suggested me to take that up
13:03:21 * ndevos might start to trigger the nightly builds from bugs.cloud.gluster.org so that it is more reliable
13:03:28 <hchiramm_> kkeithley_, its in ur github right ? :)
13:03:48 <kkeithley_> maybe mine, or maybe ndevos'
13:03:55 <ndevos> I think yours
13:04:14 <hchiramm_> yeah, I do think it was in kkeithley_ 's repo
13:04:43 <ndevos> #action lalatenduM will look into using nightly builds for automated testing, and will report issues/success to the mailinglig
13:04:43 <kkeithley_> yup,  https://github.com/kalebskeithley/gluster-release
13:05:20 <hchiramm_> yep..
13:05:32 <ndevos> I think we're done with the meeting for today?
13:05:41 <ndevos> or was there anything else?
13:05:47 <hchiramm_> not from e
13:05:50 <hchiramm_> e/me
13:05:53 <lalatenduM> not from me
13:06:08 <ndevos> Thanks for attending then!
13:06:12 <ndevos> #endmeeting