gluster-meeting
LOGS
12:08:29 <ndevos> #startmeeting
12:08:29 <zodbot> Meeting started Tue Dec  9 12:08:29 2014 UTC.  The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:08:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:08:46 <ndevos> sorry, seems that #gluster-dev isnt the right place for meetings ;)
12:08:58 <ndevos> The agenda for today: https://public.pad.fsfe.org/p/gluster-bug-triage
12:09:07 <ndevos> #topic Roll Call
12:09:12 <ndevos> #chair lalatenduM
12:09:12 <zodbot> Current chairs: lalatenduM ndevos
12:09:40 <ndevos> so, lets try that again, who is attending today?
12:09:54 * lalatenduM is here
12:09:57 <ndevos> hchiramm, kkeithley_, hagarth: ?
12:10:36 <lalatenduM> ndevos, hchiramm is in PTO today
12:10:40 <lalatenduM> is on*
12:10:49 <ndevos> lalatenduM: he picked a great day!
12:10:57 <lalatenduM> hagarth, is busy with meetings :)
12:11:05 <lalatenduM> ndevos, :)
12:11:25 <ndevos> yeah, and kaleb had a meeting during his night - so he might start later
12:12:04 <lalatenduM> ndevos, so it you and me then :0
12:12:10 <ndevos> lalatenduM: looks like it :)
12:12:24 <lalatenduM> ndevos, lets go through it :)
12:12:36 <ndevos> hah, ok
12:12:52 <ndevos> #topic Status of last week action items
12:13:17 <ndevos> #topic ndevos will close the unsupported bugs
12:13:27 <ndevos> thats not done yet, planned for today
12:13:44 <ndevos> ... and no other AIs from anyone that is attending
12:13:54 <ndevos> #topic What to do with/about issues reported by Coverity
12:14:03 <ndevos> hagarth proposed that last week
12:14:14 <lalatenduM> ndevos, yeah, it is an imp topic
12:14:23 <ndevos> but we can discuss about triaging Coverity issues
12:14:33 <ndevos> I've just had a look (since long)
12:14:42 <ndevos> https://scan.coverity.com/projects/987 (click "View Defects" on the right)
12:15:13 <lalatenduM> ndevos, there are 455 outstanding
12:15:17 <ndevos> lalatenduM: do you know if Coverity can send weekly emails or so?
12:15:39 <lalatenduM> ndevos, we have to manually schedule the runs
12:15:51 <ndevos> lalatenduM: oh, ok
12:16:10 <ndevos> show schedules those runs?
12:16:17 <ndevos> /show/who/
12:16:22 <lalatenduM> ndevos, I do it
12:16:30 <ndevos> oh, nice!
12:16:33 <lalatenduM> mostly I used to do it weekly
12:16:41 <ndevos> do you get emails about the results?
12:16:47 <lalatenduM> ndevos, yes
12:17:06 <ndevos> can you forward those to the devel list maybe?
12:17:24 <lalatenduM> ndevos, I do it actually
12:17:32 <ndevos> oh...
12:17:50 <lalatenduM> to gluster-devel ML
12:18:06 <ndevos> ah, yes, I see
12:19:28 <ndevos> hmm, maybe we should somehow get the sub-maintainers to have a look at the results
12:20:05 <ndevos> could you send a reminder about it, and include the pointer to the coverity website?
12:20:16 <lalatenduM> ndevos, sure can do
12:20:31 <ndevos> the website contains good details about fixing things, most of them seem quite straight forward
12:20:38 <ndevos> well, at least the ones I looked at
12:20:39 <lalatenduM> ndevos, yes
12:20:50 <lalatenduM> ndevos, i used to fix some
12:20:55 <ndevos> nice!
12:21:00 <lalatenduM> ndevos, but it needs more time
12:21:05 <lalatenduM> there are lots of them
12:21:20 <lalatenduM> kkeithley_, are u online
12:21:22 <lalatenduM> ?
12:21:27 <ndevos> can you also include the users ML and include a pointer to the simple developers workflow?
12:21:45 <kkeithley_> I am
12:22:03 <ndevos> I think fixing Coverity issues is a nice start for new contributors
12:22:03 <lalatenduM> ndevos, ok
12:22:26 <kkeithley_> +1 for newcomers fixing coverity issues
12:22:46 <ndevos> a little assistance and hints on how to fix them would hopefully attract some
12:24:17 <ndevos> #action lalatenduM will send a reminder to the users- and devel- ML about (and how to) fixing Coverity defects
12:25:18 <kkeithley_> and `clang analyze` bugs too
12:25:28 <ndevos> should we get davemc involved, and get the 3 top new contributors a goodie or something?
12:25:40 <kkeithley_> that's a good idea
12:26:08 <lalatenduM> ndevos, lets include devemc
12:27:06 <ndevos> #agreed get davemc to sponsor a "new contributors fixing static code analysis" tournament
12:27:11 <kkeithley_> If someone wanted to get really esoteric they could run the Intel and AMD compilers and work on fixing the issues those compilers report
12:27:33 <ndevos> oh, and other architectures
12:28:35 <ndevos> you'll get davemc involved, lalatenduM?
12:28:39 <kkeithley_> Other architectures? E.g.?
12:28:48 <lalatenduM> ndevos, sure
12:28:50 <ndevos> arm, ppc, and s390?
12:29:33 <ndevos> lalatenduM: thanks!
12:29:51 <lalatenduM> kkeithley_, do you have a setup to run clang weekly?
12:30:52 <kkeithley_> clang analyze runs daily, output d.g.o/...static_analysis   Runs daily but only outputs njew results if the code has changed
12:31:08 <kkeithley_> new results
12:31:26 <kkeithley_> bah, not awake yet
12:32:12 <lalatenduM> covscan does not have option to run on diff architectures I think
12:32:13 <kkeithley_> output on http://download.gluster.org/pub/gluster/glusterfs/static-analysis/
12:32:28 <lalatenduM> kkeithley_, cool
12:33:10 <ndevos> kkeithley_: does it show the difference between previous runs - like 'new defects detected'?
12:34:09 <ndevos> I think prefer the coverity webui, it has a code browser and all, thats quite convenient
12:34:30 <kkeithley_> There are about a months worth of runs, so you can compare today's run with prior runs
12:35:49 <lalatenduM> ndevos, kkeithley_ the daily runs have enough info for someone interested to fix stuff
12:35:57 <ndevos> yeah... but it is not as user friendly as coverity
12:36:00 <kkeithley_> I don't know whether it's possible to run the coverity components like the web UI without a license.
12:36:47 <ndevos> we have a Coverity project: https://scan.coverity.com/projects/987
12:37:38 <ndevos> I *think* they sponsor (some?) open source projects - hagarth would be able to confirm
12:38:00 <kkeithley_> yes, there's that, there's our internal coverity runs, which lala knows more about than I do (although I do get the reports from our internal runs), and there's the ones I put on d.g.o
12:38:02 <lalatenduM> ndevos, kkeithley_ the sportsmanship includes running coverity for free
12:38:23 <kkeithley_> sportsmanship?
12:38:24 <lalatenduM> sponsorship*
12:38:26 <lalatenduM> :)
12:38:29 <ndevos> :)
12:38:36 <kkeithley_> ah
12:39:10 <lalatenduM> ndevos, as of now it is not possible to get web GUI for daily runs of clang , cppcheck etc
12:39:13 <ndevos> lalatenduM: the runs/emails you send, are they from the scan.coverity.com project?
12:39:45 <lalatenduM> ndevos, yes
12:39:57 <ndevos> lalatenduM: weekly should be sufficient - that is possible?
12:40:10 <lalatenduM> but there is a limitation on how many runs I can do weekly, i can do 2 runs per week
12:40:16 <kkeithley_> Oh, I thought we had a group in the Brno office running periodic coverity scans
12:40:49 <ndevos> kkeithley_: probably, but that i RHS (I assume), and we dont care about that in this meeting ;)
12:41:23 <lalatenduM> kkeithley_, ndevos the runs for RHS , i used to do that too  :0
12:41:25 <kkeithley_> yeah, I don't know if that's RHS or community
12:42:04 <ndevos> lets not confuse people (or ourselves) and when we mention Coverity, we mean https://scan.coverity.com/projects/987
12:42:22 <ndevos> #idea lets not confuse people (or ourselves) and when we mention Coverity, we mean https://scan.coverity.com/projects/987
12:43:23 <ndevos> okay, so lalatenduM will get in touch with davemc and send a reminder about (and how to) fix coverity issues
12:43:29 <lalatenduM> yes
12:43:39 <ndevos> is possible, kept very simple, and most user friendly
12:43:52 <ndevos> hopefully we'll get some new contributors
12:44:22 <ndevos> anything else on this topic?
12:44:31 <kkeithley_> Well, *upstream first*,   as far as I'm concerned, anything found by the internal coverity should get fixed upstream so draw your own conclusions
12:45:14 <kkeithley_> Don't mind me, I'm sleep deprived
12:45:33 <ndevos> uhm, yeah, ok
12:45:52 <ndevos> #topic Group Triage
12:46:24 <ndevos> no bugs that need explicit attention from us
12:46:47 <ndevos> but, 15 new bugs: http://goo.gl/0IqF2q
12:47:10 <ndevos> lets see if we can triage these before the meeting ends
12:47:16 <ndevos> and, use IRC locking again :)
12:47:26 * ndevos locks 1171477
12:47:45 * lalatenduM locks 1169999
12:49:28 * ndevos 1170575
12:49:58 * ndevos seems to be on slow internet today...
12:53:08 <ndevos> hmm, something is wrong with my internet... bugzilla.redhat.com starts to time-out
12:54:55 <ndevos> lalatenduM, kkeithley_: seems it's up to you for now, sorry about that
12:55:15 <lalatenduM> ndevos, :)
12:55:37 <ndevos> #topic Open Floor
12:55:52 <ndevos> does anyone have any additional topics?
12:56:01 <kkeithley_> not me
12:56:06 <lalatenduM> not me
12:56:16 * ndevos me neither
12:56:38 <ndevos> thanks for joining!
12:56:40 <ndevos> #endmeeting