gluster-meeting
LOGS
12:02:13 <ndevos> #startmeeting
12:02:13 <zodbot> Meeting started Tue Nov 11 12:02:13 2014 UTC.  The chair is ndevos. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:30 <ndevos> good $LOCALTIME all
12:02:35 <ndevos> the agenda is at https://public.pad.fsfe.org/p/gluster-bug-triage
12:02:38 <ndevos> #roll call
12:02:47 <ndevos> #topic Roll Call
12:02:52 * hagarth is here .. but needs to drop off in a bit
12:02:58 <ndevos> lets see who's online
12:03:00 * kshlm is here
12:03:09 * lalatenduM in a listening mode
12:03:11 <ndevos> hagarth: we'll do your AI 1st then :)
12:03:22 <ndevos> Humble?
12:03:26 * Humble is here :)
12:03:51 <hagarth> ndevos: status quo from last week, the effort is still on
12:03:53 <ndevos> #chair lalatenduM Humble kshlm hagarth
12:03:53 <zodbot> Current chairs: Humble hagarth kshlm lalatenduM ndevos
12:04:04 <ndevos> hagarth: wait a sec
12:04:15 * kkeithley_ is late
12:04:15 <ndevos> #topic action items from last week
12:04:33 <ndevos> #topic hagarth will look for somebody that can act like a bug assigner manager kind of person
12:04:39 <ndevos> hagarth: now you may :)
12:05:00 <hagarth> ndevos: status quo from last week, the effort is still on
12:05:12 <ndevos> #action hagarth will look for somebody that can act like a bug assigner manager kind of person
12:05:17 <ndevos> thank you :)
12:05:43 <ndevos> #topic Humble will request additional versions in Bugzilla (3.6.{1,2}, 3.5.4)
12:05:58 <ndevos> Humble: whats the status there?
12:06:13 <Humble> done..
12:06:25 <ndevos> okay, nice
12:06:46 <ndevos> #topic Replacing old/unsupported versions in Bugzilla with "unsupported"?
12:06:58 <hagarth> ndevos: +1
12:07:10 <ndevos> I've sent a an email about that: http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019401.html
12:07:18 <lalatenduM> Humble, i did not see 3.6.1  yesterday
12:07:23 <lalatenduM> have not checked today
12:07:47 <Humble> ah.. rquested for 3.4.7, 3.5.{3,4}, 3.6.1
12:07:57 <Humble> lalatenduM, let me cross check
12:07:59 <ndevos> hagarth and one person from the community (Gene?) answered, do others have an opinion about it?
12:08:25 <lalatenduM> Humble, just checked, did not find it
12:08:34 <ndevos> kshlm, kkeithley_, Humble, lalatenduM: drop old versions in bugzilla, and replace them by "unsupported"?
12:08:51 <Humble> ndevos, LGTM
12:08:56 <kkeithley_> acknowledged
12:09:01 <kshlm> Sure
12:09:12 <ndevos> note, not closing the bugs without review, just letting the public know that the version will not get updated anymore
12:09:26 <kkeithley_> you mean close bugs filed against old, unsupported versions
12:09:35 <kkeithley_> ?
12:09:41 <kkeithley_> oh, okay, no
12:09:42 <ndevos> no, not close, we will need to review them for that
12:09:50 <lalatenduM> ndevos, +1 for unsupported verson
12:09:57 <kshlm> Just rename 3.2.x to 'Unsupported'
12:10:04 <kshlm> right?
12:10:28 <ndevos> I've found several bugs that were files against old/unsupported versions that were also present in newer version - according to testers
12:10:34 <ndevos> yes, kshlm
12:10:39 <kkeithley_> but then we have no idea what version they were filed against. At least not without having to scan the history
12:10:43 <kkeithley_> change history
12:10:53 <kkeithley_> I guess that's okay
12:10:58 <ndevos> in those cases, we just need to change the version from the unsupported one to the version the tester used
12:11:03 <kshlm> How about X -> X(unsupported)
12:11:04 <kshlm> ?
12:11:07 <kkeithley_> s/guess/suppose/
12:11:47 <ndevos> bugzilla does list the change on the normal page, no need to open the special history page (anymore)
12:11:57 <hagarth> i even vote for closing bugs logged in unsupported versions. that will reduce our backlog.
12:12:28 <hagarth> if it matters to anybody, we will again find them logged in a supported version.
12:12:41 <ndevos> hagarth: we could do that, but maybe in a few weeks after notifying that those versions are unsupported?
12:13:01 <Humble> hagarth, +1
12:13:03 <kkeithley_> if that's the case we can close the bug filed against the old version as a dupe of the newer one
12:13:08 <hagarth> ndevos: yes, that seems reasonable.
12:13:13 <kkeithley_> or vice versa
12:13:26 <ndevos> like, step 1) change the version to unsupported (+ message and request for testing), 2) close unsupported bugs in a few weeks?
12:13:36 <hagarth> ndevos: LGTM
12:14:00 <ndevos> #agreed Old versions in Bugzilla will be replaced by "unsupported"
12:14:07 <Humble> LGTM
12:14:35 <ndevos> #agreed Bugs that are filed against an "unsupported" version will get a note and request for testing against a current version
12:14:55 <ndevos> #agreed After 2(?) weeks, unsupported bugs will be closed
12:15:13 <kkeithley_> +1
12:15:44 * ndevos checks how many bugs that would be
12:15:57 <ndevos> .... but bugzilla is slow?
12:16:34 <ndevos> hmm, must be my vpn access :-/
12:16:44 <hagarth> ndevos: whoever closes the unsupported bugs, will get to the top of bitergia graph :)
12:16:55 <ndevos> hagarth: I'LL DO THAT
12:17:09 <ndevos> :)
12:17:12 <hagarth> ndevos: :)
12:17:48 * kkeithley_ thinks that's better than being first on the memo list leader board
12:17:56 <ndevos> Humble: could you request the Bugzilla Admins to replace all old version by "unsupported"?
12:18:01 <Humble> sure will do
12:18:22 <lalatenduM> kkeithley_, +1 :)
12:18:25 <Humble> old versions <=3.3 ?
12:18:27 <ndevos> #action Humble will request the replacement of old versions by a new "unsupported" version
12:18:55 <ndevos> yes, and maybe pre-release or something like that too? but we'd need to check that
12:19:00 * hagarth needs to drop off now, will catch up with meeting minutes later
12:19:06 <ndevos> cya hagarth!
12:20:38 <ndevos> #action ndevos will update the unsupported bugs with a message about being unsupported, and request for testing
12:20:46 <ndevos> #topic Group Triage
12:21:20 <ndevos> our favorite activity: new bugs from last week  http://goo.gl/0IqF2q
12:21:51 <ndevos> 19 that needs to be triaged, please use IRC-locking again
12:22:24 <ndevos> I'll check 1160732
12:22:38 <ndevos> anyone else interested in locking a bug?
12:23:07 <kkeithley_> 1161066
12:24:05 <kkeithley_> 1161885, 1161621
12:25:45 <ndevos> 1161025
12:26:48 <kkeithley_> 1162125
12:30:21 <kkeithley_> 1161502
12:34:32 <ndevos> kkeithley_: are you aware of any bugs in client_t related to the logging the name of the client?
12:35:36 <kkeithley_> aware, no, not per se
12:35:46 <ndevos> okay, too bad
12:35:53 <ndevos> 1161034
12:36:55 <kkeithley_> rename in a disperse volume?
12:37:02 <ndevos> no, that one was my lock
12:37:03 <kkeithley_> what am I not seeing?
12:37:13 <kkeithley_> oh, lock...
12:37:18 <ndevos> 1161025 is the potential client_t one
12:37:59 <ndevos> I think it tried to print the name of the client while it was being (or after) free'd
12:38:38 <lalatenduM> 1162479
12:38:42 <kkeithley_> okay, did you assign it to me?
12:38:49 * kkeithley_ looks
12:39:24 <ndevos> kkeithley_: no, I'm letting you know about it here :D
12:39:56 <lalatenduM> Can we replace a brick from a replica pair
12:40:16 <kkeithley_> I just assigned it to myself.
12:40:59 <kkeithley_> 1161886
12:41:25 <ndevos> kkeithley_: thanks
12:42:04 <ndevos> 1162095
12:43:59 <ndevos> 1162060
12:44:03 <kkeithley_> BTW, the master/MAINTAINERS file could use some attention. E.g. project architects includes Amar!   And DHT maintainer is Shishir
12:44:23 <kkeithley_> who owns snapshot?
12:44:54 <kkeithley_> Is that Joe Fernandes?
12:46:12 <ndevos> not sure, http://www.gluster.org/community/documentation/index.php/Features/snapshot is not current on the owners either
12:46:21 <lalatenduM> 1161893
12:46:41 <Humble> I think Rajesh owns snapshot kkeithley_
12:47:08 <ndevos> #action hagarth should update the MAINTAINERS file, add current maintainers and new components like Snapshot
12:47:11 <Humble> yep.. we need to update the MAINTAINERS file
12:49:03 <ndevos> 1162230
12:49:58 <lalatenduM> ndevos, hey sorry , i think i am done with 1162230
12:50:23 <ndevos> lalatenduM: yes, just noticed :)
12:50:32 <lalatenduM> 1161104
12:52:45 <ndevos> 1161903
12:53:18 <ndevos> 1162150
12:54:12 <lalatenduM> 2 bugs left
12:54:49 <ndevos> 1161416
12:55:15 <lalatenduM> 1161416
12:55:24 <lalatenduM> ohh ndevos you took it
12:55:31 <lalatenduM> ndevos, is it a easy fix bug
12:55:43 <kkeithley_> bug related.. http://review.gluster.org/9056 and http://review.gluster.org/9058 (libgfapi symbol versions) need reviews
12:55:54 * kkeithley_ hints
12:56:13 <ndevos> lalatenduM: I do not think it is easyfix, not for someone that is not familiar with the xml code
12:56:28 <lalatenduM> ndevos, ok
12:56:51 <ndevos> kkeithley_: are those the 3.4 and 3.5 backports? should we merge them and do a new beta?
12:57:10 <lalatenduM> ndevos, btw we dont have much bugs in easyfix category
12:57:36 <ndevos> lalatenduM: 12, that seems sufficient for now?
12:57:37 <kkeithley_> I'm not happy with postponing the 3.4.6 and 3.5.3 GA
12:57:49 <kkeithley_> but happiness is not an important criteria
12:57:53 <kkeithley_> my happiness
12:58:10 <lalatenduM> ndevos, did not find interesting ones though , may be need to talk to you
12:58:10 <ndevos> kkeithley_: okay, release 3.4.6 and 3.5.3 and merge afterwards?
12:58:37 <kkeithley_> let's see what people say in the meeting tomorrow
12:58:43 <ndevos> kkeithley_: okay
12:58:44 <lalatenduM> kkeithley_, I think we fine with 3.4.6 and 3.5.3
12:58:46 <kkeithley_> changes still need to be reviewed
12:58:50 <lalatenduM> I mean I am fine with
12:59:25 <ndevos> lalatenduM: how about the compile warning bug that you assigned to yourself?
12:59:30 <kkeithley_> you're fine with shipping 3.4.6 and 3.5.3 sooner? Or you're fine with slipping GA to merge the symbol versions?
12:59:47 <ndevos> ship it!
12:59:53 <ndevos> #topic Open Floor
13:00:09 <lalatenduM> ndevos, yeah , that looked interesting to me, saw one of ur patch too
13:00:16 <ndevos> time for review requests, and other business?
13:00:30 <ndevos> lalatenduM: yes, it was bugging me every now and then too :D
13:01:01 <Humble> kkeithley_, I think its better to include the symbol versions in GA versions
13:01:15 <ndevos> lalatenduM: when you compile on a 32-bit arch you even get more warnings... those can keep you busy for a while
13:01:31 <kkeithley_> People looking for compiler warnings to fix can look at http://download.gluster.org/pub/gluster/glusterfs/static-analysis/.  Lot's of goodies to choose from there)
13:01:42 <lalatenduM> ndevos, no 32 bits for me now :) dont want get too busy
13:01:57 <ndevos> lalatenduM: just run "mock -r fedora-20-i386 *.src.rpm"
13:02:05 <kkeithley_> Clang, clang-analyze, cppcheck, coverity...
13:02:16 <ndevos> yes, those too
13:02:24 <lalatenduM> kkeithley_, :)
13:03:02 <ndevos> kkeithley_: do you know if those warn about 64-bit pointers on 32-bit arches too?
13:03:33 * kkeithley_ repeats http://review.gluster.org/9056 and http://review.gluster.org/9058 (libgfapi symbol versions) for 3.5 and 3.4 need reviews
13:04:02 <lalatenduM> ndevos, kkeithley_ if you can give me full time dev role, then I can fix them :)
13:04:07 <kkeithley_> not sure if clang or cppcheck report those sorts of things
13:04:30 <ndevos> okay, just asking :)
13:05:00 <ndevos> lalatenduM: it seems a dev role is not about writing code that much either ;-)
13:05:03 * kkeithley_ thought you were a full time dev
13:05:28 <ndevos> no, lalatenduM does QE
13:05:32 <kkeithley_> write code? I've nearly forgotten what that is
13:05:41 <ndevos> but well, thats a dev role too, right?
13:05:45 <kkeithley_> It's been so long
13:05:53 <kkeithley_> lol
13:06:17 * ndevos reviews and discusses most of the time... and there are meetings like these!
13:06:19 <lalatenduM> ndevos, yeah :)
13:06:24 <ndevos> #endmeeting