gluster-meeting
LOGS
15:00:05 <kkeithley> #startmeeting
15:00:05 <zodbot> Meeting started Wed Apr 23 15:00:05 2014 UTC.  The chair is kkeithley. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <kkeithley> rollcall
15:00:40 <dlambrig> Hi All,
15:00:45 * lpabon here
15:00:47 <dbruhn> here
15:00:51 <atinmu> Greetings everyone
15:00:55 * purpleidea is here
15:01:19 * jdarcy is here
15:02:24 <kkeithley> while we're waiting, please add any agenda items to the google doc at http://goo.gl/NTLhYu
15:02:26 <glusterbot> Title: glusterpad - Google Docs (at goo.gl)
15:02:58 * kshlm is here
15:03:19 <tdasilva> hello
15:03:36 <kkeithley> okay, let's get started
15:04:14 <kkeithley> action item #1 was jclift to ping kshlm to find out where the gluster forge replacement investigation is
15:04:43 <kkeithley> kshlm, do you know anything about this?
15:05:00 <kshlm> I've not been able to work on that in the last couple of weeks.
15:05:15 * kshlm was down sick.
15:05:37 <kkeithley> okay, hope you're feeling better. we'll leave this as a continuing action item
15:05:45 <kshlm> I'll continue with it this week.
15:05:46 <kkeithley> #action jclift to ping kshlm to find out where the gluster forge replacement investigation is
15:06:20 <kkeithley> action #2 was for me to figure out how to use a DSA signing key on el6 rpms. I haven't done it.
15:06:28 <kkeithley> I haven't done it yet
15:07:22 <kkeithley> if anyone has experience with using two different keys to sign rpms send it to me off chat. Otherwise I'll figure it out soon
15:07:54 <kkeithley> #action kkeithley to figure out RSA+DSA signing keys
15:08:12 <kkeithley> action #3 was ndevos to Send email to devel mailing list, to clarify "when a release is done, when should bugs get closed?"
15:08:30 <kkeithley> ndevos, did this email get sent?
15:08:45 <ndevos> it got send out, I think
15:09:07 <ndevos> not many responses, but all positive - not very clear on the "wneh" though
15:09:08 <kkeithley> excellent. No responses?
15:09:18 <ndevos> *when
15:09:47 <ndevos> so, after checking with Lala who is taske with the triaging of new/open bugs, we decided to close many
15:10:31 <ndevos> after the release of 3.5.0, we have closed about 280 bugs with a 'fixed in version glusterfs-3.5.0' and about 20 bugs for older releases
15:11:10 <hagarth> ndevos: kudos for the good work on that front!
15:11:13 <ndevos> all bugs should have a clear note about the option for re-opening, but it should be good
15:11:48 <ndevos> this is not a fully automated process yet, but it is possible to script it all
15:12:22 <ndevos> in future, I hope we can move bugs to ON_QA and give a version that is supposed to fix the bug
15:12:40 <ndevos> that is, when an alpha/beta release is done
15:12:42 <kkeithley> version, as in a git commit hash?
15:13:17 <ndevos> a real version, tagged like 'qa' or 'alpha' or 'beta'
15:13:38 <ndevos> the commit is already in the bug itself, added when the patch got merged
15:14:17 <ndevos> I think thats about it, questions?
15:14:36 * jdarcy applauds ndevos for doing this bit of particularly tedious work.
15:15:25 <kkeithley> okay. moving on
15:15:54 <kkeithley> I believe we still have miles to go on docs for 3.5.0. Am I wrong?
15:16:08 <hagarth> kkeithley: I don't think so
15:16:09 <purpleidea> jdarcy:
15:16:12 <ndevos> not miles, but some docs are still missing, yes
15:16:22 <purpleidea> +1
15:16:36 <hagarth> there are a few doc bugs that we need to clean up before 3.5.1
15:16:46 <kkeithley> thoughts on how we get the remaining pieces?
15:16:53 <jdarcy> hagarth: Doc bugs?  You mean like things that are there but incorrect?
15:17:21 <hagarth> jdarcy: not along those lines but some features that lack documentation in admin guide
15:17:43 <hagarth> most of them have some description elsewhere - gerrit commit logs, feature pages etc.
15:17:58 <ndevos> admin guide, or dedicated documentation for features
15:18:07 <jdarcy> BTW, even though I was mostly on the "let's finish the release" side of that debate, it's worth mentioning that at Summit documentation was (as expected) still a top user complaint.
15:18:35 <ndevos> a complete list of undocumented (or in progress) is part of the 3.5.1 blocker: https://bugzilla.redhat.com/showdependencytree.cgi?hide_resolved=1&id=glusterfs-3.5.1
15:18:37 <glusterbot> Title: Dependency tree for Bug 1071800 (at bugzilla.redhat.com)
15:18:39 <hagarth> jdarcy: +1. I think we need two things as far as user documentation goes:
15:18:48 <hagarth> 1. Functional admin guide
15:18:55 <hagarth> 2. Operations guide
15:19:00 <ccapriotti> sorry if the comment will "sound" a bit harsh, but documentation is really hard, either to find, or outdated, right now.
15:19:27 <lalatenduM> ccapriotti, +1
15:19:39 <hagarth> if we get 1. and 2. in order, we will be doing a major favor to ourselves IMO.
15:19:43 <overclk_> d
15:19:55 <atinmu> ccapriotti, thats what we are trying to work out, isn't it
15:19:56 <jdarcy> I'll volunteer to chase down some of the new-feature authors and help them get information at least into the docs directory.
15:20:13 <lalatenduM> how to publish markdown pages in to a website? IMO we should do that
15:20:29 <msvbhat> hagarth: What is 1 and 2? I mean the difference between them
15:20:35 <kkeithley> #action jdarcy will chase new feature authors
15:20:47 <hagarth> msvbhat: 1 is about documenting all our features the right way
15:20:54 <ndevos> lalatenduM: +1 we now have worked hard on getting devs to submit docs, now they need to get displayed somehow too
15:21:28 <msvbhat> IMO all our docs should be online and 'google'able :)
15:21:30 <hagarth> msvbhat: 2 is about operational procedures, something like  "how do I decommission a gluster server?", "how do I change the IP address of my gluster server?" etc.
15:21:35 <lalatenduM> From last two weeks I have seen good progress on documentation side , if we keep on doing that we will be good in future
15:21:43 * atinmu agrees with hagarth
15:21:52 <hagarth> lalatenduM: pandoc lets you output markdown/asciidoc to html
15:22:06 <msvbhat> hagarth: Ahh... Okay.
15:22:25 <JoeJulian> I was thinking asciidoctor...
15:22:31 <lpabon> lalatenduM, github also supports restructured text (rst)
15:22:33 <hagarth> I think we should throw a wiki page to get the right ToC for operations guide
15:22:34 <lalatenduM> hagarth, need a website address too :), I am ready to volunteer for this
15:22:40 <msvbhat> Can't we have a site hosting all our docs? something like docs.gluster.org?
15:22:58 <lalatenduM> lpabon, github rendered docs do not come in in web searches
15:23:00 <hagarth> msvbhat, lalatenduM: docs.gluster.org would be great
15:23:09 <ccapriotti> here I like my documentation in PDF very much. To be kept and indexed locally. Handy, despite the fact they are not updated.
15:23:14 <lalatenduM> hagarth, what abt wiki,gluster.org
15:23:43 <hagarth> lalatenduM: we can just unroll it there - pandoc converts to mediawiki as well IIRC
15:23:52 <lpabon> with pandoc you can convert from markown and i think rst to pdf
15:23:56 <lalatenduM> hagarth, +1
15:24:07 <hagarth> lalatenduM: would you be able to take this AI and have a browseable admin guide from our repo?
15:24:09 * JoeJulian despises pdf ... edoc?
15:24:17 <lalatenduM> hagarth, yes
15:24:26 <lpabon> im not sure if github supports rendering mediawiki format
15:24:38 <hagarth> lalatenduM: cool, thanks!
15:24:41 <kkeithley> #action lalatenduM will produce a  browseable admin guide from our repo
15:25:25 <kkeithley> anything else?
15:25:38 <ndevos> lalatenduM: I read ^ as anything that is located under the doc/ directory in the sources, thanks!
15:25:39 <kkeithley> moving on
15:25:59 <lalatenduM> ndevos, yes thats the place
15:26:15 <kkeithley> anything else?
15:26:18 <dbruhn> The landing page still references 3.5 as beta everything
15:26:24 <lalatenduM> if anybody want to collaborate with me for the doc thing , you are welcome :)
15:26:31 <kasturi> lalatenduM, i am there
15:26:33 <lalatenduM> dbruhn, +1, we need to change that
15:26:37 <JoeJulian> dbruhn: I can fix that
15:26:46 <kkeithley> #action kasturi will help lala
15:26:47 <lalatenduM> hey kasturi thanks
15:26:57 <kasturi> lalatenduM, no issues :-)
15:26:58 <dbruhn> I was going to say if someone wanted to give me access I could work on it.
15:26:59 <ccapriotti> lalatenduM: I would like to see if I can help.
15:27:09 <lalatenduM> ccapriotti, awesome :)
15:27:35 <kkeithley> excellent. thanks guys
15:27:51 <kkeithley> (or gals?)
15:27:52 <atinmu> lalatenduM, even I was also interested in it, but seems like we have enough volunteers...
15:28:10 <lalatenduM> atinmu, we can always use extra hands :)
15:28:21 <hagarth> more the merrier :)
15:28:22 <ccapriotti> documentation with enough volunteers? eh... hardly...
15:28:33 <lalatenduM> ccapriotti, +1
15:28:44 <kkeithley> #action dbruhn, ccapriotti, atinmu helping
15:29:00 <kasturi> kkeithley, +kasturi
15:29:11 <kasturi> kkeithley, as well for helping lala
15:29:19 <kkeithley> (11:26:45 AM) kkeithley: #action kasturi will help lala
15:29:42 <kkeithley> yep
15:29:49 <kkeithley> are we ready to move then?
15:29:54 <lalatenduM> yes
15:29:59 <kasturi> yes
15:30:02 * ndevos is impressed with all the volunteers
15:30:27 <kkeithley> old action item, not sure what the status ended up.  Have we chased down the memory leak issue affecting NetBSD?
15:30:51 <kkeithley> anybody know?
15:31:08 <hagarth> kkeithley: Emmanuel said that it is no longer reproducible with the GA bits?
15:31:20 <kkeithley> ah, okay
15:32:09 <kkeithley> next. Two weeks ago someone added GlusterFS & OpenStack doc update in the agenda but then didn't stick around to talk about it.
15:32:18 <kkeithley> I don't suppose anyone is here to talk about it today?
15:32:58 <kkeithley> no?
15:33:01 <hagarth> kkeithley: lalatenduM might have some context
15:33:02 <lpabon> doesn
15:33:11 <lalatenduM> hagarth, nope I have no idea who added it
15:33:17 <lpabon> doesn't seem like it
15:33:48 <hagarth> kkeithley: better drop it off the agenda
15:34:17 <kkeithley> #action chair to delete GlusterFS & OpenStack doc update from agenda
15:34:19 <lalatenduM> kkeithley, hagarth I had a AI on me to update the Openstack doc for glusterfs, but I haven't add it to the agenda 2 weeks back
15:34:28 <lalatenduM> s/a AI/an AI/
15:35:10 <hagarth> lalatenduM: ok, we can discuss this offline probably. Doesn't warrant a discussion in this meeting.
15:35:20 <lalatenduM> hagarth, yeah
15:35:28 <kkeithley> just added: Gluster got accepted into GSOC. What's this regarding?
15:35:36 <kshlm> For those who didn't know, vipulnayyars project, glusterfs-iostat, was accepted for GSOC14 under the Fedora umbrella. Big thanks to the fedora team for this. :)
15:35:41 <semiosis> :O
15:35:50 <kshlm> Just getting it out there.
15:35:52 <kkeithley> #action hagarth and lalatenduM to discuss OpenStack doc offline
15:36:15 <kkeithley> #note vipulnayyars project, glusterfs-iostat, was accepted for GSOC14
15:36:55 <kkeithley> excellent news
15:36:59 <ccapriotti> indeed
15:37:00 <semiosis> getting back to forge replacement, i volunteered at the summit to look into github org... haven't made any progress on that yet, but i will in time for next week's community meeting
15:38:13 <kkeithley> moving on
15:38:18 <hagarth> semiosis: cool
15:38:33 <kkeithley> thin-p question from two weeks ago? Anyone know more about this?
15:38:58 <msvbhat> kkeithley: purpleidea wanted it. And I think I have given him what he wanted
15:39:45 <msvbhat> kkeithley: I mean thin-p ^^
15:39:56 <kkeithley> #note thin-p question from purpleidea, msvbhat gave hime the answer
15:40:08 <kkeithley> next
15:40:18 <kkeithley> skipping pkg-version for a minute
15:40:31 <kkeithley> someone has asked about addint sub-maintainers?
15:40:37 <hagarth> kkeithley: that was my topic
15:40:46 <kkeithley> s/addint/addition/
15:40:54 <hagarth> #topic addition of sub-maintainers
15:41:37 <kkeithley> oh yeah, I forgot about #topic
15:41:40 <kkeithley> :-(
15:41:54 <hagarth> In order to increase our review & merge velocity, efficiency we have been thinking of getting more maintainers.
15:42:15 <atinmu> i do feel we need sub-maintainers to make our reviews and upstream merge process faster
15:42:19 <atinmu> +1
15:42:26 <hagarth> we are thinking of bringing 2 classes here
15:42:41 <hagarth> 1. release-maintainers for various releases that we support
15:42:48 <lalatenduM> hagarth, +1
15:42:54 <hagarth> 2. sub-maintainers for modules that have significant activity
15:43:03 <lalatenduM> I also feel the same, reviews are getting stuck
15:43:18 <hagarth> with respect to release maintainers, we have kkeithley as the one driving 3.4.x
15:43:24 <msvbhat> hagarth: sub-maintainers++
15:43:34 <hagarth> I propose that we have ndevos manage release-3.5
15:44:06 <hagarth> ndevos has already been doing a lot of ground work for 3.5 tracking etc.
15:44:10 <lpabon> question: do submaintainers have push access in Gerrit?
15:44:28 <hagarth> lpabon: I will come to that, let us finish release maintainers first
15:45:03 <lalatenduM> hagarth, agree with you for 3.4 and 3.5
15:45:20 <hagarth> ndevos: more importantly, are you willing to take over 3.5? :)
15:45:39 <ndevos> hagarth: yes, that works for me
15:46:16 <hagarth> ndevos: cool!
15:46:28 <hagarth> all hail the new release-3.5 maintainer, ndevos :)
15:46:41 <lalatenduM> yw!!
15:46:53 <purpleidea> o wow
15:46:54 <kkeithley> #note ndevos will take over as release-3.5 maintainer
15:46:56 * atinmu applauds ndevos
15:47:07 <hagarth> switching tracks to sub-maintainers
15:47:10 * ndevos waves to the crowd _o/
15:47:20 <lalatenduM> \0
15:48:01 <hagarth> sub-maintainers will have push/submit rights in gerrit for patches in their respective functional areas
15:48:20 <lalatenduM> hagarth, +1
15:48:22 <hagarth> the overall responsibilities include:
15:48:38 <hagarth> 1. Overall patch management in the respective functional areas.
15:48:38 <hagarth> 2. Completely own the respective modules
15:48:38 <hagarth> - be responsible for overall quality of those modules
15:48:38 <hagarth> - be visible and responsive in the community for related queries
15:48:38 <hagarth> - work with upstream release maintainers for ensuring right  content in releases
15:49:42 <atinmu> hagarth, does gerrit have that control to give push/commit permission to specific files?
15:50:13 <hagarth> I will be sending out proposals to gluster-devel on sub-maintainers and their respective areas - we can ACK, NACK those proposals on the mailing list.
15:50:39 <kkeithley> #action hagarth to email sub-maintainer proposals to gluster-devel
15:50:51 <hagarth> atinmu: unfortunately no, it will be an informal agreement between sub-maintainers and the community that they don't go beyond their respective areas
15:51:10 <jdarcy> It's a mistake you only get to make once.  ;)
15:51:11 <hagarth> me and avati will continue to work as before but our focus might be more on patches that do not have sub-maintainers
15:51:35 <hagarth> jdarcy: sounds like a good thing to have in the disclaimer ;)
15:51:55 <atinmu> hagarth, ahhh thats what.. I was wondering how could gerrit figure it out...so accidentally sub maintainers have the same permission like a release maintainer has
15:51:59 <kkeithley> absolute power corrupts absolutely
15:52:05 <msvbhat> hagarth: So what all areas are identified as needing sub-maintainers
15:52:20 <hagarth> we will also help in arbitration of any issues, problems that might arise
15:52:27 <jdarcy> I think Gerrit can restrict by project/branch, but not directory.  Since releases are branches, that part actually works.
15:53:15 <hagarth> atinmu: the way gerrit works, sub-maintainers will have more influence than release maintainers :D
15:53:16 <kkeithley> indeed, I can't merge in anything but the release-3.4 branch. The button isn't there in gerrit to do it
15:54:07 <hagarth> msvbhat: functional areas like afr, geo-rep, quota, rpc, nfs are the ones that need attention and hence will have sub-maintainers
15:54:21 <kkeithley> time check: ~five minutes remaining
15:54:24 <hagarth> msvbhat: I will follow up with more precise details on mailing list
15:54:31 <atinmu> hagarth, even glusterd?
15:54:34 <msvbhat> hagarth: Sure...
15:54:39 <hagarth> atinmu: yes
15:54:52 <hagarth> any questions on $TOPIC ?
15:55:03 <lalatenduM> hagarth, I think it is a good idea
15:55:14 <msvbhat> hagarth: Have someone for doc as well :P :)
15:55:40 <hagarth> msvbhat: sounds like a good idea :)
15:55:42 <ndevos> hagarth: when will you send the email? it's a regular AI that gets forgotten...
15:55:55 <hagarth> ndevos: I don't think I will forget this :)
15:56:04 <ndevos> hagarth: hehe
15:56:11 <hagarth> ndevos: I am getting on a plane in a few hours from now
15:56:31 <hagarth> I will probably do this over the week .. as the plane trip is going to burn 24 hours of my life ;)
15:56:45 <atinmu> hagarth, have a pleasant and safe journey
15:56:52 <kkeithley> ready to move on?
15:57:06 <hagarth> atinmu: thanks!
15:57:28 <kkeithley> last topic is more of a question (from me)
15:57:35 <kkeithley> #topic pkg_version
15:58:30 <kkeithley> I built the $HEAD of master and noticed that the dist tarball hasd 3.5.0qa2 in the name. Seems strange. What's the intended behavior here?
15:58:40 <kkeithley> shall I take this off line?
15:58:41 <lalatenduM> kkeithley, nope
15:58:43 <jdarcy> Yeah, I had to work around the same stuff.
15:58:56 <lalatenduM> kkeithley, I think hagarth has plns to change it to 3.6
15:59:12 <kkeithley> I know I can create a VERSION file with the exact version I want to override with
15:59:15 <jdarcy> It's not quite right for a developer's private build to get a "real release" RPM instead of "3git"
15:59:42 <ndevos> it bases the version on the last tag, but what should the version for a master branch be?
15:59:43 <jdarcy> I tried creating a VERSION file, and it had no effect.
15:59:47 <hagarth> kkeithley: I would suggest sending out an email to Bala and gluster-devel
16:00:16 <kkeithley> #action kkeithley to ping bala about pkg-version
16:00:31 <jdarcy> I would say if you're not *at* a tag, it should be ${majorversion}git
16:01:16 <kkeithley> okay, we're at the top of the hour. is there any more business or do I have a motion to adjourn?
16:01:21 <lalatenduM> I think its the tag
16:01:50 <ndevos> well, it does ${majorversion}${minorversion}${githash} I think
16:01:51 <kkeithley> is there some magic git incantation that will do that?
16:01:55 <lalatenduM> kkeithley, ndevos hagarth there soem patches pending for 3.5 , are we planning to take them in 3.5.1
16:02:16 <lalatenduM> s/soem/are some/
16:02:42 <ndevos> lalatenduM: doc+bugfixes yes, features not so likely
16:02:51 <hagarth> lalatenduM: we would need to get the bug fixes in
16:03:07 <lalatenduM> hagarth, ndevos kkeithley ok
16:03:20 <ndevos> lalatenduM: well, features are open for discussion ;)
16:03:51 <lalatenduM> ndevos, yup, I am only for bug fixes in 3.5.1 :)
16:04:33 <hagarth> I need to drop off now, later everyone.
16:04:56 <ndevos> have a good flight hagarth!
16:05:11 <kkeithley> any more business?
16:05:11 <kkeithley> no?
16:05:11 <kkeithley> hagarth: safe travels
16:05:11 <kkeithley> #endmeeting