gluster-meeting
LOGS
02:21:25 <johnmark> #startmeeting
02:21:25 <zodbot> Meeting started Fri Aug 17 02:21:25 2012 UTC.  The chair is johnmark. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:21:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
02:21:29 <johnmark> ok!
02:21:55 <johnmark> #link http://www.gluster.org/community/documentation/index.php/QuickStart
02:22:10 <johnmark> #link http://www.gluster.org/community/documentation/index.php/HowTos
02:22:20 <johnmark> #topic web site software foo
02:22:41 <johnmark> #char Technicool
02:22:45 <johnmark> #chair Technicool
02:22:46 <zodbot> Current chairs: Technicool johnmark
02:22:49 <johnmark> yes!
02:22:52 <johnmark> he lives!
02:22:57 <Technicool> lookit the big brains on brad
02:23:23 <Technicool> bravo
02:23:40 <johnmark> ok - do currently we have the following things installed on the web site:
02:24:05 <johnmark> on gluster.org: wordpress (front end), mediawiki (docs collaboration), mailman (mailing lists)
02:24:39 <johnmark> big question: does this serve the community as well as it can?
02:24:43 <johnmark> and are there alternatives?
02:25:02 <johnmark> oh, and the hosted service at http://community.gluster.org
02:25:56 <JoeJulian> Wordpress was being a problem for a while with it's infinite redirect problem, but I haven't seen that in a while.
02:26:14 <johnmark> JoeJulian: yeah, that was a caching issue which I *think* has been resolved
02:26:53 <johnmark> #info on gluster.org: wordpress (front end), mediawiki (docs collaboration), mailman and hosted service at community.gluster.org
02:26:55 <Technicool> wordpress advantages, its widely used and can be picked up quickly by just about anyone
02:26:55 <JoeJulian> So it seems to be "good enough". It's working so I'm not strong on fixing it.
02:27:02 <johnmark> JoeJulian: ok
02:27:09 <johnmark> what about community.gluster.org?
02:27:22 <johnmark> there are some self-hosted alternatives, if we want to get into that
02:27:23 <JoeJulian> That isn't working for me, but I'm just one guy.
02:27:32 <johnmark> JoeJulian: yeah, I think several would agree with that
02:27:38 <JoeJulian> And we're trying to be open-source proponents.
02:27:48 <johnmark> correct
02:27:57 <Technicool> drawbacks would be more maintenance required that you might want for driving a community site, and functionality/plugins seem to sprawl
02:28:11 <johnmark> so for alternatives, there's OSQA (django-python framework) and...
02:28:19 <johnmark> Technicool: true
02:28:30 <johnmark> Technicool: wait, drawbacks for what?
02:28:39 <johnmark> the c.g.o?
02:28:42 <Technicool> for wordpress
02:28:43 <johnmark> or wordpress?
02:28:45 <johnmark> ah! ok
02:29:15 <Technicool> for the community.gluster.org site, my feeling is that it does not make finding information intuitive enough
02:29:23 <JoeJulian> I like the django based, and if we did want to leave wordpress we could still do Mezzanine. They would then integrate better since it's also Django based.
02:29:24 <johnmark> Technicool: agreed
02:29:31 <johnmark> hrm
02:29:45 <Technicool> i love the idea of it, but it can be difficult to find what you are looking ofr
02:29:50 <Technicool> ^ofr^for
02:29:52 <johnmark> last time I tried mezzanine, or anything django-based, it wasn't exactly easy to setup and maintain
02:30:03 <johnmark> that was, admittedly, over 2 years ago
02:30:29 <JoeJulian> Ah, yes. Mezzanine has been under active development. 1.0 was only released a couple months ago.
02:30:35 <johnmark> JoeJulian: ah, ok
02:30:54 <johnmark> so, one thing at a time. there's another Q&A alternative I'm trying to remember
02:31:02 <JoeJulian> Plus... I'm building a wordpress compatible api for it so you can use wordpress mobile apps with it.
02:31:05 <johnmark> I'd replace the Q&A piece first, and then look at other things
02:31:11 <johnmark> JoeJulian: interesting!
02:31:34 <JoeJulian> openqa or openqna or something like that...
02:31:52 <JoeJulian> osqa
02:32:02 <johnmark> shapado? http://shapado.com/
02:32:07 <johnmark> there's osqa, yes
02:32:15 <johnmark> and I think shapado is the other commonly used one
02:33:09 <johnmark> #info alternatives to c.g.o OSQA http://www.osqa.net/ and shapado http://shapado.com/
02:33:22 <johnmark> JoeJulian: want to give osqa a twirl?
02:33:39 <JoeJulian> Not really, I didn't like the looks or feature set very well.
02:33:48 <JoeJulian> Shapado does look better already.
02:34:26 <Technicool> their marketing guys got me...i saw the smartphone next to it and thought "well, this must be good"
02:34:40 <JoeJulian> Yeah, me too.
02:34:43 <johnmark> haha :)
02:34:43 <Technicool> shapado guys
02:34:52 <johnmark> http://gitorious.org/shapado
02:34:59 <johnmark> is the place to grab the code for self-hosting
02:35:12 <JoeJulian> I'll get that installed tomorrow.
02:35:22 <johnmark> JoeJulian: sweet
02:35:24 <JoeJulian> We can try it out.
02:35:32 <johnmark> #action JoeJulian to install shapado
02:36:05 <johnmark> JoeJulian: I'm hesitant to move off wordpress, because it's well-known, etc.
02:36:17 <johnmark> JoeJulian: but I'm open to being convinced
02:36:18 <JoeJulian> Sure
02:37:11 <johnmark> JoeJulian: so, as an example, seeing your site running mezzanine and not able to export specific tags as rss feeds was a turnoff :)
02:37:22 <johnmark> JoeJulian: although I understand you fixed that now :)
02:37:26 <JoeJulian> :D
02:37:50 <johnmark> anyway
02:38:12 <johnmark> I think that's step #2 after we move off of c.g.o.
02:38:22 <johnmark> because theyr'e going to start charging us soon :)
02:38:44 <johnmark> ok, and the wiki
02:38:49 <johnmark> there are alternatives to mediawiki
02:38:53 <johnmark> question is - are they worth it?
02:39:29 <JoeJulian> Despite some false positives, mediawiki seems to be manageable again. And, like your reasoning for wordpress, it's very well known.
02:39:37 <johnmark> for example, I use dekiwiki for a side project: http://www.geek-pac.org/
02:39:40 <Technicool> mediawiki is a solid 7 out of 10, so alternatives will need to offer something nice
02:39:45 <johnmark> JoeJulian: agred
02:39:52 <johnmark> Technicool: yup.
02:39:56 <johnmark> agreed, even
02:40:43 <johnmark> here's the thing: if we want to offer collaborative project management stuff, a la sourceforge
02:40:51 <johnmark> is mediawiki going to let us do that?
02:41:21 <johnmark> because eventually, I want to give devs the ability to run projects on gluster.org
02:41:26 <johnmark> where "eventually" means later this year
02:41:56 <JoeJulian> Well, if we want to change to markdown and use git, then probably not.
02:42:38 <johnmark> #action johnmark to ask mojavelinux about project management software
02:42:59 <johnmark> I mean, it could be that we create the forge thing with a separate web app
02:43:13 <johnmark> and leave the wiki madness on its own
02:43:14 <Technicool> im scanning the mediawiki api to see if there are things built in already
02:43:21 <johnmark> Technicool: was wodnering teh same
02:43:35 <johnmark> mw is such a multi-headed beast it wouldn't surprise me
02:44:53 <johnmark> ok. that's all I got
02:45:04 <johnmark> #action jdarcy to update us next week on dev docs
02:45:47 <JoeJulian> In the spirit of markdown, I'm toying with trying to take the presentation I got from you and making an intro to gluster presentation in Showoff
02:45:48 <JoeJulian> https://github.com/schacon/showoff
02:45:58 <johnmark> there's also the issue of the pending migration of jenkins and gerritt to our own infrastructure
02:46:07 <johnmark> JoeJulian: nice!
02:46:14 <johnmark> yeah, I've seen showoff in action
02:46:20 <JoeJulian> It would be good to have some presentations that could be collaboratively worked on.
02:46:25 <johnmark> and that migration has been delayed, unfortunately
02:46:39 <johnmark> #action johnmark to provide update on migration away from iweb
02:46:53 <johnmark> JoeJulian: that would be excellent
02:47:18 <johnmark> #action JoeJulian to look at showoff and collaborative presos
02:47:38 <johnmark> anything else about gluster.org and our community that is wonky and could be much, much better?
02:47:41 <JoeJulian> Maybe I'll see if I can get http://gitlabhq.com/ installed too.
02:47:57 <johnmark> JoeJulian: as you wish
02:48:01 <JoeJulian> hehe
02:48:04 <johnmark> that will be a bonus :)
02:48:36 <johnmark> anything else?
02:48:39 <JoeJulian> Nothing else for this topic that I can think of.
02:48:40 <johnmark> Technicool: you down with this?
02:48:43 <Technicool> johnmark, there is the cosmetic issue of having multiple sites with different layouts, not a priority but something we should think about if we are looking at changing things up
02:49:02 <johnmark> Technicool: yes. the downside of using mediawiki with anything
02:49:15 <johnmark> Technicool: I think this is where we ask Garrett very nicely if he can help out
02:49:18 <Technicool> johnmark, i would love to see what alternatives we have to the existing infra that are open source
02:49:41 <johnmark> Technicool: you're pretty booked for the next week. I can take that on
02:49:54 <Technicool> long term, i think we will get more people involved if we have tools they are used to already
02:49:59 * johnmark misses semiosis
02:50:08 <johnmark> Technicool: true
02:50:26 <JoeJulian> On the other hand, we get more quality if there's a slight barrier to entry.
02:50:36 <johnmark> Technicool: there are lots of alternatives, just a question of usefulnes and, as you say, familiarity
02:50:41 <johnmark> haha!
02:50:50 * Technicool coughs  *and something that can be done from a terminal*
02:50:57 <JoeJulian> You know, like when you have the question, "stripe".
02:50:58 <johnmark> so..
02:51:17 <Technicool> johnmark, agreed
02:51:31 <johnmark> Technicool: one thing I've wanted to look at for the site is joomla
02:51:39 <JoeJulian> :/
02:51:40 <johnmark> or drupal
02:51:44 <JoeJulian> :(
02:51:44 <johnmark> JoeJulian: haha
02:51:44 <Technicool> what is the other one....bitnami?
02:52:02 <johnmark> Technicool: bitnami is a software-stack installer
02:52:05 <Technicool> amazon loves bitnami, for sure
02:52:09 <johnmark> or software appliance maker
02:52:24 <Technicool> now it clicks
02:52:28 <johnmark> heh
02:52:29 <JoeJulian> I've gone through several and have never been an advocate for any of them before mez, just sayin.
02:52:33 <johnmark> JoeJulian: not a fan of PHP?
02:52:41 <Technicool> is anyone?
02:52:42 <johnmark> JoeJulian: gotcha, ok
02:52:43 <Technicool> oops
02:52:46 <JoeJulian> It gets pretty bloated.
02:53:05 <johnmark> JoeJulian: fair enough.
02:53:21 <johnmark> JoeJulian: what I'm thinking of is global community of devs and maintainers
02:53:40 <Technicool> hmm, they seem to want me to advocate for them as well
02:53:40 <JoeJulian> What took 2G to run Joomla/Apache reasonably quick I do now in 512 and it's 10x faster.
02:53:42 <Technicool> "An open source content management platform built using the Django framework"
02:53:45 <johnmark> JoeJulian: but I know that django-based stuff has picked up steam. I just don't know how much
02:53:53 <johnmark> wow, ok
02:54:58 <Technicool> ill gawk at this for a bit, but mezz looks like a great alternative to at least investigate
02:55:02 <johnmark> JoeJulian: if you can show me how easy it is to convert the entire site, you might have me convinced ;)
02:55:12 <johnmark> Technicool: cool
02:55:14 <JoeJulian> :)
02:55:17 <johnmark> 'aight. anything else?
02:55:25 <johnmark> going once
02:55:27 <johnmark> going twice
02:55:29 <johnmark> ...
02:55:31 <Technicool> http://mezzanine.readthedocs.org/en/latest/blog-importing.html
02:55:40 <johnmark> Technicool: nice
02:55:50 <johnmark> I hereby declare this meeting adjourned!
02:55:57 <johnmark> #endmeeting