glittergallery
LOGS
14:21:04 <banas> #startmeeting GG Jan 28, 2015
14:21:04 <zodbot> Meeting started Wed Jan 28 14:21:04 2015 UTC.  The chair is banas. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:21:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:21:14 <banas> #chair Emichan
14:21:14 <zodbot> Current chairs: Emichan banas
14:21:54 <Emichan> banas, i just got interrupted - i'll be back in ~10 min - sorry
14:22:01 <banas> cool
14:24:46 <Emichan> haha, back - that was quicker than i thought :D
14:25:51 <Emichan> just pulled it - bundling it now
14:26:29 <Emichan> banas, we got two feet of snow yesterday - sorry you missed it ;)
14:26:52 <banas> https://github.com/glittergallery/GlitterGallery/pull/193 fixes some of the bundling problems we had at the FAD, so hopefully it bundles smoothly now :)
14:26:57 <banas> TWO FEET?
14:27:04 <banas> damn
14:27:48 <banas> when it snowed, didn't it hurt if it fell on you? i mean, it had to be heavy to count for 2 feet
14:27:51 <Emichan> yep - three feet in westford actually, but two feet in boston
14:28:51 <banas> wow, that's enough snow to play hide and seek :D
14:29:00 <Emichan> no - snow's not heavy, and we didn't get two feet all at once - it was like, 2-4 inches an hour
14:29:41 <banas> ah, so it must have been like when I arrived in Logan. that was the only time the bits fell from the sky.
14:30:02 <Emichan> yeah
14:30:14 <banas> anyway how's the bundle going?
14:31:44 <Emichan> bundle went fine - running it locally now
14:32:00 <banas> cool! so that's one hurdle crossed
14:32:36 <Emichan> awesome! upload worked!
14:32:42 <banas> yay
14:33:09 <banas> for the fork, go to another persons account, pick a project with some photos, and append /fork
14:37:12 <Emichan> got undefined local variable or method `project' for #<ProjectsController:0x00000004043040>
14:38:08 <banas> reproduce? what were you trying to do?
14:39:00 <Emichan> went to /fork - is your code on master?
14:39:14 <Emichan> i'm running master atm
14:39:33 <Emichan> looks like it's still using Grit code ...
14:40:03 <banas> oh no
14:40:07 <banas> i forgot
14:40:11 <banas> the fork isnt on master
14:40:18 <banas> https://github.com/glittergallery/GlitterGallery/pull/195
14:40:38 <banas> pull from improve-rugged
14:47:12 <Emichan> hm
14:47:20 <Emichan> i'm getting redirected to http://0.0.0.0:3000/projects/1
14:48:03 <banas> well that happens when the fork didn't happen.
14:48:52 <banas> let's see. the last time you did a fork, maybe it already created a project with that name? could you do a Project.find :last on your console
14:48:52 <Emichan> well, then it didn't happen :/
14:49:15 <Emichan> do you need the return_context filter for fork?
14:49:58 <Emichan> okay, yeah, it did create the repo - but it didn't clone the original
14:50:30 <banas> for fork, no you dont
14:51:08 <banas> let me try pushing it to openshift
14:52:12 <banas> alright, could you 1) destory the last project
14:52:30 <banas> 2) manually delete the corresponding repos on the ../data ?
14:52:54 <banas> i think the previous fork you did with the master code messed it up
14:52:58 <Emichan> gimme a sec
14:54:43 <banas> oh btw you asked me if we need the return_context, yes we do, i misunderstood it as do we need to ignore it
14:56:29 <banas> ah, just realized my openshift carttridge runs ruby 1.9
14:56:35 <banas> i will need a while
14:57:34 <banas> hey shubham, what's up man?
14:59:17 <Emichan> banas, np
14:59:41 <Emichan> banas, just tried it again - worked perfectly
14:59:42 <banas> in the meanwhile, if he's around, lets make shubham try
14:59:49 <banas> yay
15:00:19 <banas> so we have that working. i'm currently improving the rugged-y stuff to show trees in the project show view
15:00:26 <banas> essentially, support directories
15:00:52 <banas> and then we can support external directories that are publicly available on a url (e,g those on github)
15:01:19 <Emichan> banas, sweet!!
15:02:08 <banas> Emichan: could you look after the openshift quickstart (if you find time)?
15:02:15 <shubham> Hi all :)
15:02:41 <shubham> I will add the followers list which was assigned to me last time.
15:02:44 <banas> i'll see if shubham wants to take up some notifications/relationships specific tasks
15:02:54 <banas> shubham: i've already done it ;)
15:03:07 <banas> shubham: it doesn't have ajax though, so you'll take that up?
15:03:54 <shubham> yeah sure. On it!
15:04:21 <banas> Emichan: I have a ruby1.9 app, do you know if there's a way i can use ruby 2 on it w/o making a new app from scratch?
15:04:26 <banas> (on openshift i mean)
15:05:12 <banas> shubham: currently, i'm improving our git-oriented stuff
15:05:42 <banas> i just added methods for fork, cleaned up our controllers a little bit, so you'll see some simplification/constant code style im trying to follow
15:05:44 <Emichan> banas, not really - i'd suggest doing a snapshot of your current app, then deleting, and recreating it with ruby 2 - then you can restore the snapshot
15:05:50 <Emichan> keep the app names the same though
15:05:54 <shubham> great. on which branch shall I continue?
15:06:08 <banas> shubham: pick the current code from improve-rugged
15:06:14 <banas> thats where i am pushing
15:06:16 <Emichan> banas, i'll work on getting the quickstart up to snuff - but won't have time to work on it for a few days
15:06:48 <banas> Emichan: alright, that's not top priority, since the deployments work for a start
15:07:34 <banas> from what i could gather in the FAD, we need directories, and external repo support
15:07:41 <Emichan> banas, have you had any luck getting a docker image working?
15:07:41 <banas> thats the main thing
15:07:49 <Emichan> banas, definitely
15:07:59 <shubham> I noticed now there is deployed version of gg on glittergallery.net :)
15:09:01 <banas> Emichan: ah no, that same night gnokii wanted me to play champions of regnum and i messed up my computer trying to get my graphics card to work
15:09:11 <Emichan> :(
15:09:28 <banas> so I'm on a new Fedora, and recently with a misbehaving terminal. (so im using xterm :P )
15:09:51 <banas> but I'll get it to work soon. if you find spare time, you could pick that up too :)
15:10:36 <banas> the deployment and docker images are things that would concern GG devs, I'm more focused on the user facing sides, since we really need to have people use it for us to get feedback
15:11:29 <banas> so for me, I'll look after tree-view and external hosted repos next, shubham looks after relationships and notifications. rohitpaulk, do you want to work on polishing the issues and comments bit?
15:12:09 <rohitpaulk> I've been experimenting a bit with docker recently - I might try to get fig setup for GG
15:12:34 <rohitpaulk> I'm more interested in teh Git part than issues and comments...
15:12:52 <banas> ah cool
15:13:06 <rohitpaulk> We'll pair up and work on whatever is most important :)
15:13:06 <banas> so from the FAD
15:13:28 <banas> i could understand that the concern everyone had was with
15:13:37 <banas> organizing their design assets
15:13:49 <banas> so they want to put stuff within folders
15:13:55 <banas> and more folders
15:13:59 <banas> .. and more folders
15:14:41 <banas> so we need to support a more flexible tree based viewing like github's as opposed to our current find-all-blobs on the head tree
15:15:17 <rohitpaulk> true
15:15:47 <banas> so I was currently writing this show_tree method that will be a way for us to support trees basically
15:15:57 <banas> do you want to work on ext supported public repos then?
15:16:18 <banas> baically, a form where user enters (lets say github) url and then we create a project for them
15:16:27 <banas> not too different from a form
15:16:29 <banas> *fork
15:17:59 <rohitpaulk> Yep, external sounds good to me
15:19:43 <banas> #action rohitpaulk work on external repos - form where user enters public url, and we create a project
15:20:01 <banas> what did I do wrong?
15:20:11 <banas> #ACTION rohitpaulk work on external repos - form where user enters public url, and we create a project
15:20:19 <Emichan> ?
15:20:26 <rohitpaulk> zodbot: ping
15:20:26 <zodbot> pong
15:20:47 <rohitpaulk> what is he supposed to say when you say #action?
15:20:55 <Emichan> i'm not sure he says anything
15:21:04 <banas> #undo
15:21:04 <zodbot> Removing item from minutes: ACTION by banas at 15:20:11 : rohitpaulk work on external repos - form where user enters public url, and we create a project
15:21:13 <banas> oh yeh, you're right
15:21:17 <Emichan> just adds to minutes
15:21:22 <banas> i thought there was some kind of feedback ;D
15:21:48 <banas> #action shubham ajax-ify user page
15:22:03 <banas> shubham: do you also want to take up multiple uploads?
15:22:36 <rohitpaulk> I remember someone sending us an email asking how to proceed on multiple uploads.
15:22:44 <rohitpaulk> Was that you, shubham?
15:23:13 <banas> #action banas Work on the tree-view
15:23:22 <rohitpaulk> Okay no, that was Shrey.
15:23:22 <shubham> I'll take that too. But today, I'll be away soon.
15:23:38 <banas> #action Emichan OpenShift QuickStart
15:23:47 <banas> so everyone has work :D
15:23:53 <banas> shubham: no worries :)
15:23:59 <shubham> @rohit, didnt get you
15:24:19 <shubham> Oh okay. Not my issue.
15:24:21 <rohitpaulk> shubham: never mind, my mistake
15:24:31 <Emichan> one other thing someone should take action on ( rohitpaulk ?) is SparkleShare integration
15:25:03 <Emichan> it's not entirely separate from external repo support
15:25:16 <rohitpaulk> yh that's somehting we've talked about. We arrived at the conclusion that it makes sense to support pushing/pulling first, and then do that.
15:25:42 <Emichan> pushing/pulling basically IS SS support
15:25:43 <rohitpaulk> Emichan: External repo support as discussed above only involves cloning a repository when creating a project.
15:25:55 <shubham> yh. we discussed it long time ago.
15:26:30 <Emichan> rohitpaulk, not entirely - you need to also have a mechanism to update the GG clone when the external repo is updated
15:26:36 <Emichan> and vice/versa
15:26:45 <banas> yep rohitpaulk's right. ext public repos -> some form of auth for private ext repos-> sparkleshare (am I right?)
15:27:12 <rohitpaulk> > you need to also have a mechanism to update the GG clone when the external repo is updated
15:27:16 <Emichan> it is essentially push/pull support with hooks for external/local repos
15:27:33 <rohitpaulk> Aah yes, that brings us in to complicated territory :D
15:27:51 <rohitpaulk> I just meant that cloning an external repo on creation is something that is easy to add to the current app :)
15:27:58 <Emichan> rohitpaulk, true
15:28:31 <banas> yep, we pretty much have methods for that lying around in our existin methods. ext repo isnt too different from the fork
15:28:38 <Emichan> that can be the first step of the process
15:28:46 <rohitpaulk> yep
15:28:56 <banas> lets get that working first and then we can think about the next step
15:29:06 <Emichan> banas, fine by me - one thing at a time
15:29:29 <shubham> banas: I cannot see any changes in social section on user page. Can you point out your last work.
15:29:37 <banas> but basically, even the kind of sync Emichan talks about: rugged gives us a fetch (remote/url)
15:30:01 <Emichan> the hard part will be handling merge conflicts
15:30:16 <banas> so we can start with a manual button to pull changes and then as a next step provide hools
15:30:19 <banas> hooks
15:30:22 <banas> shubham: sec
15:31:53 <banas> shubham: ah, I just realized I never pushed it
15:32:08 <banas> Ill do it now
15:32:21 <Emichan> at least at first, we can pass merge conflicts over to the user - if a conflict happens just notify the user, and make them fix it before GG can be updated
15:34:36 <banas> yeh in our case merge conflict fixes being pick one of the versions of the file
15:34:49 <banas> either yours or the one from the one sending in the request
15:35:33 <banas> shubham: i've pushed a new branch, you might have to fix some conflicts though: https://github.com/glittergallery/GlitterGallery/commits/show-followers
15:36:23 <banas> it's not a lot of work, so you can even just start off from the improve-rugged branch and add in those minor changes :)
15:37:45 <shubham> No worries. will work on show-followers branch
15:38:10 <banas> and rohitpaulk, the fork works
15:38:34 <banas> I modified the pushtobare method to push to a remote called 'bare' instead of 'origin'
15:39:10 <banas> that way you can clone from anywhere and not worry about the origin being set as the original url :)
15:39:53 <banas> what do all of you think about private forked repos?
15:39:58 <banas> say I have a private repo
15:40:02 <rohitpaulk> great
15:40:25 <banas> that looks like /sarup/project/funkyhash
15:40:30 <banas> if you fork it
15:40:56 <banas> should it be /yourname/project/funkyhash, or do you think the hash should change?
15:41:16 <banas> (note: those hashes are unique ids for only private repos)
15:41:47 <rohitpaulk> I think the urls should change.
15:42:00 <banas> mhm, what do the others think?
15:42:04 <rohitpaulk> I work at a company that has a lot of repos -
15:42:18 <rohitpaulk> It's possible that I want to clone one of those private repos, and have it remain private to myself.
15:43:23 <banas> hm, valid. i'm worried about the situation where the parent wants to keep track of it's forked repos
15:43:54 <rohitpaulk> when in doubt, copy github :P
15:44:07 <banas> lol, how do they deal with it?
15:44:16 <banas> i dont really remember..
15:44:34 <rohitpaulk> well for repos they handle it with user permissions, but for gists -
15:44:40 <rohitpaulk> They use unique urls like we do
15:45:12 <rohitpaulk> and when you fork/clone gists, they have different uniqueurls, if they are private.
15:45:22 <banas> ah, i see. we'll copy them then
15:46:15 <banas> another alternative is to allow people to set new funkyhashes in the click of a button, but let's not worry so much about it atm
15:47:40 <Emichan> banas, +1 to new hashes for private forks
15:48:31 <banas> alright, we'll do that then :)
15:49:00 <banas> rohitpaulk: I'll send in a commit about the hash, after which would you review my PR and merge it?
15:49:05 <Emichan> #agreed
15:49:19 <rohitpaulk> sure, banas
15:49:37 <rohitpaulk> does zodbot log #agreed too?
15:49:46 <Emichan> rohitpaulk, yep
15:49:53 <rohitpaulk> #agreed
15:49:54 <rohitpaulk> :)
15:52:52 <Emichan> okay, so are there any other topics for the meeting today? i think we all have assigned work :)
15:53:06 <banas> it does, but you have to set something along with it iirc
15:53:20 <banas> #agreed use unique hashes for private forks
15:54:01 <banas> shouldn't matter that much, we have a fix already :) https://github.com/glittergallery/GlitterGallery/pull/195
15:55:47 <banas> rohitpaulk: I didn't understand the last comment - aren't storing parent as integer?
15:56:13 <rohitpaulk> sorry, corrected. Should've been 'are'.
15:56:50 <banas> ah ok now that makes sense. well we can migrate the db, isn't such a big deal yet cuz we dont have a major production
15:57:02 <rohitpaulk> banas: I just added that there for people to see, I didn't want to block your PR on it
15:57:18 <rohitpaulk> We'll merge the PR in, we can clean up our schema and use the Rails sugar later :)
15:57:27 <banas> yep!
15:57:49 <banas> so I think it should be a wrap today?
15:57:55 <banas> it was an unusually long meeting :P
15:58:04 <Emichan> two hours!
15:58:16 <banas> lol, an unusual meeting in the first place :P
15:58:21 <shubham> last thing:  banas: about the issue having rugged os error
15:58:53 <shubham> I think we should add in the wiki to make a data folder in root directory
15:59:21 <shubham> It was the same error I got when it was my first time.
16:00:06 <banas> ah yeh, would you add that on the README under a local setup section?
16:00:35 <shubham> yeah sure (Y)
16:00:38 <banas> it served as a good test for which contributors would end up sending a PR for me though :P
16:00:58 <shubham> :D. true.
16:01:05 <banas> those who tried setting it up always got an error and emailed me, so i knew they tried
16:01:42 <banas> for the rest they said they set it up and they're "looking at code" when i send a follow up email :D
16:02:14 <shubham> even I did it for long time :P
16:02:51 <shubham> and then pinged rohit about not getting anything ;)
16:03:36 <shubham> Okay bye everyone. will see you later.
16:03:36 <banas> lol :D
16:03:49 <banas> alright! we should wrap up now!
16:03:52 <shubham> I am almost done with ajaxfying
16:04:05 <shubham> but not yet tested
16:04:08 <banas> awesome, PR it when you're done
16:04:29 <shubham> yeah :)
16:05:14 <banas> Emichan, rohitpaulk end meeting?
16:06:04 <Emichan> #endmeeting