rolekitweekly
LOGS
14:33:48 <sgallagh> #startmeeting rolekit (2015-11-24)
14:33:48 <zodbot> Meeting started Tue Nov 24 14:33:48 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:33:48 <zodbot> The meeting name has been set to 'rolekit_(2015-11-24)'
14:33:48 <sgallagh> #meetingname rolekitweekly
14:33:48 <zodbot> The meeting name has been set to 'rolekitweekly'
14:33:49 <sgallagh> #chair sgallagh twoerner nilsph
14:33:49 <sgallagh> #topic init process
14:33:49 <zodbot> Current chairs: nilsph sgallagh twoerner
14:33:54 <twoerner> .hello twoerner
14:33:55 <nilsph> .hello nphilipp
14:33:59 <sgallagh> .hello sgallagh
14:34:00 <zodbot> twoerner: twoerner 'Thomas Woerner' <twoerner@redhat.com>
14:34:03 <zodbot> nilsph: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
14:34:06 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
14:34:21 <sgallagh> #topic Agenda
14:34:22 <alxgrtnstrngl> .hello alxgrtnstrngl
14:34:23 <zodbot> alxgrtnstrngl: alxgrtnstrngl 'Alex GS' <alxgrtnstrngl@gmail.com>
14:34:29 <sgallagh> Welcome alxgrtnstrngl!
14:35:00 <sgallagh> #info Agenda Item: Status Update
14:35:10 <sgallagh> #info Agenda Item: Nulecule Support
14:35:14 <sgallagh> Other agenda items?
14:36:08 <sgallagh> OK, let's get started, then
14:36:14 <sgallagh> #topic Status Update
14:36:32 <sgallagh> As you've probably seen, I reworked the unit file creation process in rolekit.
14:36:46 <sgallagh> This will be vastly simpler than the old approach and won't require as much cleanup
14:37:50 <twoerner> I am sorry, but I was not able to have a look at this yet
14:38:08 <sgallagh> That's okay, nilsph has put me through a painful review process ;-)
14:38:10 <sgallagh> nilsph++
14:38:10 <zodbot> sgallagh: Karma for nphilipp changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:38:12 <nilsph> and I'm reviewing it and pestering you about petty stuff :)
14:39:01 <sgallagh> twoerner: Have you had any time for rolekit lately, or have you been on other tasks?
14:39:06 <twoerner> hmm.. only 5 reviwions? :-)
14:39:32 <twoerner> I did not have a lot of time for rolekit.. I am busy with some firewalld tasks right now
14:39:55 <sgallagh> #info sgallagh and nilsph have been going through the review process for the unit file rework
14:40:26 <sgallagh> #info twoerner has been lazy
14:40:26 <sgallagh> #undo
14:40:26 <zodbot> Removing item from minutes: INFO by sgallagh at 14:40:26 : twoerner has been lazy
14:40:26 <sgallagh> #info twoerner has been working on firewalld tasks and hasn't had time for rolekit
14:40:45 <twoerner> sgallagh: hey..
14:40:47 <twoerner> :-)
14:40:51 <sgallagh> (That was a joke ;-) )
14:41:01 <twoerner> that also..
14:41:14 <sgallagh> (Sure, but IRC doesn't translate nuance well)
14:41:33 <nilsph> "nuance" is the same word in German
14:41:34 <nilsph> <-<
14:41:34 <nilsph> >->
14:41:41 <sgallagh> alxgrtnstrngl: What have you been up to lately? If you're stuck, don't be afraid to ask for help.
14:43:14 <alxgrtnstrngl> sgallagh, yeah I've been looking into the refactor and it's in progress
14:44:20 <sgallagh> alxgrtnstrngl: OK, any problems following along?
14:44:46 <sgallagh> I'm hoping that nilsph will give it the final round of ShipIt acks today and I can merge that to the mainline
14:44:56 <nilsph> I think so
14:46:11 <alxgrtnstrngl> sgallagh, if I encounter any roadblocks I'll let you know
14:46:15 <sgallagh> OK, thanks
14:46:38 <sgallagh> nilsph: Aside from the code reviews, have you had any time for rolekit?
14:47:45 <nilsph> sgallagh: I need to get going on the "external roles" thing, but not much so far
14:47:59 <sgallagh> ok
14:48:06 <sgallagh> Let's move on, then
14:48:26 <sgallagh> #topic Nulecule Support
14:48:48 <sgallagh> #link https://github.com/libre-server/rolekit/issues/14
14:49:01 <sgallagh> So, this is going to be my highest-priority rolekit task for the next little while.
14:49:44 <sgallagh> This has, I think, the highest potential value for wider adoption of rolekit (in part because it will help alleviate our Fedora-specific nature today)
14:50:50 <sgallagh> In particular, the FreeIPA folks have asked us to consider moving the Domain Controller Role over to using their upcoming Nulecule-based deployment rather than RPM-based deployment
14:51:46 <sgallagh> So in order to do that, we will of course need to support deployment via Nulecule/atomicapp first.
14:52:14 <nilsph> that sounds... huge
14:52:16 <sgallagh> So expect to see some patches laying out that framework to appear in the next couple weeks
14:53:49 <sgallagh> I'm also going to spend at least part of today looking into the Vagrant situation.
14:54:06 <sgallagh> I know it was broken for a while, but I just pushed it aside while we got F23 out the door.
14:54:16 <sgallagh> Time to figure out how to fix it
14:54:28 <sgallagh> #action sgallagh to look into fixing the Vagrant box
14:55:03 <alxgrtnstrngl> sgallagh, project atomic is that sort of like managing packages from a git-like structure instead of RPM's?
14:55:41 <sgallagh> alxgrtnstrngl: So, atomicapp has its origins in Project Atomic, but it's not actually related to the ostree pieces.
14:56:13 <sgallagh> It's sort of a wrapper around docker and kubernetes that installs an "App" which may be one or more containers.
14:57:10 <sgallagh> This fits with our mission fairly well; we can do single-machine atomicapp deployment and then work with the Project Atomic folks to be able to do simple migration into their clusters.
14:58:21 <sgallagh> In response to nilsph: Yes, it will likely be a tremendous amount of work. Wish me luck.
14:59:51 <nilsph> sgallagh: I do, and let me know if you need assistance :)
15:00:16 <sgallagh> #info nilsph volunteers to help
15:00:22 <sgallagh> #undo
15:00:22 <zodbot> Removing item from minutes: INFO by sgallagh at 15:00:16 : nilsph volunteers to help
15:00:44 <sgallagh> #action sgallagh to work on developing a generic Nulecule deployment strategy in the next few weeks
15:00:45 <nilsph> heh, if I can help I will but I'm not too familiar (yet?) with atomic/nulecule
15:00:47 <sgallagh> #info nilsph volunteers to help
15:00:51 <sgallagh> Neither am I!
15:00:54 <nilsph> haha
15:01:08 <sgallagh> #topic Open Floor
15:01:23 <sgallagh> So, as some of you probably noticed, I broke Review Board yesterday.
15:01:32 <sgallagh> Fortunately, I also managed to fix it last night, so it's back up and running
15:01:45 <twoerner> sgallagh: that's great
15:01:48 <sgallagh> But I suppose it's worth circling around and asking what people think about it.
15:02:20 <sgallagh> Since we moved to github a while back, we also have access to Pull Requests as an alternative mechanism for tracking reviews.
15:02:33 <sgallagh> I personally dislike the PR interface for that purpose, but I'm open to discussing it
15:03:09 <twoerner> the PR interface is ok for small changes
15:03:19 <twoerner> s/changes/patches
15:03:36 <nilsph> I think meanwhile it grew the ability to comment on individual pieces of commits, too
15:03:48 <twoerner> but lacks patch review capabilites that reviewboard provides
15:03:55 <nilsph> which ones?
15:04:13 <twoerner> to easily mark lines in patches
15:04:33 <twoerner> with comments
15:05:26 <nilsph> twoerner: uhm, it lets me comment directly at lines in a commit diff
15:06:05 <twoerner> yes, but there is no accept or deny of comments there
15:06:28 <twoerner> or did I miss this?
15:07:02 <sgallagh> Right, there's no analog to the "issues" with the patch that RB has
15:07:09 <nilsph> Hmm, I need to check this but don't want to clutter up a real project with bogus comments.
15:07:12 <sgallagh> But you could reply to each comment individually
15:09:04 <twoerner> if you want to we could try with github next time...
15:09:27 <nilsph> let me try it on some bogus repo first
15:09:43 <twoerner> yes, this would be good o test..
15:09:53 <sgallagh> I'm not saying I want to. I like the RB interface, personally, but I acknowledge that using Github might be more visible to potential contributors
15:10:12 <sgallagh> So I'm soliciting your opinions. If you guys are happy with RB, we'll end the conversation :)
15:10:24 <nilsph> it's mostly the break in medium I don't like, and the occasional downtime ;)
15:10:26 <sgallagh> If you found it to be a pain to deal with, that's also useful information
15:11:31 <nilsph> RB seems to have a more "managed" workflow for reviewing patches, reviewing is the core use case. Github PRs seem more laissez-faire
15:12:21 <sgallagh> Right, review is an afterthought for Github; it's focus is on branch-management
15:12:33 <sgallagh> Which obviously RB does not even attempt to address
15:13:32 <nilsph> yeah
15:14:07 <nilsph> does RB allow to review a whole chain of commits, instead of individual ones (like we use it)?
15:14:36 <sgallagh> nilsph: Yes and no
15:14:44 <nilsph> Github PRs are "one per topic", and can encompass one or more commits.
15:14:56 <sgallagh> You can of course just squash all of the commits into a diff
15:15:00 <nilsph> (of course you can abuse that)
15:15:31 <nilsph> depending on the level of activity, I'm not sure how far reviewing single commits scales
15:15:39 <sgallagh> And support for managing patch-sets as individually-addressable, but grouped is the major effort going into Review Board 3.0
15:16:04 <nilsph> is there something like an ETA for this?
15:16:11 <sgallagh> "When it's done" ;-)
15:16:14 <nilsph> hahaha
15:16:25 <sgallagh> Upstream doesn't have a published timeline
15:16:35 <nilsph> for instance with the unit refactoring thing, having this grouped would have been handy
15:16:36 <sgallagh> But if I were to guess, I'd say early 2017
15:16:44 <twoerner> wow
15:16:57 <sgallagh> Yeah; in the short-term there are plans to add a dependency browser view at least
15:17:08 <sgallagh> So you can see all patches that are dependent upon each other, and in what order
15:17:39 <sgallagh> twoerner: Upstream is basically a two-man show, plus various intern programs like GSoC
15:17:51 <sgallagh> (And occasionally contributions from the community)
15:19:34 <sgallagh> Anyway, if we're generally okay with the Review Board experience, let's stick with that.
15:20:08 <sgallagh> And if external contributions come in via PR (like the documentation patch recently) we can deal with those as it happens
15:21:27 <sgallagh> Agreed?
15:21:41 <nilsph> we should stick to do it one way however, so point PR submitters to RB, work things there, and merge (or preferrably, rebase) when the review is done, IMO
15:23:21 <sgallagh> nilsph: Eh, in the interest of not scaring people off, I'm perfectly willing to post their changes to RB myself and link to it in the PR comments
15:23:52 <nilsph> another potential scaling problem ;)
15:24:59 <sgallagh> nilsph: I'll count that one as a good problem to have.
15:25:03 <nilsph> heh
15:25:09 <sgallagh> And I mostly meant "for their first contribution"
15:25:22 <sgallagh> Regular contributors should of course be guided towards using the right tools
15:28:15 <nilsph> I guess with more "outside" contributors, the calls to move to Github PR workflow will get louder
15:29:10 <nilsph> and I kind of understand it, RB doesn't lend itself well to "unstructured" -- just contribute a small thing, then go your own way -- and this is where GH shines
15:29:34 <nilsph> of course, this comes with less structure than RB
15:30:14 <nilsph> but as for now, we can just wait and see I guess
15:30:58 <twoerner> +1
15:31:51 <sgallagh> Fair enough
15:31:54 <nilsph> twoerner: btw, yes, github PRs let you only comment on (single) lines, and have no notion of an "issue" there
15:32:09 <sgallagh> #agreed Stick with Review Board for now, re-evaluate in the future if we start seeing a lot of new contributors
15:32:27 <nilsph> I just tried it out, using my first github organization and it only lived for 10 minutes, sniff.
15:34:13 <sgallagh> hahaha
15:35:21 <twoerner> lol
15:35:36 <twoerner> try reanimation.. :-)
15:35:37 <sgallagh> OK, anything else for Open Floor?
15:36:15 <nilsph> twoerner: it's dead, I tell you
15:36:19 <nilsph> not from me
15:37:41 <twoerner> nothing we should discuss in here.
15:38:32 <sgallagh> OK, thanks
15:38:36 <sgallagh> #endmeeting