f18final-blocker-review-1.2
MINUTES

#fedora-qa: f18final-blocker-review-1.2

Meeting started by tflink at 17:25:11 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 17:25:12)
  2. Introduction (tflink, 17:33:07)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 17:33:17)
    2. We'll be following the process outlined at: (tflink, 17:33:23)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 17:33:23)
    4. The bugs up for review today are available at: (tflink, 17:33:28)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 17:33:28)
    6. The criteria for release blocking bugs can be found at: (tflink, 17:33:34)
    7. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 17:33:34)
    8. https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria (tflink, 17:33:35)
    9. https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (tflink, 17:33:35)
    10. The current blocker/nth list consists of: (tflink, 17:33:54)
    11. 44 Proposed Blockers (tflink, 17:33:57)
    12. 10 Accepted Blockers (tflink, 17:33:57)
    13. 21 Proposed NTH (tflink, 17:33:58)
    14. 3 Accepted NTH (tflink, 17:33:58)

  3. (882147) SystemError: (32, 'umount: /run/install/isodir: target is busy. (In some cases useful info about processes that use the device is found by lsof(8) or fuser(1))') (tflink, 17:36:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=882147 (tflink, 17:36:13)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:36:15)
    3. AGREED: 882147 - RejectedBlocker, AcceptedNTH - While this is an obviously invalid operation that probably should be rejected, it isn't catastropic and is a bit too much of a corner case to block release over (tflink, 17:42:18)

  4. (545148) livecd boot from iscsi storage (tflink, 17:42:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=545148 (tflink, 17:42:27)
    2. Proposed Blocker, dracut, NEW (tflink, 17:42:27)
    3. AGREED: 545148 - RejectedBlocker - This doesn't hit any of the F18 release criteria and thus is rejected as a blocker for F18 final. (tflink, 17:51:37)

  5. (874553) rd.debug boot option doesn't log to /run/initramfs/init.log (tflink, 17:51:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=874553 (tflink, 17:51:46)
    2. Proposed Blocker, dracut, ASSIGNED (tflink, 17:51:46)
    3. AGREED: 874553 - RejectedBlocker - While this is a hinderance to debugging installed systems and images, it doesn't clearly hit any of the F18 release criteria and is thus rejected as a blocker for F18 final. (tflink, 17:56:58)

  6. (873817) inkscape packaging bugs prevent install (tflink, 17:57:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=873817 (tflink, 17:57:08)
    2. Proposed Blocker, inkscape, ASSIGNED (tflink, 17:57:08)
    3. AGREED: - In spirit, we are OK with modifying the alpha release criterion "There must be no file conflicts or unresolved package dependencies during a media-based (DVD) install" to include more generic packaging errors. The details and final voting will happen on test@ (tflink, 18:04:08)
    4. AGREED: 873817 - AcceptedBlocker - This violates the modified release criteria mentioned above and is thus accepted as a blocker assuming that the proposed changes go through. Will be rejected if the changed aren't accepted by test@ (tflink, 18:06:33)

  7. (873207) No entry in grub2 menu for windows8 in dual boot setup install TC7 (tflink, 18:06:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=873207 (tflink, 18:06:48)
    2. Proposed Blocker, os-prober, NEW (tflink, 18:06:51)
    3. AGREED: 873207 - RejectedBlocker - The dual-boot with windows criterion was written for BIOS systems and the UEFI/win8 case is different. If it turns out that the BIOS case is affected, please file a new bug and propose it as a blocker (tflink, 18:22:05)

  8. (867770) anaconda GUI becomes unresponsive (tflink, 18:22:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=867770 (tflink, 18:22:18)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 18:22:19)
    3. AGREED: 867770 - AcceptedBlocker - Violates the following F18 final release criteria (in spirit) if a user re-enters the storage spoke after reclaiming space: "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (tflink, 18:31:32)

  9. (879030) pungi strips langpacks metadata from comps, breaks langpacks installation for DVD (tflink, 18:31:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=879030 (tflink, 18:31:49)
    2. Proposed Blocker, yum, NEW (tflink, 18:31:51)
    3. AGREED: 879030 - AcceptedBlocker - Violates the following F18 final release criteria for DVD installs and can't be fixed with an update post-isntall without reinstalling packages: "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use" (tflink, 18:38:34)

  10. (860525) dracut-pre-pivot[272]: mount: wrong fs type, bad option, bad superblock on /var/lib/nfs/rpc_pipefs, (tflink, 18:38:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=860525 (tflink, 18:38:48)
    2. Proposed Blocker, dracut, NEW (tflink, 18:38:50)
    3. AGREED: 860525 - We still don't understand exactly how this is a release-blocking issue or which criteria it impacts. Ask for more info and revisit later (tflink, 18:43:51)

  11. (861219) Switching to discret GPU render system unusable (tflink, 18:44:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=861219 (tflink, 18:44:02)
    2. Proposed Blocker, xorg-x11-drv-nouveau, NEW (tflink, 18:44:02)
    3. AGREED: 861219 - RejectedBlocker - This doesn't hit any of the F18 release criteria as it doesn't impede basic operation. Thus, is rejected as a blocker for F18 final (tflink, 18:45:38)

  12. (873144) pressing Esc kills plymouth screen (tflink, 18:45:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=873144 (tflink, 18:45:48)
    2. Proposed Blocker, plymouth, NEW (tflink, 18:45:48)
    3. there are several bugs related to this issue and the story isn't 100% clear. it needs to be cleaned up and discussed later (tflink, 18:54:11)
    4. ACTION: tflink to clean up fedup upgrade status bugs and propose one as a blocker for F18 final (tflink, 18:55:39)
    5. we agree in principle that some status indication is needed during upgrade before F18 final is released. however, we don't want to accept anything as release blocking without being more specific on what the solution we're expecting is (tflink, 18:56:21)
    6. AGREED: 873144 - The situation here isn't 100% clear and needs to be cleaned up before farther discussion. Will re-visit when the upgrade status issue has been cleaned up (tflink, 18:57:26)

  13. (881670) Provide fedup hook to add x-systemd.device-timeout=0 to mount options for encrypted file systems that need a passphrase from the user (tflink, 18:57:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=881670 (tflink, 18:57:43)
    2. Proposed Blocker, systemd, NEW (tflink, 18:57:45)
    3. AGREED: 881670 - We need more information on potential solutions to this class of propblems before deciding on blocker status, will re-visit later (tflink, 19:23:56)

  14. (868558) anaconda needs to tell yum what's a URL and what's a mirrorlist (tflink, 19:24:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=868558 (tflink, 19:24:16)
    2. Proposed Blocker, anaconda, ASSIGNED (tflink, 19:24:18)
    3. AGREED: 868558 - AcceptedBlocker - Violates the following F18 final release criterion for mirror lists: "The installer must be able to use all supported local and remote package source options" (tflink, 19:37:39)

  15. (876223) NFSISO installation doesn't use internally mounted DVD repo, instead uses Closest Mirror (tflink, 19:39:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=876223 (tflink, 19:39:31)
    2. Proposed Blocker, anaconda, ON_QA (tflink, 19:39:34)
    3. AGREED: 876223 - AcceptedBlocker - Violates the following F18 final release criterion for NFSISO: "The installer must be able to use all supported local and remote package source options" (tflink, 19:46:58)

  16. (877623) fedup does not seem to verify the update source (tflink, 19:48:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=877623 (tflink, 19:48:33)
    2. Proposed Blocker, fedup, NEW (tflink, 19:48:33)

  17. (872088) fedup giving grubby backtrace (tflink, 19:57:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=872088 (tflink, 19:57:38)
    2. Proposed Blocker, fedup, ASSIGNED (tflink, 19:57:38)
    3. AGREED: 872088 - This needs more triage into why and in what situations the TB is occuring before deciding on blocker status. Will revisit later. (tflink, 20:01:21)

  18. Open Floor (tflink, 20:03:19)
    1. the next blocker review meeting will be 2012-12-05 @ 17:00 UTC (tflink, 20:06:32)
    2. https://fedoraproject.org/en/get-prerelease now links here, so we get more visitors (kparal, 20:09:36)
    3. we will be moving the blocker meetings back to #fedora-bugzappers for now - holding it in #fedora-qa is too disruptive (tflink, 20:13:46)


Meeting ended at 20:14:26 UTC (full logs).

Action items

  1. tflink to clean up fedup upgrade status bugs and propose one as a blocker for F18 final


Action items, by person

  1. tflink
    1. tflink to clean up fedup upgrade status bugs and propose one as a blocker for F18 final


People present (lines said)

  1. tflink (271)
  2. adamw (171)
  3. kparal (164)
  4. Viking-Ice (81)
  5. jreznik (58)
  6. mel- (10)
  7. jskladan_ (9)
  8. barry_scott (7)
  9. zodbot (7)
  10. pschindl (7)
  11. mkrizek (4)
  12. akshayvyas (4)
  13. nirik (2)
  14. satellit (2)
  15. txenoo (1)
  16. dgilmore (1)


Generated by MeetBot 0.1.4.