f18beta-blocker-review-6
MINUTES

#fedora-qa: f18beta-blocker-review-6

Meeting started by tflink at 16:00:39 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 16:00:44)
  2. Introduction (tflink, 16:04:57)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 16:05:04)
    2. We'll be following the process outlined at: (tflink, 16:05:12)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 16:05:12)
    4. The bugs up for review today are available at: (tflink, 16:05:19)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 16:05:19)
    6. The criteria for release blocking bugs can be found at: (tflink, 16:05:25)
    7. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 16:05:25)
    8. https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria (tflink, 16:05:25)
    9. https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (tflink, 16:05:25)
    10. Up for review today are: (tflink, 16:05:40)
    11. 8 Proposed Blockers (tflink, 16:05:43)
    12. 4 Accepted Blockers (tflink, 16:05:44)
    13. 19 Proposed NTH (tflink, 16:05:44)
    14. 17 Accepted NTH (tflink, 16:05:44)

  3. (868558) anaconda needs to tell yum what's a URL and what's a mirrorlist (tflink, 16:07:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=868558 (tflink, 16:07:30)
    2. Proposed Blocker, anaconda, ASSIGNED (tflink, 16:07:32)
    3. AGREED: 868558 - RejectedBlocker (beta) - The original report seems like a one-time mirror issue and thus this bug was deemed to be not a blocker. The mirrorlist issue seems to be different but more of a final blocker - ask devs whether the issues should be split or not (tflink, 16:26:51)

  4. (867593) installer must stop relying on being able to tell kpartx to use a disk/partition delimiter (tflink, 16:26:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=867593 (tflink, 16:26:58)
    2. Proposed Blocker, anaconda, ASSIGNED (tflink, 16:27:00)
    3. AGREED: 867593 - AcceptedBlocker - Violates the following F18 beta release criterion for dmraid : "The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot" (tflink, 16:30:27)

  5. (868535) AttributeError: 'NoneType' object has no attribute 'get' (tflink, 16:30:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=868535 (tflink, 16:30:34)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 16:30:36)
    3. AGREED: 868535 - AcceptedNTH - While not a clear blocker, crashing when trying to configure network after initial wireless setup is bad and this can't be fixed after release with an update. A tested fix would be accepted past freeze (tflink, 16:46:13)

  6. (871129) Network is considered 'up' even if DHCP fails (tflink, 16:46:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871129 (tflink, 16:46:45)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 16:46:45)
    3. AGREED: 871129 - RejectedBlocker, AcceptedNTH - This doesn't prevent configuration of static networking but this shouldn't happen for non-dhcp setups. A well tested fix would be accepted after freeze. (tflink, 16:52:01)

  7. (870208) Logoff does not close session so if Restart or Shutdown performed from Logon screen after logoff Authentication dialog presented (tflink, 16:52:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=870208 (tflink, 16:52:08)
    2. Proposed Blocker, gnome-desktop3, NEW (tflink, 16:52:11)
    3. AGREED: 870208 - RejectedBlocker, RejectedNTH - This doesn't violate any of the F18 beta release criteria and could easily be fixed with an update. Thus this bug is rejected as a blocker or NTH for F18 beta (tflink, 16:55:51)

  8. (844167) Error in PREIN scriptlet in rpm package libvirt-daemon-0.9.11.4-3.fc17.x86_64 (tflink, 16:55:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=844167 (tflink, 16:55:58)
    2. Proposed Blocker, selinux-policy, MODIFIED (tflink, 16:56:01)
    3. ACTION: tflink to test fedup upgrade from 17 to 18 with libvirt installed on F17 (tflink, 17:01:32)
    4. AGREED: 844167 - We're still not sure if this affects fedup, will re-evaluate after more testing has been done (tflink, 17:02:12)

  9. (869061) No output to journal after double-switch-root (tflink, 17:02:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869061 (tflink, 17:02:26)
    2. Proposed Blocker, systemd, NEW (tflink, 17:02:26)
    3. AGREED: 869061 - We still need more information on whether or not this actually needs to be fixed in the frozen package set and what the exact issue is. (tflink, 17:09:19)

  10. (871161) Fedora Upgrade Tool for F18 (fedup) requires systemd-195 (tflink, 17:12:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871161 (tflink, 17:12:08)
    2. Proposed Blocker, systemd, NEW (tflink, 17:12:08)
    3. AGREED: 871161 - AcceptedNTH - We recognize that this is likely required for upgrades but there are too many unanswered questions to take this as a blocker. However, testing of this update needs to start sooner than later and it is accepted as NTH for F18 beta. A tested fix would be taken past freeze. (tflink, 17:23:17)

  11. (855646) custom partition setup: missing volume/device identification (tflink, 17:25:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=855646 (tflink, 17:25:27)
    2. Proposed NTH, anaconda, NEW (tflink, 17:25:27)
    3. AGREED: 855646 - AcceptedNTH - This alleviates some issues with custom partitioning and determining what can be deleted and what can't. Since this can't be fixed with an update, a tested fix would be taken past freeze. (tflink, 17:28:38)

  12. (869185) Crash when reclaiming space on disks with incomplete LVM (tflink, 17:28:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869185 (tflink, 17:28:50)
    2. Proposed NTH, anaconda, NEW (tflink, 17:28:50)
    3. AGREED: 869185 - AcceptedBlocker (final), AcceptedNTH (beta) - Crashes in the installer are bad and can't be fixed with an update. A tested fix would be considered past freeze. Accepted as blocker for F18 final as it violates the F18 final criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, ..." (tflink, 17:45:13)

  13. (868509) LUKS passphrase exposed in storage.log attached to bug report (tflink, 17:45:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=868509 (tflink, 17:45:26)
    2. Proposed NTH, anaconda, MODIFIED (tflink, 17:45:26)
    3. AGREED: 868509 - AcceptedNTH - plaintext LUKS passwords in the storage log are a security issue and this can't be fixed with an update. A well tested fix would be considered past beta freeze (tflink, 17:50:13)

  14. (866717) f18 anaconda cannot use the selected disk (continue button remains grayed out and the disks does 'not count' for anaconda) (reproduced) (tflink, 17:50:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866717 (tflink, 17:50:27)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 17:50:29)
    3. AGREED: 866717 - AcceptedNTH - While not a blocker, being able to select additional disks is somewhat expected. A tested fix would be considered past freeze. (tflink, 17:53:47)

  15. (868468) anaconda displays previously installed Fedora systems as Unknown in Manual Partitioning (tflink, 17:54:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=868468 (tflink, 17:54:06)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 17:54:09)
    3. AGREED: 868468 - RejectedNTH - While unfortunate, this appears to only affect systems with pre-existing btrfs subvols. It was deemed uncommon enough not to justify NTH status for F18 beta, especially since btrfs partitioning was not possible through anaconda for F17. (tflink, 18:06:34)

  16. (870569) Custom partitioning should allow the user to specify which disk a partition should wind up on (tflink, 18:09:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=870569 (tflink, 18:09:03)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 18:09:05)
    3. AGREED: 870569 - AcceptedNTH - While not a blocker for F18 beta, this functionality is important for final and would be good to start testing now. A tested fix would be considered past freeze. (tflink, 18:11:56)

  17. (871104) Installer allows use of preexisting root filesystem (tflink, 18:12:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871104 (tflink, 18:12:14)
    2. Proposed NTH, anaconda, NEW (tflink, 18:12:14)
    3. https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-October/001824.html is the patch i believe (adamw, 18:19:15)
    4. AGREED: 871104 - AcceptedNTH - Reusing / without reformatting is a bad idea and hasn't been allowed in anaconda for a while. A tested fix would be considered past freeze. (tflink, 18:21:35)

  18. (871109) Confusing text in label for checkbutton to use custom partitioning (tflink, 18:21:52)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871109 (tflink, 18:21:55)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 18:21:58)
    3. AGREED: 871109 - AcceptedNTH - This is a minor change to a dialog to increase the accuracy of the message. A tested fix would be considered past freeze if the translation freeze break is approved. (tflink, 18:27:59)

  19. (869675) RFE: Anaconda should warn user when disabling root account in certain situations (tflink, 18:28:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869675 (tflink, 18:28:17)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 18:28:19)
    3. AGREED: 869675 - AcceptedNTH - While not a blocker, allowing people to install with no available users is a bad idea and if this changes, it needs to be changed now. A tested fix would be considered past freeze. (tflink, 18:45:34)

  20. (869978) %packages --default doesn't install default system, but minimal one (tflink, 18:45:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869978 (tflink, 18:45:47)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 18:45:49)
    3. AGREED: 869978 - AcceptedNTH - This is a regression in the behavior of previous versions and would be good to fix. A tested fix would be considered past freeze. (tflink, 18:53:50)

  21. (870570) Anaconda needs to retry downloading the repo medata on a network config change (tflink, 18:59:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=870570 (tflink, 18:59:04)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 18:59:07)
    3. AGREED: 870570 - AcceptedNTH - This makes networking configuration changes during install configuration easier and more obvious, would be useful and can't be fixed with an update. A tested fix would be considered past freeze but we request an updates.img to test before the patch is pushed. (tflink, 19:04:51)

  22. (871554) NFSISO installs fail to reboot: SystemError: (16, 'umount.nfs: /run/install/isodir: device is busy') (tflink, 19:05:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871554 (tflink, 19:05:03)
    2. Proposed NTH, anaconda, ASSIGNED (tflink, 19:05:05)
    3. AGREED: 871554 - AcceptedNTH - While NFSISO isn't required for beta, having it testable in beta would be helpful for final. A tested fix would be considered past freeze. (tflink, 19:17:18)

  23. (871648) Cannot use nfsiso repo through graphical source picker (tflink, 19:22:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871648 (tflink, 19:22:41)
    2. Proposed NTH, anaconda, POST (tflink, 19:22:41)
    3. https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-October/001845.html for anyone interested (adamw, 19:28:28)
    4. AGREED: 871648 - AcceptedNTH - While NFSISO isn't required for beta, having it testable in beta would be helpful for final. A tested fix would be considered past freeze. (tflink, 19:29:59)

  24. (869106) F18 anaconda chokes on wireless network names containing spaces (tflink, 19:30:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=869106 (tflink, 19:30:09)
    2. Proposed NTH, anaconda, MODIFIED (tflink, 19:30:12)
    3. AGREED: 869106 - AcceptedNTH - While not incredibly common, there are wireless APs whose names contain spaces. Not enough to block release over but fixing prior to beta release would be preferred. A tested fix would be considered past freeze. (tflink, 19:33:53)

  25. (871132) Protected wifi connection not enabled after secrets are set, user has to re-select it (tflink, 19:34:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871132 (tflink, 19:34:14)
    2. Proposed NTH, anaconda, NEW (tflink, 19:34:16)
    3. AGREED: 871132 - AcceptedNTH - While not a big enough problem to block release, it is an annoyance and can't be fixed with an update. A tested fix would be considered past freeze. (tflink, 19:40:15)

  26. (870781) keyboard shortcuts patch got lost during Xfce 4.10 update (tflink, 19:43:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=870781 (tflink, 19:43:26)
    2. Proposed NTH, libxfce4ui, ON_QA (tflink, 19:43:26)
    3. AGREED: 870781 - AcceptedNTH - This fixes a functionality regression in XFCE when compared to previous versions of Fedora. A tested fix would be considered after freeze. (tflink, 19:48:25)

  27. (856194) firstboot has to insist the first user is admin when root account is locked (tflink, 19:48:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856194 (tflink, 19:48:32)
    2. Proposed NTH, firstboot, ON_QA (tflink, 19:48:34)
    3. AGREED: 856194 - AcceptedNTH - Allowing for an install with no admin or root users is not desirable and should probably be fixed. A tested fix would be considered past freeze. (tflink, 19:50:10)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=871888 seems to have been added to the propsoed blocker list (adamw, 19:51:42)

  28. (871888) AttributeError: 'YumPayload' object has no attribute '_yum' (tflink, 19:54:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=871888 (tflink, 19:54:17)
    2. ProposedBlocker, anaconda, NEW (tflink, 19:54:18)
    3. AGREED: 871888 - RejectedBlocker - While severe, this doesn't seem to be happening often enough to justify blocking F18 beta. Please repropose if this starts happening more often. (tflink, 19:56:32)

  29. Open Floor (tflink, 19:56:55)
    1. the blocker review will continue tomorrow: 2012-11-01 @ 16:00 UTC (tflink, 19:59:04)


Meeting ended at 20:01:12 UTC (full logs).

Action items

  1. tflink to test fedup upgrade from 17 to 18 with libvirt installed on F17


Action items, by person

  1. tflink
    1. tflink to test fedup upgrade from 17 to 18 with libvirt installed on F17


People present (lines said)

  1. tflink (392)
  2. adamw (364)
  3. jlk (118)
  4. Viking-Ice (116)
  5. kparal (102)
  6. nirik (24)
  7. jreznik (22)
  8. jskladan (18)
  9. akshayvyas (17)
  10. zodbot (9)
  11. dlehman (8)
  12. nanonyme (8)
  13. Martix (2)
  14. nonamedotc (2)
  15. satellit (2)
  16. Martix1 (1)
  17. satellit- (1)


Generated by MeetBot 0.1.4.