f18beta-blocker-review-4
MINUTES

#fedora-qa: f18beta-blocker-review-4

Meeting started by tflink at 16:00:26 UTC (full logs).

Meeting summary

  1. Roll Call (tflink, 16:00:31)
  2. Introduction (tflink, 16:12:47)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (tflink, 16:12:57)
    2. We'll be following the process outlined at: (tflink, 16:13:04)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (tflink, 16:13:04)
    4. The bugs up for review today are available at: (tflink, 16:13:10)
    5. http://qa.fedoraproject.org/blockerbugs/current (tflink, 16:13:10)
    6. The criteria for release blocking bugs can be found at: (tflink, 16:13:15)
    7. https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria (tflink, 16:13:16)
    8. https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria (tflink, 16:13:16)
    9. https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria (tflink, 16:13:16)
    10. Up for review today we have: (tflink, 16:13:36)
    11. 15 Proposed Blockers (tflink, 16:13:39)
    12. 23 Accepted Blockers (tflink, 16:13:39)
    13. 1 Proposed NTH (tflink, 16:13:39)
    14. 9 Accepted NTH (tflink, 16:13:39)

  3. (862784) error: rpmdb open failed (tflink, 16:14:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=862784 (tflink, 16:14:57)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:14:57)
    3. AGREED: 862784 - We're still waiting on criteria changes in order to make a decision, will re-visit once the criteria changes have gone through (tflink, 16:36:48)

  4. (865776) kernel pair boot with inst.repo=nfs: hangs on reboot (tflink, 16:36:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=865776 (tflink, 16:36:57)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:36:57)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=824191 is the f17 bug (adamw, 16:45:23)
    4. AGREED: 865776 - RejectedBlocker (beta) - This doesn't clearly violate any of the F18 beta release criteria, would affect a minority of users and results in a working system after forcing reboot. Please re-propose if something changes or has been misunderstood. (tflink, 16:52:05)

  5. (866519) BIOS RAID is not shown on harddrive screen (tflink, 16:52:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866519 (tflink, 16:52:15)
    2. Proposed Blocker, anaconda, NEW (tflink, 16:52:15)
    3. AGREED: 866519 - We need more information on the types of configurations affected before deciding on blocker status. Another reporter would be preferred (tflink, 17:03:26)

  6. (866730) invalid locales configured for some languages (tflink, 17:03:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866730 (tflink, 17:03:36)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:03:36)
    3. AGREED: 866730 - RejectedBlocker (beta), AcceptedNTH - This is a conditional criteria violation for a limited number of languages but was deemed to be not enough languages to block for beta. However, a well-tested fix would be considered past freeze (tflink, 17:07:42)

  7. (867071) NameError: global name 'anaconda' is not defined (tflink, 17:07:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=867071 (tflink, 17:07:50)
    2. Proposed Blocker, anaconda, VERIFIED (tflink, 17:07:51)
    3. AGREED: 867071 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data" (tflink, 17:15:00)

  8. (865073) DependencyError: [u'1:totem-nautilus-3.6.0-1.fc18.x86_64 requires totem = 1:3.6.0-1.fc18'] (tflink, 17:15:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=865073 (tflink, 17:15:15)
    2. Proposed Blocker, anaconda, NEW (tflink, 17:15:17)
    3. AGREED: 865073 - RejectedBlocker - This only happens when there are dependency issues in the DVD or repos used for install. As such, specific issues would be caught elsewhere and this doesn't need to be a blocker for F18 beta (tflink, 17:23:03)

  9. (866101) redundancy selection for btrfs device results in raid0, not raid1 (tflink, 17:23:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866101 (tflink, 17:23:12)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 17:23:15)
    3. AGREED: 866101 - RejectedBlocker, AcceptedNTH - While not specifically stated, software raid as written in the criteria implies mdraid, not btrfs and thus, this isn't a blocker. However, a well tested fix would be considered past freeze. (tflink, 17:34:18)

  10. (867296) NameError: global name 'gtk_call_once' is not defined (tflink, 17:36:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=867296 (tflink, 17:36:56)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 17:36:56)
    3. http://dl.fedoraproject.org/pub/alt/qa/18/ (tflink, 17:40:33)
    4. AGREED: 867296 - There is nowhere near enough information in this bug to figure out what happened, much less whether it's a blocker. Will re-visit when there is more information available (tflink, 17:43:50)

  11. (856362) KeyError: 'la-latin1' (tflink, 17:44:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=856362 (tflink, 17:44:04)
    2. Proposed Blocker, anaconda, MODIFIED (tflink, 17:44:04)
    3. AGREED: 856362 - Since we still don't have an upgrade tool to test, there is no way to test whether this bug violates the F18 upgrade criterion. Will revisit once there is an upgrade tool to test (tflink, 17:48:40)

  12. (864981) BootLoaderError: bootloader install failed (tflink, 17:49:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864981 (tflink, 17:49:00)
    2. Proposed Blocker, grub2, NEW (tflink, 17:49:00)
    3. AGREED: 864981 - RejectedBlocker - With the currently available information, this does not clearly hit any release criteria and seems to be an issue with a strange disk layout. If this turns out to be more common or more information becomes available, please re-propose as a blocker. (tflink, 17:56:06)

  13. (865009) GString mem alloc crashes after dbus op (tflink, 17:56:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=865009 (tflink, 17:56:13)
    2. Proposed Blocker, NetworkManager, ON_QA (tflink, 17:56:13)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=866434 (tflink, 17:58:37)
    4. AGREED: 865009 - RejectedBlocker, AcceptedNTH - While this is a valid install issue, the available information makes it seem like not enough installs would be affected to justify blocking beta release. (tflink, 18:04:03)

  14. (866441) TypeError: 'NoneType' object is not iterable (tflink, 18:06:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866441 (tflink, 18:06:05)
    2. Proposed Blocker, python-meh, POST (tflink, 18:06:05)
    3. AGREED: 866441 - RejectedBlocker (beta), AcceptedNTH - While this is a conditional violation of the following F18 alpha criterion, it wasn't deemed common enough to justify blocking beta for it but a tested fix would be considered past freeze for F18 beta. "The installer must be able to report failures to Bugzilla and local disk, with appropriate information included" (tflink, 18:15:20)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=864204 (tflink, 18:16:52)
    5. Proposed Blocker, yum, NEW (tflink, 18:16:55)
    6. AGREED: 866441 - RejectedBlocker - As there is still no clear cause or reproducer for this and there have been no additional reports, this is rejected as a blocker for F18 beta. If it turns out to be more common or sever than currently understood, please repropose as a blocker with details on how to reproduce. (tflink, 18:24:49)

  15. (863348) ValueError: Cannot remove non-leaf device 'vda2' (tflink, 18:29:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=863348 (tflink, 18:29:29)
    2. Accepted Blocker, anaconda, POST (tflink, 18:29:29)
    3. the patch for this bug still needs review (tflink, 18:34:05)
    4. anaconda team is aware of the patch, is working on it (tflink, 18:34:34)

  16. (864360) gpt isn't automatically created on UEFI system (tflink, 18:34:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864360 (tflink, 18:34:47)
    2. Accepted Blocker, anaconda, ASSIGNED (tflink, 18:34:47)
    3. no movement on this bug since last week (tflink, 18:35:27)
    4. will poke devs on status of fix (tflink, 18:36:39)

  17. (866115) ValueError: ('invalid size specification', '0 b') (tflink, 18:36:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=866115 (tflink, 18:36:49)
    2. Accepted Blocker, anaconda, POST (tflink, 18:36:49)
    3. the update from c#22 is reported to fix this, still waiting patch review (tflink, 18:37:45)
    4. will poke devs in bug (tflink, 18:38:08)

  18. (862613) ValueError: cannot initialize a disk that has partitions (tflink, 18:38:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=862613 (tflink, 18:38:19)
    2. Accepted Blocker, anaconda, NEW (tflink, 18:38:19)
    3. this might be the same as 866895, another bug is preventing reporter from re-testing (tflink, 18:39:27)
    4. reporter will retest with TC5 (tflink, 18:40:18)

  19. (864120) LUKS encryption option has no effect (tflink, 18:40:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864120 (tflink, 18:40:30)
    2. Accepted Blocker, anaconda, MODIFIED (tflink, 18:40:30)
    3. it appears as if the original issue has been fixed and another issue has been added on to it (tflink, 18:42:40)
    4. move bug to CLOSED and ask new reporter to file another bug with the new issue (tflink, 18:43:12)

  20. (864771) KeyError: PartitionDevice instance (0x7f0f28b016d0) (tflink, 18:44:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864771 (tflink, 18:44:20)
    2. Accepted Blocker, anaconda, MODIFIED (tflink, 18:44:20)
    3. a fix for this bug is available but needs testing before it is moved to VERIFIED (tflink, 18:45:12)

  21. (863451) AttributeError: 'DeviceFormat' object has no attribute 'peStart' (tflink, 18:45:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=863451 (tflink, 18:45:24)
    2. Accepted Blocker, anaconda, NEW (tflink, 18:45:27)
    3. no movement on this bug in the last week (tflink, 18:46:15)
    4. will poke devs in bug for status update (tflink, 18:46:30)

  22. (855526) f18a tc6 anaconda cannot connect to a protected wireless network (tflink, 18:47:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=855526 (tflink, 18:47:11)
    2. Accepted Blocker, anaconda, MODIFIED (tflink, 18:47:14)
    3. a fix is available for this bug (tflink, 18:47:51)
    4. needs testing before it is moved to VERIFIED (tflink, 18:48:02)

  23. (853877) anaconda ignores keyboard settings (tflink, 18:49:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=853877 (tflink, 18:49:09)
    2. Accepted Blocker, anaconda, MODIFIED (tflink, 18:49:09)
    3. this was moved to MODIFIED on 2012-10-12 but no fixed_in_version was set (tflink, 18:51:34)
    4. clarify with devs on whether the fix has been pushed and if there is a build available to test (tflink, 18:52:06)

  24. (864765) mkfs.btrfs SIGABRT at OS install time (tflink, 18:52:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864765 (tflink, 18:52:19)
    2. Accepted Blocker, btrfs-progs, NEW (tflink, 18:52:19)
    3. a new build of btrfs-progs is available for testing (tflink, 18:53:17)
    4. ACTION: tflink to pull in the brtfs-progs scratch build into the next smoketest iso (tflink, 18:53:52)

  25. (864058) anaconda main menu not visible in F18 Beta TC2 KDE Live (tflink, 18:54:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=864058 (tflink, 18:54:09)
    2. Accepted Blocker, gtk3, NEW (tflink, 18:54:09)
    3. a fix is available, needs testing with KDE livecd (tflink, 18:55:16)

  26. Open Floor (tflink, 18:58:35)
    1. The next F18 beta blocker review will be 2012-10-24 @ 16:00 UTC (tflink, 19:00:17)


Meeting ended at 19:01:35 UTC (full logs).

Action items

  1. tflink to pull in the brtfs-progs scratch build into the next smoketest iso


Action items, by person

  1. tflink
    1. tflink to pull in the brtfs-progs scratch build into the next smoketest iso


People present (lines said)

  1. tflink (346)
  2. adamw (190)
  3. cmurf (150)
  4. dan408- (121)
  5. Viking-Ice (27)
  6. jreznik (19)
  7. zodbot (17)
  8. akshayvyas (14)
  9. nirik (7)
  10. zeenix (6)
  11. vhumpa (3)
  12. satellit_e (3)
  13. jreznik_ (1)
  14. jlk (1)


Generated by MeetBot 0.1.4.