fedora_insight
LOGS
18:00:51 <stickster> #startmeeting Fedora Insight
18:00:51 <zodbot> Meeting started Thu May 27 18:00:51 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:55 <stickster> #meetingname Fedora Insight
18:00:55 <zodbot> The meeting name has been set to 'fedora_insight'
18:01:13 <stickster> #chair rbergeron gwerra smooge
18:01:13 <zodbot> Current chairs: gwerra rbergeron smooge stickster
18:01:19 <stickster> #topic Roll call!
18:01:20 * stickster 
18:01:28 * gwerra is kinda around
18:02:35 * stickster waits around for rbergeron or smooge
18:02:48 * gbraad keeps an eye on the meeting
18:05:13 <stickster> OK then
18:05:46 <stickster> #topic Action item review
18:06:30 <stickster> #info Still waiting for smooge to determine if we have a Zikula 1.2.3 package ready from ke4qqq
18:07:15 <stickster> #info Mateo has sync'd changes from pt6 to fedora-zikula repo
18:07:51 <stickster> #info (one additional problem seen, stickster sent patch in http://lists.fedoraproject.org/pipermail/logistics/2010-May/000571.html)
18:08:00 <smooge> oh sorry
18:08:14 <smooge> was taking lunch with wife
18:08:19 <stickster> smooge: np
18:08:38 <stickster> #info rbergeron took care of forwarding Drak's email on security fixes
18:08:54 <smooge> I have not had progress time with Zikula. I got pulled into a bright shiney drupal and django CMS
18:09:42 <stickster> I'll #topic us forward
18:09:59 <stickster> #topic status of repos
18:10:17 <stickster> #info mateo sent in some patches to the hosted repo for fedora-zikula.
18:10:22 <rbergeron> oh
18:10:26 <stickster> I found another problem and sent a patch to the list.
18:10:27 <rbergeron> hi sorry. :)
18:10:31 <stickster> np rbergeron
18:11:21 <stickster> smooge: Do you know if any new zikula-fedora* packages were deployed on pt6?
18:11:36 <smooge> one sec
18:11:48 * stickster sees last zikula module deployment is April 20
18:11:53 <stickster> I guess not
18:12:10 <stickster> zikula-module-fedora-fasauth-0.3-1.el5        Tue 20 Apr 2010 09:27:03 PM UTC
18:12:24 <stickster> #info need new rollout of zikula-module-fedora-fasauth module
18:13:49 <stickster> #action stickster to deploy other fix directly on Zikula, patch is already at list
18:14:00 <stickster> rbergeron: Once I do that, you should be able to do effective testing
18:14:12 <rbergeron> excellent. :)
18:14:56 <stickster> smooge: I'm going to make a change directly on the installed files on pt6 -- it's just the patch I already sent to the logistics@ list.
18:15:14 <stickster> Another instance of "if x = n" instead of "if x == n"
18:15:37 <smooge> stickster, no rpms have been updated on the server in a while
18:15:41 <stickster> Yeah
18:15:53 <stickster> gwerra: Is the theme stuff already part of the fedora-zikula git repo?
18:16:02 <smooge> sorry slooooooow
18:17:46 <stickster> I guess gwerra is sort of not around at this particular moment :-)
18:17:48 <stickster> OK, moving on then.l
18:17:59 <stickster> #topic Milestone progress
18:18:11 <smooge> is the fedora-zikula going to be deployed as an rpm or via puppet?
18:18:33 <stickster> smooge: We should be able to deploy via RPM
18:18:45 <stickster> At least, that's my objective
18:18:49 <smooge> cool.
18:19:07 * stickster notes that the 'fedora-zikula' module on fedorahosted has code for AuthFAS module and the theme
18:19:26 <stickster> #link http://git.fedorahosted.org/git/?p=fedora-zikula.git <-- AuthFAS module and theme
18:19:58 <stickster> #info There are no theme changes in the tree since before 0.3 version, which we hope is good
18:20:19 <stickster> smooge: Do you want to take a crack at comparing what's in the repo, with what's on pt6, to make sure they're the same?
18:20:37 <stickster> Then we can proceed confidently :-)
18:21:38 <smooge> ok I will do that this afternoon
18:21:50 <smooge> I am getting the repo at this moment
18:22:28 <stickster> smooge: Awesome!
18:22:48 <stickster> #action smooge compare the repo content of the fedora theme with pt6 so we have parity
18:22:53 <rbergeron> I just need a heads-up as to when testing can be done.
18:23:16 <stickster> rbergeron: I'll let you know as soon as I make my additional change. That should be all that's needed.
18:23:40 * stickster trying to do three things at once and failing, gives up two.
18:23:47 <stickster> Let me find the milestone statement again
18:25:08 <stickster> OK
18:25:13 <rbergeron> sounds good - a mail to the logistics list would work dandy for that.
18:25:23 <stickster> rbergeron: will do
18:25:32 <rbergeron> thank you!
18:25:41 <stickster> #info Milestone 1: On June 15th, anyone should be able to type in "fedoraproject.org/insight" into a web browser and see the latest FWN issue, and get into any archives available at that point.
18:25:54 <stickster> rbergeron: Which means that's what we need to test to.
18:26:10 <stickster> Substitute pt6 for fp.o for right now
18:26:15 <rbergeron> yes.
18:26:22 <stickster> But we need to get things to staging in the next week, probably.
18:26:47 <stickster> We'll need to make sure pcalarco can still correctly enter FWN material.
18:27:24 <stickster> rbergeron: I think you had a test matrix, didn't you?
18:27:29 * stickster looks for link
18:28:54 <stickster> Can't find it.
18:29:02 <stickster> Argh, wiki fail
18:29:52 <stickster> rbergeron: any help?
18:30:17 * rbergeron is looking
18:30:31 <stickster> Aha!
18:30:33 <rbergeron> https://fedoraproject.org/wiki/Fedora_Insight_Testing
18:30:36 <stickster> Yeah
18:30:37 * rbergeron used googlez
18:30:42 <stickster> You beat me to it, caped crusader
18:30:58 * rbergeron has the big blue Cape of FI
18:31:57 <stickster> Anyone else have anything to add here?
18:32:03 <smooge> stickster, If people go to stg.fedoraproject.org/insight do they get something now?
18:32:16 <stickster> Yes
18:32:43 <stickster> smooge: But I think the database has not been carried over from pt6 -> stg, so there are some things missing at this point.
18:32:45 <smooge> ah DNS fail.
18:32:54 * gwerra is back
18:32:55 <smooge> ok it works now
18:33:22 <stickster> smooge: Do you have the ability to backup the zikula DB from stg, and then copy pt6 over?
18:34:02 <gwerra> stickster: for the theme part we will be working on it this weekend during the Indian FAD, so expect quite some progress :)
18:34:16 <stickster> Oh, aha
18:34:27 <smooge> Should it be #Milestone 1 should be that PT6 has completed development and frozen . #Milestone 2 should be stg.fedoraproject.org is a 'working' copy of frozen PT6. #Milestone 3 is a move to live?
18:34:49 <gwerra> smooge: +1 on the milestones
18:34:51 <stickster> smooge: Yes, or as 1a, 1b, 1c
18:34:58 <stickster> #undo
18:34:58 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x23036c50>
18:35:02 <stickster> #undo
18:35:02 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x23b4e790>
18:35:18 <smooge> I need to find out on database copying. Its going to have to be a dump and reload I think
18:35:40 <gwerra> smooge: I can do that btw, and yes it will a dump and import
18:35:54 <stickster> #info Milestone 1: PT6 has completed development and frozen. Milestone 2: stg.fedoraproject.org is a 'working' copy of frozen PT6. Milestone 3 move to live
18:36:03 <stickster> #link https://fedoraproject.org/wiki/Fedora_Insight_Testing <-- test matrix
18:36:10 <gwerra> we will need to sed pt6.fp.o with stg.fp.o or fp.o
18:36:33 <smooge> ok. I have to see about which db it gets imported to. The live version will probably have to be imported by someone in sysadmin-main or sysadmin-db (if they are different)
18:36:48 <stickster> gwerra: Yeah, actually   s@pt6.fp.o/zikula@stg.fp.o/insight@ I think
18:36:54 <stickster> Depending on the fields
18:37:14 <gwerra> stickster: yup
18:37:34 <smooge> gwerra, do you know what happened to the files: /usr/share/zikula/install/pntemplates/plugins/* they seem to be missing from PT6
18:37:36 <stickster> #action smooge and gwerra will coordinating the copying of pt6 Zikula DB to stg
18:38:03 <stickster> #undo
18:38:03 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2365d110>
18:38:07 <stickster> #action smooge and gwerra will coordinate the copying of pt6 Zikula DB to stg
18:38:15 <gwerra> smooge: well last I saw they weren't any
18:38:35 <smooge> ok rpm -V on the package says that a lot of files are missing
18:38:46 <gwerra> smooge: the /install folder should be removed
18:38:48 <gwerra> after install
18:39:07 <smooge> hmmm RPM needs some work
18:39:20 <smooge> later issue to deal with
18:39:22 <stickster> smooge: Bugs! We needs the bugs!
18:39:29 <stickster> ke4qqq: ^^^
18:39:37 <stickster> Those would be %ghost or something?
18:40:03 <stickster> Well, anyway, RPM work needed.
18:40:16 <gwerra> stickster: well you have to manually remove them after you have run the install script, etc
18:40:28 <stickster> #action ke4qqq Check in with smooge to figure out how to treat /install folder in RPM
18:40:37 <gwerra> dont think RPM will work, because I can choose to install at a later time as well
18:40:37 <stickster> gwerra: Right, there's an RPM function for dealing with stuff like that.
18:40:54 <gwerra> stickster: the script needs user input, that can be done?
18:41:08 * stickster not shot in the arm with the setup that removes a bunch of packaged files
18:41:27 <stickster> gwerra: Let's figure this out outside the meeting, though.
18:41:39 <gwerra> Sure
18:41:47 <stickster> I want to give smooge some time to talk about what he was doing with Drupal and Django CMS
18:41:51 <stickster> smooge: That OK with you?
18:41:52 <smooge> oh I see. normally we don't like touching stuff that is in /usr. Installation of applications should copy over to say /srv/X/ and then deal with that
18:42:10 <stickster> smooge: Or something like /etc ?
18:42:26 <smooge> only configs.. some of the install/deleted stuff is executable
18:42:31 <stickster> ah
18:42:45 <smooge> and removing it makes it so I can't do multi-zikulas per system
18:42:51 <stickster> Right
18:42:59 <smooge> which explains something I was trying to puzzle through
18:43:08 <smooge> Ok back to Drupal/Django CMS.
18:43:28 <stickster> #topic Other CMS reconnaissance
18:43:47 <smooge> Django CMS is at this point a "oooooooooh lets do it in pythong" thing. I haven't gotten it working or anything beyond tyring to read documents.
18:44:11 <smooge> Drupal on the other hand was brought up by mizmo who had found a plugin to wrap mailman with
18:44:24 <stickster> smooge: What does that plugin do?
18:44:28 <smooge> thus giving a forum like cover to mailing lists
18:44:49 <smooge> so people who like forums can look at it that way, people who like mailing lists can do it there way.
18:45:11 <rbergeron> innnnteresting.
18:45:16 <gwerra> stickster: http://drupal.org/project/mailman_manager
18:45:20 <smooge> so a work flow would be.. "I am looking at a forum.. I am on a thread.. oooh I know what the problem here is. Let me post."
18:45:23 <rbergeron> Django is python, right?
18:45:31 <gwerra> rbergeron: yes
18:45:47 <smooge> you would log in (or be logged in already using your Fedora credentials) and tada post happens.
18:45:56 <rbergeron> and I think we had noted at some point the advantages of ... being in a language that more people seem to know.
18:46:02 <smooge> No need to sign up to a list you never read again etc etc.
18:46:16 <rbergeron> vs. php, where we aren't really seeing a lot of pockets of knowledge that are willing to volunteer.
18:46:21 * rbergeron just throws that out there
18:46:29 <stickster> rbergeron: The problem is that Django CMS doesn't have a large community around it AFAIK
18:46:36 <rbergeron> stickster: i totally agree
18:46:41 <stickster> Whereas Drupal's is ginormous
18:46:42 <smooge> Django is a framework written in Python. It is in the same realm as Turbogrearrs.
18:46:58 <stickster> Right, Django-CMS is a particular project written on that framework
18:47:12 <stickster> The *Django* community is large
18:47:23 <smooge> and the community for Django is big.. but the CMS is a small project.
18:47:30 <smooge> oh sorry
18:47:35 <stickster> *jinx!
18:48:08 <stickster> But that module is interesting
18:48:15 <smooge> anyway scoping out comparisons I am focusing on Drupal for my own needs and Django CMS as a "hmmm interesting"
18:48:26 <stickster> I know that mizmo had talked with lmacken earlier about a more interactive approach to mailing lists
18:48:36 <smooge> The BIG issue is that we in infrastructure are probably project maxed out
18:48:47 <gwerra> Drupal has been around for quite some time, acquiring the stability and grace one would need
18:48:53 <stickster> smooge: Right. Which is why we can't just set something up and expect "someone else" to figure it out.
18:49:05 <stickster> Whatever we deploy, we need to be able to effectively figure out, or get help with.
18:49:11 <smooge> gwerra, correct. I used it for a project before I left RH in 2001 I think.
18:50:03 <smooge> gwerra, the other thing I want to emphasize is that I am not looking at throwing the towel in on what we are doing. This was brought up as a third PHP project and I saw overlap
18:50:25 <smooge> Our primary PHP is the wiki
18:50:46 <smooge> At this point, i believe it is a black box to most (except ricky who knows all/sees all)
18:51:00 * stickster knows a little PHP, but feels his way through mostly
18:51:08 <smooge> Our secondary PHP will be insight.
18:51:15 * gwerra is a PHP dev btw
18:52:19 * stickster has hard stop at the hour
18:52:24 <gwerra> smooge: Third project for?
18:52:27 <stickster> smooge: I've been playing around with Drupal too
18:52:29 <smooge> my work with PHP has been as a security person dealing with non-patched or bad apps... so I have the most reactionary view of it :). [Well and all the PHP i learned was version 3]
18:52:39 <stickster> I was going to try to port AuthFAS to see how hard it is
18:52:50 <smooge> gwerra, the 3rd would be some sort of mailman wrapper if that occurs
18:53:23 <gwerra> smooge: Ah, I remember mizmo asking on FB about it and I helped her with it
18:53:45 <stickster> smooge: It might make sense for us to at least keep on the scope... the idea of Insight 2.0 or 3.0 and how that might merge with that wrapper
18:53:57 <smooge> correct.
18:54:03 * stickster can't imagine we'd want to run two completely different CMS systems in tandem
18:54:10 <smooge> A tie in to mailling lists seems natural for Insight
18:54:24 <gwerra> #link http://www.ixda.org/discussion
18:54:24 <stickster> "Comment on this story here --> <list>"
18:55:07 <gwerra> Thats Drupal and the mailman-manager at work
18:55:25 <stickster> It's pretty interesting
18:55:52 <stickster> #info ixda site above is an interesting look at wrapping mailman with the Drupal CMS
18:56:17 <stickster> smooge: Anything else you wanted to mention in this regard?
18:57:02 <smooge> I am hoping to have a 'prototype' of the Drupal for a different non-Fedora project in a week or 2. That should give us enough knowledge to say "cool" or "Crap never again"
18:57:19 <stickster> smooge: Excellent!
18:57:26 <smooge> It will also allow me to figure out what kind of work FAS would need to work with Drupal
18:57:37 <stickster> smooge: There is a Drupal on pt6 that you can transfer knowledge to
18:57:51 <smooge> I will do so.
18:57:51 <stickster> Although it's 5.22, which will be deprecated when Drupal 7 comes out (probably later this summer)
18:58:09 * stickster notes that F12/F13 have Drupal 6.x available.
18:58:10 <smooge> that is one issue I had with Drupal. When it goes old.. it goes old
18:58:17 <ricky> Drupal auth would probably require no FAS modifications
18:58:18 * stickster has to run for next meeting
18:58:29 <stickster> smooge: Anything more before I wrap up?
18:58:31 <smooge> Drupal 6 requires a newer PHP correct?
18:58:34 <smooge> no I am done
18:58:35 <ricky> I think they're already just as flexible as MW (if not more) with pluggable auth
18:58:35 <stickster> Or can someone else close the meeting?
18:58:38 <smooge> my brain is full
18:58:43 <gwerra> stickster: I will
18:58:48 <stickster> #chair gwerra
18:58:48 <zodbot> Current chairs: gwerra rbergeron smooge stickster
18:59:01 <ricky> They also have a pretty impressive community, I think :-)
18:59:01 <stickster> OK, thanks gwerra, and can you post minutes?
18:59:08 <stickster> Thank you guys, sorry to run on you
18:59:11 <gwerra> stickster: Sure
18:59:14 <stickster> ricky: very much so
19:00:11 <gwerra> smooge: anything else on it?
19:00:32 <smooge> no sir
19:00:56 <gwerra> #topic Open Floor
19:01:12 * rbergeron has nothing
19:01:24 <gwerra> If anything comes up in a few, I ll close it
19:01:48 <gwerra> s/anything/nothing
19:02:34 <gwerra> Thanks everyone for coming!
19:02:38 <gwerra> #endmeeting