fedora-qa
LOGS
16:01:07 <adamw> #startmeeting Fedora QA meeting
16:01:08 <zodbot> Meeting started Mon Jan 18 16:01:07 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:08 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:01:11 <adamw> #meetingname fedora-qa
16:01:11 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:18 <adamw> #topic Roll call
16:01:25 * kparal is here
16:01:26 <adamw> ahoyhoy folks! who's around for qa meeting funtimes?
16:01:36 * kparal is still here
16:03:59 <adamw> well, that makes three of us
16:04:58 * Southern_Gentlem is here, but at work and will not know if i have to run off
16:05:04 * pschindl is here
16:06:00 <adamw> #chair kparal pschindl
16:06:00 <zodbot> Current chairs: adamw kparal pschindl
16:06:07 * adamw gives it another minute or two
16:07:48 <adamw> welp, i guess we can roll on, but probably not making any big decisions today
16:07:54 <adamw> #topic Previous meeting follow-up
16:07:59 <adamw> so, we had quite a few action items last time...
16:08:38 <adamw> #info "adamw to work with tflink and get [blockersbugs non-media blocker support] done" - oops, nope, still didn't happen. let's try that again
16:08:50 <adamw> #action adamw to get blockerbugs non-media blocker support merged
16:09:10 <adamw> kparal to work with releng and mirrormanager devs to implement 'erase stale metadata' tool for ensuring PreviousRelease blocker-fixing updates will be served - where are you on that one?
16:09:46 <kparal> puiterwijk volunteered to implement this (many thanks): https://lists.fedoraproject.org/archives/list/infrastructure%40lists.fedoraproject.org/thread/SJVBJMVUKZJ6QQQWZ4UGFDY4DTDDQU2F/
16:10:13 <puiterwijk> kparal: actually, that's been done and merged already
16:10:19 <kparal> great
16:11:02 <adamw> awesome job, kparal ;)
16:11:17 <adamw> also puiterwijk for doing the typing, I GUESS
16:11:19 <puiterwijk> https://github.com/fedora-infra/mirrormanager2/blob/master/utility/mm2_emergency-expire-repo   (and playbook et al is all done as well, including SOP for releng)
16:11:53 <puiterwijk> adamw: ? typing what?
16:11:59 <adamw> #info "kparal to work with releng and mirrormanager devs to implement 'erase stale metadata' tool for ensuring PreviousRelease blocker-fixing updates will be served" - puiterwijk went ahead and did this (thanks!), see link above
16:12:05 * jskladan lurks
16:12:09 <adamw> puiterwijk: i was just joking (giving kparal all the credit instead)
16:12:13 <puiterwijk> Ah :)
16:12:31 * adamw loves how you can get archive links from the headers in mailman3 but hates how bloody long they are
16:12:44 <puiterwijk> You're welcome for the typing
16:12:50 <kparal> puiterwijk: do you have a link for that releng SOP?
16:13:01 <puiterwijk> kparal: let me get you a link
16:13:20 <puiterwijk> https://pagure.io/fork/puiterwijk/releng/branch/expire-repo-sop
16:13:49 <kparal> puiterwijk: thanks, will look at it
16:14:04 <puiterwijk> I'm working with releng to get it in their main repo so they know where to look
16:14:43 <puiterwijk> (I still need to add the parts where they pass the arguments on, since that was related to ho wthe script ended up getting merged)
16:15:02 <adamw> alrighty, anything else on that one?
16:15:19 <kparal> puiterwijk++
16:15:20 <zodbot> kparal: Karma for puiterwijk changed to 27 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:15:28 <kparal> that's it, nothing else :)
16:15:34 <adamw> ok, next one's for you too:
16:15:35 <adamw> kparal to work on drafting proposed changes to the blocker process pages to define the rules for handling non-media blockers (when we slip, how long for, etc.)
16:17:01 <kparal> I have tried to revive the thread: https://lists.fedoraproject.org/archives/list/test%40lists.fedoraproject.org/thread/EESH6NHCJIFBTCMT3EON63R4WOXFLXGO/
16:17:11 <kparal> but not many people responded
16:17:19 <adamw> right, i had it on my todo list to reply to
16:17:38 <kparal> here's a direct link: https://lists.fedoraproject.org/archives/list/test%40lists.fedoraproject.org/message/3NC74B5QTKFUMO5TMVLMOMGRDR3DY7II/
16:17:45 <adamw> that's fine, process discussion is always a bit slow
16:18:19 <adamw> #info "kparal to work on drafting proposed changes to the blocker process pages to define the rules for handling non-media blockers (when we slip, how long for, etc.)" - this is in progress, kparal posted some points for discussion to the thread this week
16:19:18 <adamw> one more for you - i think i know the answer to this, but just for the record...
16:19:19 <adamw> "kparal to propose packaging guideline changes for N+1 upgrades to FPC"
16:20:04 <kparal> so, the packaging folks told me that packaging guidelines don't need to get updated. and I created a fesco ticket here, to have it covered by all parties: https://fedorahosted.org/fesco/ticket/1534
16:20:34 <kparal> the packaging discussion is here: https://lists.fedoraproject.org/archives/list/packaging%40lists.fedoraproject.org/thread/TAJRGAWPDKBKXUM2M5Y4MG44TEKCYC7J/
16:21:05 <adamw> thanks
16:21:38 <adamw> #info "kparal to propose packaging guideline changes for N+1 upgrades to FPC" - after further investigation all parties agree no guideline changes are really needed, but kparal has filed a ticket with FESCo for general approval of the idea of blocking on N-1 upgrades
16:22:05 <adamw> alright, and then there's a couple for me:
16:22:38 <adamw> #info "adamw to create N+1 upgrade test cases and add them to the test matrix as 'optional' for now" - this is done, with some renaming too, there were some list mails about it. 'previous' upgrade tests are now N-1, 'current' upgrade tests are N.
16:23:10 <adamw> http://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/GC6K4EHDXPPOO2RMMGCPZIESVJH4JRJA/
16:24:08 <adamw> #info "adamw to fix up all openQA's craziness" - this was down to disk space again, I think, it's all fixed up now anyway. stg is now running 4.3, I need to look into any issues with that and ultimately get prod onto it.
16:27:12 <adamw> alright, that's all the action items
16:27:15 <adamw> anything else for follow-up?
16:28:27 * kparal doesn't know about anything else
16:31:02 <adamw> alrighty then!
16:31:17 <adamw> #topic Fedora 24 status
16:31:47 <adamw> so I didn't really have anything world-ending here, just wanted to note that since the whole F24 schedule got moved out, obviously that moved out the Alpha TC1 date (and the Change deadlines, so we may still potentially have more new features)
16:33:16 <adamw> we're now looking at Feb 16th for Alpha TC1
16:34:41 <kparal> I have a question regarding i686. Are i686 images non-blocking now regardless of how individual WGs decide to handle them (produce them or not produce them)?
16:34:54 <kparal> that's what I got from your reply into desktop list
16:35:01 <kparal> or someone else's
16:35:43 <adamw> yeah, not mine, i was following someone else
16:35:46 <adamw> let me dig out their text
16:36:09 <adamw> Josh wrote "FESCo voted that no i686 media will block the release from F24 and forward"
16:36:21 <kparal> that's it
16:36:22 <adamw> I kinda took that on trust since Josh usually doesn't talk out of his ass, but I don't know specifically what he's referring to
16:36:29 <adamw> probably would be a good idea to go dig that up and let people know about it...
16:36:32 <adamw> let me action myself
16:36:42 <kparal> ok, thanks
16:37:10 <adamw> #action adamw to look into the reported FESCo vote to stop blocking on i686 media and take necessary steps (give QA team members a heads-up, adjust relevant wiki pages)
16:37:24 <sgallagh> adamw: Effectively, we're saying that any group can produce whatever images they want
16:37:40 <sgallagh> But we won't slip the release date for bugs found *only* in i686 images
16:37:42 <adamw> sgallagh: but is it true that by policy *no* group's i686 media can now be considered 'release blocking'?
16:37:43 <adamw> rgr.
16:37:47 <kparal> sgallagh: the question is whether i686 is blocking if they want it blocking
16:38:05 <adamw> #info with the Fedora 24 schedule slip, Alpha TC1 date is now Feb 16th
16:38:20 <sgallagh> kparal: I'd have to reread the specific discussion, but I think the point of having FESCo rule on this was to say that no one gets to overrule that.
16:38:33 <kparal> ok, sounds good to me
16:38:37 <kparal> less work :P
16:39:03 <sgallagh> Basically, if a WG or SIG really wants i686 media, it's up to them to deal with any bugs that would block.
16:39:13 <sgallagh> They can't count on the release date moving to accommodate them
16:40:09 <adamw> fwiw, by my reading that's the same thing as 'no blocker bugs', at least by the distro-wide blocker bug policy.
16:40:33 <kparal> I understand it like that as wel
16:40:39 <sgallagh> /me notes that there's no clear path forward on how to deal with Websites if a SIG tries to produce i686 and has unresolved blockers at Go/No-Go
16:40:39 <kparal> *well
16:40:55 * adamw notes that's not our problem, happily
16:40:56 <adamw> :P
16:41:06 <sgallagh> Just pointing it out.
16:41:09 <sgallagh> Carry on
16:41:41 <sgallagh> adamw: Your reading agrees with mine as well
16:41:54 <adamw> huh, and it looks like whatever the gremlins did to yesterday's Rawhide nightly boot.iso, it's fixed today...
16:42:05 <adamw> "Failed openQA tests: 5 of 69"
16:42:17 <sgallagh> /me runs off to motivate the gremlins
16:42:35 <adamw> so, as far as I know, F24 is rolling along fine, though we could probably stand to quit tinkering with the robots and do a few manual tests sometime
16:42:42 <adamw> firmware RAID lalala firmware RAId
16:43:39 <pschindl> If Lukas borrows me my monitor I'll try it.
16:45:20 <adamw> i was just singing my little manual testing song to myself
16:45:26 <adamw> lalala firmware RAID lalala whiskey lalala sadness
16:47:15 <adamw> okay then
16:47:25 <adamw> #topic Year in review
16:47:39 <adamw> so I caught an interesting post I think on the community blog suggesting that Fedora groups could write 'year in review' posts
16:48:03 <adamw> it's from last month, what can I say, I was behind on my RSS
16:48:04 <adamw> https://communityblog.fedoraproject.org/share-your-year-in-review-with-fedora/
16:48:18 <adamw> do folks think it'd be neat to have a QA year-in-review? anyone interested in writing one?
16:48:28 <kparal> rss is the only thing I keep up with - long commute times :)
16:49:01 * kparal is not really a writing type of person
16:49:10 <adamw> i was kinda hoping more non-RHers would be around as this is a nice thing for Da Community, ah well
16:49:29 <adamw> so i'm willing to do it if no-one else is, but given the turn out, i think i'll send a mail to the list first and see if anyone else wants to
16:50:19 * tflink should probably do one for automation/tooling
16:50:50 <adamw> tflink: i think if we can do one single article that'd be neat, we can always collaborate
16:51:14 <tflink> works for me
16:54:24 <adamw> okey dokey
16:54:37 <adamw> #action adamw to mail list about co-ordinating a QA 'year in review' post for 2015
16:54:41 <adamw> #topic Open floor
16:54:53 <adamw> anything else, folks? remember, we've got blocker review at the top of the hour in #fedora-blocker-review
16:55:20 <kparal> nothing else from me
16:56:59 * adamw sets the quantum fuse
16:58:33 <adamw> thanks for coming, everyone!
16:58:37 <adamw> #endmeeting