g11n_(i18n)
LOGS
06:00:26 <pravins> #startmeeting g11n (i18n)
06:00:26 <zodbot> Meeting started Wed Jan  6 06:00:26 2016 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:00:26 <zodbot> The meeting name has been set to 'g11n_(i18n)'
06:00:30 <pravins> #meetingname g11n (i18n)
06:00:30 <zodbot> The meeting name has been set to 'g11n_(i18n)'
06:00:36 <pravins> #topic agenda and roll call
06:00:36 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2016-01-06
06:00:50 <pravins> Who available for meeting today?
06:01:32 <suanand> Hi
06:01:35 <ueno> hi
06:02:00 <epico> hi
06:02:06 <pravins> hi suanand ueno epico :)
06:02:33 <fujiwarat> hi
06:02:39 <pravins> hi fujiwarat :)
06:02:40 <smaitra> hi
06:02:41 <tagoh_> hi
06:02:42 <paragan> hi
06:02:54 <pravins> hi smaitra tagoh_ paragan  :)
06:03:05 <pravins> #chair suanand ueno epico fujiwarat smaitra tagoh_ paragan
06:03:05 <zodbot> Current chairs: epico fujiwarat paragan pravins smaitra suanand tagoh_ ueno
06:03:47 <pravins> Hoping all you had wonderful Christmas and New year celebration.
06:04:01 <pravins> First meeting of the 2016 and wishing happy new year to all :)
06:04:15 <suanand> Happy New Year ... all
06:04:29 <smaitra> Happy New Year guys! :)
06:05:53 <pravins> Lets quickly go through upcomg schedule
06:05:57 <pravins> #topic Upcoming schedule
06:06:01 <pravins> #info 2016-01-12 	Change Checkpoint: Proposal submission deadline (System Wide Changes)
06:06:02 <pravins> #info not scheduled yet 	Side Tag Builds Deadline
06:06:02 <pravins> #info not required 	Mass Rebuild
06:06:02 <pravins> #info 2016-02-02 	Branch Fedora 24 from Rawhide (Rawhide becomes future F25)
06:06:02 <pravins> #info 2016-02-16 	Alpha Freeze (*)
06:06:02 <pravins> #info 2016-02-16 	Software String Freeze
06:06:04 <pravins> #info 2016-02-16 	Change Checkpoint: Completion deadline (testable)
06:06:06 <pravins> #info 2016-02-16 	Bodhi activation point
06:06:39 <pravins> Less than week to submit change proposals.
06:06:49 <juhp> hi
06:06:52 <pravins> Will have better picture, what going to be in Fedora 24 by our next meeting.
06:06:55 <pravins> hi juhp  :)
06:06:58 <pravins> #chair juhp
06:06:58 <zodbot> Current chairs: epico fujiwarat juhp paragan pravins smaitra suanand tagoh_ ueno
06:07:14 <pravins> #topic New topics
06:07:35 <pravins> #info #43: G11N FAD in 2015 (pravins)
06:07:35 <pravins> #link https://fedorahosted.org/i18n/ticket/43
06:07:50 <pravins> If you have noticed, i wrote one conclusive post for Fedora Globalization activity days
06:07:56 <pravins> #link https://communityblog.fedoraproject.org/fedora-globalization-g11n-activity-day-november-2015/
06:08:45 <pravins> This is more inline with what objective we planned before FAD and how much we able to complete it. We did fairly good.
06:08:56 <pravins> thanks to all for making it great.
06:09:43 <pravins> only 2 reimbursement tickets are open now
06:09:49 <pravins> #link https://fedorahosted.org/G11N/ticket/7
06:10:03 <pravins> Mike Fabian
06:10:15 <pravins> #link Anish https://fedorahosted.org/G11N/ticket/10
06:10:38 <pravins> no response from Ruth for Anish ticket yet :(
06:11:08 <juhp> pravins, thanks for the good blog post!
06:11:46 <pravins> thank you :) Was planning to keep it short but while completing all objective it became big ;)
06:12:14 <pravins> I think, once Anish reimbursement done, we can say official everything done from FAD side.
06:12:59 <pravins> hoping not missed anything for FAD.
06:13:26 <pravins> moving to next topic
06:13:36 <pravins> #info #57: Fedora 24 change planning
06:13:40 <pravins> #link https://fedorahosted.org/i18n/ticket/57
06:13:55 <pravins> From last two detailed meeting on F24 change planning.
06:14:02 <pravins> Only one change came up for F24.
06:14:21 <pravins> That is Glibc Locale sub-packaging
06:14:27 <pravins> #link https://fedoraproject.org/wiki/Changes/Glibc_locale_subpackaging
06:14:39 <pravins> This is pending on FeSco presently for approval.
06:15:20 <pravins> During holidays does anyone got any new idea/plan for change proposal ;)
06:16:32 <pravins> anything we missing for change proposal?
06:16:50 <juhp> not sure if we have any progress on the subpackaging yet - I fear it might get punted to F25
06:17:51 <pravins> ohh, lets try for F24. If still it risky we can move to F25.
06:18:12 <pravins> We have to schedule meeting with stakeholders, that meeting can help in someone way.
06:19:20 <pravins> s/someone/someway
06:19:37 <pravins> at least we will get some idea, whether its possible in F24 life cycle.
06:20:01 <pravins> looks like no other idea for now.
06:20:01 <juhp> yes
06:20:23 <pravins> #action pravins to discuss with Mike for meeting specifically on glibc locale subpackaging with interested people.
06:20:50 <juhp> just my feeling is it might be safer to push it to rawhide just after branching... actually that is what I had hoped we could do for f24...
06:21:02 <juhp> thanks
06:21:19 <pravins> +1 for rawhide
06:21:43 <pravins> #topic F24 accepted change proposals
06:22:02 <pravins> Though we have single change proposal, there are lots of accepted changes for Fedora 24.
06:22:23 <pravins> Lets quickly go through it and see if we need to give extra attention for any change proposals.
06:22:41 <pravins> #info Accepted changes for Fedora 24
06:22:43 <pravins> #link https://fedoraproject.org/wiki/Releases/24/ChangeSet
06:23:09 <pravins> list is big, so i will quickly go through all. Please feel free to comment on anyone, anytime :)
06:23:24 <pravins> #info Layered Docker Image Build Service
06:23:24 <pravins> #link https://fedoraproject.org/wiki/Changes/Layered_Docker_Image_Build_Service
06:25:02 <pravins> This is interesting one.
06:25:22 <pravins> #info Pungi Refactor
06:25:22 <pravins> #link https://fedoraproject.org/wiki/Changes/Pungi_Refactor
06:26:35 <pravins> moving to next one
06:26:36 <pravins> #info  Ruby 2.3
06:26:37 <pravins> #link https://fedoraproject.org/wiki/Changes/Pungi_Refactor
06:27:29 <pravins> #undo
06:27:29 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f474d678210>
06:27:33 <pravins> #link https://fedoraproject.org/wiki/Changes/Ruby_2.3
06:28:05 <pravins> next one is
06:28:07 <pravins> #info Node.js 4.2
06:28:07 <pravins> #link https://fedoraproject.org/wiki/Changes/NodeJS4x
06:28:38 <pravins> next
06:28:39 <pravins> #info Python 3.5
06:28:39 <pravins> #link https://fedoraproject.org/wiki/Changes/python3.5
06:29:17 <pravins> next
06:29:18 <pravins> #info  TeXLive 2015
06:29:18 <pravins> #link https://fedoraproject.org/wiki/Changes/TeXLive2015
06:29:42 <pravins> This is going to be huge :)
06:29:48 <pravins> #info Server Drop i686
06:29:48 <pravins> #link https://fedoraproject.org/wiki/Changes/Server_Drop_i686
06:30:05 <juhp> I wish there could be less texlive packages
06:30:15 <pravins> yeah.
06:30:31 <pravins> finally, no i686 from F24.
06:30:39 <pravins> #info NetworkManager 1.2
06:30:39 <pravins> #link https://fedoraproject.org/wiki/Changes/NetworkManager12
06:31:13 <pravins> next
06:31:14 <pravins> #info  Fedora 24 Boost 1.60 uplift
06:31:14 <pravins> #link   https://fedoraproject.org/wiki/Changes/F24Boost160
06:32:01 <pravins> next
06:32:06 <pravins> #info GHC 7.10
06:32:06 <pravins> #link https://fedoraproject.org/wiki/Changes/GHC_7.10
06:32:18 <pravins> This is owned by juhp :)
06:32:21 <juhp> I fear it is not going to happen again :(
06:32:27 <juhp> due to lack of resources
06:32:31 <juhp> I wish though
06:33:04 <pravins> May be should, keel these type of task somewhere with tag, required contributors
06:33:07 <juhp> mainly just package reviewing blocking this and then grunt work
06:33:10 <pravins> s/keel/keep
06:33:19 <juhp> yeah
06:33:48 <pravins> might be there is page already, need to search
06:33:52 <juhp> I am thinking to gradually drop less important libraries that might be blockers
06:34:00 <pravins> make sense.
06:34:11 <juhp> but even so...
06:34:27 <juhp> also my time is pretty limited
06:34:40 <juhp> anyway OT I guess :)
06:34:44 <pravins> yes :)
06:34:49 <pravins> lets hope for best
06:34:54 <juhp> thanks
06:35:05 <pravins> expecting everyone with double energy after new year break ;)
06:35:14 <juhp> other Haskell SIG people seem busy or unavailable
06:35:27 <pravins> next change
06:35:28 <pravins> #info  Livemedia Creator
06:35:29 <pravins> #link https://fedoraproject.org/wiki/Changes/LivemediaCreator
06:35:55 <pravins> next one
06:35:56 <pravins> #info  Systemd file triggers
06:35:56 <pravins> #link https://fedoraproject.org/wiki/Changes/systemd_file_triggers
06:36:06 <pravins> #info  Systemd package split
06:36:06 <pravins> #link https://fedoraproject.org/wiki/Changes/systemd_package_split
06:36:29 <pravins> list is huge, may be we could have divided changes in two meetings :(
06:36:46 <pravins> Will post this to ticket and one can comment there.
06:37:12 <pravins> There are few Self contained changes as well. Available on https://fedoraproject.org/wiki/Releases/24/ChangeSet
06:37:20 <pravins> Will check them in next meeting.
06:37:40 <pravins> please comment on ticket, if you feel any change required particular attention from us.
06:37:49 <pravins> I think these are more important for L10N and Zanata
06:38:10 <pravins> may be more strings..
06:38:28 <pravins> will raise in next meeting
06:38:40 <pravins> i think, we can move to next topic now
06:38:41 <pravins> #info #58: Prioritizing bugs for Fedora 24 release (pravins)
06:38:41 <pravins> #link https://fedorahosted.org/i18n/ticket/58
06:38:56 <pravins> https://fedoraproject.org/wiki/G11N/Fedora_24_G11N_Enhancements
06:39:02 <pravins> Page looks much better now :)
06:39:16 <pravins> Thanks for people who added tasks planned for F24.
06:39:30 <pravins> Now from i18n point of view, we have only one change proposal.
06:39:46 <pravins> It means there are number of improvements happening, not qualified as a change
06:40:00 <pravins> This is page, where we should put all those improvements/bug fixes
06:40:10 <pravins> requesting everyone please help to improve this page.
06:40:52 <pravins> As discussed in last meeting, we already have around 100 bugs open
06:41:00 <pravins> Please see stats in Agenda page https://fedoraproject.org/wiki/I18N/Meetings/2016-01-06
06:41:25 <pravins> If you are planning to fix any bug during F24 cycle, please add it on this page.
06:41:30 <pravins> Any comments??
06:41:32 <smaitra> pravins, thanks for this info.
06:41:43 <juhp> nice page
06:42:18 <juhp> good to use this
06:42:27 <smaitra> yeah
06:43:04 <pravins> smaitra: We can add improvements from QA side as well to this page.
06:43:21 <pravins> Its looks nice, with Zanata and L10N improvement idea.
06:43:56 <pravins> I think, after Change proposal deadline, if we clean up this page and announce as a improvement from G11N side it will make good impact.
06:44:00 <smaitra> pravins, sure. gimme some time, i add the improvements
06:44:12 <pravins> smaitra: nice :)
06:44:27 <juhp> pravins, +1
06:44:53 <pravins> We have done with all topics
06:45:25 <pravins> #action all members to add bug fixes plans and improvement on https://fedoraproject.org/wiki/G11N/Fedora_24_G11N_Enhancements
06:45:35 <pravins> moving to open floor
06:45:41 <pravins> #topic Open Floor
06:46:02 <pravins> Did we missed any topic, or anything you would like to add?
06:46:05 <smaitra> pravins, automation front topic?
06:46:17 <pravins> aha, good point.
06:46:30 <pravins> We have to discuss it with tagoh_
06:47:04 <smaitra> ah! ok, sure. lets discuss it some other time then with tagoh and sandeeps.
06:47:18 <tagoh_> sure
06:47:33 <smaitra> tagoh_, thanks! :)
06:47:37 <juhp> front?
06:47:40 <pravins> smaitra: thanks for raising it, will definitely do it for f24 :)
06:47:47 <smaitra> cool!
06:47:49 <pravins> s/front/side ;)
06:48:20 <juhp> how about the string tracking we were discussing last year?
06:48:35 <juhp> should we track that here or ?
06:48:37 <pravins> Thought we will discuss that in G11N meeting.
06:48:41 <juhp> ah okay
06:48:46 <pravins> Bit confused in it.
06:48:59 <juhp> yep makes sense since it involves Zanata I guess
06:49:11 <pravins> 2 topics, 1- String breakage monitoring script and 2- Language spins
06:49:25 <pravins> lets do it for G11N only :)
06:49:41 <juhp> and automation topic is ?
06:49:50 <juhp> same?
06:50:08 <smaitra> it would be nice for l10n members as well for us to track strings for both translated and untranslated then.
06:50:15 <juhp> ah okay
06:50:19 <juhp> good
06:50:23 <juhp> yep I think so
06:50:30 <pravins> automation is automatic testing for i18n. Yes i think we missed in this meeting.
06:50:42 <juhp> okay
06:50:50 <pravins> juhp++ :)
06:50:50 <zodbot> pravins: Karma for petersen changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:50:57 <smaitra> automation on input, rendering and other i18n features.
06:51:21 <juhp> smaitra, any particular packages you have in mind for string tracking?
06:51:23 <pravins> smaitra: yes. would you like to create ticket for Fedora?
06:51:37 * smaitra is gonna create a ticket in fedora for collaboration on automation
06:51:49 <juhp> yes I think any topic needs a ticket....
06:52:09 <pravins> #action smaitra will create ticket on automated testing for i18n.
06:52:12 <juhp> we have one already for the string tracking ?
06:52:23 <smaitra> juhp, as of now, its in early planning phase, so, no particular packages been selected for tracking.
06:52:29 <juhp> okay
06:52:38 <pravins> no, not yet.
06:52:48 <juhp> okay I will open one then
06:52:57 <smaitra> let me seat with pravin and come up with concrete plan as this is his idea!
06:53:03 <juhp> great
06:53:17 <pravins> #action juhp to open ticket for string breakage monitoring script.
06:53:18 <juhp> pravins, thanks :)
06:53:44 <pravins> done with all topics
06:53:51 <pravins> if nothing else, lets close in couple of minutes
06:54:11 <smaitra> sure, thanks pravin! Thanks everybody!
06:54:45 <smaitra> pravins, would u pls summarize the action items once!
06:54:56 <pravins> smaitra: those will get generated with minutes :)
06:55:02 <smaitra> cool!
06:55:05 <pravins> i will drop minutes to g11n list.
06:55:15 <smaitra> thanks
06:55:25 <pravins> thanks all for meeting.
06:55:26 <pravins> #endmeeting