fesco
LOGS
18:01:07 <rishi> #startmeeting FESCo (2015-10-28)
18:01:07 <zodbot> Meeting started Wed Oct 28 18:01:07 2015 UTC.  The chair is rishi. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:15 <rishi> #meetingname fesco
18:01:15 <zodbot> The meeting name has been set to 'fesco'
18:01:19 <rishi> #chair ajax dgilmore number80 jwb nirik paragn rishi thozza sgallagh
18:01:19 <zodbot> Current chairs: ajax dgilmore jwb nirik number80 paragn rishi sgallagh thozza
18:01:30 <nirik> morning
18:01:30 <rishi> #topic init process
18:01:35 <rishi> .hello rishi
18:01:36 <zodbot> rishi: rishi 'Debarshi Ray' <debarshir@redhat.com>
18:01:41 <sgallagh> .hello sgallagh
18:01:42 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:01:51 <jwb> hi
18:01:55 * linuxmodder hanging out for  informative purposes
18:02:14 <linuxmodder> s/informative/learning
18:03:28 <rishi> Four of us here, and now we have ajax
18:03:43 <ajax> hey
18:03:51 * mattdm lurking
18:04:00 <rishi> Today is a public holiday here in Czech Republic, so, I guess, thozza won't be here.
18:04:32 * rishi pokes paragn, number80, dgilmore
18:05:38 <rishi> I wonder if number80 got confused by the recent time shift. I did get caught off-guard.
18:05:46 <smdeep> .hellomynameis smdeep
18:05:47 <zodbot> smdeep: smdeep 'Sudeep Mukherjee' <smdeep@gmail.com>
18:05:55 <nirik> looking at the last minutes they said they would not be around today
18:06:01 * smdeep is a born lurker
18:06:03 * stickster lurks
18:06:29 * nirik gets some coffee
18:06:31 <rishi> Oh, yes, nirik is right.
18:06:37 <rishi> Let's start then.
18:06:57 <rishi> #topic Strategy for services that do not have systemd native unit files
18:06:59 <rishi> .fesco 615
18:07:01 <zodbot> rishi: #615 (Strategy for services that do not have systemd native unit files) – FESCo - https://fedorahosted.org/fesco/ticket/615
18:07:43 <Mohamed_Fawzy> .fas mohamedfawzy
18:07:43 <zodbot> Mohamed_Fawzy: mohamedfawzy 'Mohamed Fawzy' <medoelmasry142@gmail.com>
18:08:32 <rishi> Are we just waiting for sgallagh to send the email?
18:08:49 <nirik> yep. I think so
18:08:59 <sgallagh> rishi: Right, I was waiting for feedback and then forgot about it.
18:09:04 <sgallagh> I'll send it now, unless there is concern
18:09:40 * nirik has none.
18:10:08 <ajax> yeah, fine with me
18:10:36 <rishi> And then we can close the ticket again. Right?
18:11:07 <nirik> sure
18:11:08 <rishi> Nothing to vote / propose here, as far as I can see.
18:12:00 <sgallagh> Actually, I just noticed I wrote August when I meant October. So I'll fix that
18:12:09 <rishi> #action sgallagh will email the decision to devel-announce
18:12:26 <sgallagh> Sent
18:12:28 <rishi> #topic Nonresponsive maintainer, ownership transfer request
18:12:32 <sgallagh> (someone will need to pass it through)
18:12:34 <rishi> .fesco 1492
18:12:36 <zodbot> rishi: #1492 (Nonresponsive maintainer, ownership transfer request) – FESCo - https://fedorahosted.org/fesco/ticket/1492
18:12:36 * nirik can
18:13:23 <nirik> so, not sure whats going on with this one... I guess the entire process hasn't been yet followed.
18:13:23 <rishi> Given that I messed up the times and sent the agenda so late, I didn't manage to invite vjancik to today's meeting.
18:13:27 <rishi> Sorry about that.
18:14:05 <rishi> It is clear that TC is still active.
18:14:06 <dgilmore> hi rishi
18:14:26 <rishi> dgilmore: Hi
18:14:35 <nirik> well, not fully sure really... there's been activity a month ago...
18:14:38 <sgallagh> Yeah, I'd like to kick this back to "Follow the policy as written" and ignore it for now
18:15:20 <nirik> I do have a policy change to mention and ask people to think about (I can also send to the list)
18:16:28 <rishi> Although, I am curious about the "nodejs not being updated" part.
18:16:29 <nirik> A long time ago we discussed and may even have approved but never implemented this: add a autoapproval timeout for pkgdb acls. So after 2 weeks or a month or whatever if the maintainer doesn't approve  or deny them, pkgdb auto approves them and you can become a co-maintainer.
18:16:47 <sgallagh> rishi: It's a sizeable change (on the order of a Boost update)
18:16:50 <nirik> On the one hand that would allow people to take over packages where the maintainer wasn't active.
18:16:54 <rishi> nodejs.org says current version is 4.2.1, while koji says that our nodejs package is at 0.10.36.
18:17:14 <rishi> Not sure how to interpret that. I don't follow nodejs closely either.
18:17:16 <sgallagh> rishi: The versions jumped sharply
18:17:19 <nirik> On the other hand, it wouldn't help us find maintainers that are completely gone and they would still have packages unmaintained no one cared to request acls on
18:17:29 <sgallagh> rishi: 0.12.x went next to 2.0, then 3 and 4
18:17:43 <nirik> a nodejs rebuild would be a pretty big amount of work
18:17:53 <rishi> sgallagh: I see.
18:17:59 <rishi> So we are lagging behind a bit.
18:18:15 <sgallagh> Well, those all happened within the last year
18:18:25 <sgallagh> So keeping up with it will be... complex
18:18:34 * dgilmore wonders if we should look at building using npm, ruby gems etc and wrapping the result as a rpm
18:18:45 <dgilmore> maybe that owuld make it easier for people to do things
18:18:48 <rishi> How about kicking this ticket back to "follow the process" with a suggestion that vjancik and TC work out a way to update the nodejs stack?
18:19:15 <dgilmore> rishi: :) sounds good to me
18:19:21 <sgallagh> +1
18:19:27 <nirik> sure. It's not clear to me how active TC is tho...
18:19:33 <rishi> +1 to my own proposal
18:19:46 <ajax> +1
18:20:21 <jwb> +1
18:20:22 <dgilmore> +1
18:20:22 <sgallagh> nirik: Contacting him first and saying "Hey, can I take this over?" would at least be a good start
18:20:47 <nirik> well, they did.
18:21:20 <nirik> but they can come back to us if they can't get an answer, so +1
18:21:23 * rishi is trying to figure out how to phrase that in a more formal way
18:23:03 <rishi> How about: Since there is still some activity from TC, vjancik should "follow the process" and try to contact TC before proceeding further. We suggest that they work out a way to update the Node.js stack in Fedora ?
18:23:22 <dgilmore> rishi: ack
18:23:26 <sgallagh> ack
18:23:37 <ajax> aye
18:24:34 <jwb> i am +1 to anything suggested on this ticket that resembles common sense.
18:25:03 <rishi> #agreed Since there is still some activity from TC, vjancik should "follow the process" and try to contact TC before proceeding further. We suggest that they work out a way to update the Node.js stack in Fedora ? (+7)
18:25:25 <rishi> #topic next weeks chair
18:25:35 <rishi> Any volunteers?
18:26:10 <sgallagh> I'll be enroute to the systemd conference next week, so I won't be around
18:26:43 <ajax> i can do next week
18:27:04 <rishi> #action ajax to chair next week
18:27:08 <rishi> Thanks ajax
18:27:13 <rishi> #topic Open Floor
18:28:04 <rishi> I deliberately didn't put  https://fedorahosted.org/fesco/ticket/1491  (clarifications/improvements for new bundling policy) on today's agenda ...
18:28:20 <rishi> sgallagh: But do you want to discuss it or something?
18:28:25 <rishi> nirik: ^^
18:29:06 <nirik> well, we could... I think we need to make a wiki page with the current policy too.
18:29:07 <jwb> sgallagh: bug 1227379 would be good to mull over if you're going to be in the vicinity of the systemd developers
18:29:19 <sgallagh> Could we discuss the point jzeleny raised?
18:29:25 <nirik> How about I try to make a wiki page and proposed changes and we can discuss next week?
18:29:28 <sgallagh> .bug 1227379
18:29:29 <zodbot> sgallagh: Bug 1227379 Audit events in /var/log/messages - https://bugzilla.redhat.com/1227379
18:29:36 <sgallagh> Ah, right
18:29:51 <sgallagh> Yeah, I can bring it up with them.
18:31:40 <sgallagh> OK, I guess we'll wait for nirik's wiki page
18:31:53 <nirik> well, if you want to discuss today we could too.
18:32:52 <nirik> it could well be a lot of work to move around bundled libs... depending on the project
18:32:53 <sgallagh> Mostly I wanted to hear if anyone could poke holes in my response
18:33:29 <sgallagh> nirik: I wasn't clear on whether apps bundling libs usually dropped them in /usr/lib or kept them private.
18:33:56 <nirik> I'm not sure we have enough data to say. ;)
18:34:26 <nirik> we could include a "provides from packages that bundle should not expose bundled libraries to other packages" or something.
18:34:39 <sgallagh> /me nods
18:35:13 <ajax> they really shouldn't expose any libraries to the base runtime
18:35:26 <nirik> I know it's happened before...
18:35:26 <ajax> i'd hope rpath + $ORIGIN would be the done thing
18:35:27 * nirik looks at icecat
18:35:31 <dgilmore> they shouldn't
18:35:54 <sgallagh> Right, which is why I was going straight to the strong proscription against using /usr/lib[64]
18:36:11 <ajax> if it's %{_libdir}/foo then fine
18:36:58 <sgallagh> Right, I meant the specific path, not the subdirs
18:37:23 <rishi> Hmm... where does Firefox put the stuff that it bundles? Can't find anything in /usr/lib64/firefox.
18:39:01 <rishi> #action sgallagh will discuss bug 1227379 with the systemd developers at systemd.conf
18:40:22 <nirik> not sure off hand.
18:43:19 <rishi> Anything else?
18:43:32 <dgilmore> not here
18:45:03 <jwb> nope
18:45:26 <sgallagh> Nay
18:45:36 <nirik> neg
18:47:09 <rishi> Ok, then. Thanks for coming everyone!
18:47:09 <ajax> nein
18:47:13 <rishi> #endmeeting