kde-sig
LOGS
15:03:28 <rdieter> #startmeeting kde-sig
15:03:28 <zodbot> Meeting started Tue Sep 15 15:03:28 2015 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:32 <rdieter> #meetingname kde-sig
15:03:32 <zodbot> The meeting name has been set to 'kde-sig'
15:03:38 <rdieter> #topic roll call
15:03:54 <rdieter> hi all, friendly kde-sig meeting here, who's present today?
15:04:02 * satellit listening
15:04:18 <Kevin_Kofler> Present.
15:04:20 <heliocastro> here
15:04:23 <jreznik> hey
15:04:35 <than> present
15:04:38 <dvratil> hi
15:04:54 <tosky> hi
15:05:36 <rdieter> #info rdieter satellit Kevin_Kofler heliocastro jreznik than dvratil tosky present
15:05:46 <rdieter> #chair satellit Kevin_Kofler heliocastro jreznik than dvratil tosky
15:05:46 <zodbot> Current chairs: Kevin_Kofler dvratil heliocastro jreznik rdieter satellit than tosky
15:05:51 <rdieter> #topic agenda
15:06:12 <rdieter> what to discuss today?  (besides what I'd mentioned previously in #fedora-kde)
15:06:37 <dvratil> I'd like to say something about Plasma theme for Fedora
15:06:38 <tosky> oh, the dolphin4 story (really brief)
15:06:47 * jreznik has nothing to add
15:07:38 <rdieter> #topic dolphin4 story (brief :) )
15:07:41 <rdieter> tosky: ok, go ahead
15:08:21 <tosky> I checked the logs and realized that dolphin4 is useful to test the "all-from-last-full-kdelibs4-set of packages"
15:08:56 <tosky> so once the binary package with dolphin4 is not installed by default (dragged by some dependency), well, it should be fine
15:08:59 <tosky> </end>
15:09:37 <Kevin_Kofler> Yeah, I guess dolphin4 is the most effective way to test KDE 4 kioslaves in particular, you have a point there.
15:09:43 <rdieter> ok, I'll make sure that's implemented after meeting
15:10:03 <rdieter> 1. not installed by default (or dragged in via kde-baseapps metapackage), 2. doesn't appear in menus
15:10:38 <rdieter> oh, and minor fix, move dolphinpart to -libs
15:11:14 <rdieter> #topic Fedora Plasma theme
15:11:20 <rdieter> dvratil: ^^
15:11:33 <dvratil> first, I'm sorry I wasn't responsive last week, I went to the Randa sprints and the internet connection there was, well, not very good :)
15:11:36 <dvratil> but
15:11:46 <rdieter> np
15:12:02 <jgrulich> Hi, I'm also present, but will have to leave in 20 minutes
15:12:12 <dvratil> I talked to Jens of the VDG fame and he offered that the VDG would be willing to create a Plasma theme that would go better with our Fedora wallpapers
15:12:37 <rdieter> #info jgrulich present
15:12:52 <dvratil> so basically our own Fedora Plasma Theme that we could ship as default, and that would not look (in his own words) so horrible with the blue wallpaper :)
15:12:56 <jreznik> dvratil: what does it mean "better"?
15:13:22 <rdieter> apparently something that looks better with fedora blue
15:13:23 <jreznik> I think it looks great, much better with the standard mushroom kde wallpaper
15:13:30 <dvratil> blue-ish, or whatever colors goes well with blue wallpaper
15:13:46 <dvratil> it's not about the wallpaper, the wallpaper would stay the same
15:13:49 <rdieter> worksforme
15:13:54 <jreznik> I'm not sure I want more blue
15:14:07 <dvratil> it's about the splashscreen/logout screen/panel/etc.
15:14:17 <heliocastro> I appreciate something from design side to do that
15:14:31 <dvratil> so the question is do we want it, and do we have any special requirements/ideas/...?
15:14:43 <jreznik> dvratil: I understand and I think it works pretty well together but of course, I'm be more than happy to have Fedora theme (or at least see mockup)
15:15:08 <heliocastro> I think we should accept even to become more closer to upstream in general
15:15:22 <jreznik> dvratil: I'd like to see mockup but I think Fedora wp and current Breeze theme fits together better than original KDE wp and Breeze :)
15:15:47 <rdieter> no special requirements I can think of, I'd defer to VDG judgement on awesomeness
15:16:09 <jreznik> I would like to avoid having more blue on the screen
15:16:18 * jgrulich is not against blue Plasma theme, might be nice actually
15:16:32 <dvratil> jreznik:  noted, I'll talk to VDG and either create a forum thread where we can all discuss, or I'll just fwd VDGs ideas to the SIG (probably the first though)
15:16:37 <rdieter> no one is saying it will be blue, jus that it will match/complement blue-based wallpapers
15:16:51 <jreznik> rdieter: [17:13] <dvratil> blue-ish, or whatever colors goes well with blue wallpaper
15:17:04 <dvratil> yep, I have no idea what color goes well with blue, but it does not have to be blue :D
15:17:06 <rdieter> ok, blue-ish :-P
15:17:12 <jreznik> ok, blue-ish :D
15:17:58 <Southern_Gentlem> kurple?
15:18:04 <rdieter> #info kde VDG willing to create a Plasma theme that would go better with our Fedora wallpapers
15:18:10 <jreznik> let's see mockup and we can then comment it/provide feedback
15:18:29 <than> jreznik: +1
15:18:40 <dvratil> sure
15:18:43 <rdieter> dvratil: great, can I assume you'll continue to take the lead on this?  and let us know how things go?
15:18:45 <jreznik> maybe what makes sense is to workstationize it a bit, so fedora ws and fedora plasma fit together nicer (I know I should not say that on kde sig meeting but)
15:19:09 <dvratil> rdieter: yep, I'll ping back once we have something
15:19:14 <Kevin_Kofler> jreznik: -1
15:19:17 <dvratil> /meisdone
15:19:19 <rdieter> gracias
15:19:36 <Kevin_Kofler> Don't gnomize my Plasma!
15:20:00 <rdieter> moving on...
15:20:14 <rdieter> #topic F23 blockers/issues
15:21:10 <rdieter> just fyi, looks like we've 2 (new) f23 blockers this week: seems the theme/artwork isn't getting applied by default yet (probably my bad sorry), and pk-plasma-updates applet seems to be running on live image (needs to be disabled)
15:21:56 <rdieter> i'll probably be looking into both soon, but anyone able/willing to help would be appreciated
15:22:07 <rdieter> any other f23-related issues worth mentioning?
15:22:21 * satellit apper groups?
15:22:35 <rdieter> dvratil: I kinda assume at this point that kf5 kdepim won't be ready in time  ?
15:22:36 <Kevin_Kofler> satellit: No update there, sorry.
15:23:05 <rdieter> or worth making an extra push to get it all in for f23-beta ?
15:23:11 <dvratil> I can have kdepim, but I don't have the kdepimlibs4 compat stuff done yet
15:23:20 <than> rdieter: do you have the bz# of  f23 blockers ?
15:23:58 <rdieter> .bug 1262600
15:24:01 <zodbot> rdieter: Bug 1262600 Plasma live session notifies for available updates - https://bugzilla.redhat.com/1262600
15:24:11 <rdieter> .bug 1262599
15:24:13 <rdieter> than ^^
15:24:13 <satellit_e> https://qa.fedoraproject.org/blockerbugs/milestone/23/beta/buglist
15:24:14 <zodbot> rdieter: Bug 1262599 Fedora 23 artwork (background/wallpaper) not applied by default - https://bugzilla.redhat.com/1262599
15:24:21 <than> rdieter: thanks
15:24:27 <dvratil> I wouldn't probably push kdepim too hard now, I'd prefer more time to make sure it all works well (as opposed to getting tons of angry people who can't read their mail :))
15:25:03 <rdieter> dvratil: so... what plan then?  we can continue to work on getting all in rawhide asap... and test via copr ?
15:25:18 <rdieter> so not necessarily target f23?
15:25:18 <dvratil> that sonuds reasonable
15:25:27 <dvratil> we can push the update to F23 eventually (?)
15:25:50 <dvratil> in theory people should not notice any change, except for more awesome ;-) and missing KJots
15:25:51 <rdieter> you're saying do a kdepim kde4->kf5 update *after* F23 is released possibly?
15:26:03 <rdieter> that's scary
15:26:27 <rdieter> or try to squeeze in updates after beta (before GA)?
15:26:30 <heliocastro> kmail is scary to update
15:26:43 <Kevin_Kofler> Post-GA, I really don't think it's a good idea, sorry.
15:26:56 <heliocastro> I think after beta is ok, Post-GA nope
15:26:57 <dvratil> we pretty much polished the update, but crapton of stuff is happening for 15.12, so I'm fine with waiting for F24 with the update
15:26:59 <Kevin_Kofler> We also kept F9 on kdepim 3.5 and did not push kdepim 4.1 there.
15:27:06 <Kevin_Kofler> And back then we were MORE update-happy than now.
15:27:14 <dvratil> and in the meantime provide PIM5 from copr if anyone is interested
15:28:09 <rdieter> dvratil: ok, so general plan is keep (kde4) kdepim for f23, and target f24
15:28:35 <dvratil> +1 from me
15:29:04 <rdieter> I'll defer to your judgement on that (I happen to agree too)
15:29:30 <rdieter> any other f23 issues to mention?
15:29:35 <than> dvratil: +1 too
15:30:54 <Kevin_Kofler> +1, sounds like a reasonable plan.
15:31:07 <heliocastro> +1
15:31:12 <rdieter> dvratil: not specifically f23 related, but we seem to be getting lots of screen related crashers/bugs being filed (>1 screen), do you have any opinion or handle on that?
15:31:39 <rdieter> kinda assuming these are mostly Qt5 bugs, but that's just speculation
15:32:21 <dvratil> I noticed that but did not have chance to get through the bugs yet. I'll check if there's some more bugfixing in Qt screen stuff we could pull
15:32:30 <rdieter> (if qt5 bugs, probably best to get someone to work on triaging and upstreaming those)
15:32:32 <dvratil> (I know there's at least one)
15:32:38 <rdieter> ok, th
15:32:40 <rdieter> thx even
15:32:43 <dvratil> if there's KScreen involved, then it's up to me anyway :)
15:32:46 <heliocastro> 5.5.1 is arriving. Worth have a build now in copr ?
15:33:01 <dvratil> 5.4.1?
15:33:09 <rdieter> qt 5.5.1
15:33:09 <dvratil> no, we need 5.14 frameworks first
15:33:17 <dvratil> ah
15:33:21 <dvratil> sorry:)
15:33:29 * dvratil shuts up
15:33:35 <rdieter> ok, moving on
15:33:51 <rdieter> #topic recent kde upstream releases, plasma-5.4.1, kf5 5.14.0, kde-apps-15.08.2
15:34:00 <rdieter> speaking of 5.4.1
15:34:22 <rdieter> so I already did plasma 5.4.1, and submitted updates last earlier this week
15:34:30 <dvratil> \o/
15:34:39 <rdieter> dvratil: sounds like you had other ideas? (ie, wait for kf5 5.14?)
15:35:10 <dvratil> there *might* be some stuff in kwindowsystem/plasma-framework that we better have (in terms of bug fixes)
15:35:25 <rdieter> oh, related to plasma-5.4.x and f23, there's the upgrade path issue, of splitting out sddm-breeze theme
15:35:27 <dvratil> I can do the builds tomorrow
15:36:00 <rdieter> I forgot to mention ... so seems dnf/PK has to immediate timeframe to fix that, so I'm just going to workaround by making sddm-breeze a hard dependency
15:36:17 <rdieter> plasma-workspace : Requires: sddm-breeze , for now
15:37:11 <rdieter> #action dvratil to start work on kf5-5.14.0 tomorrow
15:37:23 <Kevin_Kofler> The dnf maintainers don't fix any of the blatant missing features in a timely manner.
15:37:29 <rdieter> i've done some baby steps importing bits of kde-apps-15.08.2 already
15:37:36 <Kevin_Kofler> Instead, they waste months trying to argue we don't need that feature.
15:37:43 <Kevin_Kofler> See e.g. --downloadonly.
15:38:02 <rdieter> I don't know about other issues, but I know *this* one is critical for handling upgrades properly
15:38:30 <rdieter> any packaging that involves split out subpkgs will suffer here
15:38:52 <rdieter> and that current implementation does not follow documented practices
15:39:59 <rdieter> Kevin_Kofler: but <nod>, sometimes a little "education" is required
15:40:22 <rdieter> (and patience)
15:41:04 <rdieter> dvratil: reminds me looking @ akonadi bugs, we still have the RFE to switch to using postgresql by default... is that still worth considering?
15:41:17 <Kevin_Kofler> The main problem is that their mindset from the beginning was to remove all the "useless" (in their eyes) features of yum in their rewrite, so now that people request them back one after the other, they keep being obstructionist.
15:41:31 <rdieter> (i'd rather not keep that feature request open indefinitely if there are no intentions to implement it)
15:41:39 <Kevin_Kofler> That said, for the Obsoletes handling, I wonder whether that can be implemented with libsolv at all.
15:41:41 <sgallagh> rdieter, Kevin_Kofler: I'm going to be liaising with the DNF people to make sure this gets fixed.
15:41:54 <Kevin_Kofler> I suspect it won't be easy, in any case.
15:41:55 <sgallagh> It isn't scheduled merely because they are already overcommitted for the next month.
15:41:56 <rdieter> sgallagh: danke
15:42:18 <dvratil> it's bit more complicitaed. PostgreSQL performs better than MySQL with Akonadi and is better maintined (because I use it :)), but we don't yet have automatic migration after major psql upgrade, so manual user intervention is required
15:42:30 <dvratil> I don't think that's something we should require our users from doing
15:42:34 <dvratil> *to do
15:42:50 <Kevin_Kofler> A SAT solver like libsolv will try to find any solution of a given system of logical equations.
15:42:51 <rdieter> dvratil: ok, so sounds like intentions are still there, and we can keep it open
15:42:51 <dvratil> so, unless the lazy upstream guy implements this, I would say stick to MySQL
15:43:04 <dvratil> s/unless/until/ ;-)
15:43:17 <Kevin_Kofler> That doesn't include preferring one kind of solution (Obsoletes) to another (regular upgrade).
15:44:07 <Kevin_Kofler> rdieter, dvratil: +1 to sticking to MariaDB
15:44:16 <rdieter> Kevin_Kofler: I don't care about the implementation, or if it may require us to change documented procedure/policy, but *some* sort upgrade path handling for split packaging is needed
15:44:29 <heliocastro> +1 for go to psql
15:44:36 <heliocastro> i use it, and is way better the mysql
15:44:41 <Kevin_Kofler> PostgreSQL needs to just work. It doesn't, for upgrades.
15:45:16 <dvratil> the major upgrades are unfortunate. It's easy to automate it, we just need to call the upgrade tool from Akonadi on start, but someone has to implement it :)
15:45:21 <Kevin_Kofler> And the upgrade procedure cannot be reasonably automated in packaging.
15:45:33 <jreznik> without it, it doesn't make sense
15:45:38 <Kevin_Kofler> dvratil: The upgrade tool doesn't work if you don't have the old PostgreSQL installed somewhere.
15:45:48 <dvratil> works now
15:45:49 <Kevin_Kofler> The alternative is to dump, upgrade, restore, which also doesn't work with RPM.
15:45:50 <rdieter> not that mysql db upgrades are all that great either, I've seen many-a-borked mysql db too
15:46:13 <Kevin_Kofler> Ah, if they have an upgrade tool you can just run now, then that'll work.
15:46:24 <Kevin_Kofler> But Akonadi needs to run it, as you say. :-)
15:46:24 <dvratil> Kevin_Kofler:  pg_upgrade
15:46:42 <dvratil> yep, and it still basically just does dump & reimport, so you also need disk space and it takes some time
15:47:19 * dvratil creates a Phabricator task
15:47:21 <rdieter> yay fun
15:47:24 <Kevin_Kofler> dvratil: Unfortunately, pg_upgrade is the tool that does NOT work without the old binaries!
15:47:30 <Kevin_Kofler> http://www.postgresql.org/docs/9.2/static/pgupgrade.html
15:47:33 <rdieter> let's move on?
15:47:38 <Kevin_Kofler> You need the old PostgreSQL binaries.
15:47:44 <Kevin_Kofler> Which you won't have in distro packaging.
15:47:52 <dvratil> we do in fedora ;0)
15:48:07 <Kevin_Kofler> Ah? Ewww!!!
15:48:07 <dvratil> just migrated couple months ago
15:48:37 <Kevin_Kofler> I'd think it's not realistic to keep the old version around to allow the migration tool, if they now do that, fine, but as I said, ewww!
15:49:00 * rdieter keeps "randa report" for last, since dvratil is phabrictor'ing
15:49:07 <Kevin_Kofler> Having old versions of the server, possibly with security holes, hidden in the new server's packaging makes me want to puke.
15:49:12 <rdieter> #topic mailing list moderation
15:50:19 <rdieter> some recent comments to kde@fpo list were arguably worthy of moderation
15:50:49 <dvratil> damn, sounds like I missed some fun
15:50:53 <rdieter> Kevin_Kofler: seems only you and I are list admins, I don't remember the password anymore, do you?
15:51:09 <tosky> is there a generic policy for this? Upstream KDE has a Code of Conduct and a group which can follow up with the various issues
15:51:14 <rdieter> if so, let's share after meeting.  if not, I'll have to request a password reset
15:51:32 <Kevin_Kofler> I can't find it either, sadly, I probably only had it on the broken hard disk. :-( I think we need to have it reset indeed.
15:51:33 <rdieter> tosky: fedora has similar, a code of conduct and community working group
15:51:46 <rdieter> Kevin_Kofler: ok, I'll do so after meeting
15:52:02 <rdieter> anyone else willing to come on board as additional ml moderators?
15:53:00 <rdieter> fyi, Reindl Harald had some personal, disparaging remarks onlist after he performed a f21->f22 upgrade
15:53:18 <rdieter> but seemed to stop the practice, after I commented on it
15:53:48 <Kevin_Kofler> Well, I'll have a look, I haven't checked on the ML for a few days, so I missed all the "fun".
15:54:12 <rdieter> he made some valid criticisms, but it's lost in the insults
15:54:31 <dvratil> also looks like he's confusing mailing list with bugzilla...
15:55:04 <Kevin_Kofler> Most of Harald's criticisms are valid, I don't think he should be banned.
15:55:05 <rdieter> #action rdieter to request kde list admin password reset
15:55:17 <rdieter> Kevin_Kofler: no one mentioned the b work, only moderation
15:55:18 <Kevin_Kofler> But I haven't read the latest thread yet.
15:55:23 <rdieter> b word
15:55:31 <dvratil> Kevin_Kofler:  it's not always the content, but the form
15:56:21 <Kevin_Kofler> The tone is just how we are here in Vienna.
15:56:35 <dvratil> :)
15:58:02 <rdieter> #topic randa report
15:58:03 <rdieter> moving on...
15:58:19 <rdieter> dvratil: ^^ how was randa?
15:58:25 <dvratil> beautiful :)
15:59:12 <rdieter> we want more than a one word report :)
15:59:16 <dvratil> I spent most time with the PIM team, I am very happy to say that we agreed on future direction, co-operation with Kolab and we did some really great performance and memory improvements
15:59:37 <dvratil> 15.12 will be an amazing release :)
16:00:07 <dvratil> Other teams in Randa were mostly focused on Android and touch devices generally
16:00:16 <heliocastro> dvratil: Did you went to mattehorn top ?
16:00:27 <dvratil> heliocastro:  not to the top, it's a bit cold up there ;)
16:00:48 <heliocastro> You missed, is one of the breathtaking views of europe
16:00:59 <dvratil> we went to Zermatt (the village under Matterhorn) and on Friday we climbed the Kreuz and did a BBQ up there, which was pretty awesome
16:01:18 * heliocastro missed Randa
16:01:24 <dvratil> I've seen the new KDEConnect Android app which now has the fancy Metro looks, so it looks really really pretty
16:01:42 <heliocastro> Metro ??
16:01:49 <dvratil> Material
16:01:51 <dvratil> sorry
16:01:55 <heliocastro> Ahhhhhh
16:01:59 <dvratil> :D
16:02:09 <heliocastro> weird android app looking windows :-)
16:02:11 <dvratil> current git should even support the reply-to-SMS-from-KTP stuff
16:02:35 <dvratil> generally I think this year was extremely productive
16:02:40 * heliocastro already compiled, is great
16:03:08 <rdieter> dvratil: thanks for the update
16:03:13 <rdieter> #topic open discussion
16:03:29 <rdieter> anything else to mention today?
16:04:13 <Kevin_Kofler> Yes…
16:04:28 <Kevin_Kofler> dvratil: Are you the one who was working on modernizing xsettings-kde?
16:04:36 <Kevin_Kofler> (If not, who was?)
16:04:57 <Kevin_Kofler> I'd like to know what has become of it, because it was lost somewhere on the road to Fedora dist-git.
16:05:23 <Kevin_Kofler> No idea whether it wasn't even completed or whether it's sitting on the developer's disk, upstream or wherever.
16:06:00 <rdieter> oh right, do we have any bugs tracking that?
16:06:02 <Kevin_Kofler> We're still stuck with the version that knows only about KDE 4 directories and that doesn't support change notifications because it still tries to use the ancient KDE 3 (!) ones.
16:06:13 <rdieter> if that work isn't completed, should seriously consider just switching to kde-gtk-config
16:06:44 <Kevin_Kofler> And drop xsettings-kde completely? That'll make us lose even more integration with GTK+ apps than we already lost. :-(
16:06:47 <rdieter> (or maybe better to work on intergrating xsettings-kde with kde-gtk-config at this point too)
16:07:15 <Kevin_Kofler> Well, that's something to look into, but that's why I was wondering about what happened to the xsettings-kde improvements.
16:07:32 <rdieter> good question
16:09:39 <rdieter> looks like nobody knows (at the moment) :(
16:09:54 <rdieter> let's continue the inquriry after meeting
16:10:10 <rdieter> had a full meeting, thanks everyone!
16:10:12 <rdieter> #endmeeting