fesco
LOGS
18:00:14 <jwb> #startmeeting FESCO (2015-09-09)
18:00:14 <zodbot> Meeting started Wed Sep  9 18:00:14 2015 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:15 <jwb> #meetingname fesco
18:00:15 <zodbot> The meeting name has been set to 'fesco'
18:00:15 <jwb> #chair ajax dgilmore hguemar jwb nirik paragan rishi thozza sgallagh
18:00:15 <zodbot> Current chairs: ajax dgilmore hguemar jwb nirik paragan rishi sgallagh thozza
18:00:18 <jwb> #topic init process
18:00:27 <jwb> #chair number80
18:00:27 <zodbot> Current chairs: ajax dgilmore hguemar jwb nirik number80 paragan rishi sgallagh thozza
18:00:30 <paragan> Hi
18:00:31 <nirik> morning everyone.
18:00:47 <rishi> .hello rishi
18:00:48 <zodbot> rishi: rishi 'Debarshi Ray' <debarshir@redhat.com>
18:00:50 <jkurik> hi FESCo
18:01:13 <jwb> i think ajax is still missing this week
18:01:35 <jwb> we'll hang on and see if sgallagh thozza and dgilmore arrive
18:01:53 <sgallagh> Hello
18:02:09 <nirik> dgilmore is traveling to fudcon LATAM I think... but he might be back online....
18:02:21 <jwb> he's typically late anyway
18:02:22 <sgallagh> (sorry, updated to the latest GNOME and lost Pidgin notifications again)
18:02:43 <number80> .hello hguemar
18:02:43 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
18:02:58 <thozza> hi all
18:03:03 <jwb> ah, excellent
18:03:08 <jwb> #topic #1467 F23 Changes - Progress at Change Checkpoint: Completion deadline
18:03:11 <jwb> .fesco 1467
18:03:13 <zodbot> jwb: #1467 (F23 Changes - Progress at Change Checkpoint: Completion deadline (testable)) – FESCo - https://fedorahosted.org/fesco/ticket/1467
18:03:14 <jwb> https://fedorahosted.org/fesco/ticket/1467
18:03:31 <jwb> i believe the news here is that everything is in order and things are either in the proper state or moved out to f24
18:03:35 <jwb> right jkurik ?
18:03:36 <thozza> So I added comments there ;) and there have been some progress also in the DNF upgrade bug
18:03:55 <jkurik> jwb: right
18:04:01 <nirik> cool. ;)
18:04:26 <jwb> #info All changes are either in MODIFIED state or moved to f24 at this point
18:04:32 <jwb> anything further on this one before we move on?
18:05:02 <jwb> ok then
18:05:12 <jwb> #topic #1472 Investigate mysterious enabled systemd presets
18:05:12 <jwb> .fesco 1472
18:05:13 <jwb> https://fedorahosted.org/fesco/ticket/1472
18:05:14 <zodbot> jwb: #1472 (Investigate mysterious enabled systemd presets) – FESCo - https://fedorahosted.org/fesco/ticket/1472
18:05:28 <jwb> sgallagh noted there were 4 presets that should probably be disabled
18:05:41 <jwb> looking at them, i certainly agree
18:05:45 <sgallagh> kalev also noted one additional
18:05:48 * nirik does too
18:05:53 <jwb> indeed
18:06:34 <jwb> proposal: Disable acpid, ladvd, lttng-sessiond, disrv-admin, and packagekit-offline-update presets
18:06:39 <nirik> +1
18:06:41 <paragan> +1
18:06:45 <sgallagh> +1
18:06:49 <rishi> +1
18:07:31 <jwb> thozza, number80 ?
18:07:47 <number80> +1
18:07:59 <number80> I was checking my notes
18:08:11 <thozza> +1
18:08:15 <jwb> great
18:08:38 <sgallagh> I'll submit a pull-request later today to fedora-release to remove those and add references to all the ones left.
18:08:43 <jwb> #agreed Disable acpid, ladvd, lttng-sessiond, disrv-admin, and packagekit-offline-update presets (+7, 0, -0)
18:08:44 <nirik> excellent.
18:08:54 <sgallagh> #action sgallagh to submit a pull-request later today to fedora-release to remove those and add references to all the ones left.
18:09:04 <jwb> ha, beat me to it.  thank you
18:09:12 <sgallagh> Any time
18:09:17 <jwb> ok, if there's nothing else, let's move on
18:09:34 * jwb pauses a bit longer as he tends to go fast
18:10:07 <jwb> moving on
18:10:08 <jwb> #topic #1474 Non-responsive maintainer - Jef Spaleta
18:10:09 <jwb> .fesco 1474
18:10:09 <jwb> https://fedorahosted.org/fesco/ticket/1474
18:10:10 <zodbot> jwb: #1474 (Non-responsive maintainer - Jef Spaleta) – FESCo - https://fedorahosted.org/fesco/ticket/1474
18:10:21 <jwb> this hasn't been the full 2 weeks, but i think this is a fairly clear cut case
18:10:29 <jwb> particularly with the emails from Jef himself
18:10:43 <nirik> yeah, he's not been around in a while. ;(
18:11:27 <jwb> paragan, and thozza voted +1 to orphan in the ticket
18:11:32 <jwb> i'm +1 as well
18:11:33 <thozza> right
18:11:39 <jwb> votes?
18:11:42 <rishi> +1
18:11:51 <nirik> sure, +1
18:12:11 <number80> +1
18:12:19 <sgallagh> +1
18:12:25 <rishi> Antartica sounds more fun than Fedora.
18:12:25 <jwb> #agreed Orphan jspaleta's packages (+7, 0, -0)
18:12:34 <jwb> nirik, can you do the "honors"?
18:12:37 <nirik> I can do the orphaning and mailing devel list that they are available.
18:12:39 * nirik nods.
18:12:50 <jwb> #action nirik will orphan and mail devel list
18:13:04 <number80> nirik: you can reassign python-dateutil to me
18:13:13 <jwb> on a side note, i'd like to thank Jef for his previous service.
18:13:16 <number80> I'll need it anyway
18:13:28 <nirik> ok
18:13:28 <number80> jwb: +1 he did great
18:13:49 <nirik> yep. Three cheers for dr jeff. Hope he has time again for Fedora down the load.
18:13:51 <nirik> road
18:14:13 <rishi> Are we planning to send him a thank you from FESCo?
18:14:21 <jwb> likely not
18:14:34 <rishi> Ok. I will send a private email.
18:14:42 <jwb> ok
18:14:48 <jwb> let's move on
18:14:50 <jwb> #topic #1475 Darktable package retirement(?)
18:14:50 <jwb> .fesco 1475
18:14:51 <jwb> https://fedorahosted.org/fesco/ticket/1475
18:14:52 <zodbot> jwb: #1475 (Darktable package retirement(?)) – FESCo - https://fedorahosted.org/fesco/ticket/1475
18:15:03 <jwb> i left this one for last as it seems to need the most discussion
18:15:20 <jwb> the two options appear to be "do nothing" or "force retire" the package
18:15:25 <sgallagh> I'm really not a fan of the way this is happening.
18:15:38 <jwb> define "this" please?
18:15:39 <sgallagh> I'd prefer to see the maintainer just orphan
18:15:55 <nirik> the maintainer seems to be missing.
18:16:01 <sgallagh> I don't like the fact that a comaintainer is attempting to wrest sole control for the purpose of retiring.
18:16:10 <sgallagh> While others have expressed interest in fixing it.
18:16:22 <jwb> "By many months I don't receive any answer from the Darktable package owner"
18:16:34 <sgallagh> Also, I think that there's an argument to be made for the utility of this package to Fedora putting it in the "Firefox" category of bundling exception
18:16:36 <number80> *sigh*
18:16:53 <nirik> sgallagh: are there people who would take ownership and do the work requested by the fpc?
18:16:57 <rishi> I don't see any wrestling for control, to be honest.
18:17:03 <jwb> sgallagh, that would require us to tell the FPC to grant an exception
18:17:08 <jwb> rishi, nor i
18:17:16 <jwb> wrestling would involve two people.
18:17:41 <sgallagh> rishi: The comaintainer (Caterpillar) has actively complained about attempts by provenpackagers to take things over and clean them up.
18:17:56 <number80> jwb: +1, I don't want to force a decision on FPC for *one* package
18:18:28 <number80> sgallagh: has he given example of problematic commits ?
18:18:28 <sgallagh> number80: The FPC *is* a subcommittee of FESCo. We can overrule them if we deem it worthwhile.
18:18:29 <rishi> sgallagh: He wrote one sentence about broken updates by provenpackagers.
18:18:41 <number80> sgallagh: it's true but we never did in the past
18:18:44 <rishi> But anyway, it isn't the main issue, I guess.
18:18:55 <jwb> sgallagh, you seem to be reading this in a much more dramatic tone than the rest of us
18:18:55 <nirik> kalev did some work on it... modernizing the spec, etc.
18:19:03 <sgallagh> The main issue (to me) is that we have a highly-valuable package at risk because of our packaging rules.
18:19:11 <number80> rishi: no example, I assume provenpackagers were correct
18:19:20 <jwb> why is it at risk?  there's a copr
18:19:22 <nirik> (and updated it and built it against lua, etc)
18:19:52 <nirik> number80: apparently there's some brokenness with the lua stuff, but wasn't documented anywhere
18:20:26 <thozza> sorry, it came too late for me to read the FPC ticket
18:20:27 <number80> nirik: ok, but modernizing spec is hardly an attempt of take over
18:20:37 <rishi> To be honest, this rawspeed thing looks similar to all the git submodule based stuff that we have these days.
18:20:49 <nirik> sure, but it's not something you want to do to something that is going to be retired either really.
18:20:51 <rishi> https://fedorahosted.org/fpc/ticket/550#comment:2
18:21:14 <rishi> sgallagh: Yes, I agree about that.
18:21:29 <nirik> I'm fine with orphaning it if there's people who would take it and do the FPC requested unbundling. If not, I'm ok with retiring it.
18:21:32 <rishi> Given comment 2 on that ticket, I would have been happier if the FPC didn't object to it.
18:21:53 <sgallagh> nirik: I'd rather orphan it and let it sort itself out.
18:22:05 <number80> sgallagh: +1
18:22:08 <sgallagh> nirik: It will get retired in F24 if no one picks it up. That's the worst case.
18:22:16 <jwb> sgallagh, that won't actually work.
18:22:22 <nirik> sure, but it might get picked up and have nothing happen to it.
18:22:27 <jwb> because the co-maintainer will grab it and then have ACLs to retire it anyway
18:23:03 <sgallagh> jwb: Well, there was an unspoken "ask Caterpillar not to do that" there.
18:23:10 * rishi is looking at what rawspeed really has in it
18:23:26 <number80> people grabbing packages to force retirement is clearly not ok
18:23:29 <jwb> unspoken things in irc meetings have a tendency to remain unspoken
18:23:36 <sgallagh> Fair enough.
18:23:49 <jwb> also, a Copr of this package exists and is more up to date than the fedora repo copy
18:23:55 <jwb> why is that not sufficient?
18:24:06 <jwb> it seems like the exact kind of package/situation Copr is great for
18:24:10 * nirik nods
18:24:25 <sgallagh> jwb: Then we need to get this package onto the short list of GNOME Software semi-enabled COPRs
18:24:37 <jwb> i have no problems with that
18:24:45 <sgallagh> Because it's a promoted package in GNOME Software and one that's installed *a lot*
18:25:01 <jwb> excellent.  so let's stop forcing people to install a broken version of it
18:25:03 <rishi> sgallagh: If we are going to promote / semi-enable it, then I would rather see it fixed the right way.
18:25:05 <sgallagh> jwb: (I wasn't arguing, I was attempting to itemize where we need to go)
18:25:22 <jwb> rishi, define the right way
18:25:37 <jwb> because we've established that upstream makes "the fpc way" fairly impossible
18:25:55 <rishi> jwb: Then maybe, just maybe, the FPC is wrong?
18:25:56 * nirik thinks now we should just retire and if there are people that will unbundle, etc they can submit it for review.
18:26:23 <rishi> As I said before ...
18:26:25 <jwb> rishi, perhaps.  but overriding them to grant an exception isn't "fixing" anything
18:26:29 <rishi> This rawspeed thing looks similar to all the git submodule based stuff that we have these days.
18:26:41 <rishi> jwb: We already have precedence.
18:27:13 <nirik> where?
18:27:15 <jwb> we're disagreeing on the word FIX here.  fix implies "change to the software".  what your proposing is "acknowledge the situation and override FPC"
18:27:23 <rishi> Just like libgd, telepathy-account-widgets, etc. rawspeed is not an established system library.
18:28:06 <rishi> nirik: libgd, telepathy-account-widgets, etc.. gnome-control-center and gnome-settings-daemon has/had some copy-pasted code.
18:28:17 <nirik> forked versions of something else?
18:28:21 <rishi> No.
18:28:26 <rishi> Copy pasted code.
18:28:36 <nirik> the fpc determined that this is not a copylib
18:28:58 <rishi> I have seen atleast a dozen copy pasted widgets all over GNOME.
18:29:07 <rishi> Not everything needs to be a formal library.
18:30:18 <rishi> nirik: https://fedorahosted.org/fpc/ticket/550#comment:2 makes it clear that it is not a normal shared library either.
18:30:49 <nirik> sure, but it's much larger than a few lines.
18:30:50 <rishi> Are we really going to stop 2 upstreams from sharing ad-hoc code in whatever way they want?
18:31:04 <jwb> rishi, our decision has no impact on upstream
18:31:52 <rishi> jwb: It has, in the sense that we are talking about removing a popular application from our repositories (only to semi-enable it through a side channel).
18:32:10 <jwb> that doesn't impact upstream.  that impacts Fedora
18:32:38 <number80> rishi: popular is not enough, or I could name multiple packages that are going to be retired because of guidelines
18:32:59 <number80> if we force that for darktable, what about hadoop?
18:33:01 <rishi> number80: Eh?
18:33:21 <jwb> you are starting to get into the weeds
18:33:35 <jwb> let's focus on this specific issue and how we want to deal with it in fedora please
18:33:43 <rishi> jwb: It does because upstream developers can't get their app into the hands of Fedora users without having them enable some weird non-official repo.
18:33:57 * number80 stepping down from this issue
18:34:00 <rishi> And I already gave evidence of prior art.
18:34:06 <jwb> rishi, that is to the detriment of fedora, because people that want it enough will use Ubuntu or something else
18:34:57 <rishi> jwb: Whatever. I don't want to play with words here. My point is that we have prior art of this thing in the distribution, so I don't see why we are going to make an example out of darktable / rawspeed.
18:35:25 * nirik thinks those things should be noted or fixed too
18:35:26 <jwb> we, being fesco, haven't done anything yet.  perhaps a deep breath would be good
18:35:50 <jwb> so there seem to be 3 proposals
18:35:57 <jwb> a) retire and point to Copr
18:36:05 <jwb> b) overrule FPC and update repo package
18:36:13 <jwb> c) orphan/do nothing
18:36:49 <jwb> s/proposals/options
18:36:50 <sgallagh> I'm a clear -1 on c)
18:37:15 <sgallagh> I very much want to see this available to Workstation users with minimal effort.
18:37:52 <jwb> i'm also -1 on c)
18:37:58 <sgallagh> I'll go with the majority on whether to overrule FPC, but if we don't do so, I want GNOME Software enabling the COPR
18:38:00 <jwb> mostly because it doesn't help anything
18:38:01 <nirik> I guess I'm +1 on a, -1 on b or c
18:38:09 <linux-modder> I would be -1 too to c)
18:38:09 <paragan> +1 to option a)
18:38:22 <jwb> linux-modder, please avoid voting unless you are a fesco member
18:38:28 <number80> -1 on b) this would encourage people requesting fesco overruling FPC
18:38:43 <sgallagh> I guess that would make me a) +1, b) +0, c) -1
18:38:48 <number80> +1 for a)
18:39:16 <rishi> I am (a) -1 (b) +1 (c) -1
18:39:21 <thozza> +1 for a)
18:39:37 <thozza> jwb: good luck counting this ;)
18:39:43 <jwb> i think i can sort it.  one sec
18:39:51 <sgallagh> For the sake of consensus, what would it take to get to a) +1?
18:40:01 <jwb> 5 votes
18:40:06 <sgallagh> What would alleviate your concern about the "official" label?
18:40:08 <rishi> Isn't dcraw (or whatever it is) also copied in a bunch of places?
18:40:31 <rishi> I can't keep track of all the RAW processing libraries / codebases out there.
18:40:49 <jwb> rishi, your point is made, but i'm afraid it's going to work against you in the long run
18:40:55 <number80> rishi: I could name a lot of packages that don't respect guidelines or have never requested bundling exception, not the right time to discuss this
18:40:55 <sgallagh> /me notes that we've had the "Playground" plans out there for a while
18:41:05 <sgallagh> That's pretty much how we're delivering things like PyCharm
18:41:13 <jwb> let me count the voting
18:41:30 <number80> jwb: to you want that we put more formally our votes?
18:41:34 <sgallagh> jwb: Mind if I try a worded proposal instead?
18:41:58 <jwb> sgallagh, sure, propose away and we'll revote
18:42:25 <sgallagh> Proposal: Retire darktable from the Fedora repositories. Request that the Workstation WG add darktable to the list of approved "Playground" repositories that are available in GNOME Software, but disabled by default.
18:42:42 <rishi> jwb: Good luck forcing the whole world to make a formal shared library out of every piece of shared code.
18:43:11 <sgallagh> rishi: You're getting into the exact reason why we've been trying to sort out how to do "rings" of policy.
18:43:20 <sgallagh> That's a conversation to have outside of this meeting, though
18:43:24 <nirik> sgallagh: +1
18:43:35 <number80> sgallagh: +1 this is the kind of problem we have solve globally not for every case
18:43:39 <jwb> rishi, i'm not even disagreeing with you.  i've been agitating against the guidelines for a long time because they're complicated and they keep growing longer.  but you are not helping your case
18:43:41 <paragan> sgallagh, +1
18:43:44 <nirik> (but if the workstation WG wants to add it they can... should we really vote on that? but whatever)
18:43:57 <sgallagh> number80: Was that a vote for my proposal or a reply to the rings statement?
18:44:06 <number80> sgallagh: both
18:44:08 <sgallagh> ok
18:44:14 <jwb> +1 for the proposal
18:44:21 <thozza> sgallagh: +1
18:44:30 <sgallagh> +1 to my own proposal
18:44:36 <rishi> jwb: I don't need to help my case. This is just reality.
18:44:37 <jwb> that's +5 so far
18:44:47 <jwb> oh +6
18:44:53 <rishi> -1
18:45:29 <rishi> -1 because I don't understand why we will remove something from the official repositories, only to add it back.
18:45:41 <jwb> rishi, it is.  and eventually reality will run right past Fedora on many things.  but until we have that discussion, i don't see grounds for moving on
18:46:03 <jwb> er, s/moving on/overriding
18:46:11 <jwb> sorry, brain thinking faster than fingers
18:46:27 <jwb> ok, so i have +6, -1 for sgallagh's proposal
18:46:53 <jwb> sgallagh, can you do the #agreed?
18:46:56 <rishi> jwb: I don't know what you meant by "grounds for moving on".
18:47:04 <jwb> rishi, s/moving on/overriding
18:47:11 <jwb> see next 2 lines below that
18:47:17 <sgallagh> #agreed Retire darktable from the Fedora repositories. Request that the Workstation WG add darktable to the list of approved "Playground" repositories that are available in GNOME Software, but disabled by default.
18:47:19 <rishi> jwb: Consistency? Precedence?
18:47:22 <sgallagh> #undo
18:47:22 <zodbot> Removing item from minutes: AGREED by sgallagh at 18:47:17 : Retire darktable from the Fedora repositories. Request that the Workstation WG add darktable to the list of approved "Playground" repositories that are available in GNOME Software, but disabled by default.
18:47:30 <sgallagh> #agreed Retire darktable from the Fedora repositories. Request that the Workstation WG add darktable to the list of approved "Playground" repositories that are available in GNOME Software, but disabled by default. (+6, 0, -1)
18:48:12 <jwb> rishi, precedence requires that fpc knew of the issues and allowed them.  you are literally listing things out that FPC has every grounds to go declare unfit since they were not aware
18:48:27 <rishi> jwb: I am sure the FPC is aware of libgd.
18:48:39 <jwb> the only thing consistent with those packages is that the FPC is consistently not doing review of existing packages for issues.
18:48:41 <rishi> I have seen tickets about it in the past.
18:49:18 <rishi> And unless you look into every file in every package, you won't ever know how much code out there is copy-pasted.
18:49:30 <jwb> rishi, now, i would very much like to see a broader discussion between FESCo, the FPC, and the Council on what the hell we plan to do about our packaging policies and the every growing reality of bundled code
18:49:39 <jwb> would you care to open a ticket to get it rolling?
18:49:53 <rishi> These guys are atleast honest about it making it somewhat clear.
18:49:59 <rishi> jwb: Ok, I will do that.
18:50:02 <jwb> great.
18:50:07 <rishi> Where do you want to open the ticket?
18:50:11 * nirik notes we do allow some bundling and some copylibs
18:50:19 <nirik> it's not a "no never" thing.
18:50:24 <jwb> rishi, either the Council or FESCo trac instances
18:50:36 <jwb> you pick, i'll make sure it gets to the rest
18:50:45 <rishi> jwb: I will start small with FESCo.
18:50:49 <jwb> sounds great
18:50:57 <jwb> we might even come up with a proposal for the other groups
18:51:07 <jwb> i'm going to move on to open floor now though
18:51:15 <jwb> er, next week's chair
18:51:20 <jwb> #topic Next Week's Chair
18:51:23 <jwb> who wants it?
18:51:28 * jwb waits at least 2 min
18:51:28 <rishi> I can do it.
18:51:32 <jwb> excellent!
18:51:36 <jwb> #info rishi to chair next week
18:51:39 <rishi> I need to make up for the fiasco 2 weeks ago.
18:51:44 <jwb> #topic Open Floor
18:51:50 <jwb> anything for open floor?
18:51:54 <thozza> no
18:52:12 * nirik has nothing off hand.
18:52:21 <sgallagh> We're now in Beta Freeze.
18:52:27 <sgallagh> Perhaps an announcement should be made about that?
18:52:53 <nirik> oh yeah.
18:53:00 * nirik can do so if no one else wants to
18:53:13 <jwb> #action nirik to announce Beta freeze
18:53:16 <jkurik> sgallagh: I talked to dgilmore and he is going to send it once rel-eng is ready
18:53:21 <jwb> #undo
18:53:21 <zodbot> Removing item from minutes: ACTION by jwb at 18:53:13 : nirik to announce Beta freeze
18:53:27 <jwb> #action dgilmore to announce Beta freeze
18:53:29 <jwb> ;)
18:53:32 <nirik> huh, ok...
18:53:36 <sgallagh> Define "ready"?
18:53:41 * nirik knows of no unreadyness
18:53:55 <sgallagh> (And why aren't they, since we have technically been in Freeze since 00:00 UTC yesterday
18:54:11 <jwb> anything else?
18:54:12 <nirik> right. I did the last final push a bit late... it was around 01:00
18:54:20 <nirik> but everything is set as far as I know
18:55:30 <jkurik> sgallagh: I am not sure what exactly needs to be done on rel-eng side
18:55:42 <nirik> I can ping dgilmore when he gets online
18:56:03 * jwb will end the meeting in 2 min
18:56:54 <sgallagh> jwb: Next chair?
18:57:05 <sgallagh> Oh, I missed it above. Sorry
18:58:12 <jwb> #endmeeting\