g11n
LOGS
04:30:09 <pravins> #startmeeting g11n
04:30:09 <zodbot> Meeting started Wed Aug 26 04:30:09 2015 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:30:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
04:30:15 <pravins> #meetingname g11n
04:30:15 <zodbot> The meeting name has been set to 'g11n'
04:30:16 <mfabian> Hi!
04:30:21 <pravins> #topic agenda and roll call
04:30:24 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2015-08-12
04:30:30 <pravins> #undo
04:30:30 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f54ed2bf390>
04:30:36 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2015-08-26
04:30:42 <pravins> hi mfabian :)
04:30:47 <pravins> who else there for meeting today?
04:31:23 <epico> hi
04:31:42 <tagoh_> hi
04:31:57 <pravins> hi tagoh_ epico :)
04:32:25 <pravins> while other joins lets go through schedule
04:32:36 <pravins> #topic Upcoming schedule
04:32:36 <pravins> #info 2015-09-08 	Beta Freeze (*)
04:32:37 <pravins> #info 2015-09-08       Change Checkpoint: 100% Code Complete Deadline
04:32:37 <pravins> #info 2015-09-22 	Beta Release
04:32:37 <pravins> #info 2015-10-13 	Final Freeze (*)
04:32:37 <pravins> #info 2015-10-27 	Fedora 23 Final Release
04:33:22 <pravins> Software Translation deadline was yesterday
04:33:42 * pravins not aware regarding L10N steps much
04:33:52 <pravins> noriko: hi :)
04:34:02 <noriko> hi!
04:34:03 <pravins> anything pending from L10N for upcoming deadlines?
04:35:05 <paragan> hi
04:35:06 <noriko> pravins, nothing I heard of so far, so it was 25-Aug
04:35:15 <pravins> from i18n experience on thing i feel Docs Beat is one
04:35:23 <pravins> hi paragan :)
04:36:53 <pravins> noriko: do we provide documentation for L10N for each Fedora release?
04:37:41 <noriko> pravins, yes, some teams do.
04:38:07 <pravins> dunno, if it makes sense to L10N but no harm is trying for same.
04:38:44 <noriko> we do have publisher for each team.
04:38:44 <pravins> umm, there is no L10N in https://docs.fedoraproject.org/en-US/Fedora/22/html/Release_Notes/
04:39:11 <pravins> dunno even if it make sense for release notes
04:39:16 <pravins> we can ask to doc team may be
04:39:32 <pravins> #info No documentation for L10N in F22 release notes
04:39:43 <noriko> https://docs.fedoraproject.org/en-US/Fedora/22/html/Release_Notes/index.html
04:39:50 <noriko> doh,
04:39:59 <tagoh_> pravins: what the kinda documentation do you expect to see there?
04:40:17 <noriko> pravins, you can toggle the languages with dropdown menu
04:40:38 <pravins> May be language available with localization? and there %?
04:40:54 <pravins> not sure
04:41:39 <pravins> noriko: no, i dont mean localization of release notes. rather content about localization in release notes. observe section about i18n.
04:42:25 <pravins> does it make sense?
04:42:49 <pravins> noriko: do you think we can add anything else in release notes, specifically on localization part?
04:42:50 <noriko> pravins, https://fedora.zanata.org/iteration/view/fedora-release-notes/f22
04:42:59 <pravins> need to explore it
04:43:33 <noriko> pravins, ? I'm lost, what you look after?
04:43:51 <pravins> noriko: https://docs.fedoraproject.org/en-US/Fedora/22/html/Release_Notes/sect-Release_Notes-Changes_for_Desktop.html#i18n
04:44:42 <fujiwarat> hi
04:44:52 <pravins> noriko: will discuss on this after meeting.
04:44:55 <pravins> fujiwarat: hi :)
04:45:03 <pravins> #topic G11N FAD - proposal Pravin
04:45:04 <pravins> #info #43: G11N FAD in 2015 (pravins)
04:45:04 <pravins> #link https://fedorahosted.org/i18n/ticket/43
04:45:29 <pravins> positive news. OSAS is fine to provide budget more than $5000 for G11N FAD
04:46:03 <pravins> Now final approval is pending from FPL though it will be just like formality since he has already shown support for G11N fad earlier
04:46:30 <pravins> now we should again start thinking how can we make it more successful.
04:47:22 <pravins> Each attendee is already contributing to Fedora from long time.
04:47:57 <pravins> I think it will be helpful if each attendee gives at least couple of idea which we can achieve/complete/plan during FAD.
04:48:56 <pravins> may be we can brainstorm on them later for it.
04:49:27 <pravins> We have draft ready
04:49:31 <pravins> #link https://ethercalc.org/g6f8rg28bz
04:50:11 <pravins> Any idea to discuss now?
04:50:39 <pravins> i hope by next meeting we will have more concrete draft ready.
04:52:47 <pravins> #action each attendee of G11N FAD suggest some more ideas to achieve/complete/plan during FAD.
04:53:12 <pravins> any more questions on FAD?
04:53:50 <noriko> pravins,
04:53:58 <pravins> yes
04:54:15 <noriko> FAD is fully open to everyone who interests fedora, right?
04:54:41 <noriko> or not...?!
04:54:42 <pravins> not exactly, its for Fedora contributors.
04:54:52 <noriko> ah, yes :-)
04:54:59 <noriko> pravins, then my qustion is
04:55:13 <noriko> what is our plan to advertise the FAD?
04:55:37 <pravins> noriko: good question.
04:55:54 <noriko> say, it is held in tokyo, then for fedora contributors in tokyo would be good position to access, and it is great chance for them.
04:56:24 <pravins> yeah, it will be nice if we can get few Fedora contributors from Tokyo to attend this.
04:56:35 <pravins> but it should be not more.
04:56:39 <pravins> managing will be difficult.
04:57:11 <pravins> 3-4 Fedora contributors from toyko will be helpful.
04:57:25 <pravins> also advertising can be for 2 purpose
04:57:54 <pravins> 1. To informing other Fedora dev, users that something like G11N FAd is happening - awareness
04:58:33 <pravins> 2. For getting new contributors -
04:59:02 <pravins> How about having session on basic of G11N in FAD if we have good numbers of new contributors interested to attend
04:59:24 <anish_> hi
04:59:28 <pravins> but we can do this in Fedora 23 release party when we can get other contributors from Toyko
04:59:32 <pravins> hi anish_ :)
04:59:41 <noriko> pravins, it sounds we'd better to clarify the objectives of this FAD?
05:00:16 <pravins> objectives are clear. https://fedoraproject.org/wiki/FAD_G11N_2015
05:00:27 <noriko> so that the objectives naturally filter the people to suit to attend, no?
05:00:39 <pravins> now we are trying to see how many other activities we can do during same time, which can benefit Fedora in long term
05:01:21 <pravins> it does but new contributors or interested people can definitely attend FEdora 23 release event
05:01:32 <pravins> and that is time when we can educate them on G11N activities
05:02:02 <noriko> fedora 23 release party?
05:02:16 <pravins> yes, its in plan for 3rd day presently
05:02:37 <noriko> ouch! sorry I totally forgot that part
05:02:44 <pravins> no problem :)
05:03:38 <pravins> any more ideas for FAD? or we will move to next topic
05:04:08 <anish_> do we have any fixed plans we want to discuss/hack?
05:04:29 <pravins> plans are not fixed but depending upon ideas, we can plan some sprints
05:05:02 <pravins> we will be around 15-20 attendees. I think we can definitely split in smaller groups to work on specific sprints
05:05:24 <anish_> cool
05:05:43 <pravins> moving to next topic
05:05:44 <pravins> #topic Zanata feedback survey - Ani
05:05:49 <pravins> #3: Zanata translation platform user survey
05:05:52 <pravins> #link https://fedorahosted.org/G11N/ticket/3
05:06:06 <pravins> Luke has prepared first questions draft.
05:06:10 <pravins> #link https://zanata.atlassian.net/wiki/display/COM/Fedora+Community+Survey
05:06:32 <pravins> unfortunately no Ani, Luke and even Alex here today :(
05:06:34 <juhp> hi
05:06:49 <pravins> hi juhp :)
05:07:07 <pravins> aeng: hi. just in time.
05:07:26 <aeng> hi pravins
05:07:30 <pravins> We drafted few objective in last survey planning meeting
05:07:34 <pravins> #link https://meetbot.fedoraproject.org/fedora-g11n/2015-07-30/zanata-survey.2015-07-30-03.42.html/
05:08:12 <pravins> aeng: should we go through questions now, or should plan another meeting to go through it?
05:08:30 <pravins> i think we should see if our questions are aligning objective or not
05:08:36 <aeng> pravins, im meeting now
05:08:48 <pravins> sure. i think make sense to have other meeting.
05:09:22 <pravins> #action Ani to plan different meeting to finalize Zanata feedback survey
05:09:53 <pravins> #topic G11N infrastructure requirements
05:09:57 <pravins> #link https://fedorahosted.org/G11N/ticket/1
05:10:02 <pravins> no update. Wiki preparation again pending on me :(
05:10:08 <pravins> I am hoping we will able to close this ticket soon.
05:10:41 <pravins> #topic Localization test day for Fedora 23
05:10:44 <pravins> #link https://fedorahosted.org/G11N/ticket/1
05:11:03 <pravins> L10n test day https://fedorahosted.org/fedora-qa/ticket/473
05:11:48 <pravins> We had good test day.
05:11:57 <pravins> Results are now available at the bottom of test day page.
05:12:00 <pravins> #link https://fedoraproject.org/wiki/Test_Day:2015-08-18_L10N?rd=/Test_Day:2015-08-18_L10N
05:12:19 <pravins> i talked with Ani earlier, she will prepare event report soon.
05:12:50 <pravins> #topic I18n test day for Fedora 23
05:12:54 <pravins> #link https://fedorahosted.org/i18n/ticket/52
05:12:57 <pravins> #link https://fedoraproject.org/wiki/Test_Day:2015-09-01_i18n
05:13:13 <pravins> I forgot to add this in Wiki. just added now.
05:13:20 <pravins> only 5 days left for i18n test day.
05:13:31 <pravins> what todo items remaining?
05:13:57 <juhp> ah so soon
05:14:07 <paragan> test cases are ready and updated?
05:14:11 <pravins> yeah, me too feel same :)
05:14:32 <paragan> iso requested in fedora-qa ticket?
05:14:41 <juhp> who is the owner? :)
05:15:28 <juhp> tagoh_, ?
05:15:35 <pravins> yeah
05:16:17 <tagoh_> I've submited a ticket yes
05:17:06 * pravins looking for metadata page.
05:17:31 <pravins> i think we support to drop yum-langpacks from test day
05:17:50 <pravins> #link http://209.132.184.193/testdays/show_event?event_id=26
05:17:52 <pravins> still has it.
05:18:46 <pravins> Here is metadata page
05:18:47 <pravins> https://fedoraproject.org/wiki/I18N/TestdayApp/F23
05:20:15 <juhp> wonder if any of this testing could be automated?
05:20:24 <pravins> i think ibus-libzhuyin testcase also remaining
05:20:34 <pravins> juhp: good point !!
05:20:48 <juhp> like use I think epico created libzhuyin testcase?
05:20:58 <juhp> s/like use //
05:21:14 <juhp> pravins, it might be another good topic for FAD even?
05:21:17 <epico> yes, I created one.
05:21:29 <juhp> but guess it is not integrated yet
05:21:31 <noriko> +1
05:21:39 <pravins> nice topic
05:22:02 <epico> https://fedoraproject.org/wiki/QA:New_Zhuyin
05:22:11 <pravins> i am sure adamw can provide some input for automation :)
05:22:17 <pravins> epico: nice
05:22:21 <pravins> epico++
05:22:21 <zodbot> pravins: Karma for pwu changed to 2:  https://badges.fedoraproject.org/tags/cookie/any
05:22:29 <epico> :)
05:22:49 <pravins> last time we created article for Fedora Magazine
05:22:53 <pravins> for testing
05:23:16 <pravins> dunno what can we do to increase awareness for i18n test day this time.
05:24:18 <pravins> article in magazine each release does not make sense. May be i can ask mattdm to add it in weekly 5 news.
05:24:44 <pravins> #action pravins to ask FPL if he can add i18n test day news in magazine article.
05:24:48 * epico added ibus-libzhuyin test case to F23 Test day.
05:24:51 <pravins> definitely we can blog about it.
05:25:53 <pravins> any other new packages in Fedora 23 for i18n?
05:26:20 <pravins> any gnome specific packages?
05:27:16 <adamw> juhp: pravins: i would like to try and get non-english installation testing running in openQA
05:27:30 <adamw> it shouldn't be especially difficult, it's basically just a question of taking a few extra screenshots in different languages
05:27:41 <juhp> adamw, aha
05:27:45 <adamw> I just need to find some time to get around to it.
05:28:18 <juhp> someone adding the zhuyin test?
05:28:50 <pravins> adamw: that will be excellent
05:29:08 <juhp> adamw, installation testing will also be great but I would like to do automated desktop testing too for i18n
05:29:46 <juhp> what's that python library again?
05:30:32 <juhp> ah behave was on my mind since fudcon
05:30:36 <pravins> Few dimensions of testing can be IME, rendering, defaults font
05:30:36 <tagoh_> dogtail you mean?
05:31:27 <juhp> pravins, yeah particular for IME and rendering - rendering might need a different approach though
05:31:32 <juhp> tagoh_, that might be another to consider
05:32:03 <juhp> pravins, or not
05:32:17 <pravins> its possible i guess.
05:32:55 <pravins> calling particular IME and checking output with expected output. it can server two purpose working of lib and accuracy.
05:33:57 <pravins> for rendering UTRRS is what we are expecting from long time
05:34:21 <pravins> it can help, if some more automation introduced in it.
05:34:30 <pravins> more languages and more on the fly image comparison.
05:34:58 <pravins> #idea automated testing can be one topic in G11N FAD
05:35:08 <pravins> #info IME and rendering testing
05:35:24 <pravins> #info dogtail can be used
05:35:55 <pravins> #info adamw planning to get non-english installation testing running in openQA
05:36:00 <pravins> we are already over the time
05:36:09 <pravins> moving to last topic
05:36:13 <pravins> #topic Open Floor
05:36:20 <pravins> if nothing else lets close meeting soon
05:37:30 <pravins> closing meeting
05:37:34 <pravins> thanks everyone for meeting :)
05:37:37 <pravins> #endmeeting