i18n
LOGS
06:00:06 <pravins> #startmeeting i18n
06:00:06 <zodbot> Meeting started Wed Aug  5 06:00:06 2015 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:00:10 <pravins> #meetingname i18n
06:00:10 <zodbot> The meeting name has been set to 'i18n'
06:00:11 <mfabian> Hi!
06:00:23 <pravins> hi mfabian :)
06:00:24 <paragan> Hi
06:00:31 <epico> hi
06:00:33 <pravins> #topic agenda and roll call
06:00:36 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2015-08-05
06:00:41 <pravins> hi paragan epico :)
06:01:07 <pravins> who else there?
06:01:10 <fujiwarat> hi
06:01:23 <pravins> hi fujiwarat :)
06:01:29 <pravins> ok, lets start while other join
06:01:37 <pravins> #topic Upcoming schedule
06:01:44 <pravins> #info 2015-08-11   Alpha Release
06:01:44 <pravins> #info 2015-08-25   Software Translation Deadline
06:01:44 <pravins> #info 2015-09-08 	Beta Freeze (*)
06:01:44 <pravins> #info 2015-09-08   Change Checkpoint: 100% Code Complete Deadline
06:01:44 <pravins> #info 2015-09-22 	Beta Release
06:01:45 <pravins> #info 2015-10-13 	Final Freeze (*)
06:01:46 <pravins> #info 2015-10-27 	Fedora 23 Final Release
06:02:11 <pravins> Alpha release just 6days away. !!
06:03:02 <pravins> This time also we are exactly on schedule. Yet no sleep in schedule.
06:03:11 <pravins> #topic New topics
06:03:15 <pravins> #info #43: G11N FAD in 2015 (pravins)
06:03:18 <pravins> #link https://fedorahosted.org/i18n/ticket/43
06:03:33 <gusennan> Hello il8n people, I'm new here and looking to help.
06:04:32 <pravins> gusennan: hi and welcome :)
06:05:15 <gusennan> @pravins, thanks
06:05:17 <tagoh_> hi
06:05:18 <pravins> We have lots of bug open. Will talk about it in Open floor !!
06:05:21 <pravins> hi tagoh_ :)
06:05:42 <juhp> hi
06:05:52 <pravins> hi juhp :)
06:05:53 <pravins> I tried to get update on this Monday. Unfortunately Ruth is on PTO and once she back Remy suppose to talk with her on budget stuff.
06:05:59 <juhp> sorry I am late
06:07:04 <pravins> no problem :)
06:07:57 <pravins> We had few discussion on council mailing list. Might be some of you might have seen it.
06:07:58 <pravins> #link https://lists.fedoraproject.org/pipermail/council-discuss/2015-August/013577.html
06:08:21 <pravins> Basically council ask us to present few more plan about G11N. This is not related with FAD but in general.
06:09:48 <pravins> May be i will jump in and try to answer queries in next meeting. I am sure we can get good inputs from council for future directions.
06:10:14 <pravins> Coming back to FAD again. In last couple of weeks we got queries whether do we need 3 days for FAD?
06:10:44 <pravins> Should we start working on schedule for it? It will make things more clear.
06:13:03 <juhp> pravins, good idea
06:13:24 <juhp> seems there is potentially a lot to do though
06:13:46 <pravins> yeah.
06:13:49 <pravins> #link https://fedoraproject.org/wiki/FAD_G11N_2015
06:14:44 <pravins> juhp: may be we can work on schedule this or next week.
06:14:56 <pravins> anyone else would like to participate in preparing schedule?
06:15:15 <pravins> we will bring aeng and noriko also while preparing schedule.
06:15:30 <pravins> specifically for Zanata and L10N tasks.
06:15:57 <pravins> #info We are going to start preparing schedule for FAD in coming week.
06:16:13 <gusennan> is there somewhere I could find information/documentation about how Zanata, L10N and L18n differ?
06:17:06 <pravins> gusennan: https://fedoraproject.org/wiki/G11N/Globalization_Proposal
06:17:43 <juhp> pravins, I will also join the schedule planning
06:17:49 <pravins> nice :)
06:18:33 <juhp> we should probably start drafting with ideas and then brainstorm/polish more in the meeting
06:18:59 <juhp> though already things listed on the FAD page I think but needs to be fleshed out
06:19:09 <pravins> yes.
06:19:35 <juhp> and yes scoping the time needed
06:19:49 <juhp> parallel sessions are also possible
06:19:55 <juhp> or groups
06:20:04 <pravins> right. parallel session is good option.
06:20:36 <pravins> after general session we can split in small groups and do some activities.
06:21:01 <pravins> #info Parallel sessions are possible in G11N FAD
06:23:27 <pravins> may be we can plan short meeting on #fedora-g11n for working on schedule. It can be meeting or general discussion.
06:23:47 <juhp> yes
06:24:17 <juhp> when do you want to have the meeting?
06:24:27 <pravins> how about Friday?
06:24:34 <juhp> +1
06:24:53 <pravins> same time?
06:25:58 <pravins> #action pravins to schedule meeting to discuss schedule for G11N FAD on Friday 2015/08/07
06:26:19 <pravins> lets move to next topic
06:26:28 <pravins> #info #50: Feature/Change planning for Fedora 23 (pravins)
06:27:17 <pravins> Our 3 change proposals are already complete. Only remaining was glibc locale subpackaging
06:27:24 <pravins> mfabian: do you want to update on same?
06:28:37 <pravins> other points was
06:28:44 <mfabian> The glibc locale subpackaging should be moved to F24, otherwise nothing new.
06:28:55 <juhp> pravins, sure - same time as today should be fine
06:29:05 <pravins> juhp: sure.
06:29:14 <pravins> mfabian: i think we need to update Wiki page also for same.
06:29:27 <juhp> mfabian: please
06:29:34 <juhp> and bugzilla?
06:29:51 <mfabian> OK, I’ll do that.
06:29:56 <pravins> thanks :)
06:30:28 <juhp> mfabian: also seems useful to have C.utf8 for containers
06:30:35 <juhp> :)
06:30:45 <pravins> yeah, i also saw few updates today on bugzilla.
06:30:48 <juhp> mfabian: it is not yet in rawhide right?
06:31:07 <mfabian> juhp: Yes, C.UTF-8 would be even smaller than en_US.UTF-8
06:31:15 <juhp> right
06:31:38 <pravins> is there any chance to get C.UTF-8 in F23?
06:31:47 <juhp> mfabian: can it go upsteam or at least into Fedora glibc?
06:31:53 <juhp> pravins, +1
06:32:17 <mfabian> C.UTF-8 was not discussed for a while on the libc-alpha mailing list.
06:32:22 <juhp> probably fedora is higher priority
06:32:24 <pravins> #link https://bugzilla.redhat.com/show_bug.cgi?id=902094#c16
06:32:33 <mfabian> During the last discussion, it seemed unclear what people want C.UTF-8 to be.
06:32:49 <juhp> mfabian: maybe just copy Ubuntu?
06:33:07 <mfabian> Ubuntu has a /usr/lib/locale/C.UTF-8/ folder.
06:33:12 <mfabian> Doing that is very easy.
06:33:34 <juhp> okay I mean the locale - not necessary the folder at this time
06:33:40 <pravins> "KDE Plasma now requires this locale and does not work at all if you do not explicitly have a non-C locale set." from Kevin kofler
06:33:49 <juhp> s/necesary/necessarily
06:33:51 <mfabian> Carlos said, he wants C.UTF-8 to be “non-removable”, which probably means it should be built in like C/POSIX, that is a bit more difficult.
06:33:59 <juhp> pravins, oh!
06:34:09 <pravins> .bug 902094
06:34:10 <juhp> KDE requires C.UTF-8??
06:34:13 <zodbot> pravins: Bug 902094 C.UTF-8 locale? - https://bugzilla.redhat.com/902094
06:34:33 <mfabian> Maybe we could add it to the Fedora 23 rpm anyway, removable or not, I think I could add it fairly easily to our rpm.
06:34:44 <juhp> man the bug is from 2013...
06:34:52 <juhp> mfabian: yes please
06:35:01 <juhp> maybe just confirm with the glibc guys
06:35:25 <pravins> yeah, lets have some implementation. It will make it more clear for discussions.
06:35:40 <juhp> getting it into F23 woiuld be great and shouldn't really cause any problems
06:35:41 <pravins> updating bug will work i think Carlos already there.
06:35:59 <juhp> Carlos may be busy with other things...
06:36:08 <juhp> so good if we can help to drive this
06:36:51 <pravins> +1
06:37:54 <pravins> in between Fedora 23 talking point page ready now :)
06:37:56 <pravins> #link https://fedoraproject.org/wiki/Fedora_23_talking_points
06:38:07 <pravins> i removed Glibc Locale subpackaging from there.
06:38:30 <pravins> other improvements are already there. May be we can add some simply pick and drop information from change proposal there..
06:38:51 <juhp> mfabian: upstream might be even better though
06:39:14 <juhp> pravins, aha
06:39:44 <pravins> for Glibc upstream takes long time. Good thing is once we have it implemented in Fedora we can use it as a proof of concept to make it faster in upstream. but same time we are taking more risk with Fedora.
06:42:28 <pravins> #info Decided to move Glibc locale subpackaging change proposal to Fedora 24.
06:42:33 <juhp> yeah (or both:)
06:42:42 <pravins> :)
06:43:12 <pravins> #info "KDE Plasma now requires this locale and does not work at all if you do not explicitly have a non-C locale set." from Kevin kofler
06:44:26 <pravins> lets move to next topic
06:44:27 <pravins> #info #52: Fedora 23 Test day planning (pravins)
06:44:31 <pravins> #link https://fedorahosted.org/i18n/ticket/52
06:44:45 <juhp> maybe https://bugzilla.redhat.com/show_bug.cgi?id=902094#c16 covers the upstream case
06:45:20 <juhp> actually I don't understand the comment: "(Thankfully, most users do, but still…)"
06:46:30 <pravins> right, they also suggestion 1. as a quick method.
06:47:27 <pravins> its says "most of the users used to be in non-c locale."
06:47:50 <pravins> we already in test day topic :)
06:47:58 <pravins> We need to decide one day for adding new test cases and improving existing one.
06:47:58 <pravins> any idea??
06:49:03 <pravins> tagoh_: we have test day on 1st September. May be couple of week before we plan day for working on test case improvement?
06:49:23 <pravins> 20th or 21st Aug looks good to me.
06:49:28 <tagoh_> pravins: yes
06:49:38 <pravins> as 18th Aug we have L10N test day.
06:50:03 <tagoh_> even having a day earlier would be good too
06:50:20 <pravins> right.
06:50:54 <pravins> how about 17th?
06:51:35 <tagoh_> works for me.
06:51:44 <pravins> nice.
06:52:50 <pravins> #agreed I18N test day readiness meeting on 17th Aug on #fedora-g11n
06:53:07 <pravins> lets move to last topic
06:53:07 <gusennan> What time?
06:53:08 <pravins> #topic Open Floor
06:53:28 <pravins> gusennan: mostly will be same time, i will drop invitation on g11n list for same.
06:53:44 <pravins> gusennan: here come how you can help :)
06:54:08 <gusennan> great ;)
06:54:22 <pravins> If we see at bottom of https://fedoraproject.org/wiki/I18N/Meetings/2015-08-05
06:54:36 <pravins> we have lots of bugs statistics.
06:55:25 <pravins> presently if we observe our particular Fedora release planning we mostly highlight/work on change proposals.
06:55:42 <pravins> How if we select few bugs from list and mark those will get fixed in next version of Fedora??
06:56:04 <gusennan> sounds good to me
06:56:15 <pravins> there is also one great opportunity to open it on mailing list and ask in someone would like to volunteer for same. Then experienced members can simply mentor to fix those bugs.
06:56:59 <pravins> gusennan: nice :)
06:57:04 <gusennan> are the bugs for F21 & F22 not going to be fixed for f23?
06:57:23 <gusennan> and should we be concentrating on those in the F23 group?
06:57:47 <pravins> definitely they suppose to be. first task is test those bugs are present in current version, move bug to that version.
06:58:26 <pravins> traditionally Fedora is well know for automatic closing EOL cycle bugs :)
06:59:29 <pravins> i think important point is prioritizing and deciding bugs list.
07:00:24 <pravins> should i create ticket for this? and may be we can work on this in next meeting.
07:00:36 <gusennan> pravins: makes sense to me
07:01:04 <paragan> pravins, +1 to prioritize bugs
07:01:24 <pravins> great.
07:01:52 <pravins> #action pravins create trac ticket for prioritizing open Fedora bugs.
07:02:20 <pravins> if nothing else lets close meeting in couple of minutes.
07:03:37 <pravins> thanks all for meeting. :)
07:03:42 <pravins> #endmeeting