fesco
LOGS
18:00:49 <dgilmore> #startmeeting FESCO (2015-07-15)
18:00:49 <zodbot> Meeting started Wed Jul 15 18:00:49 2015 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:49 <dgilmore> #meetingname fesco
18:00:49 <zodbot> The meeting name has been set to 'fesco'
18:00:49 <dgilmore> #chair ajax dgilmore hguemar jwb nirik paragan rishi thozza sgallagh
18:00:50 <zodbot> Current chairs: ajax dgilmore hguemar jwb nirik paragan rishi sgallagh thozza
18:00:50 <dgilmore> #topic init process
18:00:57 <thozza> hello
18:01:02 <paragan> Hi
18:01:14 <number80> hello
18:01:23 <jwb> hi
18:01:25 <nirik> morning
18:01:59 <dgilmore> sorry for the late agenda
18:02:14 <sgallagh> Hello
18:02:17 <dgilmore> I forgot about branching being yesterday when I said i would run the meeting
18:02:26 <number80> np
18:02:32 <thozza> no problem, you had enough work with branching
18:02:53 <dgilmore> #topic #1247 List of release blocking deliverables
18:02:53 <dgilmore> .fesco 1247
18:02:54 <dgilmore> https://fedorahosted.org/fesco/ticket/1247
18:02:55 <zodbot> dgilmore: #1247 (F21 System Wide Change: Remove python-setuptools-devel - https://fedoraproject.org/wiki/Changes/Remove_Python-setuptools-devel) – FESCo - https://fedorahosted.org/fesco/ticket/1247
18:02:59 <dgilmore> lets get moving
18:03:08 <blackbird> re
18:03:24 <dgilmore> so FESCo is supposed to provide this week a list of all the things that are supposed to be delivered in f23
18:03:37 <paragan> .fesco 1427
18:03:38 <zodbot> paragan: #1427 (List of release blocking deliverables) – FESCo - https://fedorahosted.org/fesco/ticket/1427
18:04:11 <dgilmore> gahh stupid typo
18:04:15 <nirik> fun.
18:04:15 <dgilmore> thanks paragan
18:04:22 <paragan> np
18:04:48 <dgilmore> #topic #1427 List of release blocking deliverables
18:04:51 <nirik> so, how do we want to do this?
18:05:06 <thozza> in the ticket I guess
18:05:07 <nirik> try and brainstorm now? have some folks come up with a proposed list in ticket later?
18:05:28 <dgilmore> based on the ticket I thought jaroslav was going to produce a list that we could sign off on
18:06:13 <thozza> we should go through changes we approved
18:06:16 <number80> yes
18:06:18 <dgilmore> to me it feels like f23 is catching quite a few people off guard.
18:06:27 <nirik> perhaps this wasn't handed off to the new program manager?
18:06:35 <dgilmore> as in they were not expecting it yet
18:07:01 <thozza> can we do it as part of alpha review?
18:07:20 <nirik> dgilmore: time flies when you are having fun. :)
18:07:36 <dgilmore> thozza: maybe. the reason that we had it now was to make sure releng was able to deliver everything
18:07:42 <dgilmore> nirik: indeed
18:07:53 <thozza> right
18:08:10 <dgilmore> thozza: if we wait a couple of weeks we may not be able to do so
18:08:27 <thozza> so do a check next week
18:08:39 <dgilmore> but I guess we can say it will not be in Alpha we will get it in before Beta
18:08:40 <nirik> we need the list before alpha freeze... on the 28th?
18:08:54 <dgilmore> nirik: that would be the latest
18:09:02 <nirik> so ideally next week, as thats the last meeting before then
18:09:08 <paragan> ticket says we need to decide before alpha freeze
18:09:10 <dgilmore> yep
18:09:11 <thozza> sounds good
18:09:22 * nirik added jkurik to the ticket
18:09:49 <dgilmore> proposal work with program management to get a list of all deliverables for next weeks meeting
18:10:17 <thozza> +1
18:10:24 <paragan> +1
18:10:34 <dgilmore> +1
18:10:40 <nirik> +1
18:10:52 <number80> +1
18:11:09 <jwb> +1
18:11:23 <dgilmore> #accepted work with program management to get a list of all deliverables for next weeks meeting (6,0,0)
18:11:36 <dgilmore> #topic #1461   F23 System Wide Change: Layered Docker Image Build Service
18:11:38 <sgallagh> +1 (sorry)
18:11:39 <dgilmore> .fesco 1461
18:11:40 <zodbot> dgilmore: #1461 (F23 System Wide Change: Layered Docker Image Build Service) – FESCo - https://fedorahosted.org/fesco/ticket/1461
18:11:42 <dgilmore> https://fedorahosted.org/fesco/ticket/1461
18:11:56 <nirik> sure, +1
18:12:03 <number80> +1
18:12:13 <thozza> +1
18:12:20 <dgilmore> I am +1 but i think it will be Beta before we have it in place
18:12:21 <paragan> +1
18:12:38 <nirik> yeah, it's going to be a lot of work and blazing somewhat new trails.
18:13:29 <number80> delaying it another 6 months would be bad, and as long as it's here for GA, it won't disturb existing users
18:14:41 <dgilmore> indeed
18:14:42 <thozza> I also think we should try to have it in place for F23
18:14:56 <sgallagh> +1
18:15:40 <dgilmore> i count 6 +1
18:17:53 <dgilmore> #agreed F23 System Wide Change: Layered Docker Image Build Service approved (6,0,0)
18:18:11 <dgilmore> #topic #1462  RPM Weak Dependencies and the install media compose process
18:18:14 <dgilmore> .fesco 1462
18:18:15 <zodbot> dgilmore: #1462 (RPM Weak Dependencies and the install media compose process) – FESCo - https://fedorahosted.org/fesco/ticket/1462
18:18:17 <dgilmore> https://fedorahosted.org/fesco/ticket/1462
18:18:59 <thozza> the ticket was created late today
18:19:06 <dgilmore> I covered my thoughts on the mailing list
18:19:24 <sgallagh> Yes, but only as a summary of the conversation on the mailing list
18:19:45 <sgallagh> dgilmore: I *think* my summary agrees with you, yes?
18:19:52 <nirik> I'm fine with option 1 seems fine.
18:20:17 <thozza> yes, that is right
18:20:18 <nirik> I guess it means tooling changes.
18:20:20 <dgilmore> sgallagh: not really
18:21:00 <dgilmore> sgallagh: i think that anaconda needs a switch to be able to toggle installing suggets
18:21:14 <dgilmore> but in f23 I think thats all we can do
18:21:57 <nirik> right now the compose tools all use yum right? or does pungi4 use dnf?
18:22:12 <dgilmore> nirik: they all use yum
18:22:35 <nirik> which will ignore recommends right?
18:22:52 <dgilmore> I am honestly not sure
18:23:02 <number80> nirik: it should
18:23:27 <sgallagh> nirik: Right, which is potentially a problem as packages are starting to take advantage of Recommends:
18:23:35 <sgallagh> (To shrink their minimal footprint)
18:24:12 <thozza> sgallagh: I'm ok with the proposal
18:24:36 <nirik> well, the compose tools should switch to dnf, but thats going to be a lot of work, no waving a magic 'wish this was all dnf'
18:25:01 <dgilmore> thats a lot of work thats not even started yet
18:25:54 <thozza> and it will help with the move with python3 ;-)
18:25:57 <sgallagh> Well, we basically have two choices as I see it:
18:25:58 <sgallagh> 1) Fix our compose tools to match the package manager all of our deployed users have
18:25:58 <sgallagh> 2) Ask the FPC to disallow use of weak dependencies until 1) happens
18:26:00 <nirik> so, I think for this cycle we may have to live with the yum behavior
18:26:03 <jwb> it is somewhat unfortunate that the on-list discussion didn't bring this up at all
18:26:42 <number80> then, let's make it a goal for F24 (switching compose tools to dnf)
18:26:54 <nirik> sgallagh: 3) tell everyone the composes don''t care about those and fix any cases in packages we need to care about.
18:27:01 <sgallagh> Or 3) require micromanagement of comps/spins-kickstart to work around the lack of proper support.
18:27:21 <nirik> well, or just change packages that matter back to requires or whatever.
18:27:22 <dgilmore> sgallagh: what this will mean in practice is that network installs are bigger than dvd installs
18:27:42 <sgallagh> nirik: I don't think that's realistic. The benefits of the weak deps are strongest in the important packages with big depchains
18:27:42 <dgilmore> since dvd installs will not have reccomends available
18:28:22 <nirik> sgallagh: well, its been possible for 22 releases. ;)
18:28:41 <sgallagh> My point being that if we're advising to change the packages that matter, that's rapidly approaching the same as 2) above
18:28:57 <number80> I think that compose does not need to stick with recommends even if we were using dnf
18:29:12 <sgallagh> number80: I don't follow
18:29:17 <nirik> I suppose, but I couldn't even get fesco to forbid them before there were any guidelines in existance (ie, some were used in f22 and before)
18:29:53 <number80> sgallagh: composes should not require Recommends:, and keep the same behaviour as yum in the long term
18:30:04 <dgilmore> number80: so your proposal would be to keep reccomends off of installs?
18:30:08 <sgallagh> number80: I disagree completely
18:30:27 <number80> dgilmore: yes
18:30:29 <sgallagh> The whole point of Recommends is that the default experience should be more complete than the minimal experience
18:30:48 <number80> sgallagh: we don't know yet the impact on media size on the long run
18:30:48 <sgallagh> The installer is pretty much the definition of the "default experience"
18:30:53 <dgilmore> number80: the issue there is when doing network installs dnf's default behaviour will install them
18:31:21 <dgilmore> so if you do a dvd install and a network install you will get two different installs for the same options
18:31:33 <sgallagh> nirik, dgilmore: I presume there's more to the tool switchover than s/yum/dnf/ ?
18:31:36 <number80> yes, but I would prefer having more feedback before
18:31:56 <number80> I'm not against the switch, I just say we need more data
18:32:03 <dgilmore> sgallagh: much much more
18:32:12 <nirik> yes, I am sure its a lot more.
18:32:53 <dgilmore> sgallagh: the switch to dnf is something we want to get done in the f24 timeframe
18:33:09 <dgilmore> we have had other thinsg we have been working on for f23
18:34:02 <jwb> i don't think the discrepency between DVD and network installs is an issue
18:34:22 <sgallagh> jwb: That ultimately depends on what ends up switching from Requires: to Recommends:
18:34:33 <thozza> dgilmore: ideally combining it with python 3
18:34:36 <jwb> not really.  it has always been different after ~1 week anyway, because of updates
18:34:45 <sgallagh> If it happens en-masse, we could end up with DVD installs that are just above worthless
18:34:47 <number80> there's already a discrepancy between the packages available from network and from networkless install
18:34:48 <dgilmore> thozza: thats likely f25 at the earliest
18:35:09 <jwb> dvd installs at this point are pretty worthless.  at least in the traditional sense
18:35:12 <sgallagh> jwb: updates won't pull in Recommends
18:35:39 <dgilmore> livecds use yum also
18:35:49 <dgilmore> so all the livecds will not have reccomends
18:36:01 <dgilmore> unless we manage to get livemedia-creator in place
18:36:02 <jwb> sgallagh, i'm aware it won't.  my point was there is a size discrepency already TODAY between network and dvd
18:36:19 <jwb> so i don't think it matters if there's a discrepency with f23 either
18:36:20 <sgallagh> jwb: It's not the size that bothers me
18:36:21 <number80> could we make it an Anaconda option?
18:36:30 <sgallagh> It's the potential loss of *functionality*
18:36:32 * nirik wonders how many things on the media will change from requires->recommends. is this a big thing?
18:36:34 <sgallagh> number80: No
18:36:47 <jwb> sgallagh, loss in DVD installs, yes?  *yawn*
18:36:56 <number80> sgallagh: then how could we handle the case of recommends inflation?
18:37:02 <sgallagh> jwb: You mean that thing we hand out at conferences?
18:37:20 <dgilmore> sgallagh: we hand out livecds
18:37:23 <sgallagh> number80: The only way I can think of is to just forbid Recommends: until F24
18:37:28 <jwb> sgallagh, yeah.  that thing that we hand out at conferences and then people install and then are faced with 500MB of updates IMMEDIATELY AFTER
18:37:29 <sgallagh> when the tools are there.
18:37:39 <number80> currently, there's no loss as it's the current behaviour
18:37:59 * nirik notes there's only the server dvd now
18:38:10 <sgallagh> number80: The current behavior is predicated on there not being any weak deps in the repositories
18:38:12 <jwb> sgallagh, the useful shelf life of DVD media is literally less than a month
18:38:20 <number80> but I'd like to see the same compose with both options and see the impact before deciding
18:38:31 <jwb> beyond that, it's obsolete and everything will be updated after the install anyway
18:38:42 <dgilmore> number80: with what options?
18:39:04 <number80> dgilmore: one with recommends enabled and the other recommends disabled
18:39:06 <sgallagh> jwb: I don't see why you continue to talk about the updates. Updates will only update the packages that are already installed.
18:39:13 <dgilmore> number80: we can not do that
18:39:16 <sgallagh> The packages already installed will be a reduced set
18:39:21 <dgilmore> number80: it is just not possible
18:39:24 <sgallagh> Likely with reduced functionality.
18:39:32 <number80> dgilmore: even locally?
18:39:34 <sgallagh> That will continue forward without manual intervention by the user.
18:39:37 <jwb> sgallagh, because you continue to miss my point.  DVD installs are NOT useful, nor are they a major concern
18:39:47 * dgilmore does note that if they enable updates at install time the point is moot
18:39:48 <nirik> sgallagh: once that one dnf bug is fixed yes... ;)
18:40:04 <dgilmore> it is purely disconnected dvd installs effected
18:40:10 <number80> well, I suggest that we move this discussion on the list, especially as it won't affect F23
18:40:15 <nirik> right now dnf reinstalls recommends on upgrades
18:40:21 <sgallagh> jwb: The same is true of the livecd installs except insofar as they are more meticulously curated.
18:40:30 <jwb> correct.
18:40:33 <sgallagh> nirik: OK, yeah that's unexpected.
18:40:49 <sgallagh> number80: It *does* affect F23.
18:40:52 <nirik> yeah, and undesired I think.
18:40:53 <dgilmore> sgallagh: unexpected behaviour should be expected with dnf
18:40:57 <jwb> the only value live media brings is less time spent getting into the real install, or trying things out before install
18:41:06 <sgallagh> dgilmore: s/unexpected/undesired/
18:41:14 <number80> sgallagh: composes tool will be using yum for F23 so it won't affect F23
18:41:21 <number80> or I'm missing something
18:41:33 <sgallagh> number80: You are missing something
18:41:37 <number80> ?
18:41:47 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1229701
18:41:49 <sgallagh> Packagers are making changes to their packages that will result in yum installing fewer of their deps
18:41:54 <dgilmore> number80: there will be inconsitent behaviour in f23 depending on how you install
18:42:23 <thozza> any proposal? or moving to next week?
18:42:26 <nirik> number80: if a package changes from Requires: foo to Recommends: foo, the install tools won't pull in foo...
18:42:31 <sgallagh> For example, with yum, you could only do Requires:, so if your package was most useful with a particular plugin, you'd have to Requires: it
18:42:49 <sgallagh> With the weak deps, you can now Recommends: it so it's possible for people to remove it if they truly don't want it there
18:42:56 <number80> dgilmore: yes, but we can't fix that except forbidding the use of Recommends
18:43:18 <sgallagh> number80: That's what I'm getting at (and have been saying since the beginning)
18:43:29 <sgallagh> We either fix the tools to support weak deps or forbid them until we can.
18:43:49 <number80> Yes, but I'm willing to have that small discrepancy as we need data to build consistent guidelines around weak deps
18:43:49 <nirik> I'm not sure the changes are widespread enough to matter, but I guess I could support asking for people not to use them in f23.
18:43:50 <sgallagh> Allowing them without fixed tools is going to cause headaches and user confusion.
18:43:53 <thozza> they are already used anyway
18:44:20 <dgilmore> sgallagh: or we accept the inconsitencies
18:44:38 <sgallagh> dgilmore: Right; I'm not sure I'm prepared to do that
18:45:09 <ajax> apologies, didn't see a meeting announcement in -devel
18:45:42 <thozza> there was none
18:45:47 <dgilmore> ajax: sorry it was late
18:46:00 <dgilmore> thozza: there was
18:46:06 <nirik> so, discuss on list for another week? try and vote on one of the two possible actions?
18:46:16 <dgilmore> nirik: yeah I think so
18:46:38 <nirik> which? :)
18:46:50 <thozza> dgilmore: it was after I left work, so I didn't see it
18:46:52 <sgallagh> Just to throw it out there:
18:46:52 <sgallagh> Proposal: Disallow weak dependencies on any package on the various install media of Fedora 23
18:47:23 <thozza> -1
18:47:24 <dgilmore> -1
18:47:56 <dgilmore> sgallagh: it is not enforceable
18:48:07 <thozza> I agree
18:48:13 <jwb> -1
18:49:35 <number80> -1
18:49:37 <nirik> I can try a grep of whats using them currently to send to the list if that data would be of help
18:49:46 <sgallagh> nirik: Yeah, please do
18:49:54 <dgilmore> any more votes?
18:50:10 <nirik> 0 here (want to look at it more)
18:50:11 <thozza> just today I added suggests to a package
18:50:13 <paragan> 0
18:50:30 <number80> at best, we can advise to wait F24
18:50:31 <thozza> so I think it is a bad idea to ban them
18:51:02 <dgilmore> #agreed no consensus: Disallow weak dependencies on any package on the various install media of Fedora 23 (0,2,4)
18:51:17 <dgilmore> so lets discuss further on devel list
18:51:57 <dgilmore> #topic #1460  Worfkflow/guidelines for bugs requesting change to defaul preset policy
18:52:00 <dgilmore> .fesco 1460
18:52:02 <zodbot> dgilmore: #1460 (Worfkflow/guidelines for bugs requesting change to defaul preset policy) – FESCo - https://fedorahosted.org/fesco/ticket/1460
18:52:02 <dgilmore> https://fedorahosted.org/fesco/ticket/1460
18:52:15 <dgilmore> so i think this went a bit far to not reach out to me
18:52:32 <thozza> so what about a special package?
18:52:32 <dgilmore> it was an unfortunate series of bad timings and using bugzilla
18:52:46 <dgilmore> more people watching the bugs and helping are welcome
18:52:48 <dgilmore> policy
18:52:49 <dgilmore> .fesco 1460
18:52:50 <zodbot> dgilmore: #1460 (Worfkflow/guidelines for bugs requesting change to defaul preset policy) – FESCo - https://fedorahosted.org/fesco/ticket/1460
18:52:53 <dgilmore> gahh
18:53:05 <dgilmore> I get around 200-300 bug emails a day
18:53:13 <dgilmore> so its easy for me to miss bugs
18:53:22 <nirik> I've already said I will take a look this week. :)
18:53:30 <thozza> dgilmore you are too busy. I think we need more people
18:53:32 <nirik> hopefully we can get any backlog handled.
18:53:41 <dgilmore> ideally people just send pull requests on pagure for patches
18:53:43 <sgallagh> dgilmore:  As I suggested in the bug, I think it would be prudent to get the WG liaisons on the watchlist
18:54:07 <sgallagh> dgilmore: That's a new process (and one that will make this easier, sure)
18:54:09 <dgilmore> sgallagh: I am not opposed
18:54:14 <nirik> sure.
18:54:15 <sgallagh> But one that people haven't had time to get used to yet
18:54:16 <dgilmore> more eyes are welcome
18:54:45 <dgilmore> sgallagh: sure, it is new
18:55:05 <dgilmore> bugzilla is a really bad forum for communications :(
18:55:09 <dgilmore> which is kinda sad
18:55:24 <dgilmore> sgallagh: I did add nirik to the watch list
18:55:34 <sgallagh> I just added myself as well
18:55:36 <dgilmore> anyone is free to add themselves to it
18:55:50 <dgilmore> pkgdb allows it
18:55:58 <thozza> what about special package and special mailing list as the assignee
18:55:59 <thozza> ?
18:56:09 <nirik> seems like overkill for a single file.
18:56:10 <dgilmore> If people can think of a much better workflow I am all ears
18:56:28 <dgilmore> thozza: I do not know that would work well
18:56:54 <thozza> at least it would reach more people
18:57:06 <thozza> who can fix things
18:57:41 <thozza> but yes, it's kind of overkill
18:57:42 <nirik> why wouldn't adding those people to the package do that too?
18:58:06 * dgilmore notes that very few people can actually build fedora-release
18:58:13 <thozza> it would I guess. it was just an idea
18:58:49 <nirik> anyhow, shall we move on then? or ?
18:58:51 <dgilmore> it is in the secure-boot channel same as the kernel as pjones plans to do something so that the hardware can verify things
18:58:58 <thozza> that's another thing, that the Bush are now "just" in post
18:59:03 <thozza> bugs
18:59:11 <thozza> sorry for typo
18:59:31 <pjones> dgilmore: but I'm not actually sure when we're ever going to do that, so if you want to move it back, that's fine.
18:59:50 <dgilmore> pjones: maybe we shoudl take it back out
18:59:54 <pjones> okay by me.
19:00:04 <dgilmore> we can always add it back
19:00:25 <pjones> yeah; for now do whatever makes things most convenient for you.
19:00:33 <thozza> do you want to put it into systemd again?
19:00:46 <dgilmore> thozza: systemd guys did not want it there
19:00:56 <dgilmore> thats why it was moved
19:01:09 <thozza> so where?
19:01:09 <thozza> yes
19:01:18 <dgilmore> they had been asking for it to be taken out of systemd for years
19:01:23 <sgallagh> fedora-release still makes the most sense, to me
19:01:23 <thozza> that's why I'm asking
19:01:32 <nirik> me too.
19:01:39 <thozza> dgilmore I know
19:01:42 <dgilmore> thozza: I do not think it needs to move
19:01:50 <thozza> I don't want to put it there
19:02:08 <thozza> so I misunderstood you I guess
19:02:09 <dgilmore> I think that having some more eyes on things may help things not fall through the cracks
19:02:29 <thozza> yes, that's true
19:02:34 <dgilmore> thozza: in this case it was a bunch of missteps that resulted in the bug being missed
19:02:46 <dgilmore> some unfortunate timings
19:03:12 <dgilmore> and the fact that I get so much bug email that it is too high in noise for me
19:03:43 <dgilmore> thozza: had they pinged on the bug, in email or irc it would have gotten attention and been dealt with
19:03:56 <dgilmore> but they waited a month and then filed the fesco ticket
19:04:39 <thozza> I asked Michal to file the ticket so we can discuss the thing and possibly help you
19:04:55 <thozza> it was not meant as complaining
19:05:08 <dgilmore> thozza: I did find it a bit rude to file the ticket without pinging me once before.
19:05:09 <thozza> don't take it wrong
19:05:27 <dgilmore> thozza: but I am not the sole person that can do things
19:05:40 <thozza> it was more about the process
19:05:45 <dgilmore> there is a few people that are watching bugs and can commit to the upstream repo and do builds
19:06:17 <dgilmore> thozza: the best way to get changes in is to do as sgallagh did and file a pull request in pagure
19:06:30 <dgilmore> thozza: I am not teh only one that can merge them in
19:06:45 <dgilmore> maybe we should document that better and communicate it
19:07:05 <thozza> so let's state that and we are finished
19:07:12 <dgilmore> okay
19:07:18 <thozza> sounds good to me
19:07:22 <nirik> the info on the wiki might use some updating there too (according to the mailing list)
19:07:33 <dgilmore> nirik: I am sure
19:07:50 <dgilmore> I know we have not updated all the docs with teh move to pagure
19:08:47 <dgilmore> proposal update the docs to have people send pull requests via pagure and coummicate that as much as possible
19:09:06 <nirik> sure. +1
19:09:43 <dgilmore> +1
19:09:45 <paragan> +1
19:09:58 <sgallagh> +1
19:09:59 <number80> +1
19:10:47 <ajax> +1
19:11:10 <thozza> +1
19:11:44 <dgilmore> #accepted update the docs to have people send pull requests via pagure and coummicate that as much as possible (7,0,0)
19:12:22 <dgilmore> #topic Next week's chair
19:12:32 <dgilmore> who wants to run the meeting next week?
19:13:17 * number80 will be at europython next week
19:13:35 <sgallagh> I haven't done it in a while
19:13:53 <dgilmore> #info sgallagh to run next weeks meeting
19:13:55 <dgilmore> thanbsk sgallagh
19:13:59 <dgilmore> thanks even
19:14:08 <dgilmore> #topic Open Floor
19:14:10 <number80> thanks
19:14:40 <dgilmore> does anyone have anything?
19:14:42 <nirik> FYI, I am continuing to try and work on the passphrase policy. Hopefully I will have a draft to propose before too long.
19:14:45 <thozza> no
19:14:51 <dgilmore> nirik: cool
19:15:16 <number80> great
19:15:25 <sgallagh> Excellent
19:15:34 <dgilmore> #info nirik continues to try and work on the passphrase policy
19:16:32 <dgilmore> #endmeeting