fesco
LOGS
18:00:02 <paragan> #startmeeting FESCO (2015-07-08)
18:00:02 <zodbot> Meeting started Wed Jul  8 18:00:02 2015 UTC.  The chair is paragan. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:02 <paragan> #meetingname fesco
18:00:02 <zodbot> The meeting name has been set to 'fesco'
18:00:02 <paragan> #chair ajax dgilmore number80 jwb nirik paragan rishi thozza sgallagh
18:00:02 <paragan> #topic init process
18:00:02 <zodbot> Current chairs: ajax dgilmore jwb nirik number80 paragan rishi sgallagh thozza
18:00:05 <ajax> hi
18:00:12 <paragan> hi
18:00:15 <number80> hi
18:00:34 <jwb> hello
18:00:35 <thozza> Hi all
18:00:37 <nirik> morning
18:01:07 <lupinix> hi, i'm the owner of self contained change "Astronomy Spin" and i'm here to answer any quastions ;)
18:01:13 <thozza> I'm only on mobile today. so may be little bit slow in response
18:01:13 <lupinix> *questions
18:01:23 <dgilmore> hi all
18:01:23 <paragan> Okay let's start now
18:01:34 <paragan> #topic #1445 F23 Self Contained Changes
18:01:34 <paragan> .fesco 1445
18:01:34 <paragan> https://fedorahosted.org/fesco/ticket/1445
18:01:35 <zodbot> paragan: #1445 (F23 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1445
18:01:48 <paragan> we have 2 self contained changes this week
18:02:15 <paragan> io.js Technology Preview and Astronomy spin
18:02:17 <Southern_Gentlem> isnt this meeting a day early?
18:02:27 <thozza> so what is the outcome of the io.he discussion?
18:02:41 <number80> Southern_Gentlem: nope
18:02:43 <thozza> io.js
18:02:55 <paragan> thozza, there is some reply on the list for io.js
18:03:05 <thozza> I saw it
18:03:21 <dgilmore> +1 to astronomy spin
18:03:31 <paragan> but I am still not in favor to have io.js provided sometime in future it may get merged
18:03:38 <thozza> but didn't see any final decision. I didn't check today though
18:03:48 <number80> no final decision too
18:04:15 <thozza> +1  for astronomy, too
18:04:32 <ajax> +1 both
18:04:32 <paragan> anyone got any opinion for io.js change?
18:04:38 <nirik> so it sounded like the change owner was ok with making io.js default in f23, but calling it io.js, not node... which seems reasonable to me.
18:05:03 <thozza> yes, this is what I remember
18:05:09 <nirik> but I don't think the change page is updated to reflect any of that discussion.
18:05:15 <thozza> I'm also ok with this
18:05:26 <number80> then, it's fine with me
18:05:51 <number80> +1 both then
18:06:24 <dgilmore> I do not have anything against io.js  just not been able to catch up on it and it seems there is some unanswered questions
18:06:44 <nirik> I guess I am +1 to both.
18:07:10 <number80> dgilmore: we mostly wanted to clarify the node.js/io.js transition as the current io.js will become the next node.js
18:07:42 <dgilmore> number80: okay
18:07:55 <dgilmore> I can give it a +1 then
18:08:07 <paragan> I count 4 +1 excluding me
18:08:57 <paragan> jwb, you want to vote on this?
18:09:10 <thozza> I'm   +1 for io.js if the page will reflect the discussion
18:09:24 <jwb> paragan, 0
18:09:28 <number80> fair enough
18:09:30 <thozza> so please note it
18:09:46 <paragan> okay we reach 5 +1
18:09:54 <paragan> I am 0
18:10:50 <paragan> AGREED: All self-contained changes are approved (+5, 2 , 0)
18:11:04 <paragan> #topic #1455 F23 System Wide Change: Standardized Passphrase Policy
18:11:04 <paragan> .fesco 1455
18:11:04 <paragan> https://fedorahosted.org/fesco/ticket/1455
18:11:07 <zodbot> paragan: #1455 (F23 System Wide Change: Standardized Passphrase Policy) – FESCo - https://fedorahosted.org/fesco/ticket/1455
18:11:21 <nirik> so, we don't really need to discuss this
18:11:24 <thozza> please note the change of the change page for io.js
18:11:30 <nirik> as long as fesco is ok with approving it once I have a draft.
18:12:10 <paragan> I am okay once we have a draft we can vote and decide on this change
18:12:33 <jwb> nirik, s/approving/reviewing?
18:12:36 <number80> voting without a draft has no meaning
18:12:43 <thozza> I agree
18:12:47 <nirik> right.
18:13:02 <jwb> yeah, i'm certainly fine with reviewing it whenever a draft materializes
18:13:16 <nirik> well, my concern was that since we are so far along people would say to go to F24.
18:13:25 <nirik> I wanted the change so we know it's being worked on.
18:13:50 <number80> as long as the plan is good, it could make it in F23
18:14:00 <nirik> and in fact t8m already wanted bugs against a tracker (which could be the change bug)
18:14:09 <paragan> yes it can make it in F23
18:14:48 <thozza> if the draft will not be ready for f23 it should be moved to f24. but there is still some time
18:15:11 <paragan> proposal:  let's revisit this next time when draft gets ready for review
18:15:17 <number80> +1
18:15:23 <thozza> +1
18:15:27 <nirik> if we defer to f24, there's going to be lots of pain. ;) but I will try and get something as soon as I have time to.
18:15:41 <paragan> +1
18:15:59 <paragan> votes?
18:16:13 <dgilmore> +1
18:16:15 <thozza> paragan: I'm still waiting for you to note the update of the io.js change page...
18:16:50 <paragan> you want me to add action to have io.js change page updated?
18:16:52 <nirik> sure, +1 (not sure we need to vote on this but ok)
18:17:29 <number80> at least we agreed to review it and not delay it by default ;)
18:17:32 <jwb> nirik, why will there be lots of pain?
18:17:50 <thozza> at least an info so that the change wrangled can notify the change owner
18:17:59 <thozza> wrangler
18:18:04 <nirik> jwb: because the anaconda default right now is the thing that everyone yelled about in f22.
18:18:21 <jwb> nirik, eh.  that isn't new this time around though.
18:18:39 <paragan> #info We need io.js change page updated with the information provided on devel mailing list
18:18:56 <nirik> well, I don't know that they want to patch this again without a fesco policy in place. anyhow, lets please move on?
18:19:06 <thozza> paragan: thanks
18:19:26 <paragan> #agreed let's revisit this next time when draft gets ready for review
18:19:38 <paragan> #topic #1456 F23 System Wide Change: Node.js 0.12
18:19:38 <paragan> .fesco 1456
18:19:38 <zodbot> paragan: #1456 (F23 System Wide Change: Node.js 0.12) – FESCo - https://fedorahosted.org/fesco/ticket/1456
18:20:15 <paragan> The Change proposal looks good to me. I see change owner already addressed the issues raised on devel mailing list.
18:20:57 <nirik> sgallaghl was suggesting this should be system wide on the list.
18:21:27 <nirik> oh, they adjusted for that. great
18:21:35 <paragan> yes
18:21:36 <nirik> +1
18:22:03 <thozza> shouldn't this be merged with the io.js change?
18:22:36 <paragan> maybe someone want to use node.js 0.12
18:22:55 <paragan> let this be separate
18:23:16 <number80> yes, let's keep them separate
18:23:22 <nirik> well, the io.js was supposed to be a tech prevew thing.
18:23:40 <thozza> right, but if there is only io.js, then there will be no node.js
18:24:16 <nirik> well, it's also going to be node.js down the road (love all this. ;)
18:24:41 <thozza> :-)
18:24:44 <jwb> 0
18:24:44 <nirik> so, for f23 we would have node.js and io.js, then f24 (or whenver they merge back) we just have node.js again
18:24:52 <jwb> (this is all why i keep voting 0)
18:25:00 <number80> yes
18:25:05 <thozza> ok. so I'm +1 for node.js
18:25:08 <ajax> javascript attention deficit disorder
18:25:11 <nirik> but IMHO we should also trust the folks doing the work.
18:25:21 <number80> +1
18:25:23 <paragan> +1 for this node.js
18:25:39 <number80> and I agree that javascript ecosystem is a PITA
18:26:06 <dgilmore> +1 but this seems like an ugly mess that will get messed up and have issues
18:26:19 <thozza> I also trust the js experts
18:26:37 <ajax> +1
18:26:45 <paragan> #agreed F23 System Wide Change: Node.js 0.12 (+6, 1, -0)
18:27:08 <paragan> #topic #1457 F23 System Wide Change: jQuery
18:27:08 <paragan> .fesco 1457
18:27:10 <zodbot> paragan: #1457 (F23 System Wide Change: jQuery) – FESCo - https://fedorahosted.org/fesco/ticket/1457
18:27:19 <paragan> another js change
18:27:41 <number80> at least, it's an improvement
18:27:44 <paragan> This change was approved for Fedora 21 but it did not complete on time due to unfinished package reviews which are all completed in May 2015.
18:28:26 <dgilmore> +1
18:28:32 <paragan> I am +1 for this change
18:28:38 <thozza> I'm not convinced that this is beneficial after reading the conversation on devel list
18:28:39 <nirik> +1 but I don't think there's any way they can all be moved without some massive efforts... but still, progress.
18:28:49 <ajax> +1 i guess
18:28:49 <dgilmore> but it seems we can't claim to be first in that it took us two releases to get it reviewed
18:28:57 <paragan> thozza, what issue you see?
18:29:30 <thozza> that it is almost impossible to move all applications to system package
18:30:17 <paragan> I think there are different cases given https://fedoraproject.org/wiki/Changes/jQuery#Migrating_Web_Applications
18:30:27 <thozza> however I see the benefit of trying to move at least as much packages as possible
18:30:56 <thozza> *applications
18:31:03 * nirik nods
18:31:24 <thozza> so for marketing purposes I'm for it
18:31:29 <number80> +1
18:31:41 <thozza> also to appreciate the work already done
18:32:04 <thozza> +1 then
18:32:40 <paragan> jwb, your vote 0 for this also?
18:34:05 <paragan> #agreed F23 System Wide Change: jQuery (+6, 0, -0)
18:34:09 <paragan> #topic #1458 F23 System Wide Change: IBus 1.5.11
18:34:10 <paragan> .fesco 1458
18:34:12 <zodbot> paragan: #1458 (F23 System Wide Change: IBus 1.5.11) – FESCo - https://fedorahosted.org/fesco/ticket/1458
18:34:45 <paragan> As explained in the ticket, this is a simple change that provides 2 sub-changes
18:35:02 <dgilmore> +1
18:35:03 <paragan> One for KDE to show language prefix icons for xkb layouts
18:35:12 <number80> we also had concerns about GNOME support?
18:35:21 <paragan> second is dynamically load system compose tables along with any other extra mappings written in $HOME/.XCompose file.
18:35:33 <nirik> +1
18:35:53 <jwb> paragan, sorry, distracted.  i am +1 for jQuery
18:36:06 <jwb> i'm also +1 for this
18:36:41 <ajax> +1
18:36:42 <paragan> number80, we already have langauge prefix icons in GNOME
18:36:52 <number80> then, it's all good for me
18:36:54 <number80> +1
18:36:59 <paragan> +!
18:37:03 <paragan> +1
18:38:01 <paragan> thozza1, we are discussing last change IBus
18:38:16 <paragan> your vote please
18:39:25 <thozza2> sorry my connection dropped
18:39:55 <thozza2> I'm +1 for ibus
18:39:58 <paragan> cool
18:40:18 <paragan> #agreed F23 System Wide Change: IBus 1.5.11 (+7, 0, 0)
18:40:32 <paragan> #topic Next week's chair
18:40:43 <paragan> any volunteer?
18:41:18 <dgilmore> sure I can
18:41:27 <paragan> dgilmore, thanks
18:41:42 <paragan> #info dgilmore to chair next week
18:41:49 <paragan> #topic Open Floor
18:42:01 <paragan> anything for open floor?
18:42:21 <thozza> nothing from me
18:42:35 * nirik has nothing.
18:43:14 <number80> nein
18:43:37 <dgilmore> nada
18:43:52 <ajax> same
18:44:41 <paragan> thanks everyone for having this meeting.
18:44:46 <paragan> #endmeeting