i18n
LOGS
06:00:09 <pravins> #startmeeting i18n
06:00:09 <zodbot> Meeting started Wed Jun 24 06:00:09 2015 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:00:13 <pravins> #meetingname i18n
06:00:13 <zodbot> The meeting name has been set to 'i18n'
06:00:16 <pravins> #topic agenda and roll call
06:00:20 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2015-06-24
06:00:23 <pravins> hi all
06:00:26 <tagoh_> hi
06:00:29 <ueno__> hi
06:00:33 <epico> hi
06:00:39 <pravins> hi tagoh_ ueno__ epico :)
06:00:54 <paragan> hi
06:01:01 <pravins> juhp is travelling to Pune today for FUDCon in, will meet him tomorrow :)
06:01:07 <pravins> hi paragan
06:01:52 <pravins> FUDCon APAC 2015 fever already started at Pune. Most of the speakers are arriving today.
06:02:53 <pravins> i am going to talk on "Nuts and Bolts of Fedora Internationalization, Globalization" http://fudconin15.shdlr.com/conferences/talk/14733
06:03:13 <pravins> #topic Upcoming schedule
06:03:23 <pravins> #info 2015-06-23 	Change Checkpoint: Proposal submission deadline (System Wide Changes)
06:03:23 <pravins> #info info not scheduled yet 	Side Tag Builds Deadline
06:03:23 <pravins> #info 2015-06-16 	Mass Rebuild
06:03:24 <pravins> #info 2015-07-14 	Branch Fedora 23 from Rawhide (Rawhide becomes future F24)
06:03:24 <pravins> #info 2015-07-28 	Alpha Freeze (*), Software String Freeze, Change Checkpoint: Completion deadline (testable), Bodhi activation point
06:03:51 <mfabian> Hi!
06:03:55 <pravins> #chair tagoh_ ueno__ epico paragan mfabian
06:03:55 <zodbot> Current chairs: epico mfabian paragan pravins tagoh_ ueno__
06:04:00 <pravins> hi mfabian :)
06:04:23 <pravins> Change proposal deadline was yesterday. Glad our most of the planned changes are in already.
06:04:28 <pravins> #topic New topics
06:04:41 <pravins> #info #43: G11N FAD in 2015 (pravins)
06:04:41 <pravins> #link https://fedorahosted.org/i18n/ticket/43
06:05:03 <pravins> We have budget ready now. We are already bit over budget.
06:05:36 <pravins> I was thinking to drop an email yesterday but RHSummit already started and less chance to get response quickly.
06:05:58 <pravins> will drop email early next week. We will have an update July first week.
06:06:12 <pravins> #action pravins to drop email to Fedora council for G11N fad approval.
06:06:17 <pravins> #info #49: Internationalization talking points for Fedora 22 (pravins)
06:06:29 <pravins> #link https://fedorahosted.org/i18n/ticket/49
06:06:58 <pravins> I have provided initial draft to Fedora Magazine. https://lists.fedoraproject.org/pipermail/marketing/2015-June/017699.html
06:07:02 <pravins> its still in review. :(
06:07:30 <pravins> Ryan Lerch coming to FUDCon pune, will coordinate with him and try to publish it soon.
06:08:33 <pravins> if you want to see draft please visit http://fedoramagazine.org/wp-admin/post.php?post=9259  (need to login first through http://fedoramagazine.org/wp-admin/)
06:08:41 <pravins> feel free to add if anything missing.
06:09:34 <pravins> Lets move to most important topic of the day :)
06:09:35 <pravins> #info #50: Feature/Change planning for Fedora 23 (pravins)
06:09:39 <pravins> #link https://fedorahosted.org/i18n/ticket/50
06:11:40 <pravins> https://fedoraproject.org/wiki/Changes/Unicode_8.0
06:11:48 <pravins> I have to add other packages related to Unicode. libunistring and unicode-ucd.
06:12:04 <pravins> do you think there is any other packages needed Unicode 8.0 update.
06:12:13 <mfabian> Emacs.
06:12:19 <pravins> mfabian: aha
06:12:49 <mfabian> “M-x ucs-insert” doesn’t yet know the names of new characters like “NERD FACE” ☺
06:12:50 <pravins> Emacs does not use any other library like libicu and glibc?
06:14:03 <mfabian> It does not use libicu and does not use glibc for Unicode stuff. glibc does not have the names anyway.
06:14:49 <pravins> does Emacs support Unicode 7>
06:14:50 <pravins> ?
06:15:40 <pravins> fujiwarat: thanks for https://fedoraproject.org/wiki/Changes/IBus1.6
06:16:36 <pravins> may be good to add some screenshots, even pointing to blog will be nice for IBus 1.6.
06:16:59 <pravins> epico:  thanks for reporting https://fedoraproject.org/wiki/Changes/ibus-libzhuyin
06:17:09 <epico> welcome
06:17:25 <pravins> i am still confuse should it be systemwide or self contained.
06:17:49 <ueno__> mfabian, might be supported in the git master of Emacs https://lists.gnu.org/archive/html/emacs-diffs/2015-06/msg00223.html
06:18:10 <mfabian> ueno__: Thank you, just checking ...
06:18:41 <pravins> ueno__: excellent. Thanks :)
06:18:47 <anish_> Hi just realised meeting
06:18:48 <paragan> file a bug to update emacs in rawhide
06:19:05 <pravins> anish_: hi :)
06:19:10 <pravins> #chair anish_
06:19:10 <zodbot> Current chairs: anish_ epico mfabian paragan pravins tagoh_ ueno__
06:19:46 <pravins> epico: i am doubtful whether Ibus-Lbzhuyin is systemwide or self contained. Since we are changing systems default i think it should be systemwide.
06:19:59 <epico> it is self-contained.
06:20:02 <anish_> hi pravins
06:20:17 <epico> only comps.xml for zh_TW will be affected.
06:20:24 <tagoh_> pravins: should be self contained
06:21:19 <pravins> tagoh_: epico sure.
06:22:08 <pravins> mfabian: thanks for https://fedoraproject.org/wiki/Changes/Glibc_locale_subpackaging
06:22:37 <paragan> epico, let it be self-contained
06:22:52 <epico> okay
06:23:28 <pravins> paragan: so in next Fesco meeting these changes will get accepted?
06:24:05 <paragan> yeah once they come on Agenda there will be discussions and if everything looks fine, fesco will accept it :)
06:24:57 <pravins> paragan: great, hope you can bat for our changes there :)
06:25:08 <pravins> from ideas we draft only two are missing
06:25:49 <pravins> ueno__: i did not saw Wayland change proposal from Desktop for F23. did i missed it.
06:26:03 <pravins> presently accepted changes are At  https://fedoraproject.org/wiki/Category:ChangeAcceptedF23
06:26:15 <pravins> and announced changes are At https://fedoraproject.org/wiki/Category:ChangeAnnounced
06:26:45 <pravins> i dropped audit of default fonts from F23. I was thinking to propose idea first and then if it get approved we can go ahead with it.
06:28:09 <pravins> meanwhile lets move to next topic.
06:28:10 <pravins> #info #51: Fedora 23 Workstation Tasks (petersen)
06:28:13 <pravins> #link https://fedorahosted.org/i18n/ticket/51
06:28:58 <pravins> juhp is again away today. We have gone through the list once.
06:29:05 <pravins> may be we can close this ticket?
06:29:40 <pravins> In next meeting we are anyway going to discuss all the proposed changes for F23 and do we need to track any change. As we did for F22.
06:31:21 <pravins> may be will ask to juhp.
06:31:33 <pravins> We done with all the topics for day.
06:31:35 <pravins> #topic Open Floor
06:31:48 <pravins> anish_: i moved Gnome redesign plan from agenda list today.
06:32:04 <pravins> If you have anything to discuss please add it to agenda.
06:32:18 <pravins> do we have any other topic for open floor?
06:32:20 <mfabian> Rajasthani is written in Devanagari, not in Latin script, right?
06:32:48 <pravins> mfabian: yes.
06:33:12 <mfabian> Then this looks wrong: http://unicode.org/cldr/trac/browser/trunk/common/supplemental/supplementalData.xml#L2026
06:33:23 <mfabian> <language type="raj" scripts="Latn"/>
06:33:47 <mfabian> There seem to be quite a few mistakes in that file ...
06:34:23 <pravins> We have added Rajasthani locale recently https://sourceware.org/bugzilla/show_bug.cgi?id=16857
06:35:02 <mfabian> I saw that our Rajasthani locale uses devanagari script, so I reported this as a bug in the CLDR tracker.
06:35:04 <pravins> i think that is why lot of people says Unicode CLDR is not trusted one :(
06:35:34 <mfabian> For the other mistakes I am less sure then in the Rajasthani case and therefore didn’t yet report them, but quite a few seem a bit strange.
06:36:33 <pravins> mfabian:  can you provide bug report link here?
06:37:03 <mfabian> http://unicode.org/cldr/trac/ticket/8683
06:37:15 <pravins> thanks mfabian
06:37:25 <pravins> any other topic for day?
06:38:12 <pravins> lets close meeting in few minutes then.
06:38:19 <fujiwarat> pravins: https://fedoraproject.org/w/index.php?title=Changes/IBus1.6&diff=416112&oldid=416109
06:38:36 <fujiwarat> self-contained is ok?
06:39:29 <pravins> fujiwarat: does any other packages need to update due to this change?
06:40:17 <fujiwarat> pravins: No, I think other packages are not updated.
06:40:17 <paragan> I think if we look at other submitted proposals, many package version upgrades are self-contained changes
06:40:36 <fujiwarat> ok, i see.
06:40:38 <paragan> so yes IBus change is okay to be self-contained
06:40:43 <pravins> fujiwarat: in that case self-contained is fine. :)
06:42:23 <tagoh_> isn't ibus a critical path component?
06:42:39 <epico> I think so.
06:43:09 <fujiwarat> yes, it's a critical path component.
06:43:11 <tagoh_> critical path component should be system-wide changes
06:43:39 <paragan> yes that is also right
06:44:22 <fujiwarat> ok, so I will enable system-wide and disable self-contained.
06:44:39 <paragan> yes please
06:45:40 <pravins> tagoh_: thanks :)
06:46:16 <paragan> so basically changes related to these packages https://admin.fedoraproject.org/pkgdb/api/critpath should be marked as system-wide change
06:47:37 <fujiwarat> done
06:47:44 <paragan> cool
06:49:05 <pravins> great. i think we done with most of the topic.
06:49:46 <pravins> if nothing more, lets close meeting in couple of minutes.
06:50:43 <pravins> #info From i18n group 3 system wide and 1 self contained change proposed for Fedora 23.
06:51:24 <paragan> great!!
06:52:25 <pravins> #endmeeting