fesco
LOGS
18:00:08 <rishi> #startmeeting FESCo (2015-06-03)
18:00:08 <zodbot> Meeting started Wed Jun  3 18:00:08 2015 UTC.  The chair is rishi. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:17 <rishi> #meetingname fesco
18:00:22 <rishi> #meetingname fesco
18:00:22 <zodbot> The meeting name has been set to 'fesco'
18:00:45 <rishi> #chair ajax dgilmore jwb mitr nirik paragn rishi thozza sgallagh
18:00:45 <zodbot> Current chairs: ajax dgilmore jwb mitr nirik paragn rishi sgallagh thozza
18:00:52 <jwb> hi
18:00:55 <nirik> .hello kevin
18:00:55 <ajax> howdy
18:00:56 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
18:01:01 <paragan> Hi
18:01:07 <jkurik> .hello jkurik
18:01:08 <rishi> #topic init process
18:01:08 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
18:01:18 <mitr> Hello
18:01:24 <sgallagh> I'm semi-around but stuck in an all-day meeting in a room with fluctuating wifi
18:01:29 <sgallagh> So... yeah
18:02:01 <rishi> #topic #1442 Admin and Commits privileges for Puppet package
18:02:08 <rishi> .fesco 1442
18:02:10 <zodbot> rishi: #1442 (Admin and Commits privileges for Puppet package) – FESCo - https://fedorahosted.org/fesco/ticket/1442
18:02:55 <rishi> FYI, I had CCed kanarip on the agenda email, and pinged him on IRC 5 minutes back.
18:03:03 <nirik> so I haven't heard anything from him since he said he would take care of it when he got back home...
18:03:22 <nirik> but since he said that, I would like to propose we just approve the acls.
18:03:32 <nirik> he didn't seem to have any objection.
18:03:37 <rishi> nirik: Yeah.
18:03:58 <rishi> Proposal: Grant ACLs to gchamoul
18:04:01 <paragan> good to approve puppet package acls to gchamoul
18:04:03 <nirik> +1
18:04:06 <paragan> +1
18:04:09 <rishi> +1
18:04:10 <ajax> +1
18:04:14 <jwb> +1
18:04:45 <rishi> I count 6 +1s.
18:04:57 <rishi> sgallagh: Do you hav ean opinion?
18:04:59 <rishi> mitr: ?
18:05:13 <mitr> rishi: 0, I didn’t have time to follow this I’m afraid.
18:05:24 * nirik can go into pkgdb and approve them.
18:05:32 <rishi> #agreed Grant ACLs to gchamoul (+6)
18:05:46 <rishi> #topic #1444 updates deliverables
18:05:52 <rishi> .fesco 1444
18:05:54 <zodbot> rishi: #1444 (updates deliverables) – FESCo - https://fedorahosted.org/fesco/ticket/1444
18:06:04 <sgallagh> Sorry, belated +1 above.
18:06:15 <rishi> Thanks, sgallagh
18:06:35 <rishi> nirik: dgilmore: I think we didn't update the ticket after last week's meeting.
18:06:51 <nirik> right. dgilmore is out at the releng fad today/this weekend.
18:06:56 <rishi> Did anyone talk to QA?
18:08:09 <jwb> i think dgilmore sent an email, but i've not seen much discussion
18:08:09 <nirik> I think there was a list post.
18:08:12 <nirik> yeah
18:08:26 <paragan> yes I see dgilmore sent an email to test list
18:08:38 <rishi> How about we postpone it and wait for dgilmore to return from the FAD?
18:08:43 <nirik> yep. sounds good.
18:08:43 <sgallagh> rishi: +1
18:08:53 <rishi> Proposal: Postpone and wait for dgilmore to return from the FAD.
18:09:06 <paragan> +1 yes revisit next week
18:10:00 <ajax> +1
18:10:02 <rishi> mitr: jwb: ?
18:10:10 <rishi> +1, obviously
18:10:11 <mitr> sure
18:10:29 <jwb> yeah, i guess +1
18:10:39 <rishi> #agreed Postpone and wait for dgilmore to return from the FAD. (+7)
18:10:55 <rishi> #topic #1445 F23 Self Contained Changes
18:11:01 <rishi> .fesco 1445
18:11:03 <zodbot> rishi: #1445 (F23 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1445
18:11:36 <jwb> i don't think we discussed netizen
18:11:36 <thozza> hi, sorry I'm late.... :-/
18:11:37 <nirik> I failed to start discussion on it. ;(
18:11:49 <jkurik> We have postponed the decision about Netizen spin at the last meeting
18:13:00 <nirik> I'd be ok waiting another week...
18:13:05 <rishi> Proposal: Postpone until further discussion
18:13:32 <jkurik> I do not expect much discussion on it
18:13:37 <sgallagh> Can we at least request that the proposer provide more info?
18:13:54 <mitr> jkurik: Why? Is the proposer inactive?
18:13:54 <jwb> sgallagh, sure, if we actually ASK them for it
18:14:10 <jkurik> mitr: I am not sure
18:14:22 <jkurik> I will ask him to provide more info
18:14:32 <nirik> there was not much discussion on list, they may have no idea we have any questions for them
18:14:52 <jkurik> anything specific we would like to know about the Netizen spin ?
18:14:53 <mitr> Yeah, there were a few concerns raised but it was not obvious that they may be blocking or need a response.
18:15:05 <sgallagh> From the proposal, I have no idea what exactly they intend to do (and whether they intend to do it themselves or are expecting someone to do it for them)
18:15:36 * nirik thinks it's best for fesco members to actually ask those things on the devel list...
18:16:03 <mitr> nirik: yeah; and before the first meeting about the Change
18:16:08 <jwb> nirik, right.
18:16:51 <rishi> It wasn't clear to me why we need a separate spin for this, instead of the user just installing whatever packages they want. Or in other words, how does the spin non-trivially help users?
18:17:12 <mitr> rishi: This question is somewhat applicable to all spins
18:17:48 <mitr> This one does seem to promise more than other spins do, though.
18:18:04 <rishi> nirik: A KDE spin is non-trivial because asking a user to install a few dozen packages with sometimes vaguely expressed interdependencies is impractical.
18:18:49 * nirik isn't following...
18:18:58 <nirik> kde spins should work fine.
18:19:46 <nirik> anyhow, shall we try and ask things for real this week?
18:20:13 <mitr> I am sending a more explicit clarification right now, please pile on if it is insufficient.
18:21:53 <rishi> "Fedora Netizen is an open source operating system for enabling internet citizens to engage with online services and communities." <-- The sentences after this one stop making sense to me.
18:22:25 <rishi> Anyway ...
18:23:03 <rishi> How about we explicitly ask things (mitr has already started) this week, and postpone taking a decision to next week?
18:23:21 <jkurik> rishi: +1
18:23:23 <nirik> yep.
18:23:44 * nirik will add additional questions as followup to mitr's post.
18:24:06 <rishi> +1
18:24:18 <paragan> rishi, +1 to proposal. Wait for discussion on devel list.
18:24:20 <rishi> I assume mitr is implicitly +1
18:24:20 <sgallagh> +1
18:24:21 <ajax> +1
18:24:25 <mitr> +1
18:24:53 <jwb> +1
18:24:56 <rishi> #agreed Let's explicitly ask things this week, and postpone taking a decision to next week (+7)
18:25:06 <jkurik> thanks for starting the discussion on devel list
18:25:26 <rishi> jkurik: Do you have something to discuss?
18:25:46 <jkurik> rishi: nothing more this week
18:25:51 <rishi> ok
18:25:52 <rishi> #topic Next week's chair
18:26:28 <paragan> I can chair next week
18:26:50 <rishi> Thanks for volunteering, paragan
18:26:52 <rishi> #info paragan will chair next week's meeting
18:26:58 <rishi> #topic Open Floor
18:27:27 <sgallagh> Sorry I had to bail on chairing. Thanks for covering, rishi
18:27:54 <sgallagh> Also, one point of order: FESCo chairs are up for election. Just a reminder to nominate.
18:28:08 <rishi> sgallagh: My pleasure.
18:28:55 <jkurik> sgallagh: https://lists.fedoraproject.org/pipermail/devel-announce/2015-June/001594.html
18:29:24 <rishi> jkurik: Yeah
18:29:39 <rishi> I already pinged a few people to submit nominations.
18:29:42 <sgallagh> Hmm, I missed that the nomination wasn't open yet.
18:29:59 <rishi> Anything else?
18:30:03 <thozza> I have one question... I installed F22 Workstation last week and found out, that it is not trivial for user to determine which services have workstation-specific settings and there is no easy way to get rid of the product specific settings. is this expected?
18:30:09 <nirik> seems odd that it's not...
18:30:50 <sgallagh> thozza: Any change you make is preserved.
18:30:59 * rishi hasn't installed F22 yet
18:31:00 <sgallagh> The product-specific settings are only defaults
18:31:15 <thozza> e.g. the firewalld. I know it was a feature, that product-specific settings, but after I install the product, I have to do it manually and determine it from SPEC file
18:31:32 <sgallagh> thozza: What do you mean?
18:31:38 <rishi> What is "it"?
18:31:55 <sgallagh> Any firewall-cmd call should behave normally
18:32:04 <thozza> I mean that after installing workstation, there is no way to know that firewalld has specific settings, other than to know it
18:32:18 <sgallagh> Are you expecting that removing 'fedora-release-workstation' should change your firewall to the non-product default?
18:32:21 <thozza> and then I have to manually swap it, since it is done in %post script
18:32:27 <sgallagh> We expressly decided that was bad and unsafe
18:32:36 <sgallagh> thozza: You shouldn't have to know it.
18:32:47 <thozza> sgallagh: not specifically, but at least some easier way if possible
18:32:48 <sgallagh> It's *just* default settings. If you make any change at all, that will persist
18:33:05 <sgallagh> thozza: That's an explicit non-goal
18:33:09 <mitr> thozza: If you want to install Server, don’t install Workstation ☺
18:33:25 <thozza> Right, I just don't know what everything is changed in Workstation, because there is no way to determine it
18:33:34 <sgallagh> Converting between products (or non-product) is expressly unsupported, YMMV, etc.
18:33:44 <thozza> mitr: I want to install desktop enwironment ;)
18:34:00 <sgallagh> thozza: You're not supposed to care.
18:34:03 <mitr> https://fedoraproject.org/wiki/Packaging:Per-Product_Configuration suggests grepping the RPM scripts should work. But then there are the kickstarts.
18:34:28 <mitr> So, it is possible to know but we are not maintaining a support page listing all the differences.
18:34:34 <thozza> ahh, ok.... so repoquery on the configuration should work
18:34:36 <sgallagh> (the only exception is the cloud->server transformation, which is maintained by the Cloud WG as a script)
18:35:22 <thozza> so the bottom line is that it is expected that it is hard ;)
18:36:07 <gholms> Do we even have a supported path for installing a basic system with a non-workstation DE any more?
18:36:17 <sgallagh> thozza: It should *never matter*, is the point I think I'm failing to make :)
18:36:46 <sgallagh> gholms: Sure, use one of the livecds or any of the netinstalls
18:37:03 <thozza> sgallagh: I'm not sure I agree as a user
18:37:17 <gholms> Net installs wind up as nonproduct, then?
18:37:32 <thozza> since it is not like everyone is configuring every single service after the installation, so I have my own defaults
18:37:35 <dgilmore> hey guys sorry I am late
18:37:39 <thozza> in that case it would not matter
18:37:50 <sgallagh> thozza: That makes no sense.
18:38:00 <mitr> thozza: Are you reviewing every config change made by non-product RPM packages; or every config value default chosen by upstream? If not, why would you review every Workstation change?
18:38:02 <sgallagh> If you're not changing the configuration, then presumably you're trusting that the OS default is sensible
18:38:40 <sgallagh> thozza: And if you're that paranoid: don't use Workstation...
18:38:49 <thozza> mitr: I'm not... just beacuse I liked the defaults from pre-workstation times more than in the workstation
18:38:52 <thozza> as a user
18:38:53 <dgilmore> thozza: the only service change from system defaults on workstation is that sshd is disabled
18:39:04 <sgallagh> dgilmore: The Firewall rules are different too
18:39:30 <mitr> thozza: You can have a personal list of things you like to set just so, or changed; but I don't see that it matters whether you want to change them from upstream, package, or product defaults.
18:39:42 <thozza> dgilmore: also the service presets can be changed and inspected using fedora-release-workstation
18:39:49 <dgilmore> sgallagh: they are different.
18:39:58 <nirik> the sshd disabled is also on all lives
18:40:31 <thozza> Right, I think it is good to provide sane defaults like products do
18:40:34 <sgallagh> dgilmore: What he originally asked about was how to figure out which packages have a different default config than the non-product set.
18:40:41 <thozza> and that every product has different target audience
18:40:45 <dgilmore> thozza: perhaps we need somewhere to document the differences between the versions
18:40:59 <thozza> just wanted to know if there is an easy way to determine what is different
18:41:04 <nirik> (also it enables NetworkManager, disables network).
18:41:08 <thozza> and change it if I want to
18:41:50 <sgallagh> thozza: To that end, 'dnf repoquery --whatprovides "variant_config(workstation)" is supposed to work
18:41:52 <dgilmore> thozza: honsetly I think that answer is no
18:42:05 <thozza> sgallagh: yeah, I missed that
18:42:09 <dgilmore> sgallagh: you mean --whatrequires
18:42:11 <thozza> thanks for pointing it out
18:42:22 <dgilmore> or maybe i am getting is wrong
18:42:23 <sgallagh> dgilmore: No, I didn't
18:42:39 <sgallagh> But I forgot to capitalize Workstation in that command
18:42:49 <rishi> thozza: Problem solved?
18:43:10 <thozza> rishi: yes ;)
18:43:27 <thozza> thanks all
18:43:41 <sgallagh> np
18:44:29 <rishi> I am going to close the meeting in 2 minutes if nobody speaks up.
18:44:58 * gholms has a question about net install disks
18:45:23 <rishi> Sure, gholms
18:45:25 <rishi> Go ahead.
18:45:41 <gholms> I see that F22 has a workstation netinstall disk, a server netinstall disk, and so on.  Are those supposed to be different in some meaningful way?
18:46:10 <sgallagh> gholms: The only difference between them is branding images
18:46:20 <sgallagh> Otherwise, they draw from exactly the same package collections.
18:46:32 <gholms> Either one can install either product, then?
18:46:36 <sgallagh> You can install Server from the Workstation netinstall if you want to (and vice versa) or any other env ggroup
18:46:37 <nirik> I thought also the default selection was also set... ?
18:46:42 <sgallagh> Oh right, yeah
18:46:54 <sgallagh> Obviously they default to the matching env group as well
18:47:03 <gholms> Of course.  :)
18:47:04 <sgallagh> Oh, one other thing
18:47:09 <nirik> but you could uncheck that and install whatever
18:47:24 <sgallagh> If you install Server from the Workstation disk and take the default FS, it will be the WS default FS
18:47:34 <sgallagh> (So ext4 on LVM, rather than XFS on LVM)
18:47:38 <dgilmore> gholms: workstation only offers workstation
18:47:53 <sgallagh> dgilmore: No it doesn't.
18:48:02 <dgilmore> sgallagh: it did in my testing but okay
18:48:04 <sgallagh> ... I thought
18:48:43 <gholms> Okay, but the *intention* is that they be equivalent apart from their defaults.
18:48:46 <gholms> Right?
18:48:51 <sgallagh> gholms: Yes
18:48:55 <gholms> Excellent.  Thanks.
18:48:59 <jwb> sort of?
18:49:06 * gholms will test and find out for sure
18:49:49 <rishi> Anything else?
18:50:03 <sgallagh> /me is booting the WS netinst iso now... one moment
18:52:29 <sgallagh> It does indeed present all possible install environments
18:52:43 <sgallagh> defaulting to Workstation, of course
18:54:55 <dgilmore> okay
18:59:45 <rishi> Ok, then.
18:59:51 <rishi> I guess, that is it.
19:00:11 <rishi> Thanks for your time.
19:00:12 <rishi> #endmeeting