kde-sig
LOGS
15:05:48 <rdieter> #startmeeting kde-sig
15:05:49 <zodbot> Meeting started Tue May 19 15:05:48 2015 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:52 <rdieter> #meetingname kde-sig
15:05:52 <zodbot> The meeting name has been set to 'kde-sig'
15:05:58 <rdieter> #topic roll call
15:06:04 <Kevin_Kofler> Present.
15:06:10 <rdieter> hi all, friendly kde-sig meeting about to start, who's present today?
15:06:19 * jgrulich is present
15:06:30 <tosky> (sorry, here)
15:07:02 <heliocastro> here too
15:09:21 <rdieter> #info rdieter jgrulich tosky Kevin_Kofler heliocastro present
15:09:28 <rdieter> #chair jgrulich tosky Kevin_Kofler heliocastro
15:09:28 <zodbot> Current chairs: Kevin_Kofler heliocastro jgrulich rdieter tosky
15:09:40 <rdieter> #topic agenda
15:09:45 <rdieter> what to discuss today?
15:10:46 * jreznik is here
15:10:48 <danofsatx> sorry, folks, I'm working under a deadline here.
15:11:07 <rdieter> #info jreznik danofsatx present
15:11:10 <rdieter> #chair jreznik danofsatx
15:11:10 <zodbot> Current chairs: Kevin_Kofler danofsatx heliocastro jgrulich jreznik rdieter tosky
15:11:15 <rdieter> just collecting agenda topics
15:11:25 <rdieter> (maybe this will be a short meeting) :)
15:11:41 <danofsatx> agenda: is Plasma 5 ready for GA?
15:12:13 <Kevin_Kofler> Yeah, I guess some F22 status update could be useful, also for 0-day updates maybe?
15:12:34 <rdieter> ok, F22
15:12:48 <rdieter> let's start with that
15:13:01 <rdieter> #topic F22/plasma5 status
15:13:37 * rdieter checks tracking bugs
15:13:40 <rdieter> .bug 1135100
15:13:43 <zodbot> rdieter: Bug 1135100 Fedora 22 Blocker KDE Tracker - https://bugzilla.redhat.com/1135100
15:13:49 <rdieter> .bug 1135101
15:13:51 <zodbot> rdieter: Bug 1135101 Fedora 22 Target KDE Tracker - https://bugzilla.redhat.com/1135101
15:14:25 <rdieter> oops, looks like the Desktop thing got filed twice
15:14:27 <rdieter> .bug 1199460
15:14:31 <zodbot> rdieter: Bug 1199460 kde-live: add liveinst link - https://bugzilla.redhat.com/1199460
15:15:07 <rdieter> .bug 1199553
15:15:10 <zodbot> rdieter: Bug 1199553 kde-settings: gtk3 CSD issues - https://bugzilla.redhat.com/1199553
15:15:18 <rdieter> i think that one can be closed, all the bad csd issues seem to be resolved
15:16:39 <danofsatx> CSD?
15:16:41 <pino|work> ah, there's me too (chair me plztnx)
15:16:44 * danofsatx looks it up
15:16:49 <pino|work> danofsatx: client-side decorations
15:17:05 <danofsatx> ah, okie
15:17:30 <rdieter> #info pino|work present
15:17:31 <rdieter> #chair pino|work
15:17:32 <zodbot> Current chairs: Kevin_Kofler danofsatx heliocastro jgrulich jreznik pino|work rdieter tosky
15:17:33 <Kevin_Kofler> i.e., wrong end decorations
15:17:45 <Kevin_Kofler> (Decorations belong in the WM and that's it!)
15:18:39 <Kevin_Kofler> Those gtk3 windows still look like crap because its idea of "disabling CSD" is to just show a nested window decoration as a normal window element.
15:18:44 <Kevin_Kofler> But there's not much we can do about that.
15:19:22 <jreznik> well, doesn't matter - we can't do anything with it
15:20:14 <rdieter> we have the known, ongoing issues related to Session management, but I see no immediate solution or resolution to that
15:20:31 <rdieter> I suppose since we know SM is broken, we could consider disabling it by default
15:20:51 <rdieter> (but I think that's overly drastic)
15:21:31 <Kevin_Kofler> That would actually turn the issue into a blocker, as per your analysis in the bug. :-)
15:21:44 <rdieter> no it would not
15:21:52 <Kevin_Kofler> (The only reason it's a blocker because there's no default menu entry for "Save Session". Making it manual would make the entry show up.)
15:22:10 <rdieter> maybe if we set "Restore Manually saved session", but still that's a stretch
15:22:23 <rdieter> I was only using that as an argument against your rationale
15:22:27 <Kevin_Kofler> *The only reason it's NOT a blocker, I mean
15:23:11 <Kevin_Kofler> There's a clear criterion that everything in the application launcher needs to pass a basic functionality test.
15:23:15 * than__ is present
15:24:08 <rdieter> #info than__ present
15:24:11 <rdieter> #chair than__
15:24:11 <zodbot> Current chairs: Kevin_Kofler danofsatx heliocastro jgrulich jreznik pino|work rdieter than__ tosky
15:24:32 * danofsatx doesn't see "Save Session" in the log out dialog.
15:24:38 <rdieter> there's also the fun driver/mesa related issues of kwin and plasmashell periodically freezing
15:24:50 <Kevin_Kofler> danofsatx: It's not shown by default.
15:24:53 <danofsatx> well...there appears to be progress on that.
15:25:04 <danofsatx> if it's not shown by default, then it's not a blocker.
15:25:04 <rdieter> danofsatx: it's only present if you select option in SM settings: Restore manually saved session (it gives the ability to actually do the manual saving)
15:25:05 <Kevin_Kofler> But if we were to change to manually saved sessions, then it would be shown by default.
15:26:12 <rdieter> there's a proposed patch in the mesa/dri3 freedesktop.org bug , anyone interested in trying it out ?
15:26:33 <rdieter> if so, I could work on making a mesa scratch build (or copr)
15:26:39 <jgrulich> rdieter: if there is a scratch build available I would definitely try it, because it's super annoying
15:26:42 <danofsatx> I received a dri3 update this week.
15:26:48 <danofsatx> the freezes have....changed.
15:27:12 * rdieter last mesa update was installed may 05
15:27:23 <danofsatx> I've not gotten a complete lockup, but I have gotten a momentary freeze when opening the kicker or a window preview popup from the task bar.
15:27:40 <rdieter> https://admin.fedoraproject.org/updates/FEDORA-2015-7655/mesa-10.5.4-1.20150505.fc22
15:27:58 <danofsatx> maybe it took me a week to update it ;)
15:28:01 <rdieter> danofsatx: momentary freezes are probably different, but hard to speculate
15:28:21 <danofsatx> I consider them MUCH improved over complete lockups.
15:28:39 <rdieter> I've still had plasmashell hangs since installing that update, at least 3-4 of theme
15:29:26 <rdieter> odd, looks like we don't have the dri thing on either of our tracker bugs
15:29:49 <danofsatx> I've not seen it on the Intel machine, but I have on the neauvou
15:29:53 <danofsatx> or however you spell it
15:30:10 <danofsatx> My update to mesa-dri-drivers-10.5.4-1.20150505.fc22.x86_64 took place on 11 May.
15:30:13 <rdieter> .bug 1193742
15:30:15 <zodbot> rdieter: Bug 1193742 Plasma5 Freezes (often due to notifications while locked), xcb/dri3 deadlock? - https://bugzilla.redhat.com/1193742
15:31:00 <rdieter> upstream reference, http://bugs.freedesktop.org/show_bug.cgi?id=84252
15:31:24 <rdieter> ok, I'll try to pull in the candidate fix for scratch build testing
15:31:36 <danofsatx> but yes, I'll gladly test it.
15:31:37 <rdieter> #action rdieter to make mesa scratch build for testing
15:32:08 <rdieter> any other f22-related issues to discuss?
15:32:49 <danofsatx> apper?
15:34:09 <rdieter> fyi, https://bugzilla.redhat.com/show_bug.cgi?id=1217844#c23  had what appears to be a completely different backtrace, if anyone has input on that one, please comment in the bug
15:34:18 <rdieter> danofsatx: what about apper?
15:34:33 <Kevin_Kofler> danofsatx: Nothing much new there, I'll take the blame for being the roadblock this time. Sorry, very busy days lately, so no time to update the upstream pull request.
15:34:49 <danofsatx> the fact that there is _still_ no graphical software component for Plasma that allows users to browse available packages and groups.
15:35:13 <rdieter> danofsatx: there are options, we just don't include them (yumex, muon-discover)
15:35:33 * rdieter really likes muon, fwiw
15:35:42 <Kevin_Kofler> Muon doesn't browse groups.
15:35:49 <Kevin_Kofler> It browses AppStream, which is a wholely different thing.
15:36:05 <rdieter> true, I like that
15:36:14 <Kevin_Kofler> And Yumex is not "for Plasma", it's a GTK+ app.
15:36:24 <danofsatx> I just had a co-worker intsall F22 Plasma, and when I asked him to install kvm/libvirt, the first place he went was Apper because it was in the menus.
15:36:36 <rdieter> Kevin_Kofler: strictly speaking, apper isn't "for plasma5" either
15:37:49 <rdieter> can apper (in f20) install groups?  I personally never figured out how, but didn't try very hard either
15:38:01 <rdieter> looks like we lost some folks, netsplit?
15:38:09 <danofsatx> no, it was broken in F20 also.
15:38:09 <rdieter> helio and jreznik
15:38:26 * danofsatx isn't sure how that made it through release validation, but it's water under the bridge now.
15:38:27 <Kevin_Kofler> danofsatx: Groups work in F20. F21 broke them.
15:38:31 <Kevin_Kofler> F20 used PK-yum.
15:38:38 <rdieter> not sure if apper ever really supported installing groups as a whole, but you could install individual components of a group
15:38:41 <Kevin_Kofler> One of the reasons I still use F20.
15:39:06 <rdieter> Kevin_Kofler: so how does it work (to install groups)?
15:39:36 <Kevin_Kofler> To install a whole group, you can search for its group ID and there should be a "metapackage" showing up that you can install.
15:39:53 <rdieter> ok, so that's not browseable either :-P
15:40:05 <Kevin_Kofler> You asked for how to install the group as a group.
15:40:06 <rdieter> but at least that worked compared to now?
15:40:12 <Kevin_Kofler> It's not the most important feature to me.
15:40:17 <rdieter> ok
15:40:21 <Kevin_Kofler> What ALSO works on F20 is that you can browse the group contents.
15:40:57 <Kevin_Kofler> None of that works (and not even the hardcoded PackageKit fallback groups, because those also need to be mapped to comps somewhere) because PK-hif does not support comps, at all.
15:41:17 <Kevin_Kofler> The pull request that I need to fix up would make at least the static fallback groups work.
15:41:30 <rdieter> that's something at least
15:41:32 <Kevin_Kofler> The dynamic groups and the metapackage installation would STILL not work, those need additional code.
15:41:46 <Kevin_Kofler> (but they also need the comps reading to build upon)
15:41:50 <rdieter> baby steps
15:41:54 <Kevin_Kofler> (so that pull request needs to be done first)
15:42:05 <rdieter> moving on then...
15:42:08 <rdieter> #topic open discussion
15:42:14 <Kevin_Kofler> The big problem is that nobody cares about this anymore, because hughsie thinks everyone should just use AppStream.
15:42:23 <rdieter> anything else to report or discuss?
15:42:40 <danofsatx> Go team go?
15:42:51 <Kevin_Kofler> Switching from Anaconda liveinst to Calamares by default for F23?
15:42:54 <rdieter> any quick updates on interesting stuff folks are working on this week?
15:43:21 <rdieter> Kevin_Kofler: sounds like a good mailing list topic for discussion
15:43:46 <rdieter> (i don't think the little time we have here would do it justice)
15:43:56 <danofsatx> agreed, but I like the idea.
15:44:25 <Kevin_Kofler> Seeing yet another case of Anaconda not working properly on KDE (though it now looks like it only happens when run in a Konsole) really made me want to ditch that GNOME-centric thing ASAP.
15:44:27 <danofsatx> submissions for that are due in ~3 weeks, aren't they?
15:45:05 * rdieter thinks "gnome-centric" is an unfair characterization, but it *is* using gtk
15:46:59 <rdieter> clearly everyone is working on boring stuff this week, not worth mentioning today  :)
15:47:11 <danofsatx> RC1 is dropping today.
15:47:24 <danofsatx> are we ready for the onslaught of distraught users?
15:48:01 <rdieter> omg, we fear change
15:48:17 <Kevin_Kofler> We survived F9, we're going to survive F22 too. :-)
15:48:39 <danofsatx> well....there are some "transition" issues we're going to run into going from 4 to 5. the sessions is one of those
15:48:45 <rdieter> I suppose we could prep for that with copious blogs and awareness campaigns so folks have fewer excuses to be surprised
15:49:01 <danofsatx> If you have a saved session from KDE4, it is resumed on Plasma5 but you can't change it.
15:49:14 <danofsatx> Also, a lot of icons don't switch to the new ones.
15:49:40 <rdieter> danofsatx: that's... odd, plasma5 uses a completely different SM config dir and mechanism, I wouldn't expect kde4 sessions to be recognized at all
15:50:30 <rdieter> danofsatx: can you be more specific?
15:50:42 <rdieter> and/or list bugs tracking the issues you mention?
15:51:03 <danofsatx> for one, the system settings icon is still the olde KDE4 icon: http://i.imgur.com/0FdBEiV.png
15:51:41 <rdieter> wtf
15:51:45 <danofsatx> But as for the saved session, my issue may be unique. The session management was working in the F21 Plasma preview, that is the session that gets restored on every login.
15:52:00 <rdieter> possible you're using oxygen icon theme?
15:52:07 <rdieter> if so, then not surprising it's showing the old one
15:52:09 <danofsatx> Konversation is different, too, come to think of it
15:52:41 <danofsatx> huh, didn't even think of that.
15:53:02 <danofsatx> that was held over from F21 plasma, which itself was an upgrade from KDE4
15:53:04 <Kevin_Kofler> Yeah, looks like the theme is set to Oxygen.
15:53:17 <Kevin_Kofler> So IMHO the real bug is the icons that do NOT look like the old ones.
15:53:31 <rdieter> danofsatx: plasma theme affects some items too (systray icons for example)
15:53:32 <Kevin_Kofler> Unfortunately, Plasma icons seem hardcoded to Breeze-themed ones.
15:53:48 <Kevin_Kofler> I guess I need to do a Plasma 5 version of my Oxygen systray icon pack.
15:54:58 <danofsatx> also, you can see the blank spot in my notification tray on that screenshot.
15:55:01 <rdieter> I'll be working on kde-apps-15.04.1 this week too
15:56:03 <rdieter> danofsatx: i've seen tha once or twice with kde telepathy applet (either on resume or when network goes up/down)
15:57:11 <rdieter> ok, let's end the meeting, thanks everyone
15:57:14 <rdieter> #endmeeting