kde-sig
LOGS
15:11:19 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:11:19 <zodbot> Meeting started Tue May 12 15:11:19 2015 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:11:24 <Kevin_Kofler> #meetingname kde-sig
15:11:24 <zodbot> The meeting name has been set to 'kde-sig'
15:11:31 <Kevin_Kofler> #topic Roll call
15:11:39 * Kevin_Kofler is present, obviously. Who else?
15:11:51 <than_> present
15:11:52 <jgrulich> o/
15:11:56 <_heliocastro> here
15:11:58 * dvratil is here
15:12:55 * rdieter waves
15:13:00 <rdieter> .hello rdieter
15:13:01 <zodbot> rdieter: rdieter 'Rex Dieter' <rdieter@math.unl.edu>
15:13:06 <pino|work> ...
15:13:41 <Kevin_Kofler> #chair than_ jgrulich _heliocastro dvratil pino|work rdieter
15:13:41 <zodbot> Current chairs: Kevin_Kofler _heliocastro dvratil jgrulich pino|work rdieter than_
15:15:40 <tosky> hi
15:18:13 <Kevin_Kofler> #chair ltinkl tosky heliocastro
15:18:13 <zodbot> Current chairs: Kevin_Kofler _heliocastro dvratil heliocastro jgrulich ltinkl pino|work rdieter than_ tosky
15:18:36 <Kevin_Kofler> #info Kevin_Kofler, than_, jgrulich, heliocastro, dvratil, pino|work, rdieter, ltinkl, tosky present.
15:18:40 <Kevin_Kofler> #topic Agenda
15:18:50 <Kevin_Kofler> So I think we can finally start.
15:19:07 <Kevin_Kofler> I think there are still F22-related items to discuss, aren't there?
15:20:05 <heliocastro> I wouyld like to propose a review about to include dolphin from framewworks
15:20:21 <rdieter> probably, f22 theming could use some extra work/polish, kf5-5.10 submitted to fix some freeze_exceptions
15:21:35 <rdieter> heliocastro: for f22?
15:21:42 <heliocastro> Yes
15:21:52 <rdieter> ok, can include that in f22 topic
15:22:03 <heliocastro> I've been using it from master branch with our packges from more than two weeks
15:22:10 <heliocastro> Had no crashes at all
15:22:28 <Kevin_Kofler> #topic Fedora 22 final polishing
15:22:35 <jgrulich> heliocastro: it would break some stuff, like using ark from dolphin
15:22:35 <Kevin_Kofler> So let's officially make that our topic.
15:22:50 <Kevin_Kofler> heliocastro: I also think it's way too late to make this change for F22 GA.
15:23:25 * danofsatx arrived back at the desk...you may start the party now
15:23:40 * rdieter agrees it's too late to change *right now*, but could consider it later
15:23:41 <Kevin_Kofler> By the way, what about the request from KWin developer mgraesslin to enable Wayland support in F22's KWin? Are we doing anything about that?
15:23:46 * dvratil is against pushing non-released KF5 ports just because they are KF5 ports
15:23:48 <heliocastro> jgrulich: That's why i want to review the idea, how important is ark and other related plugins to keep a 4 version of such critical component
15:23:59 <Kevin_Kofler> I think it's fairly late for that change (KWin Wayland), too, to be honest.
15:24:11 <marcdeop> today was the final freeze, wasn't it?
15:24:16 <rdieter> kf5 dolphin in rawhide, +1, and maybe copr for more testing
15:24:18 <Kevin_Kofler> But then again upstream says KWin without Wayland support is more or less unsupported upstream.
15:24:22 <dvratil> Kevin_Kofler: to enable wayland support just requires flipping a switch in the specfile
15:24:25 <Kevin_Kofler> IIRC they only allow it at all because of Slackware.
15:24:44 <dvratil> there'll be a new kwin_wayland executable
15:24:57 <dvratil> if marketed as a super-unstable beta feature, we could do that
15:25:01 <rdieter> does enabling wayland support change kwin_x11 at all?  (I assume no, but...)
15:25:08 <Kevin_Kofler> #chair danofsatx
15:25:09 <zodbot> Current chairs: Kevin_Kofler _heliocastro danofsatx dvratil heliocastro jgrulich ltinkl pino|work rdieter than_ tosky
15:25:09 <dvratil> not really
15:25:11 <jgrulich> heliocastro: if that breaks user experience, then I would say it's important
15:25:25 <dvratil> but I'm afraid of people jumping on the wayland hypetrain and using it, then complaining to us
15:25:47 <rdieter> ok, I see no harm in it really, esp if that's what martin wants
15:25:48 <marcdeop> I don't think wayland is ready, specially kde wise
15:25:49 <Kevin_Kofler> rdieter: It does change it somehow, in that the core of KWin gets linked against Wayland.
15:25:59 <heliocastro> dvratil: No problem, we redirect to upstream
15:26:01 <Kevin_Kofler> And kwin_x11 also supports Wayland windows then.
15:26:21 <heliocastro> dvratil: This a tradeoff that they need to do if we accept their requests
15:26:35 <Kevin_Kofler> (I guess you'll only get them when explicitly forcing GTK+ 3 and/or Qt 5 to use Wayland though, they should still detect X11 by default.)
15:27:08 <rdieter> similar to how we had kwin-gles pkg before, make a kwin-wayland I guess
15:27:16 <heliocastro> jgrulich: Yes, but i think dolphin on 4 is breaking more the user experience
15:27:33 <Kevin_Kofler> Still, the fact that it touches code deep in the core of KWin also used by kwin-x11 makes me a bit nervous.
15:27:36 <dvratil> I'm not afraid about upstream, I'm afraid of the fact that nobody ever tested any part of KDE on Fedora under wayland, so this close to F22 release we have no idea what will happen when people start testing it ..:/
15:27:38 <rdieter> or... if wayland is linked anyway, may not be worth making a subpkg at all
15:27:56 <Kevin_Kofler> I think it's too late to try to get it into GA, QA would not let this through the freeze.
15:28:01 <Kevin_Kofler> At most we could aim for 0-day.
15:28:08 <jgrulich> heliocastro: how? there is almost no difference between KDE 4 and KF 5 version on first glance
15:28:13 <rdieter> dvratil: if folks start using non-default stuff, they deserve whatever they get :-P
15:28:20 <dvratil> *shrug*
15:28:51 <rdieter> I agree wayland support probably isn't worth breakig freeze for
15:28:54 <heliocastro> And we can get in a connundrum
15:29:23 <rdieter> proposal: defer kwin/wayland enablement decision until after f22 GA
15:29:24 <heliocastro> Imagine people telling on internerds that fedora is incomplete and upstream from KDE is refusing support
15:29:30 <Kevin_Kofler> Another issue is that we still don't have a folder view by default in F22, so the installer doesn't show up on the desktop.
15:29:32 <Kevin_Kofler> That sucks.
15:29:42 <danofsatx> 0 day. untested change of this magnitude isn't to be introduced so close to RC1.
15:29:54 <Kevin_Kofler> rdieter: Defer +1.
15:30:00 <Kevin_Kofler> I wouldn't even 0-day it, to be honest.
15:30:13 <Kevin_Kofler> I'd try for it once the dust from the release has settled.
15:30:23 * dvratil is OK with enabling this with 5.4 release
15:30:27 <danofsatx> I wouldn't either....it needs testing. I was only noting that if it is acceptable at all, it is after GA.
15:30:28 <dvratil> silently
15:30:52 <dvratil> and marketing it with F23
15:31:06 <Kevin_Kofler> dvratil: Yeah.
15:31:17 * rdieter is ok either way, as long as it's after f22 ga :)
15:31:22 * danofsatx agrees with dvratil
15:32:45 <rdieter> I think we have close to consensus there (kwin) then
15:32:58 <heliocastro> Agreed
15:33:28 * heliocastro need to leave
15:33:49 <rdieter> heliocastro: would you agree to update dolphin in rawhide (master branch) to frameworks version?
15:33:53 <Kevin_Kofler> #agreed It is too late to push kwin_wayland to F22 GA, so we defer the decision on enabling it (in updates) to after the release.
15:33:58 <heliocastro> rdieter: Yes
15:34:08 * dvratil still does not see the point in randomly updating apps to unreleased branches
15:34:25 <rdieter> dvratil: more/early testing
15:34:26 <Kevin_Kofler> dvratil: Well, Rawhide is made for testing things.
15:34:41 <heliocastro> dvratil: and we prefert test things before and fix, than after released
15:34:42 <rdieter> fwiw, kf5 dolphin *almost* made kde-15.04
15:34:55 <Kevin_Kofler> If it is expected that the KF5 version will be released in time for F23, upgrading it in Rawhide now is not a bad idea.
15:34:55 <heliocastro> And i'm using daily
15:34:57 <rdieter> it was proposed a little too late, and was rejected at the time
15:34:59 * heliocastro things in ark again
15:35:07 <dvratil> heliocastro:  I'm using KDE PIM from master daily .... :)
15:35:15 <heliocastro> dvratil: Brave man !!!
15:35:32 * heliocastro going
15:35:37 <Kevin_Kofler> But KDE PIM can hardly get more unusable than the current KDE 4 version, can it? ;-)
15:35:55 <dvratil> but does not Dolphin depend on the new Baloo features?
15:36:06 <rdieter> dvratil: good question
15:36:56 <Kevin_Kofler> Newer than KF5.10 that is being (has been?) released right now?
15:37:13 <dvratil> Vishesh is working on completely new stuff in some branch
15:37:17 <rdieter> if it does, then it obviously won't work
15:37:18 <jgrulich> looks I'll have to take a look at ark if you are going to update dolphin to KF5 version
15:37:20 <dvratil> that should be merged for Plasma 5.4
15:37:25 <rdieter> other polish...
15:37:28 <rdieter> .bug 1199521
15:37:31 <zodbot> rdieter: Bug 1199521 kde-settings: oxygen(qt) vs adwaita(gtk) cursor inconsistency - https://bugzilla.redhat.com/1199521
15:37:38 <ltinkl> dvratil: that branch is already in master iirc
15:37:40 <rdieter> .bug 1220497
15:37:43 <zodbot> rdieter: Bug 1220497 Missing Fedora KSplash theme - https://bugzilla.redhat.com/1220497
15:37:52 <dvratil> ltinkl:  ah, good news then  :)
15:38:23 <Kevin_Kofler> Re #1199521, guess why I have always vetoed using a non-Adwaita cursor theme.
15:38:26 <Kevin_Kofler> It just doesn't work in Fedora.
15:38:33 <Kevin_Kofler> We need to switch the default to Adwaita.
15:38:39 <dvratil> bleh
15:38:54 <rdieter> adwaita doesn't work for window resize handles though
15:39:00 <ltinkl> why? I don't see any adwaita cursor anywhere
15:39:14 <rdieter> ltinkl: I do when I mouse over firefox for example
15:39:17 <Kevin_Kofler> rdieter: Oh fun, there's that bug, too.
15:39:41 * ltinkl launches firefox
15:39:45 <rdieter> ltinkl: I believe you already said you couldn't reproduce it when I brought it up before
15:39:57 <rdieter> but now it's not just me, others are reporting "me too" in that bug
15:40:12 <ltinkl> all breeze cursors, even above firefox
15:40:17 <rdieter> wierd
15:40:17 <Kevin_Kofler> I think Firefox just ignores the XSetting entirely and uses the X11-level default, which is hardcoded to Adwaita.
15:40:30 <tosky> what does it mean switching to dolphin/frameworks in rawhide now? Could it land in F22 before the proper release with 15.08?
15:40:35 <Kevin_Kofler> (at least in rdieter's setup)
15:40:38 <rdieter> Kevin_Kofler: hard to say, that doesn't explain why ltinkl doesn't see adwaita
15:40:51 <rdieter> tosky: no
15:40:52 <ltinkl> yup looks like it, the only difference would be my startkde to fedora's
15:40:58 <Kevin_Kofler> tosky: F22 was branched weeks ago.
15:41:02 <jgrulich> I see adwaita cursor in Firefox
15:41:02 <Kevin_Kofler> So no.
15:41:19 <rdieter> ltinkl: ah
15:41:22 <Kevin_Kofler> The snapshot could land in F23, if upstream somehow cancels the 15.08 release or something unlikely like that.
15:41:25 <ltinkl> jgrulich, rdieter: try to launch firefox from konsole
15:41:29 <rdieter> I'll try to review startkde diffs after meeting
15:41:37 <ltinkl> instead of menu/krunner
15:41:39 <jgrulich> ltinkl: that's what i did
15:42:08 <rdieter> ltinkl: still adwaita
15:42:20 <ltinkl> echo $XCURSOR_THEME
15:42:37 <jgrulich> ltinkl: breeze_cursors
15:42:40 <rdieter> echo $XCURSOR_THEME => breeze_cursors
15:42:45 <ltinkl> heh, ok :)
15:43:08 <danofsatx> I see the Breeze cursur in FF, but it doesn't work properly - I can scroll any non-focused application except FF
15:43:26 <rdieter> danofsatx: I don't think that's related
15:43:36 <rdieter> danofsatx: scrolling and cursor theme, that is
15:43:40 <danofsatx> k, I wasn't sure exactly what we're talking about ;)
15:44:07 <Kevin_Kofler> If we're speaking of issues like #1220497 (the "no KSplash theme one"), then there's also:
15:44:10 <Kevin_Kofler> .bug 1218700
15:44:13 <zodbot> Kevin_Kofler: Bug 1218700 Plasma 5 menu icon is KDE logo, should be Fedora logo - https://bugzilla.redhat.com/1218700
15:44:17 <ltinkl> ok, another thing: try launching "kcminit" from konsole and then start firefox
15:44:24 <ltinkl> jgrulich, rdieter ^^
15:45:13 <jgrulich> ltinkl: still adwaita
15:45:34 <rdieter> adwaita too
15:45:42 <rdieter> I wonder if xsettings-kde is getting in the way
15:46:09 <rdieter> heh, kilall xsettings-kde, now firefox is using breeze
15:46:17 <ltinkl> ah there you go :)
15:46:22 <rdieter> wtf
15:46:28 <ltinkl> I don't have xsettings-kde installed
15:46:34 <ltinkl> that would explain it
15:46:54 <rdieter> xsettings-kde is supposed to export your kde-configured cursor theme though, it's getting it wrong?
15:47:05 <ltinkl> I think exporting $XCURSOR_THEME is enough here (which we do in kcminit_mouse)
15:47:12 <jgrulich> yeah, killing xsettings-kde works here too
15:47:28 <ltinkl> rdieter: it gets exported via kcminit_mouse
15:48:05 <ltinkl> Kevin_Kofler: still convinced we have to use adwaita?
15:48:41 <Kevin_Kofler> ltinkl: We install xsettings-kde by default, so yes. :-)
15:48:57 <ltinkl> Kevin_Kofler: we have to fix xsettings-kde or nuke it
15:49:14 <Kevin_Kofler> Also, we have several cursor themes bloating the live image now (at least Adwaita that always gets dragged in and Breeze) when 1 would be enough.
15:49:33 <Kevin_Kofler> But yes, we need to fix xsettings-kde.
15:49:40 <ltinkl> "bloating" is far fetched
15:49:49 <Kevin_Kofler> Do we still ship the version that looks only in KDE 4 settings?
15:49:54 <Kevin_Kofler> If so, that's likely the issue.
15:49:57 <rdieter> Kevin_Kofler: yes
15:50:13 <rdieter> though systemsettings5 is supposed to sync stuff to kde4 kdeglobals (and friends)
15:51:47 <rdieter> so we're left with theming items
15:51:50 <rdieter> .bug 1220497
15:51:53 <zodbot> rdieter: Bug 1220497 Missing Fedora KSplash theme - https://bugzilla.redhat.com/1220497
15:51:55 <rdieter> .bug 1218700
15:51:58 <zodbot> rdieter: Bug 1218700 Plasma 5 menu icon is KDE logo, should be Fedora logo - https://bugzilla.redhat.com/1218700
15:52:05 <rdieter> anyone able/interested in working on those?
15:52:29 <rdieter> I suppose I can, but can't promise when I'll find time this week
15:52:51 <jgrulich> I can do it tomorrow
15:53:01 <dvratil> "Fedora's own, unique and beautiful KSplash theme is missing."
15:53:14 <dvratil> meh - I doubt it's more beautiful than Plasma 5 splash
15:53:14 <rdieter> yay, thanks.  bonus points if you can create a F22 looknfeel theme too
15:53:41 <Kevin_Kofler> There's also the installer not shown on the desktop.
15:53:44 <rdieter> dvratil: likely it's the same, only difference would be wallpaper
15:54:06 <rdieter> Kevin_Kofler: is there any bug(s) for that yet?
15:54:12 <Kevin_Kofler> (We should either put a folder view widget or the desktop or have the desktop BE the folder view.)
15:54:59 <Kevin_Kofler> Hmmm, I thought we had one, but apparently not. I'm filing one, so that we have something to propose for Blocker/FE.
15:55:19 <ltinkl> I'd go with the same splash screen tbh with a modified (Fedora) wallpaper behind it
15:55:27 <rdieter> ltinkl: +1
15:55:51 <rdieter> jgrulich: while you're at it, f22-themed lockscreen would be nice too, then everything should match
15:55:53 <ltinkl> the splash screen itself is a QML component (albeit themeable)
15:56:08 <ltinkl> ditto for the splashscreen
15:56:26 <jgrulich> rdieter: ok, I'll try to make everything look the same :)
15:56:36 <rdieter> interestingly, when testing plasma-5.2.x, the lockscreen always used my configured wallpaper (F22), but after plasma-5.3, lockscreen uses the default kde one
15:56:44 <ltinkl> if we are brave, we could ship a whole Fedora-themed desktop via the looknfeel package
15:56:50 <ltinkl> IIRC that's what SUSE did
15:56:58 <rdieter> [10:53] <rdieter> yay, thanks.  bonus points if you can create a F22 looknfeel theme too
15:57:01 <rdieter> +1 ^^ :)
15:57:06 <ltinkl> ye well :)
15:57:43 <ltinkl> it won't be as easy as just exchanging the wallpapers tho (what we did in the past)
15:58:03 <rdieter> I tried when I looked at it last, but I tried re-using default/breeze components via symlinks, and all I ended up doing was confusing/crashing plasma
15:58:18 <ltinkl> jgrulich: plasma-workspace/lookandfeel
15:58:25 <ltinkl> jgrulich: I can help you tomorrow if you want
15:58:55 <jgrulich> ltinkl: I'll let you know if I need something :)
15:59:02 <ltinkl> jgrulich: kk
15:59:43 <Kevin_Kofler> .bug 1220862
15:59:47 <zodbot> Kevin_Kofler: Bug 1220862 The installer icon (and everything else in ~/Desktop) is not displayed anywhere on the Plasma Desktop 5 desktop - https://bugzilla.redhat.com/1220862
15:59:56 <Kevin_Kofler> Should we try to propose that as Blocker? FE?
16:02:17 <danofsatx> damned bounces....
16:02:53 <rdieter> Kevin_Kofler: if you want it fixed, it needs to be at least FE
16:03:41 <rdieter> I'm ok with either added folderview applet or folderview layout, but doing the latter is probably a more intrusive change to introduce this late
16:04:04 <rdieter> anyone else have an opinion ?
16:04:33 <danofsatx> I'd go with the folderview applet
16:05:08 <Kevin_Kofler> rdieter: I know, which is why I'm asking.
16:05:19 <Kevin_Kofler> Do you think it'd qualify as a blocker?
16:06:00 <rdieter> I don't think it's a blocker (we already have installer in favorites)
16:06:02 <Kevin_Kofler> There is the criterion that the installer needs to be discoverable, but it does not require it to be on the desktop (due to gnome-shell developers refusing to do that).
16:06:05 * dvratil has to go, will catch up later
16:07:09 * jgrulich is leaving too
16:07:15 <danofsatx> not a blocker.
16:07:24 <Kevin_Kofler> What's the tracker for FEs again?
16:07:27 * danofsatx doesn't even feel it's FE worthy if it's in the launcher
16:07:49 <danofsatx> https://bugzilla.redhat.com/show_bug.cgi?id=1043132
16:08:07 <Kevin_Kofler> Yeah, found a working alias (FinalFreezeException).
16:08:27 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=1220862#c1
16:08:41 <rdieter> use the qa blockers app
16:09:12 <rdieter> qa.fedoraproject.org/blockerbugs/propose_bug
16:09:16 <danofsatx> that's how I do it
16:12:44 <rdieter> looks like we're over time and losing meeting participants. :)  any last words before closing ?
16:13:00 <Kevin_Kofler> I'm checking if the other theming bugs are on any blocker/FE tracker.
16:13:04 <danofsatx> any progress on the dri-3 bug?
16:13:18 * danofsatx doesn't know where to look for that
16:13:43 <rdieter> danofsatx: if there's nothing in bz (either rh or freedesktop), means likely no progress
16:13:55 <Kevin_Kofler> Looks like they're not, should they? Or have we already given up on fixing them for GA?
16:14:11 <Kevin_Kofler> I'm talking about these:
16:14:12 <Kevin_Kofler> Bug 1199521 kde-settings: oxygen(qt) vs adwaita(gtk) cursor inconsistency - https://bugzilla.redhat.com/1199521
16:14:13 <rdieter> though one person (gerald?) posted a new backtrace, but that one looked different than the dri3 issue
16:14:16 <Kevin_Kofler> Bug 1220497 Missing Fedora KSplash theme - https://bugzilla.redhat.com/1220497
16:14:20 <Kevin_Kofler> Bug 1218700 Plasma 5 menu icon is KDE logo, should be Fedora logo - https://bugzilla.redhat.com/1218700
16:15:02 <danofsatx> those need fixed. shall I propose them as FEs?
16:15:09 <rdieter> Kevin_Kofler: i'd say the latter 2 are worthy of FE, the cursor theme thing not (it's cosmetic only)
16:15:41 <danofsatx> true...
16:15:56 <rdieter> well, theming is all cosmetic, but the cursor theme is not nearly as visible
16:15:57 <Kevin_Kofler> rdieter: OK, so can you propose them for FE?
16:16:08 <danofsatx> I'll do it, Kevin_Kofler
16:16:13 <Kevin_Kofler> OK
16:17:22 <Kevin_Kofler> Of course, FE will only help if the stuff gets fixed REALLY quickly.
16:17:31 <Kevin_Kofler> By definition they won't wait for a non-blocker.
16:17:36 <rdieter> that too, thanks everyone
16:17:40 <rdieter> #endmeeting