fedora-meeting
LOGS
16:56:52 <mattdm> #startmeeting Council Open Floor (2015-05-04)
16:56:52 <zodbot> Meeting started Mon May  4 16:56:52 2015 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:56:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:57:00 <mattdm> #chair mattdm jreznik jwb cwickert rdieter langdon sgallagh decause
16:57:00 <zodbot> Current chairs: cwickert decause jreznik jwb langdon mattdm rdieter sgallagh
16:57:05 <mattdm> #topic Open Floor!
16:57:12 <jwb> oh, right
16:57:25 <langdon> .hello langdon
16:57:26 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
16:57:27 <decause> .hello decause
16:57:29 <zodbot> decause: decause 'None' <decause@redhat.com>
16:57:31 <mattdm> Hi everyone. By the schedule, this is an informal open floor session for the council
16:57:58 * langdon may be a little distracted today as he has a conflicting meeting
16:58:15 * rdieter waves
16:58:21 <decause> \o
16:58:24 <mattdm> I am opening the meeting and then i'm gonna run away for a few minutes because my wife invited me to sit outside with her for lunch. so afk for a few minutes while foodstuffs and etc. are arranged.
16:58:50 <mattdm> but as it is open floor I hope that will be fine :)
16:59:06 <jreznik> mattdm: enjoy your food :)
16:59:51 * cwickert is here
17:01:16 <decause> #topic OpenFloor
17:02:20 <decause> The idea here is that folks likely have official/unofficial business to bring to the floor of the council, and we want to give people an opportunity to do so
17:03:14 <decause> I will defer to other folks, but I've got a few items to add to the queue :)
17:04:27 <decause> #link http://twitter.com/fedobot
17:05:31 <decause> this is a fedora account being used to test out content aggregation tools
17:05:39 <decause> s/fedora/twitter
17:06:18 <decause> at the top of the list, you'll see text about a meeting concluding, and an image to a wordcloud
17:06:43 <decause> whenever an IRC meeting is closed, there is a fedmsg that is broadcast on the bus
17:07:23 <decause> wordcloudbot listens on the bus for those messages, downloads the transcript, parses it, and creates a wordcloud with the Fedora Logo as an image mask, and then posts it to twitter
17:07:26 * cwickert wonders if tools are really important
17:08:39 <decause> wordcloudbot can be run as a systemd service, and will be deployed (in the near future, once the stack is packaged up) to somewhere in Fedora Infra
17:08:45 * jwb wonders how many times he has to say "crap" for it to be the largest word in the wordcloud
17:08:58 <decause> jwb: just more than any other word ;)
17:09:14 <decause> not in the blacklist, that is
17:09:16 <jwb> so what is the end goal with this tool?
17:10:02 <decause> the end goal here is to start generating content based on existing community activity to help tell stories
17:10:59 <decause> in an instrumented way
17:11:35 <decause> the bot itself is not as interesting, as the story that can be told about how to tap into Fedmsg to help each subproject tell it's stories
17:11:36 <jwb> so someone sees the wordcloud, wonders what "pagure" is, and then looks it up more?
17:11:48 * mattdm is back :)
17:12:34 <decause> jwb: stuff like that can def happen, and is somewhere more likely to draw eyeballs than a raw transcript or a text-only mail-list post
17:12:44 <decause> s/somewhere/somewhat
17:13:14 <jwb> you might want to suggest filtering out IRC nicks.  i mean, "adamw" is awesome but i don't think that's the story we want to tell for the content of the QA meeting
17:13:44 <mattdm> Yeah I suggested having two clouds for each meeting -- one for nicks, one for content
17:13:50 <decause> jwb: this is a great point. Already we do filter out nicks, and this is a result of meeting attendees talking about/to adamw directly
17:14:35 <jwb> right.  which is fine, but that is expected during every QA meeting.  it isn't content.  they aren't talking about adamw.  there're talking to him
17:14:53 <jwb> wow.  s/there're/they're
17:15:08 <mattdm> (could take everything from the nicks column, remove that from the other)
17:15:14 <jwb> yes
17:15:18 <decause> considering we hacked this together on Friday, there is certainly much potential to improve from here :)
17:15:21 <jwb> anyway, that's a technical detail
17:15:30 <jreznik> :)
17:15:37 <jwb> so this is one example of a tool.  do you have others?
17:16:33 <decause> jwb: last week I posted a link to the cardsite prototype we hacked on at the pycon sprints:
17:16:42 <decause> http://decause.github.io/cardsite
17:17:07 <decause> #link http://decause.github.io/cardsite
17:17:23 <jwb> i see lots of fancy popping icons.  i have no idea what this is
17:17:28 <jwb> --verbose? :)
17:17:34 <decause> this is a Proof of concept tapping into Fedmsg/datagrepper from websockets via the browser
17:17:52 <decause> there are 3 panes: top level is messages, middle is users, bottom is packages
17:18:08 <decause> it is loosely inspired by http://emojitracker.com
17:18:16 <mattdm> it's basically `fedmsg-tail` in gui form :)
17:18:23 <decause> which is a project to show in real-time, emoji usage on twitter
17:19:52 <mattdm> I have a completely, completely different question -- but still kind of tools focused....
17:20:12 <decause> the important parts of cardsite aren't necessarily that one GUI, but proving that we can bild on top of Fedmsg, and using some automated build tools to make it happen (i.e. gulp, bower)
17:20:22 <mattdm> Next week is planned a presentation from chris roberts about the state of marketing
17:20:50 <mattdm> and I'd suggested video....
17:21:05 <mattdm> And ideally some sort of open source video tech
17:21:15 <mattdm> either many-many or one-many with an irc side channel
17:21:32 <mattdm> And failing open source, Google Hangouts.
17:21:34 * langdon wishes to add "contributor blog site" and/or "developer blog site"
17:21:48 <mattdm> Does anyone want to experiment with tech _before_ the meeting?
17:22:16 <decause> langdon: +1
17:22:22 <jwb> hangouts is the only one i've gotten working consistently, but there are clearly downsides to it.
17:22:29 <jreznik> langdon: what's planet.fpo than contributor blog site? aggregated
17:22:34 <decause> mattdm: there is firefox hello, but I reckon that is one-to-one only still
17:22:36 <langdon> mattdm, mizmo was having poor luck with some tools last? week (sometime before now that was recent) to do her user survey thing
17:22:52 <decause> mattdm: bluejeans?
17:22:54 <mattdm> langdon: yeah. we definitely shouldn't use whatever that was
17:22:59 <jreznik> from hangouts, we can easily get recording...
17:23:04 <mattdm> decause: bluegenes was the fallback, yeah.
17:23:04 * decause isn't sure of it's FOSS-y status
17:23:13 <jwb> it's not foss
17:23:15 <mattdm> bluejeans is non-foss
17:23:24 <decause> sadface
17:23:30 <jreznik> but it's pretty open in terms of how you can connect there...
17:23:47 <langdon> jreznik, planet is not curated.. this is curated.. was on the council mailing list (i think it was that one) a couple weeks ago.. then I asked something and killed the whole thread.. :/  would like to bring it back
17:24:21 <misc> the backend is non foss, but you can use a regular phone line to connect, or a regular sip client, provided you have the codecs, who are likely patented
17:24:33 <mattdm> i was thinking Jitsi might be worth looking at. Saw an impressive demo at FOSDEM https://jitsi.org
17:24:36 <misc> ( the plugin is based on bsd code, for the record )
17:24:47 <mattdm> and it's 100% open, including, I think, Fedora-friendly codecs
17:25:52 <jwb> can we go back to the tools again?  cwickert asked if they're really important.  i asked a couple questions on the examples.
17:26:17 <langdon> jwb, you lost me... which tools?
17:26:25 <langdon> the video ones?
17:26:34 <sgallagh> /me is here now.
17:26:37 <jwb> i understand that fedmsg can be used to generate content, but it is unclear to me 1) who is actually supposed to be coding these tools, 2) who is going to be currating the content, 3) what the end goal of said content is
17:26:45 <jwb> langdon, no the one's decause was talking about
17:26:57 <langdon> jwb, ahh now i see...
17:27:13 * mattdm also rewinds :)
17:27:16 <sgallagh> I thought we met every other week; I don't have the presentation about the Fedora Editions process ready.
17:27:44 <mattdm> sgallagh: true. this is open floor informal time, not official meeting
17:27:53 <sgallagh> oh ok
17:27:56 <decause> cwickert: there was a proposal on council-discuss last week about creating a "Community _______ Team"
17:28:04 <jwb> i'm slightly skeptical that the transition from 1->2->3 is going to be magically easier than what mizmo used to do for the Server WG with her summarized blog postings
17:28:09 <sgallagh> /me panicked for a moment when Fedora Notifications told him he was supposed to be in this meeting
17:28:40 <jwb> from what i understand, she put a lot of work into those and they were wonderful but i'm not sure how much that gained the Server WG in terms of increased contributions
17:28:49 <decause> the _______ in that title is still up for grabs, but Architecture is out now for sure.
17:28:50 <mattdm> sgallagh: see https://lists.fedoraproject.org/pipermail/council-discuss/2015-April/013298.html
17:29:09 <sgallagh> Right, I remember that now
17:29:22 <decause> I'm leaning towards "Community Operations Team" after some convo's unofficially :P
17:29:24 <cwickert> decause: yeah, just saw it and I am very confused about it
17:30:43 <decause> cwickert: so, if/when we can put together this vehicle for community operations, in whatever incarnation it manifests, it is my hope that these types of tools/metrics are going to be built by that group of contributors
17:30:49 <decause> that's #1
17:31:33 <decause> 2) Within that group, there is an opportunity for folks to contribute raw/uncurated content, which can be published to a community blog of somekind, somewhere (Langdon)
17:31:53 <jreznik> jwb: we did it also for board meeting long time ago... but maybe the first step should be to start meetings as proposed (with other teams coming), sending invitations ahead of time, sending and storing notes and with a good work with meetbot, we can get a lot for free
17:31:55 <cwickert> decause: I know your job is a lot about metrics, but I think this is a different story. I feel like we got completely side-tracked from what FOSCo was supposed to be
17:32:21 <decause> 3) The end goal of having this content is to help make it more clear to contributors what happens, and who is doing it, and how to get involved (hopefully by syndicating to a place like Hubs)
17:32:28 <mattdm> I think it turned out that a lot of people had different ideas of what it was supposed to be
17:33:15 <jwb> decause, s/contributors/potential contributors?
17:33:35 <decause> cwickert: we should touch base this week at some point about FOSCo for sure
17:33:37 <jwb> because contributors tend to already know who is doing what, where it is happening, and how to get involved.  at least to the extent they care about
17:33:49 <decause> jwb: yes, potential/new contributors
17:34:01 <cwickert> mattdm: well, when I say "supposed to be" I mean "what I had in mind" or "what FAmSCo had in mind when we decided to support the idea of FOSCo"
17:34:15 <cwickert> decause: sure, let me know a time
17:34:21 <mattdm> cwickert Yeah :)
17:34:51 <decause> cwickert: in the proposal, I described why I thought FOSCo was not the best organizational umbrella for this type of activity
17:34:59 <jwb> decause, i'm certainly not opposed to this, but i'd like to avoid having a whole team of people writing neat tools that nobody is reading or using in the end.  the payoff has to be there because otherwise it's a drain on infra resources to maintain, etc
17:35:21 <cwickert> decause: yeah, your view of the activities already is different
17:35:22 <decause> jwb: this is a *real* concern
17:35:27 <mattdm> I'm also worried about an over-emphasis on tools
17:35:35 <cwickert> +1
17:36:31 <decause> jwb: this is a real concern, not wanting to be a drain on resources/dev cycles from existing contributors
17:37:15 <decause> as much as possible, these tools are going to be "fed" by fedmsg/zodbot and other curated channels so that folks don't have to spend time making all this content themselves
17:38:06 <decause> I'm hoping that these types of tools, as a proof-of-concept, can help people understand the types of pipelines we want to build
17:38:26 <decause> I'm not looking ot spend all my time engineering/building, for sure
17:38:55 <decause> in the beginning, there is a need for building things that can give us metrics
17:39:20 <decause> in addition to "fancy word clouds" I also get a natural langauge processed corpus of everything said in IRC, Everyday
17:39:37 <decause> this is something that we didn't have before, that is data, that we can use to make decisions, and support strategy
17:39:45 * mattdm nods
17:40:06 * cwickert wonders how this is related to FOSCo
17:40:34 <decause> cwickert: This is something tha tis going to run in parallel with FOSCo, not instead of
17:40:35 <jreznik> cwickert: say FOSCo 100000 times and it will be in all word clouds :)
17:41:31 <decause> having a delegation of self-selected group members--a "big tent" strategy--is important for doing community organizing, in my experience
17:41:36 <cwickert> decause: ah, sorry, I thought we had left the tools discussion and moved on to FOSCo
17:41:46 <decause> cwickert: no worries :)
17:41:53 <decause> cwickert: we do need to figure out FOSCo, too
17:41:59 <mattdm> open floor means we talk about everything all at once :)
17:42:11 <decause> cwickert: your orig proposal when I first got here was a good start, and we should def revisit it
17:42:34 <decause> mattdm: :P
17:43:12 <cwickert> decause: ok, ready when you are.
17:43:23 <cwickert> except, I have to leave in a few.
17:43:47 <decause> cwickert: we'll sync calendar for tomo or something after this meeting
17:44:26 <decause> #action decause get Community Operations Team Proposal added to the wiki
17:45:40 <decause> changing streams: I'm going to be meeting with EDU team in OSAS on Wednesday to talk more about high-level Objective things
17:45:41 * mattdm promised to not bikeshed on the name too much
17:46:16 <decause> I will post a transcript/notes to council-discuss after
17:46:41 <jreznik> decause: looking on the word cloud from blocker review - links should be excluded - I see a lot of instances of link, redhat and bugzilla there... but that giant BLOCKER is awesome :D
17:46:56 <decause> jreznik: :)
17:47:02 <decause> I can update the blacklist
17:47:32 <decause> parsing URL's is usually an interesting problem in NLTK
17:47:41 <decause> jreznik++
17:47:41 <zodbot> decause: Karma for jreznik changed to 11:  https://badges.fedoraproject.org/badge/macaron-cookie-i
17:47:45 <mattdm> Depends on how these are used. In a list of all meetings, having BLOCKER be gigantic in the blocker review meeting makes sense
17:48:01 <mattdm> in a list of blocker review meetings, it's quite a bit less useful
17:48:21 <decause> meeting specific blacklists can be a thing we try
17:48:37 <decause> #link http://github.com/decause/wordcloudbot
17:48:49 <decause> issues will go directly into my task queue
17:49:02 <decause> (though likely not at the very top of the list ;) )
17:49:08 <jreznik> mattdm: yeah, BLOCKER makes sense, sure, I was talking about links
17:49:14 <mattdm> jreznik: ah yeah.
17:49:39 <jreznik> like two examples - where it doesn't work (links) and where it works well (blocker)
17:49:50 <mattdm> I like that "thing" is big in the rel-eng meeting
17:49:54 <jreznik> even the best result of blocker review meeting would be no blocker :D
17:49:55 <mattdm> rel-eng deals with a lot of things
17:50:08 <jreznik> Internet of Things!
17:53:23 <decause> #action decause set up time to talk FOSCo with cwickert
17:53:51 <decause> #action decause meet with OSAS EDU team on Wednesday
17:54:20 <cwickert> thanks
17:55:41 <decause> we're at 5 minutes
17:55:51 <decause> anybody have any last minute biz?
17:56:26 <langdon> are we tabling the blog convo for post fosco or not-fosco?
17:56:47 <mattdm> langdon: I think it's separate, yeah?
17:56:56 <jwb> the open floor concept seems to have worked well, but at the side effect of having 3 or 4 interweaving conversations :)
17:56:57 <mattdm> Or at least, can be parallel?
17:57:16 <langdon> jwb, and i am on the phone too.. /me has a headache :)
17:57:21 <decause> jwb: next time, perhaps we get an "agenda" as the first item :P
17:57:27 <langdon> mattdm, i think it can be either ..
17:57:40 <langdon> but ... i would rather move forward on the "split blog" asap
17:57:49 <jwb> decause, i think just setting topic as we go would probably be enough
17:57:50 <decause> langdon: I'm interested in helping with this
17:58:19 <mattdm> AFAIK ryan and chris are working on setting up a council blog -- not necessarily the developer blog you are talking about though
17:58:23 <langdon> decause, i am happy for you to run it :)
17:58:37 <langdon> mattdm, well this is the danger
17:58:46 <decause> s/decause/python
17:58:46 <langdon> so... is that the same as the "contributor blog"?
17:58:50 <decause> :P
17:58:59 <langdon> how is that the same or different from a "developer blog"?
17:59:20 * langdon afraid of too much straition (thinks he made that word up)
17:59:21 <jwb> i need to duck out for an appt now.  i'll read the scrollback
17:59:31 <mattdm> langdon: could be "contributor blog", but i was thinking _less ambitious_.
17:59:32 <decause> the important part, from my understanding, is that Magazine stays focused on user content
18:00:14 <langdon> "contrib blog" is just content targeted at contributors (like election annc) vs "users" which is more what magazine could be... "dev content" could be in either..
18:00:33 * langdon doesnt think it has to be "ambitious"
18:00:53 <decause> langdon: nod nod
18:01:10 * mattdm doesn't want it to turn into another Planet
18:01:17 <mattdm> because we alrady have one of those
18:01:20 <langdon> mattdm, curaiton is key
18:01:20 <jreznik> langdon: I'm still not sure we want to split it this hard - we tried to get elections to magazine, as I think it's interesting topic for both users and contributors...
18:01:23 <langdon> *curation
18:01:34 <decause> #action decause meet with langdon later this week to discuss council/contrib blog(s)
18:01:51 <langdon> jreznik, might depend on the election.. council = yes, fesco?
18:01:52 <mattdm> we could call this one "fedora insight"
18:01:59 * mattdm is not sure what happened with that name :)
18:02:00 <langdon> oooo
18:02:58 <decause> we're at 2 past the hour
18:03:04 <decause> any other last minute business?
18:03:23 * rdieter apologizes, got pulled away for most of the meeting, so didn't contribute much
18:03:25 * mattdm is sitting pleasantly outside, can go on if people want :)
18:03:31 <decause> mattdm: :)
18:03:58 <mattdm> at least until my battery gives out. stupid thing is at 39% of design capacity
18:05:56 * decause has to bounce, but will keep an eye on backchannel
18:06:01 <decause> thanks all :)
18:06:03 * decause &
18:06:18 <mattdm> okay, let's call it :)
18:06:21 <mattdm> thanks everyone!
18:06:33 <mattdm> #endmeeting